前言

概述

此文档描述VCN产品的对外提供的REST API接口。

阅读此文档需要 熟悉以下技术：

Restful web services

HTTP/1.1

Json data serialization formats

读者对象

本文档主要适用于以下工程师：

  • 解决方案开发工程师
  • 解决方案测试工程师

符号约定

在本文中可能出现下列标志，它们所代表的含义如下。

符号 | 说明
 | 表示有高度潜在危险，如果不能避免，会导致人员死亡或严重伤害。
 | 表示有中度或低度潜在危险，如果不能避免，可能导致人员轻微或中等伤害。
 | 表示有潜在风险，如果忽视这些文本，可能导致设备损坏、数据丢失、设备性能降低或不可预知的结果。
 | 表示能帮助您解决某个问题或节省您的时间。
 | 表示是正文的附加信息，是对正文的强调和补充。

命令行格式约定

格式 | 意义
粗体 | 命令行关键字（命令中保持不变、必须照输的部分）采用加粗字体表示。
斜体 | 命令行参数（命令中必须由实际值进行替代的部分）采用斜体表示。
[ ] | 表示用“[ ]”括起来的部分在命令配置时是可选的。
{ x | y | ... } | 表示从两个或多个选项中选取一个。
[ x | y | ... ] | 表示从两个或多个选项中选取一个或者不选。
{ x | y | ... } * | 表示从两个或多个选项中选取多个，最少选取一个，最多选取所有选项。
[ x | y | ... ] * | 表示从两个或多个选项中选取多个或者不选。
&<1-n> | 表示符号&的参数可以重复1～n次。
# | 由“#”开始的行表示为注释行。

限制说明

对于请求参数的body，如果传入的XML节点非数组但是存在相同的多个节点时，以最后一个输入值处理。比如<request><group>1</group><group>2</group></request>，group又不是一个数组，则以第二个<group>2</group>处理。

修订记录

修改记录累积了每次文档更新的说明。最新版本的文档包含以前所有文档版本的更新内容。

文档版本02 (2018-9-15)

该版本的更新如下：

资料随产品更新。

内容 | 原因 | 接口 | 兼容性 | 说明
加强请求校验 | 安全性提高 | 所有 | 兼容 排查方法说明：对于除了接口之外的请求字段都会拒绝访问，因此需要使用之前本版本需要进行排查。 | 针对接口除了接口请求之外的所有字段都做了强校验。
Result code扩展 |  | 所有 | 兼容 排查方法说明：如果有使用Result code进行判断具体值的需要进行排查。 | 详细返回请求结果的错误信息。
存量接口扩展字段 |  |  |  |
枚举值变更 |  |  |  |

文档版本01 (2018-05-10)

第一次正式发布。

版权所有 © 华为技术有限公司


简介

此文档描述VCN产品的对外提供的REST API以及对外提供的eSDK接口，该restful由Java编写的接口服务，请求数据格式为Json格式。

本文定义VCN向二次开发者提供的开发接口。为便于开发和使用，所有接口采用HTTP REST接口和eSDK接口方式向外提供，为了数据的安全传输，VCN的接口采用全程https通道。

系统主要提供基本接口88个，合肥专用接口27个，接口具体分类如下：

  1. 事件回调：用户注册事件回调，事件消息通过接口地址返回用户；
  2. 用户管理：用户登录、注销、查询等管理功能；
  3. 设备管理：获取或设置设备相关参数信息功能；
  4. 告警：告警订阅请求或查询功能；
  5. 实况管理：实时浏览相关控制功能；
  6. 录像管理：视频录像相关控制功能；
  7. 回放管理：视频回放相关控制功能；
  8. 抓拍：平台抓拍相关功能。


GDPR要求

为了保证系统的安全及个人隐私安全，需要执行以下操作：

  • 智能视频云系统提供用户管理、设备管理、告警管理、实时浏览、录像管理、视频控制、图片抓拍等能力，可以获取个人数据；
  • 通过智能视频云系统的接口进行二次开发或访问，必须获取数据控制者书面授权，并根据数据控制者的风险评估结果，满足权限和数据最小化要求；
  • 数据控制者授权第三方进行接口使用或二次开发前，请确保第三方同时满足GDPR合规的要求。


接口描述及部署

  • 接口描述


接口描述

  1. 在执行GET操作时，所有数据以资源XML的形式返回。当资源不存在时，以HTTP 404响应。当用户无权限操作或者其它错误时，将以HTTP 500响应。
  2. 注：在调用其他接口时，需要结合login接口生成的Session ID，否则无法建立会话、无法完成鉴权。例如：在HTTP Header中设置

    Cookie：JSESSIONID=071C2C82E975299F7025976A96B7FE5A (该值为调用登录接口时SDK在Cookie中返回的Session ID值)。

  3. 使用示例中的ip、编码等信息均非实际值，实际使用需要参考调用接口返回的真实值。
  4. Xml消息中如果值中包含特殊字符的，需要将特殊字符做html编码，如<，需要转化为&lt;
  5. 特殊字符包含<、>、&、’、“等
  6. 在执行POST操作时，如果操作成功，将返回指定的内容，并且错误码为0，否则将返回非0的错误码，同时还会包含一条简单的错误信息。
  7. 所有的错误码都是以0表示成功，其它值，无论正负，无论是否为数字，均表示失败。
  8. 所有操作都支持长链接，这要求客户端在HTTP请求头中设置Keep-alive参数。
  9. 通用响应结果体:
result |  | Integer | 结构响应信息
 | code | Integer | 0为成功，非0为不成功,详情参见附录“错误码”
 | errmsg | String | 错误消息
父主题： 接口描述及部署


鉴权接口

  • 用户登录
  • 用户注销
  • 用户保活


用户登录

接口描述

登录系统接口。

在调用其他接口时，需要结合登录接口生成的SessionID，否则无法建立会话、无法完成鉴权。

例如：在HTTP Header中设置Cookie：JSESSIONID=071C2C82E975299F7025976A96B7FE5A (该值为调用登录接口时SDK在Cookie中返回的Session ID值)。Cookie默认超时时间为30分钟。

注意：serverIp 为vcn服务器的ip地址。默认restful服务于vcn具有一对一的关系。如果要更换登录的serverIp，需要重启restful服务才能生效。

使用说明

请求方法 | POST
请求URL | loginInfo/login
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /loginInfo/login HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | userName | String | 必选 | IVS系统登录账号
2 | password | String | 必选 | IVS系统登录密码
3 | serverIp | String | 必选 | 系统服务器IP
4 | serverPort | String | 必选 | 系统服务器端口号

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 返回状态码：0成功；其余返回错误码

使用示例

接口请求消息示例数据如下：

{

"userName": "admin",

"password": "super123",

"serverIp": "192.168.203.36",

"serverPort": "9900"

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 鉴权接口


用户注销

接口描述

根据请求的sessionID进行登出。

使用说明

请求方法 | GET
请求URL | /users/logout
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /users/logout HTTP/1.1

Host: 192.168.203.36:18531

参数描述

请求参数

无

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 返回状态码：0成功；其余返回错误码

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/users/logout

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 鉴权接口


用户保活

接口描述

此接口用于会话保活。默认30分钟超时。

使用说明

请求方法 | GET
请求URL | /common/keepAlive
请求数据 | application/json;charset=UTF-8

参数描述

无

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultcode | Integer | 成功返回0，失败返回错误码

使用示例

https://192.168.203.36:18531/common/keepAlive

接口请求消息示例数据如下：

无

接口返回消息示例数据如下：

{

"resultCode": 0,

}

父主题： 鉴权接口


用户管理接口

  • 根据用户id查询用户信息
  • 查询当前用户信息
  • 获取用户ID
  • 获取用户列表
  • 查询角色列表
  • 查询用户组列表


根据用户id查询用户信息

接口描述

此接口用于根据用户id用户详细信息

使用说明

请求方法 | GET
请求URL | /users/userinfo/{domaincode}/{userid}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET users/userinfo/dc451bcc70ff4ed1a23e2ea56f166082/1 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | domaincode | String | 必选 | 域编码，如果为空字符串，则默认使用当前登录用户所在域的编码,可通过获取域路由信息获得
2 | userid | String | 必选 | 用户ID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 成功返回0，失败返回错误码
2 | userInfo | Object | 用户对象集合，参见类型 UserInfo

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/users/userinfo/dc451bcc70ff4ed1a23e2ea56f166082/1

接口返回消息示例数据如下：

{

"resultCode": 0,

"userInfo": {

"domainCode": "",

"userId": 1,

"isFirstLogin": 0,

"roleId": 1,

"groupId": 1,

"loginName": "admin",

"password": "",

"pwdModifyDate": "",

"userType": 0,

"userDomain": "",

"status": 1,

"registerDate": "20121108190530",

"userDesc": "",

"ptzLevel": 1,

"maxSessionCount": 300,

"maxVideoCount": 0,

"lockTime": "",

"userName": "admin",

"mail": "",

"phone": "",

"sex": 1,

"reserve": "",

"validDateFlag": 0,

"validDateStart": "",

"validDateEnd": ""

}

}

父主题： 用户管理接口


查询当前用户信息

接口描述

此接口用于查询当前登录用户的详细信息

使用说明

请求方法 | GET
请求URL | /users/userinfo/{domaincode}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET users/userinfo/dc451bcc70ff4ed1a23e2ea56f166082 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | domaincode | String | 必选 | 域编码，如果传入不存在的值，则默认使用当前登录用户所在域的编码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 成功返回0，失败返回错误码
2 | userInfo | Object | 用户对象集合，参见类型 UserInfo

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/users/userinfo/dc451bcc70ff4ed1a23e2ea56f166082

接口返回消息示例数据如下：

{

"resultCode": 0,

"userInfo": {

"domainCode": "",

"userId": 1,

"isFirstLogin": 0,

"roleId": 1,

"groupId": 1,

"loginName": "admin",

"password": "",

"pwdModifyDate": "",

"userType": 0,

"userDomain": "",

"status": 1,

"registerDate": "20121108190530",

"userDesc": "",

"ptzLevel": 1,

"maxSessionCount": 300,

"maxVideoCount": 0,

"lockTime": "",

"userName": "admin",

"mail": "",

"phone": "",

"sex": 1,

"reserve": "",

"validDateFlag": 0,

"validDateStart": "",

"validDateEnd": ""

}

}

父主题： 用户管理接口


获取用户ID

接口描述

此接口用于获取当前登录用户的ID。当前登录用户的ID常被作为其他接口的入参使用

使用说明

请求方法 | GET
请求URL | users/userid
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /users/userid HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

无

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | userId | Integer | 用户ID

使用示例

接口请求消息示例数据如下：

无

接口返回消息示例数据如下：

{

"resultCode": 0,

"userId": 1

}

父主题： 用户管理接口


获取用户列表

接口描述

此接口用于查询用户列表信息。

使用说明

请求方法 | GET
请求URL | /users/userList/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /users/userList/v1.0?domainCode=dc451bcc70ff4ed1a23e2ea56f166082 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | domainCode | String | 必选 | 域编码，如果为空字符串，则默认使用当前登录用户所在域的编码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 成功返回0，失败返回错误码
2 | userInfos | Object | 用户对象集合，参见类型 UserInfos

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/users/userList/v1.0?domainCode=9610cfb832cd46e3b26b1562923ad505

接口返回消息示例数据如下：

{

"resultCode": 0,

"userInfos": {

"total": 2,

"indexRange": {

"fromIndex": 1,

"toIndex": 2

},

"userInfoList": {

"userInfo": [

{

"userId": 3,

"loginName": "ww1234",

"userType": 0,

"userName": "哈哈",

"ptzLevel": 7,

"mail": "123456@qq.com",

"phone": "789456",

"userDesc": "test",

"status": 1,

"groupId": 1,

"roleId": 2,

"validDateFlag": 0,

"validDateStart": "20191128043800",

"validDateEnd": "20191128143800",

"sex": 0

}

]

}

}

}

父主题： 用户管理接口


查询角色列表

接口描述

此接口用于查询角色列表信息

使用说明

请求方法 | GET
请求URL | /users/roleList/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /users/roleList/v1.0?domainCode=dc451bcc70ff4ed1a23e2ea56f166082 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | domainCode | String | 必选 | 域编码，如果为空字符串，则默认使用当前登录用户所在域的编码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 成功返回0，失败返回错误码
2 | roleInfos | Object | 用户对象集合，参见类型 RoleInfos

使用示例

接口请求消息示例数据如下：

https://192.168.203.36/users/roleList/v1.0?domainCode=9610cfb832cd46e3b26b1562923ad505

接口返回消息示例数据如下：

{

"resultCode": 0,

"roleInfos": {

"total": 3,

"indexRange": {

"fromIndex": 1,

"toIndex": 3

},

"roleInfoList": {

"roleInfo": [

{

"roleId": "2",

"roleName": "role_manager",

"roleType": 1

},

{

"roleId": "4",

"roleName": "role_special",

"roleType": 1

},

{

"roleId": "3",

"roleName": "role_normal",

"roleType": 1

}

]

}

}

}

父主题： 用户管理接口


查询用户组列表

接口描述

此接口用于查询当前登录用户的详细信息

使用说明

请求方法 | GET
请求URL | /users/groupList/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /users/groupList/v1.0/?domainCode=dc451bcc70ff4ed1a23e2ea56f166082 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | domainCode | String | 必选 | 域编码，如果为空字符串，则默认使用当前登录用户所在域的编码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 成功返回0，失败返回错误码
2 | userGroupInfos | Object | 用户对象集合，参见类型 UserGroupInfos

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/users/groupList/v1.0/?domainCode=9610cfb832cd46e3b26b1562923ad505

接口返回消息示例数据如下：

{

"resultCode": 0,

"userGroupInfos": {

"total": 1,

"indexRange": {

"fromIndex": 1,

"toIndex": 1

},

"userGroupInfoList": {

"userGroupInfo": [

{

"groupID": 1,

"groupName": "root",

"parentGroupID": 0,

"level": 0,

"groupDesc": "this is root group"

}

]

}

}

}

父主题： 用户管理接口


设备管理接口

  • 设置转发域
  • 获取域路由信息
  • 获取域路由扩展信息
  • 查询集群编码
  • 查询网关
  • 设置设备参数
  • 获取设备参数
  • 获取子设备列表
  • 获取子设备列表（新）
  • 获取设备组列表信息
  • 添加设备
  • 删除设备
  • 彻底删除设备
  • 修改设备名称
  • 启动搜索前端设备
  • 停止搜索前端设备
  • 验证前端设备
  • 设备信令透传下发
  • 查询主设备列表
  • 大联网分层展现接口(本域)
  • 大联网分层展现接口(外域)
  • 设置摄像机IP与国标编码映射关系
  • 删除摄像机IP与国标编码映射关系
  • 获取摄像机信息
  • 获取摄像机列表


设置转发域

接口描述

设置转发域，包括设置或取消支持转发域功能的域为转发域。

当多个用户通过转发域访问同一路实况时，转发域只需向接入域获取一路码流，然后将该路实况码流分发给多个用户。

使用说明

请求方法 | PUT
请求URL | /device/progressionTransmit/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

PUT /device/progressionTransmit/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号

请求字段

字段类型

必选/可选

字段名称

1

isSet

Integer

必选

是否设置某个域为转发域：

  • 0：取消设置
  • 1：设置

2

newDomainCode

String

必选

转发域编码，转发域编码是当前设置的转发域

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例数据如下：

{

"isSet": 1,

"newDomainCode": "887ba4a217cb47028201ff2a6b0a024d"

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 设备管理接口


获取域路由信息

接口描述

此接口用于获取用户拥有权限的整个系统中的域路由信息列表。通过该路由列表，用户可以查询所有拥有权限的设备信息。

使用说明

请求方法 | GET
请求URL | /device/domainroute
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/domainroute HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

无

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | domainRouteInfos | Object | 域路由信息集合，参见类型DomainRouteInfos

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/device/domainroute

接口返回消息示例数据如下：

{

"resultCode": 0,

"domainRouteInfos": {

"total": 2,

"domainRouteList": {

"domainRoute": [

{

"domaintype": 1,

"isAgent": 0,

"domainCode": "3bf63c6d6b8c44e88f40b2e3db1aeec8",

"domainName": "IVS System",

"domainIPInfo": {

"ipType": 0,

"ip": "192.168.215.132"

},

"domainPort": 9900,

"superDomain": "",

"isLocalDomain": 1,

"reserve": ""

},

{

"domaintype": 1,

"isAgent": 0,

"domainCode": "dc3aadbe8b8f4f8f8aa237aa75e7c403",

"domainName": "下级域名称",

"domainIPInfo": {

"ipType": 0,

"ip": "192.168.215.130"

},

"domainPort": 9900,

"superDomain": "3bf63c6d6b8c44e88f40b2e3db1aeec8",

"isLocalDomain": 0,

"reserve": ""

}

]

}

}

}

父主题： 设备管理接口


获取域路由扩展信息

接口描述

获取用户拥有权限的整个系统中的域路由扩展信息信息，包括转发域信息，域最大数目为128*8。

使用说明

请求方法 | GET
请求URL | /device/domainRoute/v1.1
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/domainRoute/v1.1 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

无

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | domainRouteInfos | Object | 域路由信息集合，参见类型DomainRouteInfos

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/device/domainRoute/v1.1

接口返回消息示例数据如下：

{

"resultCode": 0,

"domainRouteInfos": {

"total": 2,

"domainRouteList": {

"domainRoute": [

{

"domaintype": 1,

"isAgent": 0,

"domainCode": "3bf63c6d6b8c44e88f40b2e3db1aeec8",

"domainName": "IVS System",

"domainIPInfo": {

"ipType": 0,

"ip": "192.168.215.132"

},

"domainPort": 9900,

"superDomain": "",

"isLocalDomain": 1,

"isProgressionTransmit": 1

"reserve": ""

},

{

"domaintype": 1,

"isAgent": 0,

"domainCode": "dc3aadbe8b8f4f8f8aa237aa75e7c403",

"domainName": "下级域名称",

"domainIPInfo": {

"ipType": 0,

"ip": "192.168.215.130"

},

"domainPort": 9900,

"superDomain": "3bf63c6d6b8c44e88f40b2e3db1aeec8",

"isLocalDomain": 0,

"isProgressionTransmit": 0

"reserve": ""

}

]

}

}

}

父主题： 设备管理接口


查询集群编码

接口描述

此接口用于查询集群编码。该接口适配支持集群功能的产品。

使用说明

请求方法 | GET
请求URL | /cluster/clusters/{domaincode}/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /cluster/clusters/{domaincode}/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | domaincode | String | 必选 | 域编码，可通过获取域路由接口获取 示例：d9808a7bfff94de09ecc47a6baa3bf5d

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | clusterList | Object | 集群信息列表，参见类型 Clusters

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/cluster/clusters/6a7d3ca5ec984fe48ac634e3b22ff36a/v1.0

接口返回消息示例数据如下：

{

"resultCode": 0,

"clusterList": {

"total": 1,

"clusterInfos": [

{

"clusterName": "MCluster-0001",

"clusterCode": "F1A64694217111E98000505DAC8BFDF6",

"domainCode": "",

"productType": "VCN3000",

"status": 1，

"reserve":""

}

]

}

}

父主题： 设备管理接口


查询网关

接口描述

此接口用于查询网关接口。该接口适配支持集群功能的产品。

使用说明

请求方法 | GET
请求URL | /cluster/gateways/{domaincode}/{clustercode}/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /cluster/gateways/{domaincode}/{clustercode}/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | domaincode | String | 必选 | 域编码，可通过获取域路由接口获取 示例：d9808a7bfff94de09ecc47a6baa3bf5d
2 | clustercode | String | 必选 | 集群编码，通过查询集群编码接口获取 示例：BCBC3DEA03211E78000643E8C33B73B

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | responseXML | String | 网关查询响应XML，详见查询网关响应XML

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/cluster/gateways/4f297e89479e4867bf38ec5af75679d8/F1A64694217111E98000505DAC8BFDF6/v1.0

接口返回消息示例数据如下：

{

"resultCode": 0,

"responseXML": "<Content><CGList><CGInfo><FloatIP>192.168.12.201</FloatIP><FloatCGCode>DD1CB266500711E980003C15FBD3A86F</FloatCGCode><NVRCode>03eff5591bdf43a39df5641b9c88187e</NVRCode><FloatCGStatus>1</FloatCGStatus></CGInfo></CGList></Content>"

}

表1 查询网关响应XML
属性 |  |  |  | 可选/必选 | 描述
Content |  |  |  | M | 消息体根节点
 | CGList |  |  | O | 网关列表
 |  | CGInfo |  | M | 网关信息
 |  |  | FloatIP | M | 浮动ip
 |  |  | FloatCGCode | M | 网关编码
 |  |  | NVRCode | M | 设备编码
 |  |  | FloatCGStatus | M | 网关状态：1在线，0离线（暂无）。
 |  |  | FloatIPIndex | M | 浮动网关索引
父主题： 设备管理接口


设置设备参数

接口描述

此接口用于设置设备参数

使用说明

请求方法 | POST
请求URL | /device/setdeviceconfig
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /device/setdeviceconfig HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号

请求字段

字段类型

可选/必选

字段名称

1

deviceCode

String

必选

设备编码

可为主设备编码、摄像机编码、音频设备编码、告警设备编码，详见设备编码规则

例如：32010300100201030000#6bdacabae9c546e9ab5b8688ccd85a59、32010300100201030101#6bdacabae9c546e9ab5b8688ccd85a59、32010300100201030401#6bdacabae9c546e9ab5b8688ccd85a59等，长度限制64字节

2

configType

Integer

必选

设备参数配置类型

  • 1：主设备基本参数DeviceConfig
  • 2：主设备网络参数DeviceNetConfig
  • 3：主设备时间参数（NTP、时区）DeviceTimeConfig
  • 4：摄像机基本参数设置CameraConfig
  • 5：摄像机码流参数设置CameraStreamConfig
  • 6：摄像机基本显示参数设置CameraDisplayConfig
  • 7：摄像机图像参数设置CameraImagingConfig
  • 8：摄像机OSD参数设置CameraOSDConfig
  • 9：摄像机运动检测参数设置MotionDetection
  • 10：摄像机遮挡告警参数设置VideoHideAlarm
  • 11：摄像机隐私保护参数设置VideoMask
  • 12：摄像机音频参数设置AudioConfig
  • 13：摄像机串口参数设置SerialChannelConfig
  • 14：告警输入子设备设置AlarmInConfig
  • 15：告警输出子设备设置AlarmOutConfig
  • 16：云台参数设置PTZConfig
  • 17：摄像机扩展参数设置CameraExtendConfig
  • 18：摄像机抓拍参数设置CameraSnapShotConfig
  • 19：摄像机前端录像码流设CameraRecordStreamConfig

3

configItem

Object

必选

设备参数

传入参数类型参见下表

参数 | 类型 | 可选/必选 | 描述
deviceConfig | DeviceConfig | 可选 | 主设备基本参数
deviceNetConfig | DeviceNetConfig | 可选 | 主设备网络参数
deviceTimeConfig | DeviceTimeConfig | 可选 | 主设备时间参数
cameraConfig | CameraConfig | 可选 | 摄像机基本参数设置
cameraStreamConfig | CameraStreamConfig | 可选 | 摄像机码流参数设置
cameraDisplayConfig | CameraDisplayConfig | 可选 | 摄像机基本显示参数设置
cameraImagingConfig | CameraImagingConfig | 可选 | 摄像机图像参数设置
cameraOSDConfig | CameraOSDConfig | 可选 | 摄像机OSD参数设置
motionDetection | MotionDetection | 可选 | 摄像机运动检测参数设置
videoHideAlarm | VideoHideAlarm | 可选 | 摄像机遮挡告警参数设置
videoMask | VideoMask | 可选 | 摄像机隐私保护参数设置
audioConfig | AudioConfig | 可选 | 摄像机音频参数设置
serialChannelConfig | SerialChannelConfig | 可选 | 摄像机串口参数设置
alarmInConfig | AlarmInConfig | 可选 | 告警输入子设备设置
alarmOutConfig | AlarmOutConfig | 可选 | 告警输出子设备设置
ptzConfig | PTZConfig | 可选 | 云台参数设置
cameraExtendConfig | CameraExtendConfig | 可选 | 摄像机扩展参数设置
cameraSnapShotConfig | CameraSnapshotConfig | 可选 | 摄像机抓拍参数设置
cameraRecordStreamConfig | CameraRecordStreamConfig | 可选 | 摄像机前端录像码流设置

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例数据如下：

{

"deviceCode":"06296510000000000101#c5fa198c20c7416bb19999173b445e5a",

"configType":8,

"configItem":{

"deviceConfig": null,

"deviceNetConfig": null,

"deviceTimeConfig": null,

"cameraConfig": null,

"cameraStreamConfig": null,

"cameraDisplayConfig": null,

"cameraImagingConfig": null,

"cameraOSDConfig": {

"enableOSD":1,

"osdTime": {

"enableOSDTime": 1,

"timeFormat": 2,

"timeX": 0,

"timeY": 0,

"reserve": ""

},

"osdName": {

"enableOSDName": 1,

"osdNameText": "hahahh",

"rectText": {

"left": 0,

"top": 0,

"right": 10,

"bottom": 10

},

"enableSwitch": 0,

"switchInterval": 0,

"enableTextBlink": 0,

"enableTextTranslucent": 0,

"textTranslucentPercent": 0,

"reserve": ""

},

"reserve": ""

},

"motionDetection": null,

"videoHideAlarm": null,

"videoMask": null,

"audioConfig": null,

"serialChannelConfig": null,

"alarmInConfig": null,

"alarmOutConfig": null,

"ptzConfig": null,

"cameraExtendConfig": null,

"cameraSnapShotConfig": null,

"cameraRecordStreamConfig": null,

"cameraFECConfig": null,

"cameraMultiOsdConfig": null,

"cameraStreamEventExConfig": null,

"cameraSECConfig": null

}

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 设备管理接口


获取设备参数

接口描述

此接口用于获取设备参数

使用说明

请求方法 | GET
请求URL | /device/deviceconfig/{configType}/{cameraCode}/{domainCode}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /device/deviceconfig HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号

请求字段

字段类型

可选/必选

字段名称

1

configtype

String

必选

设置参数类型：

  • 1：主设备基本参数DeviceConfig
  • 2：主设备网络参数DeviceNetConfig
  • 3：主设备时间参数（NTP、时区DeviceTimeConfig
  • 4：摄像机基本参数设置CameraConfig
  • 5：摄像机码流参数设置CameraStreamConfig
  • 6：摄像机基本显示参数设置 CameraDisplayConfig
  • 7：摄像机图像参数设置CameraImagingConfig
  • 8：摄像机OSD参数设置CameraOSDConfig
  • 9：摄像机运动检测参数设置MotionDetection
  • 10：摄像机遮挡告警参数设置VideoHideAlarm
  • 11：摄像机隐私保护参数设置VideoMask
  • 12：摄像机音频参数设置AudioConfig
  • 13：摄像机串口参数设置SerialChannelConfig
  • 14：告警输入子设备设置AlarmInConfig
  • 15：告警输出子设备设置AlarmOutConfig
  • 16：云台参数设置PTZConfig
  • 17：摄像机扩展参数设置CameraExtendConfig
  • 18：摄像机抓拍参数设置CameraSnapShotConfig
  • 19：摄像机前端录像码流设置CameraRecordStreamConfig

2

cameracode

String

必选

设备编码（可为主设备编码、摄像机编码、音频设备编码、告警设备编码）(为#号前面数据)，详见设备编码规则

3

nvrcode

String

必选

设备所属NVR编码。例如：a87f463b7dd741908668c89c84a27e30

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | configItem | Object | 设备参数 传出参数类型参见下表

1 设备参数

参数 | 类型 | 可选/必选 | 描述
deviceConfig | DeviceConfig | 可选 | 主设备基本参数
deviceNetConfig | DeviceNetConfig | 可选 | 主设备网络参数
deviceTimeConfig | DeviceTimeConfig | 可选 | 主设备时间参数
cameraConfig | CameraConfig | 可选 | 摄像机基本参数设置
cameraStreamConfig | CameraStreamConfig | 可选 | 摄像机码流参数设置
cameraDisplayConfig | CameraDisplayConfig | 可选 | 摄像机基本显示参数设置
cameraImagingConfig | CameraImagingConfig | 可选 | 摄像机图像参数设置
cameraOSDConfig | CameraOSDConfig | 可选 | 摄像机OSD参数设置
motionDetection | MotionDetection | 可选 | 摄像机运动检测参数设置
videoHideAlarm | VideoHideAlarm | 可选 | 摄像机遮挡告警参数设置
videoMask | VideoMask | 可选 | 摄像机隐私保护参数设置
audioConfig | AudioConfig | 可选 | 摄像机音频参数设置
serialChannelConfig | SerialChannelConfig | 可选 | 摄像机串口参数设置
alarmInConfig | AlarmInConfig | 可选 | 告警输入子设备设置
alarmOutConfig | AlarmOutConfig | 可选 | 告警输出子设备设置
ptzConfig | PTZConfig | 可选 | 云台参数设置
cameraExtendConfig | CameraExtendConfig | 可选 | 摄像机扩展参数设置
cameraSnapShotConfig | CameraSnapshotConfig | 可选 | 摄像机抓拍参数设置
cameraRecordStreamConfig | CameraRecordStreamConfig | 可选 | 摄像机前端录像码流设置

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/device/deviceconfig/4/00096500000000000101/d2a93ae72f154f31b8a0a91b3e8b2775

接口返回消息示例数据如下：

{

"resultCode": 0,

"configItem": {

"deviceConfig": null,

"deviceNetConfig": null,

"deviceTimeConfig": null,

"cameraConfig": {

"videoChannel": 1,

"cameraCode": "04019648611616930101",

"cameraName": "10.5.66.37",

"cameraPosition": {

"longitude": 0.0,

"latitude": 0.0,

"height": 0.0,

"cameraLocationDesc": "",

"reserve": ""

},

"isSupportBroadcast": 0,

"broadcastInfo": {

"ip": {

"ipType": 0,

"ip": ""

},

"port": 0,

"timeToLive": 0,

"reserve": ""

},

"enableVoice": 0,

"voiceOutCode": "04019648611616930501",

"parentCode": "04019648611616930000",

"nvrCode": "",

"cameraType": 4,

"cameraStatus": 1,

"reserve": ""

},

"cameraStreamConfig": null,

"cameraDisplayConfig": null,

"cameraImagingConfig": null,

"cameraOSDConfig": null,

"motionDetection": null,

"videoHideAlarm": null,

"videoMask": null,

"audioConfig": null,

"serialChannelConfig": null,

"alarmInConfig": null,

"alarmOutConfig": null,

"ptzConfig": null,

"cameraExtendConfig": null,

"cameraSnapShotConfig": null,

"cameraRecordStreamConfig": null,

"cameraFECConfig": null,

"cameraMultiOsdConfig": null,

"cameraStreamEventExConfig": null,

"cameraSECConfig": null

}

}

父主题： 设备管理接口


获取子设备列表

接口描述

此接口用于获取子设备列表，子设备包括摄像机设备、告警设备

使用说明

请求方法 | GET
请求URL | /device/devicelist/{devicetype}/{fromindex}/{toindex}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/devicelist/{devicetype}/{fromindex}/{toindex} HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | devicetype | Integer | 必选 | 设备类型： 2：摄像机设备 4：告警设备 35：摄像机设备V2（带国标编码)
2 | indexRange | Object | 必选 | 分页信息 参见类型IndexRange

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
cameraBriefInfos | Object | 摄像机设备信息列表（根据请求中deviceType字段确定返回类型） 参见类型CameraBriefInfos
audioBriefInfos | Object | 语音设备信息列表（根据请求中deviceType字段确定返回类型） 参见类型AudioBriefInfos
alarmBriefInfos | Object | 告警设备信息列表（根据请求中deviceType字段确定返回类型） 参见类型AlarmBriefInfos
cameraBriefInfosV2 | Object | 摄像机设备信息V2版本列表（根据请求中deviceType字段确定返回类型） 参见类型CameraBriefInfosV2

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/device/devicelist/2/1/100

接口返回消息示例数据如下：

{

{

"resultCode": 0,

"cameraBriefInfos": {

"total": 72,

"indexRange": {

"fromIndex": 1,

"toIndex": 3

},

"cameraBriefInfoList": {

"cameraBriefInfo": [

{

"code": "00592900000000000101#0b58e09762554feb93649f724d2df135",

"name": "192.168.40.78",

"deviceGroupCode": "0#0b58e09762554feb93649f724d2df135",

"parentCode": "00592900000000000000",

"domainCode": "0b58e09762554feb93649f724d2df135",

"deviceModelType": "IPC6126-WDL-F",

"vendorType": "HW",

"deviceFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 0,

"netType": 0,

"isSupportIntelligent": 1,

"enableVoice": 0,

"nvrCode": "31231860b3ee484b83a04228c42b35d9",

"deviceCreateTime": "",

"isExDomain": 0,

"deviceIP": "192.168.40.78",

"reserve": ""

},

{

"code": "02149410000000000101#0b58e09762554feb93649f724d2df135",

"name": "192.168.40.70hiksdk",

"deviceGroupCode": "0#0b58e09762554feb93649f724d2df135",

"parentCode": "02149410000000000000",

"domainCode": "0b58e09762554feb93649f724d2df135",

"deviceModelType": "DS-2CD5022GA-XW",

"vendorType": "HIKVISION",

"deviceFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 0,

"netType": 0,

"isSupportIntelligent": 0,

"enableVoice": 0,

"nvrCode": "06339841e22c4f73bda86865019e7c0f",

"deviceCreateTime": "",

"isExDomain": 0,

"deviceIP": "192.168.40.70",

"reserve": ""

},

{

"code": "06655460000000000101#0b58e09762554feb93649f724d2df135",

"name": "192.168.123.107",

"deviceGroupCode": "0#0b58e09762554feb93649f724d2df135",

"parentCode": "06655460000000000000",

"domainCode": "0b58e09762554feb93649f724d2df135",

"deviceModelType": "M1221-V",

"vendorType": "HW",

"deviceFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 0,

"netType": 1,

"isSupportIntelligent": 1,

"enableVoice": 0,

"nvrCode": "4367a3a5c8674ba7b775e0bbabb4bead",

"deviceCreateTime": "",

"isExDomain": 0,

"deviceIP": "192.168.123.107",

"reserve": ""

}

]

}

},

"audioBriefInfos": null,

"alarmBriefInfos": null

}

{

"resultCode": 0,

"cameraBriefInfos": {

"total": 72,

"indexRange": {

"fromIndex": 1,

"toIndex": 3

},

"cameraBriefInfoList": {

"cameraBriefInfo": [

{

"code": "00592900000000000101#0b58e09762554feb93649f724d2df135",

"name": "192.168.40.78",

"deviceGroupCode": "0#0b58e09762554feb93649f724d2df135",

"parentCode": "00592900000000000000",

"domainCode": "0b58e09762554feb93649f724d2df135",

"deviceModelType": "IPC6126-WDL-F",

"vendorType": "HW",

"deviceFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 0,

"netType": 0,

"isSupportIntelligent": 1,

"enableVoice": 0,

"nvrCode": "31231860b3ee484b83a04228c42b35d9",

"deviceCreateTime": "",

"isExDomain": 0,

"deviceIP": "192.168.40.78",

"reserve": ""

},

{

"code": "02149410000000000101#0b58e09762554feb93649f724d2df135",

"name": "192.168.40.70hiksdk",

"deviceGroupCode": "0#0b58e09762554feb93649f724d2df135",

"parentCode": "02149410000000000000",

"domainCode": "0b58e09762554feb93649f724d2df135",

"deviceModelType": "DS-2CD5022GA-XW",

"vendorType": "HIKVISION",

"deviceFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 0,

"netType": 0,

"isSupportIntelligent": 0,

"enableVoice": 0,

"nvrCode": "06339841e22c4f73bda86865019e7c0f",

"deviceCreateTime": "",

"isExDomain": 0,

"deviceIP": "192.168.40.70",

"reserve": ""

},

{

"code": "06655460000000000101#0b58e09762554feb93649f724d2df135",

"name": "192.168.123.107",

"deviceGroupCode": "0#0b58e09762554feb93649f724d2df135",

"parentCode": "06655460000000000000",

"domainCode": "0b58e09762554feb93649f724d2df135",

"deviceModelType": "M1221-V",

"vendorType": "HW",

"deviceFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 0,

"netType": 1,

"isSupportIntelligent": 1,

"enableVoice": 0,

"nvrCode": "4367a3a5c8674ba7b775e0bbabb4bead",

"deviceCreateTime": "",

"isExDomain": 0,

"deviceIP": "192.168.123.107",

"reserve": ""

}

]

}

},

"audioBriefInfos": null,

"alarmBriefInfos": null

}

{

"resultCode": 0,

"cameraBriefInfos": {

"total": 72,

"indexRange": {

"fromIndex": 1,

"toIndex": 3

},

"cameraBriefInfoList": {

"cameraBriefInfo": [

{

"code": "00592900000000000101#0b58e09762554feb93649f724d2df135",

"name": "192.168.40.78",

"deviceGroupCode": "0#0b58e09762554feb93649f724d2df135",

"parentCode": "00592900000000000000",

"domainCode": "0b58e09762554feb93649f724d2df135",

"deviceModelType": "IPC6126-WDL-F",

"vendorType": "HW",

"deviceFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 0,

"netType": 0,

"isSupportIntelligent": 1,

"enableVoice": 0,

"nvrCode": "31231860b3ee484b83a04228c42b35d9",

"deviceCreateTime": "",

"isExDomain": 0,

"deviceIP": "192.168.40.78",

"reserve": ""

},

{

"code": "02149410000000000101#0b58e09762554feb93649f724d2df135",

"name": "192.168.40.70hiksdk",

"deviceGroupCode": "0#0b58e09762554feb93649f724d2df135",

"parentCode": "02149410000000000000",

"domainCode": "0b58e09762554feb93649f724d2df135",

"deviceModelType": "DS-2CD5022GA-XW",

"vendorType": "HIKVISION",

"deviceFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 0,

"netType": 0,

"isSupportIntelligent": 0,

"enableVoice": 0,

"nvrCode": "06339841e22c4f73bda86865019e7c0f",

"deviceCreateTime": "",

"isExDomain": 0,

"deviceIP": "192.168.40.70",

"reserve": ""

},

{

"code": "06655460000000000101#0b58e09762554feb93649f724d2df135",

"name": "192.168.123.107",

"deviceGroupCode": "0#0b58e09762554feb93649f724d2df135",

"parentCode": "06655460000000000000",

"domainCode": "0b58e09762554feb93649f724d2df135",

"deviceModelType": "M1221-V",

"vendorType": "HW",

"deviceFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 0,

"netType": 1,

"isSupportIntelligent": 1,

"enableVoice": 0,

"nvrCode": "4367a3a5c8674ba7b775e0bbabb4bead",

"deviceCreateTime": "",

"isExDomain": 0,

"deviceIP": "192.168.123.107",

"reserve": ""

}

]

}

},

"audioBriefInfos": null,

"alarmBriefInfos": null

}

}

父主题： 设备管理接口


获取子设备列表（新）

获取子设备列表

接口描述

此接口用于获取子设备列表，子设备包括摄像机设备、告警设备、影子摄像机、带互联编码的子设备

使用说明

请求方法 | GET
请求URL | /device/deviceList/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/deviceList/v1.0?deviceType={devicetype}&fromIndex={fromindex}&toIndex={toindex} HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | devicetype | int | 必选 | 设备类型： 2：摄像机设备 4：告警设备 30: 影子摄像机 32:普通摄像机和影子摄像机 33:带有经纬度扩展信息的摄像机 35：摄像机设备V2（带国标编码)
2 | fromIndex | int | 必选 | 开始索引。例如：1
2 | toIndex | int | 必选 | 结束索引，结束索引必须大于或等于开始索引。例如：1000

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
cameraBriefInfos | Object | 摄像机设备信息列表（根据请求中deviceType字段确定返回类型） 参见类型CameraBriefInfos
audioBriefInfos | Object | 语音设备信息列表（根据请求中deviceType字段确定返回类型） 参见类型AudioBriefInfos
alarmBriefInfos | Object | 告警设备/外域告警设备 信息列表（根据请求中deviceType字段确定返回类型） 参见类型AlarmBriefInfos
cameraBriefInfosV2 | Object | 摄像机设备信息V2版本列表（根据请求中deviceType字段确定返回类型） 参见类型CameraBriefInfosV2
shadowCameraBriefInfos | Object | 影子摄像机/普通摄像机和影子摄像机 信息列表（根据请求中deviceType字段确定返回类型） 参见类型▪ShadowCameraBriefInfos
cameraBriefExInfos | Object | 带有经纬度扩展信息的摄像机信息列表（根据请求中deviceType字段确定返回类型） 参见类型•CameraBriefExInfos

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/device/deviceList/v1.0?deviceType=33&fromIndex=1&toIndex=2

接口返回消息示例数据如下：

{

"resultCode": 0,

"cameraBriefInfos": null,

"audioBriefInfos": null,

"alarmBriefInfos": null,

"cameraBriefInfosV2": null,

"shadowCameraBriefInfos": null,

"cameraBriefExInfos": {

"total": 11,

"indexRange": {

"fromIndex": 1,

"toIndex": 2

},

"cameraBriefInfoExList": {

"cameraBriefInfoExes": [

{

"code": "05199871611126810101#d4b895b7110b4e6ca1dbdf30ed41826f",

"name": "10.5.66.7",

"devGroupCode": "0#d4b895b7110b4e6ca1dbdf30ed41826f",

"parentCode": "05199871611126810000",

"domainCode": "d4b895b7110b4e6ca1dbdf30ed41826f",

"devModelType": "DS-2CD4826FWD-IZHS",

"vendorType": "HIKVISION",

"devFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 1,

"netType": 0,

"supportIntelligent": 0,

"enableVoice": 0,

"nvrCode": "72752469a449448eb2977cc9a87a1237",

"devCreateTime": "20191115085424",

"isExDomain": 0,

"devIp": "10.5.66.7",

"longitude": "",

"latitude": "",

"height": 0,

"reserve": ""

},

{

"code": "10659703091543650101#d4b895b7110b4e6ca1dbdf30ed41826f",

"name": "10.5.66.23",

"devGroupCode": "0#d4b895b7110b4e6ca1dbdf30ed41826f",

"parentCode": "10659703091543650000",

"domainCode": "d4b895b7110b4e6ca1dbdf30ed41826f",

"devModelType": "IPC6325-WD-VF",

"vendorType": "HW",

"devFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 1,

"netType": 0,

"supportIntelligent": 1,

"enableVoice": 0,

"nvrCode": "9a2d7666f13a433db66a6a6208f05c98",

"devCreateTime": "20191115072711",

"isExDomain": 0,

"devIp": "10.5.66.23",

"longitude": "",

"latitude": "",

"height": 0,

"reserve": ""

}

]

}

}

}

父主题： 设备管理接口


获取设备组列表信息

接口描述

此接口用于获取设备组列表信息。系统支持一个设备组下最多5000个子设备组

使用说明

请求方法 | GET
请求URL | /device/devicegroup/{devicegroupcode}/{domaincode}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/devicegroup/{devicegroupcode}/{domaincode} HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | devicegroupcode | Integer | 必选 | 设备组编码。根设备组编码为0
2 | domaincode | String | 必选 | 设备组所属域编码

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
deviceGroupInfos | Object | 设备组列表 参见类型DeviceGroupInfos

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/device/devicegroup/0/43b42979e85d4c0bb4e59b3e9724b675

接口返回消息示例数据如下：

{

"resultCode": 0,

"deviceGroupInfos": {}

}

父主题： 设备管理接口


添加设备

接口描述

此接口用于用于添加设备，如IPC、NVR、DVR等，支持批量添加

使用说明

请求方法 | POST
请求URL | /device/maindevice/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /device/maindevice/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | domainCode | String | 必选 | 域编码，可通过获取域路由接口获取 示例：d9808a7bfff94de09ecc47a6baa3bf5d
2 | deviceNum | Integer | 必选 | 批量增加的设备数量
3 | deviceOperInfos | Object | 必选 | 需要增加的设备信息列表，类型参见•DeviceOperInfos

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | deviceOperResultInfos | Object | 增加设备服务端返回操作结果，参见类型•DeviceOperResultInfos

使用示例

接口请求消息示例如下：

{

"domainCode": "4f297e89479e4867bf38ec5af75679d8",

"deviceNum": 1,

"deviceOperInfos": {

"deviceOperInfo": [

{

"sequence": 1,

"deviceConfig": {

"deviceBasicInfo": {

"type": 1,

"serialNumber": "100",

"code": "51866666660000000000",

"name": "better_ipc_restful",

"parentCode": "",

"domainCode": "4f297e89479e4867bf38ec5af75679d8",

"vendorType": "HW",

"model": "IPC6225-VRZ-SP",

"ipInfo": {

"ipType": 0,

"ip": "192.168.14.9"

},

"port": 5060

},

"protocolType": "HWSDK",

"loginType": 0,

"enableAlarm": 1,

"videoFormat": 1,

"directConnectFirst": 0,

"maxDirectConnectNum": 3,

"enableSchedule": 1,

"nvrCode": "a770c75947264dedb3b070fde7e96ad9",

"tasCode": "",

"deviceUser": "admin",

"devicePassword": "ChangeMe@123",

"deviceRegPassword": "",

"deviceChannel": {

"maxVideoNum": 1,

"maxAudioInNum": 1,

"maxAudioOutNum": 1,

"maxAlarmInNum": 2,

"maxAlarmOutNum": 2,

"maxSerialNum": 1

}

}

}

]

}

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"deviceOperResultInfos": {

"number": 1,

"deviceOperResultList": {

"deviceOperResult": [

{

"deviceCode": "51866666660000000000",

"nvrCode": "20e7cc4b50164144a351ced66098db93",

"sequence": 1,

"result": 0

}

]

}

}

}

父主题： 设备管理接口


删除设备

接口描述

此接口用于删除设备，支持批量删除。注意在新版本中，该接口功能是一个软删除接口，即延迟删除设备，被删除的设备实际仍然存在，30天后未恢复才会彻底删除，或者调用彻底删除设备接口对被软删除的设备再进行一次彻底删除。

使用说明

请求方法 | DELETE
请求URL | /device/maindevice/v1.0
请求数据 | text/xml;charset=UTF-8

HTTP Header示例如下：

DELETE /device/maindevice/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | domainCode | String | 必选 | 域编码，可通过获取域路由接口获取 示例：d9808a7bfff94de09ecc47a6baa3bf5d
2 | deviceNum | Integer | 必选 | 批量删除的设备数目，正整数
3 | deviceCodeList | Object | 必选 | 设备编码列表，参见类型•DeviceCodeList

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | resultInfos | Object | 操作结果信息，参见类型 ResultInfos

使用示例

接口请求消息示例如下：

{

"domainCode": "4f297e89479e4867bf38ec5af75679d8",

"deviceNum": 1,

"deviceCodeList": {

"deviceCode": ["51866666660000000000"]

}

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"resultInfos": {

"number": 1,

"resultInfoList": {

"resultInfo": [

{

"sequence": 0,

"result": 0,

"code": "51866666660000000000"

}

]

}

}

}

父主题： 设备管理接口


彻底删除设备

接口描述

此接口用于彻底删除设备，支持一次删除多个设备。此接口有两种调用方式：1、用于对在设备回收站中的那些已被删除一次的设备进行第二次的彻底性删除。2、直接调用此接口，对设备进行彻底删除。

使用说明

请求方法 | DELETE
请求URL | /device/maindevice/recyclemaindevice/v1.0
请求数据 | text/xml;charset=UTF-8

HTTP Header示例如下：

DELETE /device/maindevice/recyclemaindevice/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | domainCode | String | 必选 | 域编码，可通过获取域路由接口获取 示例：d9808a7bfff94de09ecc47a6baa3bf5d
2 | deviceNum | Integer | 必选 | 批量删除的设备数目，正整数
3 | deviceCodeList | Object | 必选 | 设备编码列表，参见类型 DeviceCodeList

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | resultInfos | Object | 操作结果信息，参见类型 ResultInfos

使用示例

接口请求消息示例如下：

{

"domainCode": "4f297e89479e4867bf38ec5af75679d8",

"deviceNum": 1,

"deviceCodeList": {

"deviceCode": ["51866666660000000000"]

}

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"resultInfos": {

"number": 1,

"resultInfoList": {

"resultInfo": [

{

"sequence": 0,

"result": 0,

"code": "51866666660000000000"

}

]

}

}

}

父主题： 设备管理接口


修改设备名称

接口描述

此接口用于修改主设备名称。

使用说明

请求方法 | PUT
请求URL | /device/maindevicename/v1.0
请求数据 | text/xml;charset=UTF-8

HTTP Header示例如下：

PUT /device/maindevicename/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | deviceCode | String | 必选 | 设备编码#域编码 域编码通过获取域路由接口获取 示例：51277777770000000000#d9808a7bfff94de09ecc47a6baa3bf5d
2 | newDeviceName | String | 必选 | 主设备新名字

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"deviceCode": "51277777770000000000#d9808a7bfff94de09ecc47a6baa3bf5d",

"newDeviceName": "newName"

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 设备管理接口


启动搜索前端设备

接口描述

此接口用于启动搜索前端设备任务。启动搜索前端设备后，服务端通过事件推送方式告知发现的设备和搜索进度。

使用说明

请求方法 | POST
请求URL | /device/mainDevice/startSearch/v1.0
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | domainCode | String | 必须 | 域编码，设备的域编码，非用户所在的域编码
2 | searchInfo | String | 必须 | 设备搜索信息XML，具体如表 设备搜索信息XML所示。

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

https://192.168.203.36:18531/device/mainDevice/startSearch/v1.0

接口请求消息示例数据如下：

{

"domainCode"："089d6ae965674667bf7f9e5339f8e76b",设备的域编码

"searchInfo"："<Content><SearchInfo><ProtocolType>HWSDK</ProtocolType><DevModelType>MPU46</DevModelType><ServerCode>f563c8bc3f8240009637a9edd500ca19</ServerCode><IPList><IPInfo><DevIPFrom>10.170.54.45</DevIPFrom><DevIPTo>10.170.54.50</DevIPTo><DevPort></DevPort></IPInfo></IPList></SearchInfo></Content>"

}

接口返回消息示例数据如下：

{

"resultCode"：0表示成功，其他表示失败，整形

}

表1 设备搜索信息XML

属性

必选/可选

描述

Content

必须

消息体根节点

SearchInfo

必须

搜索信息

ProtocolType

必须

主设备协议类型(长度限制64位非中文字符):

  • TEYES：千里眼
  • ONVIF：开放型网络视频接口论坛
  • HWSDK：华为SDK
  • HIKSDK：海康SDK
  • T28181
  • DHSDK：大华SDK
  • HBSDK
  • HESDK
  • HIKSDK2：海康SDK2
  • DHSDK2：大华SDK2

DevModelType

可选

主设备型号（由各设备厂家提供，长度限制32位非中文字符）

ServerCode

可选

接入服务器编码，具体说明如下：

  • 集群模式时可以不选该节点，如果填写只需要填写tasCode
  • 堆叠模式时必选该节点，需要填写tasCode或者nvrCode

IPList

必须

IP地址段列表

IPInfo

可选

IP信息

DevIPFrom

必须

起始IP地址（点分十进制格式，例如：10.166.166.126）

DevIPTo

必须

截止IP地址（点分十进制格式，例如：10.166.166.126）

DevPort

必须

端口（例如：8000），该字段必须存在，但字段内容可以为空
父主题： 设备管理接口


停止搜索前端设备

接口描述

此接口用于停止已启动的搜索前端设备任务。停止搜索前端设备后，服务端通过事件推送方式告知搜索前端设备任务停止。

使用说明

请求方法 | POST
请求URL | /device/mainDevice/stopSearch/v1.0
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | domainCode | String | 必须 | 域编码，设备的域编码
2 | searchInfo | String | 必须 | 设备搜索信息XML，具体如表 设备搜索信息XML所示。

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

https://192.168.203.36:18531/device/mainDevice/stopSearch/v1.0

接口请求消息示例数据如下：

{

"domainCode"："089d6ae965674667bf7f9e5339f8e76b",设备的域编码

"searchInfo"："<Content><ServerCode>f563c8bc3f8240009637a9edd500ca19</ServerCode></Content>"

}

接口返回消息示例数据如下：

{

"resultCode"：0表示成功，其他表示失败，整形

}

表1 设备搜索信息XML

属性

必选/可选

描述

Content

必须

消息体根节点

ServerCode

可选

接入服务器编码，具体说明如下：

  • 集群模式时可以不选该节点，如果填写只需要填写tasCode
  • 堆叠模式时必选该节点，需要填写tasCode或者nvrCode
父主题： 设备管理接口


验证前端设备

接口描述

此接口用于搜索发现前端设备后，验证前端设备是否可以接入管理服务器。

使用说明

请求方法 | POST
请求URL | /device/mainDevice/verify/v1.0
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | domainCode | String | 必须 | 域编码，设备的域编码，可通过获取域路由信息
2 | verifyInfo | String | 必须 | 设备验证信息XML，具体如表 设备验证信息XML。

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | responseXML | String | 验证结果XML，具体如表 验证结果XML所示。

使用示例

https://192.168.203.36:18531/device/mainDevice/verify/v1.0

接口请求消息示例数据如下：

{

"domainCode"："089d6ae965674667bf7f9e5339f8e76b",，设备的域编码

"verifyInfo"："<Content><ValidateInfo><ServerCode>4322119b0bd34114861e3ac662c13277</ServerCode><ProtocolType>HIKSDK</ProtocolType><DevIP>172.22.8.111</DevIP> <DevPort>8000</DevPort><DevUser>admin</DevUser><DevPWD>123456</DevPWD></ValidateInfo></Content>"

}

接口返回消息示例数据如下：

{

"resultCode"：0表示成功，其他表示失败，整形

"responseXML":"<Content><DevInfo><DevVendor>HIKVISION</DevVendor><DevModelType>IPDOME</DevModelType><DevSN>DS-2DF1-617H-B0020110120BCWR402633188WC</DevSN></DevInfo></Content>"

}

表1 设备验证信息XML

属性

必选/可选

描述

Content

必须

消息体根节点

ValidateInfo

必须

验证信息

ServerCode

必须

接入服务器

ProtocolType

必须

主设备协议类型：（长度限制64位非中文字符）

  • TEYES：千里眼
  • ONVIF：开放型网络视频接口论坛
  • HWSDK：华为SDK
  • HIKSDK：海康SDK
  • T28181
  • DHSDK：大华SDK
  • HBSDK
  • HESDK
  • HIKSDK2：海康SDK2
  • DHSDK2：大华SDK2

DevIP

必须

前端设备IP地址（点分十进制格式，例如：10.166.166.126）

DevPort

必须

端口（例如：8000）

DevUser

可选

设备登录用户名

DevPWD

可选

设备登录密码

表2 验证结果XML

属性 |  |  | 必选/可选 | 描述
Content |  |  | 必须 | 消息体根节点
 | DevInfo |  | 可选 | 设备信息(验证通过时有该节点)
 |  | DevVendor | 必须 | 设备厂商
 |  | DevModelType | 必须 | 设备型号
 |  | DevSN | 必须 | 设备SN号
父主题： 设备管理接口


设备信令透传下发

接口描述

设备信令透传接口。只支持本域HWSDK接入的设备。且SDC版本为8.0.1及其之后版本。

支持下发设备配置或查询类信令到摄像机。

使用说明

请求方法 | POST
请求URL | /device/request/passthrough/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /device/request/passthrough/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 可选/必选 | 描述
cameraCode | String | 必选 | 摄像机编码，不带域编码默认为本域
info | CameraPassThroughInfo | 必选 | 参见类型▪CameraPassThroughInfo

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
resultInfo | Object | 详细透传数据

使用示例

接口请求消息示例如下：

{

"cameraCode":"03851633529920350000#f0cb964f27f343c1947d11aeaa72d01e",

"info":{

"requestUrl":""GET /SDCAPI/V1.0/VideoIaas/Channels/VO/Capability""

}

}

接口响应消息示例如下：

{

"resultCode": 0,

"resultInfo": "[{\"CameraCode\":\"06260371755602440000\",\"Data\":[{\"Support\":false,\"channelNo\":101,\"param\":{\"channelNo\":101}}],\"DomainCode\":\"4bccb1362d1542c8acb5da3fb7b43060\",\"RspCode\":0}]\n"

}

父主题： 设备管理接口


查询主设备列表

接口描述

此接口用于查询主设备列表。

使用说明

请求方法 | GET
请求URL | /device/masterDeviceList/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/mainList/v1.0?domainCode=6686e2ae61c540f4a38abffcca13465b&NVRCode=a87f463b7dd741908668c89c84a27e30&fromIndex=1&toIndex=20 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数

类型

可选/必选

描述

domainCode

String

必选

设备所属域编码(必须)。例如：6686e2ae61c540f4a38abffcca13465b

NVRCode

String

必选

设备所属NVR编码。例如：a87f463b7dd741908668c89c84a27e30

deviceType

Integer

必选

设备类型，取值为

  • 1：主设备
  • 34：主设备，带互联编码

fromIndex

int

非必选

开始索引,默认值：1。例如：1

toIndex

int

非必选

结束索引，结束索引必须大于或等于开始索引，默认值：1000。例如：1000

响应参数

参数 | 类型 | 可选/必选 | 描述
resultCode | int | 必选 | 成功返回0，失败返回错误码
deviceBriefInfos | Object | 必选 | 主设备信息列表参数。详见 DeviceBriefInfos

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/device/masterDeviceList/v1.0?domainCode=f7e3c94ecb634094b31d888c02e34b5c&fromIndex=1&toIndex=20&NVRCode=6acdec984d554cffa4d9887c8ecfd8d3&deviceType=34

接口响应消息示例如下：

{

"resultCode": 0,

"deviceBriefInfos": {

"total": 8,

"indexRange": {

"fromIndex": 1,

"toIndex": 10

},

"reserve": "",

"deviceBriefInfoV2": [

{

"protocolType": "HWSDK",

"loginType": 0,

"enableSchedule": 1,

"status": 1,

"deleteStatus": 1,

"reserve": "",

"deviceBasicInfoV2": {

"type": 1,

"serialNumber": "2102353CCKRSK9000049",

"code": "02909227649042900000",

"name": "10.5.66.37",

"parentCode": "",

"domainCode": "",

"vendorType": "HW",

"model": "M6620-10-EZ23",

"ipInfo": {

"ipType": 0,

"ip": "10.5.66.37"

},

"port": 0,

"connectCode": "02909227649042900000",

"reserve": "",

"unifiedAccessCode": ""

}

},

{

"protocolType": "HWSDK",

"loginType": 0,

"enableSchedule": 1,

"status": 1,

"deleteStatus": 1,

"reserve": "",

"deviceBasicInfoV2": {

"type": 1,

"serialNumber": "2102352WDCRSK7000044",

"code": "02909227643098860000",

"name": "10.5.66.45",

"parentCode": "",

"domainCode": "",

"vendorType": "HW",

"model": "M2140-EFI(6mm)",

"ipInfo": {

"ipType": 0,

"ip": "10.5.66.45"

},

"port": 0,

"connectCode": "02909227643098860000",

"reserve": "",

"unifiedAccessCode": ""

}

}

]

}

}

父主题： 设备管理接口


大联网分层展现接口(本域)

接口描述

大联网分层展现接口, 分层加载获取指定类型的子设备列表，包含摄像机设备、告警设备的列表。

使用说明

请求方法 | GET
请求URL | /device/localLevelList/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/localLevelList/v1.0?domainCode={domainCode}&groupCode={groupCode}&deviceType={deviceType}&fromIndex={fromIndex}&toIndex={toIndex}&isIncludeSubGroup={isIncludeSubGroup} HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 可选/必选 | 描述
domainCode | String | 必选 | 设备所属域编码(必须)。例如：fd949d5637bb40988ee155f27d47f74b
groupCode | Integer | 必选 | 组ID编码,根设备组的编码为0。从0开始递增的正整数 例如：0，长度限制128字节
deviceType | int | 必选 | 设备类型。 2:摄像机设备 4:告警设备（同时获取告警输入、告警输出） 30:影子摄像机 32:普通摄像机和影子摄像机 33:有经纬度扩展信息的摄像机 35:带互联编码的子设备信息
isIncludeSubGroup | Integer | 必选 | 0-只查询当前组 ，1-查询当前组及其子组；当设备类型为告警设备时只能查询当前组信息。
fromIndex | int | 可选 | 开始索引。默认值为1
toIndex | int | 可选 | 结束索引，结束索引必须大于或等于开始索引。默认值为1000

响应参数

参数 | 类型 | 可选/必选 | 描述
resultCode | int | 必选 | 成功返回0，失败返回错误码
cameraInfo | Object | 必选 | 主设备信息列表参数。详见▪CameraInfo

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/device/localLevelList/v1.0?domainCode=887ba4a217cb47028201ff2a6b0a024d&groupCode=87853772788654&deviceType=3&fromIndex=1&toIndex=10&isIncludeSubGroup=1

接口响应消息示例如下：

{

"resultCode": 0,

"cameraInfo": {

"total": 1,

"indexRange": {

"fromIndex": 1,

"toIndex": 10

},

"reserve": null,

"cameraBriefInfoEx": [

{

"code": "09017854308065730101#fd949d5637bb40988ee155f27d47f74b",

"name": "axis_1",

"deviceGroupCode": "0#fd949d5637bb40988ee155f27d47f74b",

"parentCode": "09017854308065730000",

"domainCode": "fd949d5637bb40988ee155f27d47f74b",

"deviceModelType": "P1344",

"vendorType": "AXIS",

"deviceFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 1,

"netType": 0,

"isSupportIntelligent": 0,

"enableVoice": 0,

"nvrCode": "52879a2bf82e463ab88ea0f2618d8e0a",

"deviceCreateTime": "20191112100049",

"isExDomain": 0,

"deviceIp": "10.5.66.39",

"longitude": "",

"latitude": "",

"height": 0,

"isShadowDev": 0,

"origDevCode": "",

"origParentDevCode": "",

"oriDevDomainCode": "",

"haveAlarmLinkage": 0,

"deleteStatus": 1,

"connectCode": "09017854308065730101",

"supportGA1400": 0,

"reserve": ""

}

]

}

}

父主题： 设备管理接口


大联网分层展现接口(外域)

接口描述

大联网分层展现接口, 分层加载获取指定类型的子设备列表，包含摄像机设备、告警设备的列表。

使用说明

请求方法 | GET
请求URL | /device/externLevelList/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/externLevelList/v1.0?domainCode={domainCode}&groupCode={groupCode}&deviceType={deviceType}&fromIndex={fromIndex}&toIndex={toIndex}&isIncludeSubGroup={isIncludeSubGroup} HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 可选/必选 | 描述
domainCode | String | 必选 | 设备所属域编码(必须)。例如：fd949d5637bb40988ee155f27d47f74b
groupCode | String | 必选 | 组ID编码。例如：0
deviceType | Integer | 必选 | 设备类型: 4:告警设备（同时获取告警输入、告警输出） 35:带互联编码的子设备信息
isIncludeSubGroup | Integer | 必选 | 0-只查询当前组 ，1-查询当前组及其子组；当设备类型为告警设备时只能查询当前组信息。
fromIndex | Integer | 可选 | 开始索引。默认值为1
toIndex | Integer | 可选 | 结束索引，结束索引必须大于或等于开始索引。默认值为1000

响应参数

参数 | 类型 | 可选/必选 | 描述
resultCode | int | 必选 | 成功返回0，失败返回错误码
cameraInfo | Object | 必选 | 主设备信息列表参数。详见▪CameraInfo

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/device/externLevelList/v1.0?domainCode=887ba4a217cb47028201ff2a6b0a024d&groupCode=87853772788654&deviceType=3&fromIndex=1&toIndex=10&isIncludeSubGroup=1

接口响应消息示例如下：

{

"resultCode": 0,

"cameraInfo": {

"total": 1,

"indexRange": {

"fromIndex": 1,

"toIndex": 10

},

"reserve": null,

"cameraBriefInfoEx": [

{

"code": "09017854308065730101#fd949d5637bb40988ee155f27d47f74b",

"name": "axis_1",

"deviceGroupCode": "0#fd949d5637bb40988ee155f27d47f74b",

"parentCode": "09017854308065730000",

"domainCode": "fd949d5637bb40988ee155f27d47f74b",

"deviceModelType": "P1344",

"vendorType": "AXIS",

"deviceFormType": 1,

"type": 0,

"cameraLocation": "",

"cameraStatus": 1,

"status": 1,

"netType": 0,

"isSupportIntelligent": 0,

"enableVoice": 0,

"nvrCode": "52879a2bf82e463ab88ea0f2618d8e0a",

"deviceCreateTime": "20191112100049",

"isExDomain": 0,

"deviceIp": "10.5.66.37",

"longitude": "",

"latitude": "",

"height": 0,

"isShadowDev": 0,

"origDevCode": "",

"origParentDevCode": "",

"oriDevDomainCode": "",

"haveAlarmLinkage": 0,

"deleteStatus": 1,

"connectCode": "09017854308065730101",

"supportGA1400": 0,

"reserve": ""

}

]

}

}

父主题： 设备管理接口


设置摄像机IP与国标编码映射关系

接口描述

深圳局点使用，其余使用前请咨询华为工程师。

此接口用于设置摄像机IP与国标编码映射关系，并标明是否为双仓摄像机。

使用说明

请求方法 | PUT
请求URL | /device/cameraIpRelation/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

PUT /device/cameraIpRelation/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 可选/必选 | 描述
domainCode | String | 可选 | 域编码，可通过获取域路由接口获取示例。(只支持本域，不传默认本域)
cameraList | Object | 必选 | 设备信息列表 参见类型 •IpNoRelationList

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
cameraResultList | Object | 返回失败结果列表 CameraResultList，resultcode为0设置成功时，无该字段

使用示例

接口请求消息示例如下：

{

"cameraList": {

"cameraInfo": [{

"channelNo": 1,

"connectCode": "00054113041319470101",

"ip": "172.16.5.26"

},

{

"channelNo": 1,

"connectCode": "00044113041319470101",

"ip": "172.16.5.27"

}

]

},

"domainCode": "a5173ff9ce0649ee855664a2838466aa"

}

接口响应消息示例如下：

{

"resultCode": 0

}

父主题： 设备管理接口


删除摄像机IP与国标编码映射关系

接口描述

深圳局点使用，其余使用前请咨询华为工程师。

此接口用于删除摄像机IP与国标编码映射关系。

使用说明

请求方法 | DELETE
请求URL | /device/cameraIpRelation/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

DELETE /device/cameraIpRelation/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 可选/必选 | 描述
domainCode | String | 可选 | 域编码，可通过获取域路由接口获取示例。(只支持本域，不传默认本域)
cameraList | Object | 必选 | 设备信息列表 参见类型 IpNoRelationList

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
cameraResultList | Object | 返回失败结果列表 CameraResultList，resultcode为0删除成功时，无该字段

使用示例

接口请求消息示例如下：

{

"cameraList": {

"cameraInfo": [{

"channelNo": 1,

"connectCode": "00054113041319470101",

"ip": "192.168.203.36"

},

{

"channelNo": 1,

"connectCode": "00044113041319470101",

"ip": "192.168.203.36"

}

]

},

"domainCode": "a5173ff9ce0649ee855664a2838466aa"

}

接口响应消息示例如下：

{

"resultCode": 0

}

父主题： 设备管理接口


获取摄像机信息

接口描述

深圳局点使用，其余使用前请咨询华为工程师。

此接口用于获取单个摄像机基本信息，包括摄像机ID、国标编码、创建时间、域编码、域名，注意如果是双仓摄像机，只会返回摄像机第一个通道的信息。

使用说明

请求方法 | GET
请求URL | /device/cameraList/v1.0/{codeType}/{cameraCode }/{domainCode}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/cameraList/v1.0/{codeType}/{cameraCode }/{domainCode}

HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 可选/必选 | 描述
codeType | int | 必选 | 摄像机编码类型，即cameraCode字段的类型， 0:摄像机平台编码，1:摄像机国标编码
cameraCode | String | 必选 | 与codeType配合使用 codeType：0 填写摄像机编码 codeType：1 摄像机国标编码
domainCode | String | 必选 | 域编码，可通过获取域路由接口获取示例。(只支持本域，不传默认本域)

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
cameraInfo | Object | 返回结果 CameraInfo信息

使用示例

请求消息：

https://192.168.203.36:18531/device/cameraList/v1.0/0/04598710000000000001/d9808a7bfff94de09ecc47a6baa3bf5d

响应消息：

{

"resultCode": 0,

"cameraInfo": {

"cameraCode": "04598710000000000001",

"connectCode": "04598710131000000001",

"ip": "192.168.100.101",

"createTime": "20191028100800",

"domainCode": "d9808a7bfff94de09ecc47a6baa3bf5d",

"domainName": "domain name"

}

}

父主题： 设备管理接口


获取摄像机列表

接口描述

深圳局点使用，其余使用前请咨询华为工程师。

此接口用于获取摄像机基本信息列表，包括摄像机ID、国标编码、创建时间、域编码、域名，注意如果是双仓摄像机，只会返回摄像机第一个通道的信息。

使用说明

请求方法 | GET
请求URL | /device/cameraList/v1.0?domaincode={domaincode}&fromIndex={fromIndex}&endIndex={endIndex}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/cameraList/v1.0?domaincode={domaincode}&fromIndex={fromIndex}&endIndex={endIndex} HTTP/1.1

Host: 192.168.203:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 可选/必选 | 描述
domainCode | String | 可选 | 域编码，可通过获取域路由接口获取示例。(只支持本域，不传默认本域)
fromIndex | int | 可选 | 查询起始索引，需和endIndex配对使用，不传递默认查询1-1000
endIndex | int | 可选 | 查询结束索引，需和fromIndex配对使用，不传递默认查询1-1000

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
cameraInfoList | Object | 返回结果 •CameraInfoList信息

接口请求消息示例如下：

https://192.168.203:18531/device/cameralist/v1.0?domaincode=d9808a7bfff94de09ecc47a6baa3bf5d&fromIndex=1&endIndex=1000

接口返回消息示例数据如下：

{

"resultCode": 0,

"cameraInfoList": {

"cameraInfo": [

{

"cameraCode": "00044113043129470101",

"connectCode": "00054113041319470101",

"ip": "10.16.60.8",

"createTime": "20191110145843",

"domainCode": "a5173ff9ce0649ee855664a2838466aa",

"domainName": "a5173ff9ce0649ee855664a2838466aa"

},

{

"cameraCode": "00044113048410710101",

"connectCode": "00054113041319470101",

"ip": "10.16.60.20",

"createTime": "20191110145842",

"domainCode": "a5173ff9ce0649ee855664a2838466aa",

"domainName": "a5173ff9ce0649ee855664a2838466aa"

}

]

}

}

父主题： 设备管理接口


告警管理接口

  • 告警订阅请求
  • 告警订阅查询
  • 告警上报
  • 告警确认
  • 告警撤销
  • 新增告警联动策略
  • 修改告警联动策略
  • 删除告警联动策略
  • 获取告警联动策略详情
  • 获取告警联动策略列表
  • 获取告警联动策略动作详情
  • 查询OMU告警事件列表


告警订阅请求

接口描述

此接口用于订阅告警信息

使用说明

请求方法 | POST
请求URL | /device/subscribealarm
请求数据 | text/xml;charset=UTF-8

HTTP Header示例如下：

POST /device/subscribealarm HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 必选/可选 | 描述
requestXML | String | 必选 | 告警订阅请求XML，具体如表1所示

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"requestXML":"<Content><DomainCode>064822d55df846d49b471d4806802500</DomainCode><Subscribe><SubscriberInfo><Subscriber>2</Subscriber><SubscriberID>1</SubscriberID><UserDomainCode>064822d55df846d49b471d4806802500</UserDomainCode></SubscriberInfo><SubscribeList><SubscribeInfo><AlarmInCode>32451937314580530101</AlarmInCode><SubscribeType>1</SubscribeType><AlarmLevelValueMin/><AlarmLevelValueMax/><AlarmTypeList><AlarmType>ALARM_INTRUSION</AlarmType></AlarmTypeList></SubscribeInfo></SubscribeList><DelSubscribeList/></Subscribe></Content>"

}

接口返回消息示例数据如下：

{

"resultCode": 0,

}

补充说明告警推送消息体"PreviewUrl"为预留节点,目前无填充值,具体"eventType"对应的"eventData"对应xml结构中各个节点业务含义可以通过eSDK IVS V200R019C20 接口参考 01(客户端,API)-->附录-->告警类型-->事件类型定义中查询,如下:

{

"eventData":

"<Content>\n

<AlarmEventId>0</AlarmEventId>\n

<AlarmInCode>06326867552491310000#1680d4ac1d68436db75c4b0a5777af3d</AlarmInCode>\n

<DevDomainCode>1680d4ac1d68436db75c4b0a5777af3d</DevDomainCode>\n

<AlarmInType>1</AlarmInType>\n

<AlarmInName>1_0_2_26</AlarmInName>\n

<AlarmLevelValue>100</AlarmLevelValue>\n

<AlarmLevelName></AlarmLevelName>\n

<AlarmLevelColor>#ffff0000</AlarmLevelColor>\n

<AlarmType>ALARM_IPC_OFFLINE</AlarmType>\n

<AlarmTypeName></AlarmTypeName>\n

<AlarmCategory>03</AlarmCategory>\n

<OccurTime>20190813235045</OccurTime>\n

<OccurNumber>1</OccurNumber>\n

<AlarmStatus>0</AlarmStatus>\n

<IsCommission>0</IsCommission>\n

<PreviewUrl></PreviewUrl>\n

<ExistsRecord>0</ExistsRecord>\n

<NVRCode>0923a180637f4b1d86391d3dc896653b</NVRCode>\n

<AlarmDesc></AlarmDesc>\n

<ExtParam>HostIP=172.22.0.112,deviceCode=0923a180637f4b1d86391d3dc896653b,LocalDesc=DecisionSequence:54</ExtParam>\n

</Content>",

"eventType": "10013"

}

表1 告警订阅请求XML

属性

可选/必选

描述

Content

必选

消息体根节点

DomainCode

必选

消息目标域

Subscribe

必选

告警订阅信息

SubscriberInfo

必选

订阅者信息

Subscriber

必选

订阅者：

  • 1：本域用户
  • 2：外域（域间订阅）

SubscriberID

必选

订阅者ID：

  • 订阅者是本域用户时为用户ID
  • 订阅者是外域用户时为外域ID，即请求域的域互联编码

AddSubscribeList

可选

新增告警订阅列表

SubscribeInfo

必选

单条告警订阅信息

AlarmInCode

必选

告警源编码

SubscribeType

必选

订阅方式：

  • 1：所有
  • 2：按告警类型
  • 3：按告警级别

AlarmLevelValueMin

可选

告警级别下限值。订阅方式为“3-按告警级别”必须有该节点，其他类型时可以没有该节点

AlarmLevelValueMax

可选

告警级别上限值。订阅方式为“3-按告警级别”必须有该节点，其他类型时可以没有该节点

AlarmTypeList

可选

告警类型列表。当订阅方式为“2-按告警类型”时，必须有该节点

AlarmType

必选

告警类型，不可为空，详见告警类型

DevDomainCode

必选

设备所在域编码

DelSubscribeList

否

删除告警订阅列表

SubscribeInfo

必选

单条告警订阅信息

AlarmInCode

必选

告警源编码

DevDomainCode

必选

设备所在域编码
父主题： 告警管理接口


告警订阅查询

接口描述

此接口用于查询用户已订阅的告警信息

使用说明

请求方法 | POST
请求URL | /device/subscribealarmquery
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /device/subscribealarmquery HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 必选/可选 | 描述
requestXML | String | 必选 | 告警订阅查询请求XML，具体如表1所示。

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
responseXML | String | 告警订阅查询响应XML，具体如表2所示。

使用示例

接口请求消息示例如下：

{

"requestXML": "<Content><DomainCode>43b42979e85d4c0bb4e59b3e9724b675</DomainCode><PageInfo><FromIndex>1</FromIndex><ToIndex>3</ToIndex></PageInfo><Subscribe><SubscriberInfo><Subscriber>1</Subscriber><SubscriberID>1</SubscriberID></SubscriberInfo></Subscribe></Content>"

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"responseXML": ""

}

表1 告警订阅查询请求XML

属性

是否必选

描述

Content

是

消息体根节点

DomainCode

是

消息目标域

PageInfo

是

分页信息

FromIndex

是

从第几条记录开始返回，第1条记录的索引值为1

ToIndex

是

截止第几条记录

Subscribe

是

告警订阅信息

SubscriberInfo

是

订阅者信息：

  • 如果订阅者是本域用户，则表示要查询的信息为该用户订阅的告警信息，目标设备可以为本域能见的所有设备
  • 如果订阅者是外域用户，则表示要查询的信息为向外域注册的告警信息，目标设备为该外域能见设备

Subscriber

是

订阅者：

  • 1：本域用户
  • 2：外域用户（域间订阅）

SubscriberID

是

订阅者ID：

  • 订阅者是本域用户时为用户ID
  • 订阅者是外域用户时为外域ID，即请求域的域互联编码

表2 告警订阅查询响应XML

属性

是否必选

描述

Content

是

消息体根节点

ResultCode

是

操作结果，成功为0，失败返回错误码

PageInfo

是

分页信息

RealNum

是

总的符合条件的记录数

FromIndex

是

从第几条记录开始

ToIndex

是

截止第几条记录

SubscribeList

否

告警订阅列表

SubscribeInfo

是

单条告警订阅信息

AlarmInCode

是

告警源编码

SubscribeType

是

订阅方式：

  • 1：所有
  • 2：按告警类型
  • 3：按告警级别

AlarmLevelValueMin

否

告警级别下限值。订阅方式为“3-按告警级别”必须有该节点，其他类型时可以没有该节点

AlarmLevelValueMax

否

告警级别上限值。订阅方式为“3-按告警级别”必须有该节点，其他类型时可以没有该节点

AlarmTypeList

否

告警类型列表。当订阅方式为“2-按告警类型”时，必须有该节点

AlarmType

是

告警类型。有告警类型列表节点时，至少有一个告警类型节点。详见告警类型
父主题： 告警管理接口


告警上报

接口描述

此接口用于手动上报告警信息。一般用于第三方告警系统将告警信息上报给平台时使用。

使用说明

请求方法 | POST
请求URL | alarm/report/v1.0
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | alarmReportInfo | Object | 必须 | 告警上报信息•AlarmReportInfo

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

https://192.168.203.36:18531/alarm/report/v1.0

接口请求消息示例数据如下：

{

"alarmReportInfo": 告警上报信息

{

"alarmInCode":告警源编码，字符串类型

"deviceDomainCode":告警源所属域编码，字符串类型

"alarmType":告警类型，字符串类型

"occurTime":告警发生时间，字符串类型

"reportTime":告警上报时间，字符串类型

"action":操作类型，0：告警消除，1：告警上报，整型

"alarmId":告警ID，字符串类型

"occurNumber":告警发生次数，整形

"nvrCode":告警源所属NVR编码，字符串类型

"alarmDesc":告警描述信息，字符串类型

}

}

接口返回消息示例数据如下：

{

"resultCode"：0表示成功，其他表示失败，整形

}

父主题： 告警管理接口


告警确认

接口描述

此接口用于确认告警信息为真实告警。

使用说明

请求方法 | POST
请求URL | alarm/confirm/v1.0
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | alarmEventId | int | 必须 | 告警事件ID
2 | alarmInCode | String | 必须 | 告警源编码
3 | operateInfo | Object | 必须 | 告警处理信•AlarmOperateInfo

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultcode | Integer | 成功返回0，失败返回错误码

使用示例

https://192.168.203.36:18531/alarm/confirm/v1.0

接口请求消息示例数据如下：

{

"alarmEventId":告警事件ID，整型

"alarmInCode":告警源编码，字符串型

"operateInfo":告警处理信息

{

"operatorId":处理人ID，即处理人用户ID，值为大于0的正整数

"operatorName":处理人名，由汉字和字母（a-z和A-Z）、数字、中划线和下划线组合，长度限制128字节，字符串类型

"operateTime":告警处理时间，格式yyyyHHddhhmmss，长度限制20字节，字符串类型

"reserver":保留字段，长度限制32字节，必须保留该字段，字段内容可以置空，字符串类型

"operateInfo": 告警处理人员输入的描述信息，长度限制1024字节，字符串类型

}

}

接口返回消息示例数据如下：

{

"resultCode"：0表示成功，其他表示失败，整形

}

父主题： 告警管理接口


告警撤销

接口描述

此接口用于撤销无效告警信息。

使用说明

请求方法 | POST
请求URL | alarm/cancel/v1.0
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | alarmEventId | int | 必须 | 告警事件ID
2 | alarmInCode | String | 必须 | 告警源编码
3 | operateInfo | Object | 必须 | 告警处理信•AlarmOperateInfo

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

https://192.168.203.36:18531/alarm/cancel/v1.0

接口请求消息示例数据如下：

{

"alarmEventId":告警事件ID，整型

"alarmInCode":告警源编码，字符串型

"operateInfo":告警处理信息

{

"operatorId":处理人ID，即处理人用户ID，值为大于0的正整数

"operatorName":处理人名，由汉字和字母（a-z和A-Z）、数字、中划线和下划线组合，长度限制128字节，字符串类型

"operateTime":告警处理时间，格式yyyyHHddhhmmss，长度限制20字节，字符串类型

"reserver":保留字段，长度限制32字节，必须保留该字段，字段内容可以置空，字符串类型

"operateInfo": 告警处理人员输入的描述信息，长度限制1024字节，字符串类型

}

}

接口返回消息示例数据如下：

{

"resultCode"：0表示成功，其他表示失败，整形

}

父主题： 告警管理接口


新增告警联动策略

接口描述

此接口用于新增告警联动策略。

使用说明

请求方法 | POST
请求URL | /alarm/linkage/v1.0
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | domainCode | String | 必须 | 目标域编码
2 | linkageInfo | Object | 必须 | 告警联动信息AddAlarmLinkageInfo

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | linkageId | Integer | 告警联动策略ID，失败返回null

使用示例

https://192.168.203.36:18531/alarm/linkage/v1.0

接口请求消息示例数据如下：

{

"domainCode": "dabce15d2fd342659eef4176c5a686f4",

"linkageInfo": {

"actionList": [

{

"actionBranch": 0,

"actionType": 5,

"deviceList": [

{

"deviceCode": "04022518981969460101#dabce15d2fd342659eef4176c5a686f4",

"positionId": 1

}

],

"globalParam": "1"

}

],

"alarmInCode": "04022518981969460101",

"alarmInType": "01",

"alarmType":"ALARM_TYPE_MOVE_DECTION"

}

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"linkageId": 2

}

父主题： 告警管理接口


修改告警联动策略

接口描述

此接口用于修改告警联动策略。

使用说明

请求方法 | PUT
请求URL | /alarm/linkage/v1.0
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | linkageInfo | Object | 必须 | 修改告警联动策略信息。ModifyAlarmLinkageInfo

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

https://192.168.203.36:18531/alarm/linkage/v1.0

接口请求消息示例数据如下：

{

"linkageInfo": {

"actionList": [

{

"actionBranch": 1,

"actionType": 5,

"deviceList": [

{

"deviceCode": "04022518981969460101#dabce15d2fd342659eef4176c5a686f4",

"positionId": 3

}

],

"globalParam": "1"

}

],

"alarmInCode": "04022518981969460101",

"alarmInType": "01",

"alarmType":"ALARM_TYPE_MOVE_DECTION",

"linkageId":2

}

}

接口返回消息示例数据如下：

{

"resultCode"：0表示成功，其他表示失败

}

父主题： 告警管理接口


删除告警联动策略

接口描述

此接口用于删除告警联动策略。

使用说明

请求方法 | DELETE
请求URL | /alarm/linkage/v1.0
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | domainCode | String | 必选 | 域编码
2 | linkageInfo | Object | 必选 | 联动策略信息。DeleteAlarmLinkageInfo

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

https://192.168.203.36:18531/alarm/linkage/v1.0

接口请求消息示例数据如下：

{

"domainCode": "dabce15d2fd342659eef4176c5a686f4",

"linkageInfo": {

"alarmInCode": "04022518981969460101",

"alarmInType": "01",

"alarmType":"ALARM_TYPE_MOVE_DECTION",

"linkageId":2",

"deviceDomainCode":"dabce15d2fd342659eef4176c5a686f4"

}

}

接口返回消息示例数据如下：

{

"resultCode"：0表示成功，其他表示失败

}

父主题： 告警管理接口


获取告警联动策略详情

接口描述

查询告警联动策略详情。

使用说明

项目 | 描述
接口名称 | /alarm/alarmLinkage/v1.0/{domainCode}/{linkageId}/{alarmInCode}/{alarmInType}/{alarmType}
请求方式 | GET
请求参数格式 | JSON
URL | https://server-addr:port/alarm/alarmLinkage/v1.0/{domainCode}/{linkageId}/{alarmInCode}/{alarmInType}/{alarmType}

HTTP Header示例如下：

GET /alarm/alarmLinkage/v1.0/{domainCode}/{linkageId}/{alarmInCode}/{alarmInType}/{alarmType} HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

名称

类型

必选/可选

描述

domainCode

String

必选

设备所在域编码，本域时留空

linkageId

Integer

必选

联动策略ID

alarmInCode

String

必选

告警源编码，参考用户及设备编码ID与命名规则

alarmInType

String

必选

告警源类型：

  • 01：摄像机
  • 02：开关量输入
  • 09：第三方开关量输入
  • 90:防区

alarmType

String

必选

告警类型

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
linkage | AlarmLinkageInfo | 联动策略详情

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/alarm/alarmLinkage/v1.0/f563c8bc3f8240009637a9edd500ca19/12/45255396048042610101/01/ALARM_TYPE_MOVE_DECTION

接口返回消息示例数据如下：

{

"resultCode":0,错误码

"linkage": {

"actionList": {

{

"actionBranch": 0,执行分支

"actionType": 4,告警动作类型

"devList": {

"devInfo": {

"devCode": "13547458568686040101#b15f8103a1dc40b4b4963aae7ddd0baf" 设备编码,

"param": "yu" 动作参数。联动预置位：预置位ID

}

},

"globalParam": "99" 全局动作参数

}

},

"linkageId": 1 联动策略id

}

}

父主题： 告警管理接口


获取告警联动策略列表

接口描述

此接口用于获取告警联动策略列表

使用说明

项目 | 描述
接口名称 | /alarm/linkageList/v1.0/{alarmInCode}/{nvrCode}/{alarmInType}
请求方式 | GET
请求参数格式 | JSON
URL | https://server-addr:port/alarm/linkageList/v1.0/{alarmInCode}/{nvrCode}/{alarmInType}

HTTP Header示例如下：

GET /alarm/linkageList/v1.0/{alarmInCode}/{nvrCode}/{alarmInType} HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

属性

类型

必选/可选

描述

alarmInCode

String

必选

告警摄像机编码#号之前

nvrCode

String

必选

设备所属域编码。例如：a87f463b7dd741908668c89c84a27e30

alarmInType

String

必选

告警源类型：

  • 01：摄像机
  • 02：开关量输入
  • 09：第三方开关量输入
  • 90：防区

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
linkageList | List<•Linkage> | 告警联动策略列表信息

使用示例

https://192.168.203.36:18531/alarm/linkageList/v1.0/01572998006447760101/a87f463b7dd741908668c89c84a27e30/5

接口返回消息示例数据如下：

{

"resultCode": 0,

"linkageList": [

{

"domainCode": "4514fb19192e40cda1252a49035a23c7",

"linkageId": 1,

"alarmInCode": "45255396048042610101#4514fb19192e40cda1252a49035a23c7",

"alarmInType": "",

"alarmType": "ALARM_TYPE_MOVE_DECTION"

}

]

}

父主题： 告警管理接口


获取告警联动策略动作详情

接口描述

此接口用于获取告警联动策略动作详情.

使用说明

项目 | 描述
接口名称 | /alarm/linkageAction/v1.0/{alarmInCode}/{nvrCode}/{alarmInType}/{alarmType}/{actionType}
请求方式 | GET
请求参数格式 | JSON
URL | https://server-addr:port/alarm/linkageAction/v1.0/{alarmInCode}/{nvrCode}/{alarmInType}/{alarmType}/{actionType}

HTTP Header示例如下：

GET /alarm/linkageAction/v1.0/{alarmInCode}/{nvrCode}/{alarmInType}/{alarmType}/{actionType} HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

名称

类型

必选/可选

描述

alarmInCode

String

必选

告警源编码

nvrCode

String

必选

设备所属域编码。例如：a87f463b7dd741908668c89c84a27e30

alarmInType

String

必选

告警源类型:

  • 01：摄像机
  • 02：开关量输入
  • 09：第三方开关量输入
  • 90：防区

alarmType

String

必选

告警类型

actionType

Integer

必选

告警动作类型。 具体信息如下：

  • 1：用户交互
  • 2：联动录像
  • 3：联动前端录像
  • 4：联动抓拍
  • 5：联动预置位
  • 6：联动开关量输出
  • 7：联动客户端弹出实况
  • 8：联动实况上墙
  • 9：联动Email
  • 10：联动短信
  • 11：联动彩信
  • 12：联动录像备份

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
actionList | List<ActionLinkageModel> | linkage 联动策略动作

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/alarm/linkageAction/v1.0/01572998006447760101/a87f463b7dd741908668c89c84a27e30/01/ALARM_TYPE_MOVE_DECTION/5

接口返回消息示例数据如下：

"resultCode":0,错误码

"actionList": {

"actionBranch": 0,执行分支

"actionType": 4,告警动作类型

"devList": {

"devCode": "13547458568686040101#b15f8103a1dc40b4b4963aae7ddd0baf" 设备编码,

"param": "yu" 动作参数。联动预置位：预置位ID

},

"globalParam": "99" 全局动作参数

}

}

父主题： 告警管理接口


查询OMU告警事件列表

接口描述

查询OMU告警事件列表，可以设置各种查询条件。

使用说明

请求方法 | GET
请求URL | /alarm/omuList/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /alarm/omuList/v1.0?domainCode={domainCode}&startTime={startTime}&endTime={endTime}&fromIndex={fromIndex}&toIndex={toIndex}&alarmType={alarmType} HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 可选/必选 | 描述
domainCode | String | 必选 | 设备所属域编码或者节点编码。例如：cf07d89edf2c43cdbb79a775771e78bb
startTime | String | 必选 | 查询操作开始时间，格式为yyyyMMddhhmmss
endTime | String | 必选 | 查询操作结束时间，格式为yyyyMMddhhmmss
alarmType | String | 非必选 | 告警类型。详见 状态通知类告警类型
fromIndex | int | 非必选 | 开始索引。默认值为1
toIndex | int | 非必选 | 结束索引，结束索引必须大于或等于开始索引。默认值为1000

响应参数

参数 | 类型 | 可选/必选 | 描述
resultCode | int | 必选 | 成功返回0，失败返回错误码
deviceAlarmEvents | Object | 必选 | 主设备信息列表参数。详见▪DeviceAlarmEvents

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/alarm/omuList/v1.0?domainCode=cf07d89edf2c43cdbb79a775771e78bb&startTime=20190911000000&endTime=20191116000000&fromIndex=1&toIndex=10&alarmType=ALARM_PCG_OFFLINE

接口响应消息示例如下：

{

"resultCode": 0,

"deviceAlarmEvents": {

"total": 1,

"indexRange": {

"fromIndex": 1,

"toIndex": 10

},

"reserve": "",

"deviceAlarmNotifies": [

{

"alarmEventID": 3,

"alarmInCode": "BMA#fd949d5637bb40988ee155f27d47f74b",

"alarmInType": 25,

"alarmInName": "OMU",

"nodeType": "30859",

"alarmLevelValue": 100,

"alarmType": "ALARM_PCG_OFFLINE",

"alarmCategory": "02",

"occurFirstTime": "20191111201124",

"occurEndTime": "20191111201124",

"occurNumber": 1,

"reserver": "",

"locationInfo": "HostIP=172.16.10.2,deviceCode=fd949d5637bb40988ee155f27d47f74b,LocalDesc=PCG",

"netEleID": "",

"netName": "fd949d5637bb40988ee155f27d47f74b",

"alarmDest": "",

"extParam": ""

}

]

}

}

父主题： 告警管理接口


实时浏览接口

  • 开始实时浏览
  • 停止实时浏览
  • 获取视频URL信息


开始实时浏览

接口描述

此接口用于开始实时浏览，将媒体流发送到目的IP、PORT

使用说明

请求方法 | POST
请求URL | /device/startrealplaybyipex
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST/device/startrealplaybyipex HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 可选/必选 | 描述
cameraCode | String | 必选 | 摄像机编码。例如：32010300100201030101#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节
realplayParam | Object | 必选 | 实时浏览媒体参数 参见类型RealplayParam
mediaAddrDst | Object | 必选 | 媒体流目标地址，该参数中除reserve字段，均为必填字段 参见类型MediaAddress

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码
mediaAddrSrc | Object | 媒体流源地址 参见类型MediaAddress
handle | Long | 播放句柄

使用示例

接口请求消息示例如下：

{

"cameraCode": "00130760000000000101#43b42979e85d4c0bb4e59b3e9724b675",

"realplayParam": {

"streamType": 0,

"protocolType": 1,

"directFirst": 0,

"multiCast": 0,

"reserve": ""

},

"mediaAddrDst": {

"dstIP": {

"ipType": 0,

"ip": "192.168.120.189"

},

"audioPort": 21200,

"videoPort": 21202,

"reserve": ""

}

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"mediaAddrSrc": {},

"handle": 392823712

}

父主题： 实时浏览接口


停止实时浏览

接口描述

此接口用于停止实时浏览，停止实况媒体分发。

使用说明

请求方法 | GET
请求URL | /device/stoprealplaybyipex/{handle}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/stoprealplaybyipex/{handle} HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

参数 | 类型 | 可选/必选 | 描述
handle | Long | 必选 | 播放句柄

响应参数

参数 | 类型 | 描述
resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/device/stoprealplaybyipex/392822592

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 实时浏览接口


获取视频URL信息

接口描述

获取媒体信息。

调用该接口获取的视频URL地址有效期为30s，过期后URL将不能使用，如需使用则重新调用该接口获取，视频流不支持TS打包协议。如果录像回放调用该接口前，请先查询录像列表，确保下发录像时间内是有录像的。

该接口适配产品 V100R019C10SPC110及以上版本。NAT场景适配R19C20SPC100及以上版本

使用说明

请求方法 | POST
请求URL | /video/rtspurl/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /video/rtspurl/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号

请求字段

字段类型

可选/必选

字段名称

1

cameraCode

String

必选

实时浏览或录像的摄像机编码（6.6获取子设备列表返回值cameraBriefInfos code字段）

2

mediaURLParam

Object

必选

RTSP URL请求参数

3

serviceType

Integer

必选

目前仅支持业务类型：

1：实时浏览

4：平台录像回放

4

packProtocolType

Integer

必选

打包协议类型

1：ES

2：PS

说明： PS用于国标摄像机；一般ES比较多，推荐选择ES。

5

timeSpan

Object

可选

录像的开始和结束时间，

如果是平台或前端录像回放、下载需要时必填

格式为：年月日T时分秒Z-年月日T时分秒Z（20160214T155505Z-20160214T160505Z）

说明： 一般通过9.4获取录像列表查到，和返回的录像时间段统一。

6

startTime

String

可选

开始时间（UTC时间）

格式如yyyyMMddHHmmss，例如：20121207102035，长度限制20字节

7

endTime

String

可选

结束时间（UTC时间）

格式如yyyyMMddHHmmss，例如：20121207202035，长度限制20字节

8

streamType

Integer

必选

码流类型（默认为1）：

1：主码流

2：辅码流1

3：辅码流2

9

protocolType

Integer

必选

协议类型（默认为1）：

1：UDP

2：TCP

说明：推荐使用TCP

10

transMode

Integer

必选

是否直连优先（默认为0）：

0：否

1：是

11

broadCastType

Integer

必选

是否支持组播（默认为0）：

0：不支持

1：支持

12

clientType

Integer

可选

客户端类型（可填参数）：

  • 0：IVS CU或eSDK
    • 1：标准RTSP客户端
    • 5：RTSP短URL客户端

      说明：clientType为5时返回短URL;针对外域设备或者海康解码器上墙场景，需传入该值

13

dstIP

String

可选

NAT场景下目的IP（默认为空）：

格式：xx.xx.xx.xx,长度限制 16字节

说明：该字段在R19C20SPC100版本及以上开始支持

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | rtspURL | String | RTSP URL地址

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/video/rtspurl/v1.0

{

"cameraCode": "01042570000000000101#c5fa198c20c7416bb19999173b445e5a",

"mediaURLParam": {

"broadCastType": 0,

"packProtocolType": 1,

"protocolType": 2,

"serviceType": 1,

"streamType": 1,

"transMode": 0

}

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"rtspURL": "rtsp://192.168.0.1:554/01042570000000000101?DstCode=01&ServiceType=1&ClientType=0&StreamID=1&SrcTP=2&DstTP=2&SrcPP=1&DstPP=1&MediaTransMode=0&BroadcastType=0&SV=0&Token=TjBL+9HAe0aqavdJqs8GbpmSvNZd9NVf&DomainCode=c5fa198c20c7416bb19999173b445e5a&UserId=1&"

}

父主题： 实时浏览接口


录像管理接口

  • 查询NVR列表
  • 开始平台录像
  • 停止平台录像
  • 获取录像列表
  • 开始平台录像回放
  • 停止平台录像回放
  • 暂停平台录像回放
  • 恢复平台录像回放
  • 回放拖动
  • 查询手动录像任务
  • 设置录像时间策略
  • 查询录像时间策略
  • 新增平台/前端录像计划
  • 删除平台/前端录像计划
  • 修改平台/前端录像计划
  • 查询平台/前端录像计划
  • 查询录像列表（录像结构列表）
  • 开始前端录像
  • 停止前端录像
  • 新增录像备份任务
  • 删除录像备份任务
  • 查询录像备份任务列表
  • 启动/继续录像备份任务
  • 暂停/停止录像备份任务
  • 针对指定IP端口设置回放速度
  • 暂停录像回放指定IP
  • 恢复录像回放指定IP
  • 针对指定IP端口拖动录像回放时间


查询NVR列表

接口描述

此接口用于查询集群中对应NVR设备列表

使用说明

请求方法 | GET
请求URL | /playback/nvrlist/{servertype}/{domaincode}/{fromindex}/{toindex}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /playback/nvrlist/0/3bf63c6d6b8c44e88f40b2e3db1aeec8/1/5 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | servertype | Integer | 必选 | NVR类型：0：全部;1：NVR;2：TAS;3：MBS
2 | domaincode | String | 必选 | 域编码
3 | fromindex | Integer | 必选 | 开始索引:正整数，取值范围：1~1000
4 | toindex | Integer | 必选 | 结束索引:正整数，取值范围:1~1000，且结束索引必须大于或者等于开始索引

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | nvrInfos | Object | NVR信息列表 参见类型CameraBriefInfos

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/nvrlist/0/3bf63c6d6b8c44e88f40b2e3db1aeec8/1/5

接口返回消息示例数据如下：

{

"resultCode": 0,

"nvrInfos": {}

}

父主题： 录像管理接口


开始平台录像

接口描述

此接口用于启动指定摄像机平台录像功能

使用说明

请求方法 | GET
请求URL | /platform/startplatformrecord/{recordtime}/{cameracode}/{nvrcode}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /platform/startplatformrecord/5000/00130760000000000101/43b42979e85d4c0bb4e59b3e9724b675 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | recordtime | Integer | 必选 | 录像时长。取值范围：300~43200，单位秒
2 | cameracode | String | 必选 | 摄像机编码#号之前数据
3 | nvrcode | String | 必选 | 设备所属域编码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/platform/startplatformrecord/5000/00130760000000000101/43b42979e85d4c0bb4e59b3e9724b675

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


停止平台录像

接口描述

此接口用于停止指定摄像机平台录像功能

使用说明

请求方法 | GET
请求URL | /platform/stopplatformrecord/{cameracode}/{nvrcode}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /platform/stopplatformrecord/0418531030000000000101/3bf63c6d6b8c44e88f40b2e3db1aeec8 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameracode | String | 必选 | 摄像机编码#号之前数据
2 | nvrcode | String | 必选 | 设备所属NVR编码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/platform/stopplatformrecord/0418531030000000000101/3bf63c6d6b8c44e88f40b2e3db1aeec8

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


获取录像列表

接口描述

此接口用于获取录像列表。用户可获取平台录像信息或前端设备内的录像信息

使用说明

请求方法 | GET
请求URL | /platform/recordlist/{recordmethod}/{cameracode}/ {nvrcode}/{starttime}/{endtime}/{fromindex}/{toindex}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /platform/recordlist/0/0418531030000000000101/3bf63c6d6b8c44e88f40b2e3db1aeec8/20180120102035/20180129232035/1/5 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | recordmethod | Integer | 必选 | 录像方式：0：平台录像,1：前端录像,2：备份服务器,3：容灾录像
2 | cameracode | String | 必选 | 相机编码的#号前面数据
3 | nvrcode | String | 必选 | 设备所属域编码。例如：a87f463b7dd741908668c89c84a27e30
4 | starttime | String | 必选 | 开始时间：格式如yyyyMMddHHmmss，例如：20121207102035
5 | endtime | String | 必选 | 结束时间：格式如yyyyMMddHHmmss，例如：20121207202035 说明： 在查询集群环境下设备录像的时候，查询时间跨度不能大于30天。
6 | fromindex | Integer | 必选 | 开始索引：正整数，取值范围：1~1000
7 | toindex | Integer | 必选 | 结束索引：正整数，取值范围:1~1000，且结束索引必须大于或者等于开始索引

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | recordInfos | Object | 录像查询结果分页信息 参见类型RecordInfos

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/platform/recordlist/0/0418531030000000000101/3bf63c6d6b8c44e88f40b2e3db1aeec8/20180120102035/20180129232035/1/5

接口返回消息示例数据如下：

{

"resultCode": 0,

"recordInfos": {}

}

父主题： 录像管理接口


开始平台录像回放

接口描述

此接口用于开始平台录像播放，可设置播放参数，并将媒体流发送到指定的目标IP地址和端口

使用说明

请求方法 | POST
请求URL | /playback/startplatformplaybackbyip
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /playback/startplatformplaybackbyip HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameraCode | String | 必选 | 摄像机编码
2 | playbackParam | Object | 必选 | 录像播放媒体参数 参见类型PlaybackParam
3 | mediaAddrDst | Object | 必选 | 媒体流目标地址 参见类型MediaAddress

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | mediaAddrSrc | Object | 媒体流源地址 参考类型MediaAddress
3 | handle | Long | 播放句柄

使用示例

接口请求消息示例如下：

{

"cameraCode": "0418531030000000000101#3bf63c6d6b8c44e88f40b2e3db1aeec8",

"playbackParam": {

"protocolType": 1,

"recordTime": {

"startTime": "20180120102035",

"endTime": "20180129232035"

},

"speed": 1,

"NVRCode": "1bc7f387d5a44079a7751f951d51fd5e"

},

"mediaAddrDst": {

"dstIP": {

"ipType": 0,

"ip": "192.168.120.59"

},

"audioPort": 21200,

"videoPort": 21202,

"reserve": ""

}

}

{

"cameraCode": "0418531030000000000101#3bf63c6d6b8c44e88f40b2e3db1aeec8",

"playbackParam": {

"protocolType": 1,

"recordTime": {

"startTime": "20180120102035",

"endTime": "20180129232035"

},

"speed": 1,

"NVRCode": "1bc7f387d5a44079a7751f951d51fd5e"

},

"mediaAddrDst": {

"dstIP": {

"ipType": 0,

"ip": "192.168.120.59"

},

"audioPort": 21200,

"videoPort": 21202,

"reserve": ""

}

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"mediaAddrSrc": {},

"handle": 402524064

}

父主题： 录像管理接口


停止平台录像回放

接口描述

此接口用于停止平台录像播放

使用说明

请求方法 | GET
请求URL | /playback/stopplatformplaybackbyip/{handle}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /playback/stopplatformplaybackbyip/402524064 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | handle | Long | 必选 | 播放句柄

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/stopplatformplaybackbyip/402524064

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


暂停平台录像回放

接口描述

暂停平台录像回放，调用本接口前，需保证已成功调用开始平台录像回放接口，并获取到该接口返回的播放句柄handle。

使用说明

请求方法 | POST
请求URL | /playback/platformplaybackpausebyip/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /playback/platformplaybackpausebyip/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playHandle | long | 必选 | 播放句柄，调用开始平台录像回放接口获取 示例：123223

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"playHandle": 123223

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


恢复平台录像回放

接口描述

此接口用于恢复平台录像回放，与暂停平台录像回放接口成对使用，调用本接口前，需保证已成功调用暂停平台录像回放接口。

使用说明

请求方法 | POST
请求URL | /playback/platformplaybackresumebyip/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /playback/platformplaybackresumebyip/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playHandle | long | 必选 | 播放句柄，调用开始平台录像回放接口获取，与暂停平台录像回放接口的playHandle为相同值 示例：123223

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"playHandle": 123223

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


回放拖动

接口描述

此接口用于设置平台录像码流回放时间(根据码流回访时间设置录像回放)

使用说明

请求方法 | GET
请求URL | /playback/playbacktimebyip/{playhandle}/{time}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /playback/playbacktimebyip/405384792/10 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playhandle | Long | 必选 | 播放句柄
2 | time | Integer | 必选 | 播放时间。注：回放拖动尺度，单位秒，正整数，绝对时间。如0s~100s，当前在30s处，要拖到40s处，接口中的参数是40s而不是10s

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/playbacktimebyip/405384792/10

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


查询手动录像任务

接口描述

此接口用于查询当前用户的手动录像任务。

使用说明

请求方法 | GET
请求URL | /record/recordtask/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /record/recordtask/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

无

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | responseXML | String | 手动录像任务查询响应XML，详见录像任务求XML

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/record/recordtask/v1.0

接口返回消息示例数据如下：

{

"resultCode": 0,

"responseXML": "<Content><CameraList><CameraInfo><DomainCode>1cf095245105466181d4fa0efa6f7743</DomainCode><CameraCode>10345678901310000101</CameraCode><RecordMethod>0</RecordMethod></CameraInfo></CameraList></Content>"

}

表1 录像任务求XML
属性 |  |  |  | 可选/必选 | 描述
Content |  |  |  | 必选 | 消息体根节点
 | CameraList |  |  | 可选 | 摄像机列表
 |  | CameraInfo |  | 必选 | 摄像机信息
 |  |  | DomainCode | 必选 | 域编码
 |  |  | CameraCode | 必选 | 摄像机编码
 |  |  | RecordMethod | 必选 | 录像方式： 0：平台录像 1：前端录像
父主题： 录像管理接口


设置录像时间策略

接口描述

此接口用于设置录像时间策略。

使用说明

请求方法 | POST
请求URL | /record/recordpolicybytime/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /record/recordpolicybytime/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameraCode | String | 必选 | 摄像机编码#域编码 域编码通过获取域路由接口获取 示例：51277777770000000101#d9808a7bfff94de09ecc47a6baa3bf5d
2 | recordPolicy | Object | 必选 | 录像策略，类型参见 RecordPolicy

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"cameraCode": "09334270000000000101#904956f64b3c48e48671856357ca23f4",

"recordPolicy": {

"recordMode": 0,

"time": 7,

"planStreamType": 1,

"alarmStreamType": 0,

"alarmRecordTTL": 0,

"manualRecordTTL": 0,

"preRecord": 0,

"preRecordTime": 0,

"associatedAudio": 1

}

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


查询录像时间策略

接口描述

此接口用于查询录像时间策略。

使用说明

请求方法 | GET
请求URL | /record/recordpolicybytime/{cameracode}/{domaincode}/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /record/recordpolicybytime/{cameracode}/{domaincode}/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameracode | String | 必选 | 摄像机编码 示例：51277777770000000101
2 | domaincode | String | 必选 | 域编码，可通过获取域路由接口获取 示例：9808a7bfff94de09ecc47a6baa3bf5d

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码
22 | recordPolicy | Object | 录像策略，类型参见RecordPolicy

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/record/recordpolicybytime/09334270000000000101/904956f64b3c48e48671856357ca23f4/v1.0

接口返回消息示例数据如下：

{

"resultCode": 0,

"recordPolicy": {

"recordMode": 0,

"time": 7,

"planStreamType": 1,

"alarmStreamType": 0,

"alarmRecordTTL": 0,

"manualRecordTTL": 0,

"preRecord": 0,

"preRecordTime": 0,

"associatedAudio": 1

}

}

父主题： 录像管理接口


新增平台/前端录像计划

接口描述

此接口用于新增平台/前端录像计划，可批量配置摄像机的录像计划，每个摄像机仅有一个录像计划，重复调用该接口，新计划将覆盖旧计划。

使用说明

请求方法 | POST
请求URL | /record/recordplan/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /record/recordplan/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameraNum | Integer | 必选 | 批量添加录像计划的摄像机数目
2 | cameraCodeList | Object | 必选 | 摄像机编码列表，类型参见 CameraCodeList
3 | recordPlan | Object | 必选 | 录像计划，类型参见 RecordPlan

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"cameraNum": 1,

"cameraCodeList": {

"cameraCode": ["51866666660000000101#4f297e89479e4867bf38ec5af75679d8"]

},

"recordPlan": {

"recordMethod": 0,

"enableRecordPlan": 0,

"recordPlanType": 1,

"planInfoNum": 1,

"planInfoList": {

"planInfo": [{

"dayType": 0,

"timeSpanInfoNum": 1,

"timeSpanInfoList": {

"timeSpan": [{

"startTime": "130000",

"endTime": "160000"

}]

}

}]

}

}

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


删除平台/前端录像计划

接口描述

此接口用于删除平台/前端录像计划。

使用说明

请求方法 | DELETE
请求URL | /record/recordplan/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

DELETE /record/recordplan/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameraNum | Integer | 必选 | 批量删除录像计划的摄像机数目
2 | cameraCodeList | Object | 必选 | 摄像机编码列表，类型参见CameraCodeList
3 | recordMethod | Integer | 必选 | 录像方式： 0：平台录像 1：前端录像

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"cameraNum": 1,

"cameraCodeList": {

"cameraCode": ["51866666660000000101#4f297e89479e4867bf38ec5af75679d8"]

},

"recordMethod": 0

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


修改平台/前端录像计划

接口描述

此接口用于修改平台/前端录像计划。

使用说明

请求方法 | PUT
请求URL | /record/recordplan/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

PUT /record/recordplan/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameraNum | Integer | 必选 | 批量添加录像计划的摄像机数目
2 | cameraCodeList | Object | 必选 | 摄像机编码列表，类型参见CameraCodeList
3 | recordPlan | Object | 必选 | 录像计划，类型参见RecordPlan

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"cameraNum": 1,

"cameraCodeList": {

"cameraCode": ["51866666660000000101#4f297e89479e4867bf38ec5af75679d8"]

},

"recordPlan": {

"recordMethod": 0,

"enableRecordPlan": 0,

"recordPlanType": 1,

"planInfoNum": 1,

"planInfoList": {

"planInfo": [{

"dayType": 0,

"timeSpanInfoNum": 1,

"timeSpanInfoList": {

"timeSpan": [{

"startTime": "150000",

"endTime": "160000"

}]

}

}]

}

}

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


查询平台/前端录像计划

接口描述

此接口用于查询平台/前端录像计划。

使用说明

请求方法 | GET
请求URL | /record/recordplan/{cameracode}/{domaincode}/{recordmethod}/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /record/recordplan/51866666660000000101/4f297e89479e4867bf38ec5af75679d8/0/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameracode | String | 必选 | 摄像机编码 示例：51866666660000000101
2 | domaincode | String | 必选 | 域编码，可通过获取域路由接口获取 示例：d9808a7bfff94de09ecc47a6baa3bf5d
3 | recordmethod | Integer | 必选 | 录像方式： 0：平台录像 1：前端录像

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | recordPlan | Object | 录像计划，类型参见RecordPlan

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/record/recordplan/51866666660000000101/4f297e89479e4867bf38ec5af75679d8/0/v1.0

接口返回消息示例数据如下：

{

"resultCode": 0,

"recordPlan": {

"recordMethod": 0,

"enableRecordPlan": 0,

"recordPlanType": 1,

"planInfoNum": 1,

"planInfoList": {

"planInfo": [{

"dayType": 0,

"timeSpanInfoNum": 1,

"timeSpanInfoList": {

"timeSpan": [{

"startTime": "150000",

"endTime": "160000"

}]

}

}]

}

}

}

父主题： 录像管理接口


查询录像列表（录像结构列表）

接口描述

此接口用于查询录像列表

使用说明

请求方法 | POST
请求URL | /record/records/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /record/records/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 是否必填 | 字段名称
1 | queryFormat | QueryUnifiedFormat | 是 | 通用查询结构体

续表queryFormat

index | IndexRange | 必选 | 分页信息
orderCondition | OrderCondition | 必选 | 排序信息
fieldNum | Integer | 必选 | 查询需要使用的过滤条件字段的数量 fieldNum为0表示无查询限制条件，fieldNum需要和queryFieldList中查询条件个数保持一致。
queryFieldList | QueryFieldList | 可选 | 查询需要使用的过滤条件字段信息列表 说明： fieldNum为0时，不填写该字段 fieldNum非0时，该字段必填

响应参数

序号 | 请求字段 | 字段类型 | 是否必填 | 字段名称
1 | resultCode | Integer | 是 | 成功返回0，失败返回错误码
2 | recordInfos | RecordInfos | 是 | 录像查询结果分页信息

使用示例

接口请求消息示例如下：

{

"queryFormat": {

"index": {

"fromIndex":1,

"toIndex":1000

},

"orderCondition": {

"enableOrder":0,

"fieldType":0,

"isAscend":0

},

"fieldNum": 1,

"queryFieldList": {

"queryField":[{

"fieldType":0,

"value":"1",

"exactQuery":1

}]

}

}

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"recordInfos": {

"total": 0,

"indexRange": {

"fromIndex": 0,

"toIndex": 0

},

"reserve": "",

"recordInfoList": {

"recordInfo": []

}

}

}

父主题： 录像管理接口


开始前端录像

接口描述

此接口用于开始前端录像

使用说明

请求方法 | POST
请求URL | /record/startpurecord/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /record/startpurecord/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 是否必填 | 字段名称
1 | cameraCode | String | 是 | 摄像机编码
2 | recordTime | Int | 是 | 录像时长，单位秒，整数，300 ~ 43200（12小时）

响应参数

序号 | 请求字段 | 字段类型 | 是否必填 | 字段名称
1 | resultCode | Integer | 是 | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"cameraCode": "32010300100201030101#6bdacabae9c546e9ab5b8688ccd85a59",

"recordTime": 1235

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


停止前端录像

接口描述

此接口用于停止前端录像

使用说明

请求方法 | POST
请求URL | /record/stoppurecord/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /record/stoppurecord/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 是否必填 | 字段名称
1 | cameraCode | String | 是 | 摄像机编码

响应参数

序号 | 请求字段 | 字段类型 | 是否必填 | 字段名称
1 | resultCode | Integer | 是 | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"cameraCode": "32010300100201030101#6bdacabae9c546e9ab5b8688ccd85a59"

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


新增录像备份任务

接口描述

新增录像备份任务.

使用说明

请求方法 | POST
请求URL | /record/recordBackupTask/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /record/recordBackupTask/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

参数

类型

必选/可选

描述

cameraCode

String

必选

摄像机编码

taskType

Integer

必选

任务类型：

  • 0：计划任务
  • 1：手动备份
  • 2：告警联动备份

executeType

Integer

必选

执行方式：

  • 0：立即(告警联动备份只有立即)
  • 1：延后

executeTime

String

可选

延后执行时间(延后执行时有效)，格式为YYYYMMDDHHMMSS

backupMethod

Integer

必选

备份方式：

  • 0：录像备份
  • 1：实时备份

sourceType

Integer

必选

录像来源(实时备份只有平台)：

  • 0：平台
  • 1：前端

streamType

Integer

可选

流类型：(当备份方式为实时备份时)：

0：主码流（固定为主码流）

startTime

String

必选

录像/实况的开始时间，格式为YYYYMMDDHHMMSS

endTime

String

可选

录像/实况的结束时间（录像备份时必填），格式为YYYYMMDDHHMMSS

backupTime

String

可选

备份时长（单位秒）实时备份有效

alarmType

String

可选

告警类型，在任务类型为告警联动备份时，需携带告警类型信息

响应参数

序号 | 请求字段 | 字段类型 | 是否必填 | 字段名称
1 | resultCode | Integer | 是 | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"sourceType": 0,

"backupTime": "1000",

"cameraCode": "05745261637147320101",

"executeType": 0,

"taskType": 1,

"backupMethod": 1,

"startTime": "20191227120021",

"executeTime":"20191227130022"

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


删除录像备份任务

接口描述

删除录像备份任务

使用说明

请求方法 | DELETE
请求URL | /record/recordBackupTask/v1.0/{cameraCode}/{domainCode}/{taskID}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

DELETE /record/recordBackupTask/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

参数 | 类型 | 必选/可选 | 描述
cameraCode | String | 必选 | 摄像机编码
domainCode | String | 必选 | 摄像机所在域编码
taskID | Integer | 必选 | 备份任务ID，唯一标识一个备份任务

响应参数

序号 | 请求字段 | 字段类型 | 是否必填 | 字段名称
1 | resultCode | Integer | 是 | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/record/recordBackupTask/v1.0/01572998006447760000/78ee7a51c50544559a9aa7b8f3c0c941/2

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


查询录像备份任务列表

接口描述

此接口用于查询录像备份任务列表

使用说明

项目 | 描述
接口名称 | /record/backupTask/v1.0?cameraCode=?&nvrCode=?&finishType=?&fromIndex=?&toIndex=?&fromTime=?&toTime=?
请求方式 | GET
请求参数格式 | JSON
URL | http:server:port/record/backupTask/v1.0?cameraCode=?&nvrCode=?&finishType=?&fromIndex=?&toIndex=?&fromTime=?&toTime=?

HTTP Header示例如下：

GET /record/backupTask/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求字段

字段类型

可选/必选

字段名称

cameraCode

String

必选

摄像机编码#号之前数据

nvrCode

String

可选

设备所属域编码。例如：a87f463b7dd741908668c89c84a27e30

备注：默认为当前域

finishType

Integer

必选

任务完成类型：

  • 0：未完成
  • 1：已完成

fromIndex

Integer

可选

从第几条记录开始返回，第1条记录的索引值为1（默认为1）

toIndex

Integer

可选

截止第几条记录（默认为1000）

fromTime

String

可选

开始时间（UTC，格式为yyyyMMddHHmmss）

备注：只有与结束时间都不为空时，参数有效

toTime

String

可选

结束时间（UTC，格式为yyyyMMddHHmmss）

备注：只有与开始时间都不为空时，参数有效

响应参数

序号 | 请求字段 | 字段类型 | 是否必填 | 字段名称
1 | resultCode | Integer | 是 | 成功返回0，失败返回错误码
2 | pageInfo | PageInfo4Backup | 是 | 分页信息
3 | backupTaskList | List<BackupTaskList> | 是 | 备份任务列表

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/record/backupTask/v1.0?cameraCode=01572998006447760101&nvrCode=78ee7a51c50544559a9aa7b8f3c0c941&finishType=1&fromIndex=1&toIndex=100&fromTime=?&toTime=?

接口返回消息示例数据如下：

{

"resultCode": 0,

"pageInfo": {

"realNum":0,总的符合条件记录数

"fromIndex":1,开始索引值

"toIndex":100 截止索引值

},

"backupTaskList":[]

}

父主题： 录像管理接口


启动/继续录像备份任务

接口描述

删除录像备份任务

使用说明

项目 | 描述
接口名称 | /record/backupTask/start/v1.0
请求方式 | PUT
请求参数格式 | JSON
URL | https://server-addr:port/record/backupTask/start/v1.0

HTTP Header示例如下：

PUT /record/backupTask/start/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

参数 | 类型 | 必选/可选 | 描述
cameraCode | String | 必选 | 摄像机编码
taskID | Integer | 必选 | 备份任务ID，唯一标识一个备份任务

响应参数

序号 | 请求字段 | 字段类型 | 是否必填 | 字段名称
1 | resultCode | Integer | 是 | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"cameraCode":"01146170000000000101#904956f64b3c48e48671856357ca23f4" //摄像机编码,

"taskID":6 备份任务ID //唯一标识一个备份任务

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


暂停/停止录像备份任务

接口描述

此接口用于暂停/停止录像备份任务

使用说明

项目 | 描述
接口名称 | /record/backupTask/stop/v1.0
请求方式 | PUT
请求参数格式 | JSON
URL | http://server-addr:port/record/backupTask/stop/v1.0

HTTP Header示例如下：

PUT /record/backupTask/stop/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

参数 | 类型 | 必选/可选 | 描述
cameraCode | String | 必选 | 摄像机编码
taskID | Integer | 必选 | 备份任务ID，唯一标识一个备份任务

响应参数

序号 | 请求字段 | 字段类型 | 是否必填 | 字段名称
1 | resultCode | Integer | 是 | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"cameraCode":"01146170000000000101#904956f64b3c48e48671856357ca23f4" //摄像机编码,

"taskID":6 //备份任务ID，唯一标识一个备份任务

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


针对指定IP端口设置回放速度

接口描述

设置录像回放速度，针对指定IP端口的录像回放。

使用说明

请求方法 | PUT
请求URL | /playback/speed/v1.0/{playHandle}/{speed}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

PUT /playback/speed/v1.0/123223/1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playHandle | Long | 必选 | 播放句柄，调用开始平台录像回放接口获取 示例：123223
2 | speed | Float | 必选 | 播放速度 示例：1.0 正常速度

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/speed/v1.0/123223/1.0

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


暂停录像回放指定IP

接口描述

暂停平台录像回放，调用本接口前，需保证已成功调用开始平台录像回放接口，并获取到该接口返回的播放句柄handle。

使用说明

请求方法 | PUT
请求URL | /playback/pause/v1.0/{playHandle}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

PUT /playback/pause/v1.0/123223 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playHandle | long | 必选 | 播放句柄，调用开始平台录像回放接口获取 示例：123223

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/pause/v1.0/123223

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


恢复录像回放指定IP

接口描述

此接口用于恢复平台录像回放，与暂停平台录像回放接口成对使用，调用本接口前，需保证已成功调用暂停平台录像回放接口。

使用说明

请求方法 | PUT
请求URL | /playback/resume/v1.0/{playHandle}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

PUT /playback/resume/v1.0/123223 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playHandle | long | 必选 | 播放句柄，调用开始平台录像回放接口获取，与暂停平台录像回放接口的playHandle为相同值 示例：123223

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/resume/v1.0/123223

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


针对指定IP端口拖动录像回放时间

接口描述

此接口用于设置平台录像码流回放时间(根据码流回访时间设置录像回放)

使用说明

请求方法 | PUT
请求URL | /playback/playbackTime/v1.0/{playHandle}/{time}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

PUT /playback/playbackTime/v1.0/405384792/10 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playHandle | Long | 必选 | 播放句柄
2 | time | Integer | 必选 | 播放时间。注：回放拖动尺度，单位秒，正整数，绝对时间。如0s~100s，当前在30s处，要拖到40s处，接口中的参数是40s而不是10s

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/playbackTime/v1.0/405384792/10

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 录像管理接口


回调接口

  • 注册回调信息


注册回调信息

接口描述

第三方应用向eSDK注册回调地址信息。

通过该接口第三方应用可以接收到IVS系统返回的回调消息。当传入参数wsUrl中注册回调地址信息为空字符串时，表示取消接收回调消息。

使用说明

请求方法 | POST
请求URL | /users/regeditcallback
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /users/userid HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | wsUri | String | 必选 | 回调信息，具体说明如下： 格式：http://{IP地址}:{端口}/应用程序/回调服务模块， 例如：http://192.168.1.1:18531/isv/ivscallback 其中{IP地址}、{端口}为Native所在服务器的IP地址和端口号，同时确保能够连通。注册成功后将将向指定url推送消息，调用者需自己拦截回调信息，拦截到的消息内容参见事件定义类型

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例数据如下：

{

"wsUri": " http://192.168.203.36:8080/loginInfo/regeditcallback"

}

接口返回消息示例数据如下：

{

"resultCode": 0,

}

父主题： 回调接口


视频控制接口

  • 获取回放速度
  • 获取回放时间
  • 获取回放时间（精确到毫秒）
  • 获取回放状态
  • 获取媒体信息
  • 查询视频诊断计划
  • 设置每天视频诊断计划
  • 删除视频诊断计划


获取回放速度

接口描述

此接口用于获取平台录像码流回放的速度

注意：linux操作系统不支持

使用说明

请求方法 | GET
请求URL | /playback/playbackspeed/{playhandle}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /playback/playbackspeed/402527904 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playhandle | Long | 必选 | 播放句柄，如：1238492328

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | speed | Float | 回放速度

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/playbackspeed/402527904

接口返回消息示例数据如下：

{

"resultCode": 0,

"speed":1

}

父主题： 视频控制接口


获取回放时间

接口描述

此接口用于获取平台录像码流回放的时间

注意：linux操作系统不支持

使用说明

请求方法 | GET
请求URL | /playback/playbacktime/{playhandle}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /playback/playbacktime/45554555 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playhandle | Long | 必选 | 播放句柄

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | playBackTime | Object | 时间集合 参见类型PlaybackParam

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/playbacktime/45554555

接口返回消息示例数据如下：

{

"resultCode": 0,

"playBackTime": {

"playBackTime": "",

"playBackStartTime": "",

"playBackEndTime": "",

"reserve": ""

}

}

父主题： 视频控制接口


获取回放时间（精确到毫秒）

接口描述

此接口用于获取平台录像码流回放的时间(获取录像回放时间精确到毫秒)

注意：linux操作系统不支持

使用说明

请求方法 | GET
请求URL | /playback/currentframetick/{playhandle}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /playback/currentframetick/45554555 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playhandle | Long | 必选 | 播放句柄

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | tick | Integer | 回放时间，指1970年1月1日到现在的毫秒数

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/currentframetick/4555455

接口返回消息示例数据如下：

{

"resultCode": 0,

"tick": 5000

}

父主题： 视频控制接口


获取回放状态

接口描述

此接口用于获取平台录像码流回放的状态

注意：linux操作系统不支持

使用说明

请求方法 | GET
请求URL | /playback/playbackstatus/{playhandle}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /playback/playbackstatus/45554555 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playhandle | Long | 必选 | 播放句柄

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | pause | String | 播放状态：0：暂停（单帧播放为暂停状态）1：播放

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/playbackstatus/45554555

接口返回消息示例数据如下：

{

"resultCode": 0,

"pause": "暂停"

}

父主题： 视频控制接口


获取媒体信息

接口描述

此接口用于获取媒体信息

注意：linux操作系统不支持

使用说明

请求方法 | GET
请求URL | /playback/mediainfo/{playhandle}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /playback/mediainfo/45554555 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | playhandle | Long | 必选 | 播放句柄

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | mediaInfo | Object | 媒体信息，参见类型MediaInfo

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/playback/mediainfo/45554555

接口返回消息示例数据如下：

{

"resultCode": 0,

"mediaInfo": {

"winID": 0,

"audioStatus": 0,

"videoFrameRate": 0,

"videoBitrate": 0,

"videoAverageBitrate": 0,

"audioBitRate": 0,

"audioAverageBitRate": 0,

"videoCodec": 0,

"videoWidth": 0,

"videoHeight": 0,

"fLossTolerance": 0,

"uiInfoLocationX": 0,

"uiInfoLocationY": 0,

"stMediaSourceIP": {

"ipType": 0,

"ip": "192.168.120.189"

},

"reserve": ""

}

}

父主题： 视频控制接口


查询视频诊断计划

接口描述

此接口用于查询单台摄像机的视频质量诊断计划。

使用说明

请求方法 | GET
请求URL | /video/diagnose/v1.0/{domainCode}/{cameraCode}
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | domainCode | String | 必须 | 域编码，设备的域编码
2 | cameraCode | String | 必须 | 摄像机平台编码。

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultcode | Integer | 成功返回0，失败返回错误码
2 | videoDiagnoseInfo | Object | 单台摄像机视频质量诊断计划信息。VdeoDiagnoseInfo

使用示例

https://192.168.203.36:18531/video/diagnose/v1.0/dabce15d2fd342659eef4176c5a686f4/04022518988412720101

接口返回消息示例数据如下：

{

"resultCode": 0,

"videoDiagnoseInfo": {

"domainCode": "dabce15d2fd342659eef4176c5a686f4",

"planList": [

{

"cameraId": "04022518988412720101",

"planInfo": {

"planId": "36549FC607A311EA8000485702355341",

"planName": "04022518988412720101",

"activeFlag": 1,

"planStatus": 0,

"startFlag": 0,

"manuaFlag": 0,

"alarmType": 0,

"periodType": 1,

"dayPlan": {

"timeList": [

{

"startTime": "080000",

"stopTime": "100000"

},

{

"startTime": "110000",

"stopTime": "120000"

},

{

"startTime": "190000",

"stopTime": "200000"

}

]

}

},

"ruleGroup": {

"ruleGroupId": "3654AC1407A311EA8000485702355341",

"streamId": 1,

"ruleType": 0,

"qualityDiagnosis": {

"ruleSize": 2,

"ruleInfoList": [

{

"diagnoseType": 4,

"sensitivity": 4,

"duration": 0

},

{

"diagnoseType": 6,

"sensitivity": 4,

"duration": 0

}

]

}

}

}

]

}

}

父主题： 视频控制接口


设置每天视频诊断计划

接口描述

此接口用于设置单台摄像机的视频质量诊断计划。

使用说明

请求方法 | PUT
请求URL | /video/diagnose/dayPlan/v1.0
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | domainCode | String | 必须 | 摄像机所在域编码
2 | cameraId | String | 必须 | 摄像机平台编码
3 | planName | String | 必须 | 计划名称，支持中文,
4 | dianosisType | String | 必须 | 视频质量诊断类型，用逗号分隔，例如：“1,2,3”(0:Brightness亮度,1:Darkness暗度2:Blur清晰度,3:SnowNoise雪花,4:ColourCast偏色,5:StripeNoise条纹,6:FrameFrozen冻结,7:Shake抖动,8:CameraCovered遮挡)
5 | timeList | List<DiagnoseTimePlan> | 必须 | 时间段，支持多个时间段

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultcode | Integer | 成功返回0，失败返回错误码

使用示例

https://192.168.203.36:18531/video/diagnose/dayPlan/v1.0

接口请求消息示例数据如下：

{

"domainCode": "dabce15d2fd342659eef4176c5a686f4",

"cameraId":"04022518988412720101",

"planName":"04022518988412720101",

"timeList":[

{

"startTime":"080000",

"stopTime":"100000"

},

{

"startTime":"110000",

"stopTime":"120000"

},

{

"startTime":"190000",

"stopTime":"200000"

}

],

"dianosisType":"4,6"

}

接口返回消息示例数据如下：

{

"resultCode"：0表示成功，其他表示失败，整形

}

父主题： 视频控制接口


删除视频诊断计划

接口描述

此接口用于删除单台摄像机的视频质量诊断计划。

使用说明

请求方法 | DELETE
请求URL | /video/diagnose/v1.0
请求数据 | application/json;charset=UTF-8

参数描述

序号 | 字段名称 | 字段类型 | 必选/可选↵ | 字段描述
1 | domainCode | String | 必须 | 摄像机所在域编码
2 | camreaId | String | 必须 | 摄像机平台编码
3 | periodType | int | 必须 | 周期类型

响应信息

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultcode | Integer | 成功返回0，失败返回错误码

使用示例

https://192.168.203.36:18531/video/diagnose/v1.0

接口请求消息示例数据如下：

{

"domainCode": "dabce15d2fd342659eef4176c5a686f4",

"cameraId":"04022518988412720101",

"periodType":1

}

接口返回消息示例数据如下：

{

"resultCode"：0表示成功，其他表示失败，整形

}

父主题： 视频控制接口


图片抓拍

  • 平台抓拍
  • 获取平台抓拍图片列表
  • 删除平台抓拍图片
  • 获取告警抓拍图片列表
  • 订阅图片实时统计
  • 取消订阅图片实时统计
  • 查询历史图片统计（按摄像机维度）
  • 查询历史图片统计（整域查询）


平台抓拍

接口描述

抓取实况图片保存到平台。

该接口仅支持实时浏览或录像回放接口调用。

平台抓拍，可在设备管理设置设备参数时对每个摄像机设置抓拍参数。当uiConfigType = CONFIG_CAMERA_SNAPSHOT_CFG时，设置的就是摄像机抓拍参数。

使用说明

请求方法 | GET
请求URL | /platform/platformSnapshot/{cameracode}/{domaincode}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /platform/platformSnapshot/00000000100000000101/dc451bcc70ff4ed1a2 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameracode | String | 必选 | 摄像机编码
2 | domaincode | String | 必选 | 设备所属域编码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/platform/platformSnapshot/00000000100000000101/dc451bcc70ff4ed1a2

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 图片抓拍


获取平台抓拍图片列表

接口描述

从服务器获取抓拍图片列表

使用说明

请求方法 | GET
请求URL | /platform/snapshotlist/{cameracode}/{nvrcode}/{starttime}/ {endtime}/{fromindex}/{toindex}/{snaptype}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /platform/snapshotlist/04029040000000000101/3bf63c6d6b8c44e88f40b2e3db1aeec8/20180130102010/20180131231020/1/10/4/ HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameracode | String | 必选 | 摄像机编码#号之前数据
2 | domaincode | String | 必选 | 设备所属域编码
3 | starttime | String | 必选 | 开始时间，格式如yyyyMMddHHmmss
4 | endtime | String | 必选 | 结束时间，格式如yyyyMMddHHmmss
5 | fromindex | Integer | 必选 | 开始索引
6 | toindex | Integer | 必选 | 结束索引(结束索引必须大于或者等于开始索引)
7 | snaptype | Integer | 必选 | 抓拍类型： 异或标记值（例如0x01 | 0x02=3表示查询类型包括智能分析抓拍和告警抓拍）： 1：智能分析抓拍 2：告警抓拍 4：手动抓拍(包括定时抓拍)

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | snapshotInfoList | Object | 获取的抓拍图片列表信息 参见类型SnapshotInfoList

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/platform/snapshotlist/04029040000000000101/3bf63c6d6b8c44e88f40b2e3db1aeec8/

20180130102010/20180131231020/1/10/4/

接口返回消息示例数据如下：

{

"resultCode": 0,

"snapshotInfoList": {

"total": 2,

"indexRange": {

"fromIndex": 1,

"toIndex": 100

},

"snapshotInfos": [

{

"cameraCode": "04029040000000000101#3bf63c6d6b8c44e88f40b2e3db1aeec8",

"snapTime": "20180131141505",

"snapType": 4,

"pictureID": 67,

"pictureName": "/Snapshot/04029040000000000101/0402904000000000010120180131141505045625.jpg",

"pictureSize": 1394,

"previewUrl": "https://192.168.215.136:8481/FileService/DownloadFile?filesessionid=FN1KTHG6I48UH000UH67UC6948",

"pictureUrl": "https://192.168.215.136:8481/FileService/DownloadFile?filesessionid=FN1JRUG6I48UH000UH67UC6948",

"reserve": ""

},

{

"cameraCode": "04029040000000000101#3bf63c6d6b8c44e88f40b2e3db1aeec8",

"snapTime": "20180131141508",

"snapType": 4,

"pictureID": 68,

"pictureName": "/Snapshot/04029040000000000101/0402904000000000010120180131141508547384.jpg",

"pictureSize": 1393,

"previewUrl": "https://192.168.215.136:8481/FileService/DownloadFile?filesessionid=FN1LGEG6I48UH000UH67UC6948",

"pictureUrl": "https://192.168.215.136:8481/FileService/DownloadFile?filesessionid=FN1LLR06I48UH000UH67UC6948",

"reserve": ""

}

]

}

}

父主题： 图片抓拍


删除平台抓拍图片

接口描述

删除平台或前端抓拍的图片

使用说明

请求方法 | GET
请求URL | /platform/deletesnapshot/{cameracode}/{nvrcode}/{pictureid}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /platform/deletesnapshot/04029040000000000101/3bf63c6d6b8c44e88f40b2e3db1aeec8/1 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameracode | String | 必选 | 摄像机编码#号之前数据
2 | nvrcode | String | 必选 | 设备所属域编码。例如：a87f463b7dd741908668c89c84a27e30
3 | pictureid | String | 必选 | 抓拍到的图片ID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/platform/deletesnapshot/04029040000000000101/3bf63c6d6b8c44e88f40b2e3db1aeec8/1

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 图片抓拍


获取告警抓拍图片列表

接口描述

根据告警ID获取对应抓拍图片信息。

使用说明

请求方法 | POST
请求URL | /snapshot/alarmsnapshotlist/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /snapshot/alarmsnapshotList/v1.0

HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 |  | 字段类型 | 是否必填 | 字段名称
1 | deviceCodeList |  | List | 是 | 告警联动设备列表
2 |  | deviceCode | String | 是 | 告警联动设备编码
3 | alarmInfo |  | Object | 是 | 告警信息
4 |  | alarmEventId | Long | 是 | 告警事件ID
5 |  | alarmInCode | String | 是 | 告警源编码，参考用户及设备编码ID与命名规则

响应参数

序号 | 请求字段 |  |  | 字段类型 | 是否必填 | 字段名称
1 | resultCode |  |  | Integer | 是 | 成功返回0，失败返回错误码
2 | snapShotList |  |  | List | 是 | 抓拍图片列表
3 |  | snapInfo |  | Object | 是 | 抓拍信息
4 |  |  | pictureId | Long | 是 | 抓拍图片ID
5 |  |  | pictureName | String | 是 | 抓拍图片文件名
6 |  |  | cameraCode | String | 是 | 摄像机编码
7 |  |  | snapTime | String | 是 | 抓拍时间(UTC时间)，yyyyMMddHHmmss
8 |  |  | snapType | Integer | 是 | 抓拍类型： 1：智能分析抓拍 2：告警抓拍 4：手动抓拍(包括定时抓拍)
9 |  |  | pictureSize | Integer | 是 | 图片文件大小，单位KB
10 |  |  | previewUrl | String | 是 | 抓拍缩略图URL
11 |  |  | pictureUrl | String | 是 | 抓拍图片URL

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/snapshot/alarmsnapshotlist/v1.0

{

"deviceCodeList": [

{"deviceCode":"83739310225011830101#bec9582c522646f8b393225a54b4a73a"}

],

"alarmInfo": {

"alarmEventId": 3671,

"alarmInCode": "83739310225011830201#bec9582c522646f8b393225a54b4a73a"

}

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"snapShotList": [

{

"pictureId": 610,

"pictureName": "/Snapshot/83739310225011830101/8373931022501183010120190821025251888004_000.jpg",

"cameraCode": "83739310225011830101",

"snapTime": "20190821025251",

"snapType": 2,

"pictureSize": 110,

"previewUrl": "http://172.16.5.36:1047/downloadfile?filesessionid=RO9NJ2M3NS8UJ000A1EQP2VTUG",

"pictureUrl": "http://172.16.5.36:1047/downloadfile?filesessionid=RO9M0763NS8UJ000A1EQP2VTUG"

}

]

}

父主题： 图片抓拍


订阅图片实时统计

接口描述

第三方应用向eSDK订阅单个域的实时图片统计数据的回调URL地址信息。

调用该接口的订阅的用户，在用户在REST服务上线时可以在设定的URL接收到IVS系统返回的单个域的图片传输统计实时推送消息。每次推送的时间间隔在CSP Portal统一设置。

如果同一个用户多次订阅，以最后一次的订阅数据生效并进行推送。

使用说明

请求方法 | POST
请求URL | /images/realstatistics/subscribe/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /images/realstatistics/subscribe/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 |  | 字段类型 | 可选/必选 | 字段名称
1 | subscribeInfoList |  | List | 必选 | 请求相关信息列表
 |  | domainCode | String | 必选 | 域编码
 |  | url | String | 必选 | 推送的url（请求方式为小写，如：http）

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码。推送数据类型，详见此事件类型

使用示例

接口请求消息示例如下：

{

"subscribeInfoList":[{

"domainCode":"d53423689bd94da9a42a8d5ceeeb277c",

"url":"http://192.168.203.36:18533/RM/GetToken"

}]

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 图片抓拍


取消订阅图片实时统计

接口描述

第三方应用不再需要订阅实时图片统计数据时，通过该接口取消本用户的所有实时订阅。取消订阅成功后，第三方应用不再接收到IVS系统推送的实时图片统计消息

使用说明

请求方法 | GET
请求URL | /images/realstatistics/unsubscribe/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /images/realstatistics/unsubscribe/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

无

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码 具体错误码参考整体IVS接口文档错误码页描述。此处接口错误码有：119135110未订阅图片流量统计不可退订；等。有错误码时可能是部分成功取消订阅，但有部分失败，请再次调用取消接口确保所有域数据全部取消订阅。

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/images/realstatistics/unsubscribe/v1.0

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 图片抓拍


查询历史图片统计（按摄像机维度）

接口描述

此接口用于获取按照摄像机维度在某个时间段的图片传输统计分类汇总值。用户可根据不同的条件获取在某个时间段的按条件统计的历史图片数量。

使用说明

请求方法 | POST
请求URL | /images/historystatisticsbycamera/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /images/historystatisticsbycamera/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 |  | 字段类型 | 可选/必选 | 字段名称
1 | domainCode |  | String | 必选 | 域编码
2 | snapType |  | Integer | 必选 | 图片类型，1 人脸2 过车 3 人体。也就是是否按照图片类型汇总。如果传入0，则全部类型都要，但不会按照类型汇总，分开数据返回。
3 | picType |  | Integer | 必选 | 大小图片类型，1 小图 2 大图。也就是是否按照大小图类型汇总。如果传入0，则全部类型都要，但不会按照类型汇总，分开数据返回。
4 | tranType |  | Integer | 必选 | 图片传输统计类型，1 存储 2 转发。如果传入0，则返回的图片数包括存储和转发，不会按照类型汇总，分开数据返回。（转发包括实时转发和历史转发，记录的时间是具体转发时间做统计）。
5 | startTime |  | String | 必选 | 开始时间（UTC时间）：时间精度为小时时，格式如yyyyMMddHH，例如：2019020710。时间精度为天时，格式yyyyMMdd，例如20190207。时间精度为月时，格式yyyyMM，例如201902。
6 | endTime |  | String | 必选 | 结束时间（UTC时间）：格式同开始时间保持一致，必须等于或大于开始时间。时间精度为小时时，格式如yyyyMMddHH，例如：2019020712。时间精度为天时，格式yyyyMMdd，例如20190208。时间精度为月是，格式yyyyMM，例如201905。 以小时为精度，小时粒度时时间段为UTC时间。天/月做归档时，以运维管理节点系统的本地时间0点做分割。 最大跨度为3个小时/3天/3月。统计计数包含开始和结束的时间。如小时举例2019020710~2019020712为返回2019年2月7日10点到2月7日12点共3小时的数据统计值。 备注：结束时间不能晚于当前时间段时间（UTC时间）
7 | cameraList |  | List | 必选 | 相机编码列表
 |  | cameraCode | String | 必选 | 相机编码 备注：如果不带#号，标识为本域的原始相机或影子相机cameraCode。如果带#号，标识为查询为影子摄像机，请求的参数支持以真实摄像机cameraCode+”#”+domainId方式查询

响应参数

序号 | 请求字段 |  |  |  |  | 字段类型 | 字段名称
1 | resultCode |  |  |  |  | Integer | 成功返回0，失败返回错误码
2 | imgStatisticReport |  |  |  |  | Object | 图片传输统计数据的查询结果。
3 |  | domainCode |  |  |  | String | 域编码
4 |  | cameraList |  |  |  | List | 摄像机列表信息
 |  |  | cameraCode |  |  | String | 摄像机编码（cameraCode保持为请求参数。）
 |  |  | tlvList |  |  | Object | 历史图片信息列表
 |  |  |  | tlvInfo |  | Object | 图片相关信息。
 |  |  |  |  | snapType | Integer | 图片类型，1人脸2过车 3 人体。各类型分开数据返回。
 |  |  |  |  | picType | Integer | 大小图片类型，1小图2大图。各类型分开数据返回。
 |  |  |  |  | tranType | Integer | 图片传输统计类型，1 存储 2 转发。各类型分开数据返回。
 |  |  |  |  | tlvSuccessNum | Long | 统计时间段的成功图片总数量

使用示例

接口请求消息示例如下：

{

"domainCode":"4c1ed8b2e59b44c88719fa865e333a3f",

"snapType":0,

"picType":0,

"tranType":0,

"startTime":"2019092500",

"endTime":"2019092623",

"cameraList":[

{

"cameraCode":"11285156447927980101"

},

{

"cameraCode":"11285156447927980102"

}]

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"imgStatisticReport":{

"domainCode": "4c06c63ce5a144a6bb3be65b316abdf0",

"cameraList": [

{

"cameraCode": "02026301008272380102",

"tlvList": [

{

"tlvInfo":{

"snapType": 1,

"picType": 1,

"tranType": 1,

"tlvSuccessNum": 0

}

}

]

}

]

}

}

父主题： 图片抓拍


查询历史图片统计（整域查询）

接口描述

此接口用于获取单个域某个时间段的整域的图片传输统计分类汇总值。用户可根据不同的条件获取在某个时间段的按条件统计的历史图片数量。

使用说明

请求方法 | POST
请求URL | /images/historystatistics/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /images/historystatistics/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | domainCode | String | 必选 | 域编码
2 | snapType | Integer | 必选 | 图片类型，1 人脸 2 过车 3 人体。也就是是否按照图片类型汇总。如果传入0，则全部类型都要，但不会按照类型汇总，分开数据返回。
3 | picType | Integer | 必选 | 大小图片类型，1 小图 2 大图。也就是是否按照大小图类型汇总。如果传入0，则全部类型都要，但不会按照类型汇总，分开数据返回。
4 | tranType | Integer | 必选 | 图片传输统计类型，1 存储 2 转发。如果传入0，则返回的图片数包括存储和转发，不会按照类型汇总，分开数据返回。（转发包括实时转发和历史转发，记录的时间是具体转发时间做统计）。
5 | startTime | String | 必选 | 开始时间（UTC时间）：时间精度为小时时，格式如yyyyMMddHH，例如：2019020710。时间精度为天时，格式yyyyMMdd，例如20190207。时间精度为月时，格式yyyyMM，例如201902。
6 | endTime | String | 必选 | 结束时间（UTC时间）：格式同开始时间保持一致，必须等于或大于开始时间。时间精度为1小时时，格式如yyyyMMddHH，例如：2019020712。时间精度为天时，格式yyyyMMdd，例如20190208。时间精度为月是，格式yyyyMM，例如201905。 以小时为精度，小时粒度时时间段为UTC时间。天/月做归档时，以运维管理节点系统的本地时间0点做分割。 最大跨度为3个小时/3天/3月。统计计数包含开始和结束的小时。如举例2019020710~2019020712为返回2019年2月7日10点到2月7日12点共3小时的数据统计值。 备注：结束时间不能晚于当前时间段时间（UTC时间）

响应参数

序号 | 请求字段 |  |  |  |  | 字段类型 | 字段名称
1 | resultCode |  |  |  |  | Integer | 成功返回0，失败返回错误码
2 | imgStatisticReport |  |  |  |  | Object | 图片传输统计数据的查询结果。
3 |  | domainCode |  |  |  | String | 域编码
4 |  | cameraList |  |  |  | List | 摄像机图片信息
 |  |  | cameraCode |  |  | String | 此参数为空字符串“”，默认为整域，无相机编码
 |  |  | tlvList |  |  | Object | 历史图片信息列表
 |  |  |  | tlvInfo |  | Object | 图片相关信息。
 |  |  |  |  | snapType | Integer | 图片类型，1人脸2过车 3 人体。各类型分开数据返回。
 |  |  |  |  | picType | Integer | 大小图片类型，1小图2大图。各类型分开数据返回。
 |  |  |  |  | tranType | Integer | 图片传输统计类型，1 存储 2 转发。存储和转发总是按分开数据返回的。
 |  |  |  |  | tlvSuccessNum | Long | 统计时间段的成功图片总数量

使用示例

接口请求消息示例如下：

{

"domainCode":"4c1ed8b2e59b44c88719fa865e333a3f",

"snapType":0,

"picType":0,

"tranType":0,

"startTime":"2019092500",

"endTime":"2019092623"

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"imgStatisticReport":{

"domainCode": "4c06c63ce5a144a6bb3be65b316abdf0",

"cameraList": [

{

"cameraCode": "",

"tlvList": [

{

"tlvInfo":{

"snapType": 1,

"picType": 1,

"tranType": 1,

"tlvSuccessNum": 0

}

}

]

}

]

}

}

父主题： 图片抓拍


云台管理

接口仅适用球机 、带云台的摄像机

  • 增加预置位
  • 删除预置位
  • 修改预置位
  • 查询预置位列表
  • 设置看守位
  • 删除看守位
  • 查询看守位
  • 云台控制命令


增加预置位

接口描述

此接口用于增加预置位（将云台当前位置设置为预置位，添加预置位后转动云台时可将云台直接转动到该位置），每个摄像机最多可设置255个预置位。

使用说明

  • 非球机类型摄像机不建议调用此接口、即使调用成功、也是不生效的
  • 摄像机类型可以通过 获取设备列表接口的返回值查询 ，获取子设备列表
请求方法 | POST
请求URL | /ptz/presetposition/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /ptz/presetposition/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameraCode | String | 必选 | 摄像机编码#域编码 域编码通过获取域路由接口获取 示例：51277777770000000101#d9808a7bfff94de09ecc47a6baa3bf5d
2 | presetName | String | 必选 | 预置位名称，取值范围1~84个字符

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | presetIndex | Integer | 预置位索引号，非负整数 示例：1

使用示例

接口请求消息示例如下：

{

"cameraCode": "51277777770000000101#d9808a7bfff94de09ecc47a6baa3bf5d",

"presetName":"preset1"

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"presetIndex":1

}

父主题： 云台管理


删除预置位

接口描述

此接口用于删除预置位

使用说明

  • 非球机类型摄像机不建议调用此接口、即使调用成功、也是不生效的
  • 摄像机类型可以通过 获取设备列表接口的返回值查询 ，获取子设备列表
请求方法 | DELETE
请求URL | /ptz/presetposition/{cameracode}/{domaincode}/{presetindex}/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

DELETE /ptz/presetposition/51277777770000000101/d9808a7bfff94de09ecc47a6baa3bf5d/0/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameracode | String | 必选 | 摄像机编码 示例：51277777770000000101
2 | domaincode | String | 必选 | 域编码，可通过获取域路由接口获取 示例：d9808a7bfff94de09ecc47a6baa3bf5d
3 | presetindex | String | 必选 | 预置位索引号,非负整数 示例：1

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/ptz/presetposition/51277777770000000101/d9808a7bfff94de09ecc47a6baa3bf5d/1/v1.0

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 云台管理


修改预置位

接口描述

此接口用于修改预置位的名称。预置位信息包括索引号和名称。修改预置位信息时，通过摄像机编码和预置位索引号唯一确定一个预置位，然后修改该预置位的名称。

如果该预置位不存在，则服务端会默认为新增一个预置位。

使用说明

  • 非球机类型摄像机不建议调用此接口、即使调用成功、也是不生效的
  • 摄像机类型可以通过 获取设备列表接口的返回值查询 ，获取子设备列表
请求方法 | PUT
请求URL | /ptz/presetposition/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

PUT /ptz/presetposition/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameraCode | String | 必选 | 摄像机编码#域编码 域编码通过获取域路由接口获取 示例：51277777770000000101#d9808a7bfff94de09ecc47a6baa3bf5d
2 | ptzPresetInfo | Object | 必选 | 预置位信息，类型参见•PTZPresetInfo

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"cameraCode":"01759865897126200101#1cf095245105466181d4fa0efa6f7743",

"ptzPresetInfo":{

"presetName": "hangzhou",

"presetIndex":121

}

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 云台管理


查询预置位列表

接口描述

此接口用于查询指定摄像机的预置位列表

使用说明

  • 非球机类型摄像机不建议调用此接口、即使调用成功、也是不生效的
  • 摄像机类型可以通过 获取设备列表接口的返回值查询 ，获取子设备列表
请求方法 | GET
请求URL | /device/ptzpresetlist/{cameracode}/{nvrcode}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /device/ptzpresetlist/02502460000000000101/43b42979e85d4c0bb4e59b3e9724b675 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameracode | String | 必选 | 相机编码的#号之前数据
2 | nvrcode | String | 必选 | 设备所属域编码。例如：a87f463b7dd741908668c89c84a27e30

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | ptzPresetInfoList | Objecet | 预置位信息列表。最多128个预置位 参见类型PTZPresetInfoList
3 | ptzPresetNum | Integer | 预置位个数

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/device/ptzpresetlist/02502460000000000101/43b42979e85d4c0bb4e59b3e9724b675

接口返回消息示例数据如下：

{

"resultCode": 0,

"ptzPresetInfoList": {

"ptzPresetInfo": {

"presetIndex": 0,

" presetName ": "",

"reserve": ""

}

},

"ptzPresetNum": 1

}

父主题： 云台管理


设置看守位

接口描述

此接口用于设置看守位（看守位作用：设置某一预置位A作为看守位，并设置自动归位等待时长为30秒，则当调整云台位置到另一位置后，将在30s之后，返回到设置的看守位，即预置位A处。）

看守位信息只有一条记录，且重复调用此接口，将直接覆盖上一次记录内容。

使用说明

  • 非球机类型摄像机不建议调用此接口、即使调用成功、也是不生效的
  • 摄像机类型可以通过 获取设备列表接口的返回值查询 ，获取子设备列表
请求方法 | POST
请求URL | /ptz/guardposition/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /ptz/guardposition/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameraCode | String | 必选 | 摄像机编码#域编码 域编码通过获取域路由接口获取 示例：51277777770000000101#d9808a7bfff94de09ecc47a6baa3bf5d
2 | guardPosInfo | Object | 必选 | 看守位信息 参见类型 GuardPosInfo

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

{

"cameraCode": "51277777770000000101#d9808a7bfff94de09ecc47a6baa3bf5d",

"guardPosInfo": {

"presetIndex":0,

"enableGuardPosition":0,

"waitTime":60

}

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 云台管理


删除看守位

接口描述

此接口用于删除看守位

使用说明

  • 非球机类型摄像机不建议调用此接口、即使调用成功、也是不生效的
  • 摄像机类型可以通过 获取设备列表接口的返回值查询 ，获取子设备列表
请求方法 | DELETE
请求URL | /ptz/guardposition/{cameracode}/{domaincode}/{presetindex}/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

DELETE /ptz/guardposition/51277777770000000101/d9808a7bfff94de09ecc47a6baa3bf5d/0/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameracode | String | 必选 | 摄像机编码 示例：51277777770000000101
2 | domaincode | String | 必选 | 域编码，可通过获取域路由接口获取 示例：d9808a7bfff94de09ecc47a6baa3bf5d
3 | presetindex | String | 必选 | 看守位信息中的预置位索引，非负整数

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/ptz/guardposition/51277777770000000101/d9808a7bfff94de09ecc47a6baa3bf5d/1/v1.0

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 云台管理


查询看守位

接口描述

此接口用于查询看守位

使用说明

  • 非球机类型摄像机不建议调用此接口、即使调用成功、也是不生效的
  • 摄像机类型可以通过 获取设备列表接口的返回值查询 ，获取子设备列表
请求方法 | GET
请求URL | /ptz/guardposition/{cameracode}/{domaincode}/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /ptz/guardposition/51277777770000000101/d9808a7bfff94de09ecc47a6baa3bf5d/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json;charset=UTF-8

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameracode | String | 必选 | 摄像机编码 示例：51277777770000000101
2 | domaincode | String | 必选 | 域编码，可通过获取域路由接口获取 示例：d9808a7bfff94de09ecc47a6baa3bf5d

响应参数

序号 | 参数 | 类型 | 描述
1 | resultCode | Integer | 成功返回0，失败返回错误码
2 | guardPosInfo | Object | 看守位信息 参见类型 GuardPosInfo

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/ptz/guardposition/51277777770000000101/d9808a7bfff94de09ecc47a6baa3bf5d/v1.0

接口返回消息示例数据如下：

{

"resultCode": 0,

"guardPosInfo": {

"presetIndex":0,

"enableGuardPosition":0,

"waitTime":60

}

}

父主题： 云台管理


云台控制命令

接口描述

此接口用于操作摄像机云台和设置摄像机镜头

使用说明

  • 非球机类型摄像机不建议调用此接口、即使调用成功、也是不生效的
  • 摄像机类型可以通过 获取设备列表接口的返回值查询 ，获取子设备列表
请求方法 | POST
请求URL | /device/ptzcontrol
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /device/ptzcontrol HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | cameraCode | String | 必选 | 摄像机编码
2 | controlCode | Integer | 必选 | 云镜控制码
3 | controlPara1 | String | 必选 | 云镜控制参数1
4 | controlPara2 | String | 必选 | 云镜控制参数2

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 返回状态码
2 | lockStatus | Integer | 云台是否锁定：0：未锁定1：锁定

使用示例

接口请求消息示例如下：

{

"cameraCode": "00130760000000000101#43b42979e85d4c0bb4e59b3e9724b675",

"controlCode": 1,

"controlPara1": "1",

"controlPara2": "1"

}

接口返回消息示例数据如下：

{

"resultCode": 0,

"lockStatus": 0

}

云镜控制码、控制参数

  • 云镜控制码
  • 云镜控制参数1
  • 云镜控制参数2

描述

1：PTZ_STOP

空值

空值

云台停止转动

2：PTZ_UP

1：点动模式2：连续模式

步长(1-10)

云台向上转动。连续模式下使用1-PTZ_STOP停止转动

3：PTZ_DOWN

1：点动模式2：连续模式

步长(1-10)

云台向下转动。连续模式下使用1-PTZ_STOP停止转动

4：PTZ_LEFT

1：点动模式2：连续模式

步长(1-10)

云台向左转动。连续模式下使用1-PTZ_STOP停止转动

5：PTZ_UP_LEFT

1：点动模式2：连续模式

步长(1-10)

云台左上转动。连续模式下使用1-PTZ_STOP停止转动

6：PTZ_DOWN_LEFT

1：点动模式2：连续模式

步长(1-10)

云台左下转动。连续模式下使用1-PTZ_STOP停止转动

7：PTZ_RIGHT

1：点动模式2：连续模式

步长(1-10)

云台向右转动。连续模式下使用1-PTZ_STOP停止转动

8：PTZ_UP_RIGHT

1：点动模式2：连续模式

步长(1-10)

云台右上转动。连续模式下使用1-PTZ_STOP停止转动

9：PTZ_DOWN_RIGHT

1：点动模式2：连续模式

步长(1-10)

云台右下转动。连续模式下使用1-PTZ_STOP停止转动

10：PTZ_AUTO

空值

空值

云台自动控制

11：PTZ_PREFAB_BIT_RUN

预置位序号。该参数为空值时，表示云台转动到看守位

空值

云台转动到指定预置位

12：PTZ_CRUISE_RUN

巡航轨迹序号

空值

启动巡航轨迹

13：PTZ_CRUISE_STOP

空值

空值

停止巡航轨迹

14：PTZ_MODE_CRUISE_RUN

模式轨迹序号

空值

启动模式轨迹

15：PTZ_MODE_CRUISE_STOP

空值

空值

停止模式轨迹

16：PTZ_MENU_OPEN

空值

空值

打开镜头菜单

17：PTZ_MENU_EXIT

空值

空值

关闭镜头菜单

18：PTZ_MENU_ENTER

空值

空值

进入镜头菜单

19：PTZ_FLIP

空值

空值

云台翻转180度

20：PTZ_START

空值

空值

云台转至起始位

21：PTZ_LENS_APERTURE_OPEN

2：连续模式

速度(1-10)

光圈放大

22：PTZ_LENS_APERTURE_CLOSE

2：连续模式

速度(1-10)

光圈缩小

23：PTZ_LENS_ZOOM_IN

2：连续模式

速度(1-10)

范围放大

24：PTZ_LENS_ZOOM_OUT

2：连续模式

速度(1-10)

范围缩小

25：PTZ_LENS_FOCAL_NEAR

2：连续模式

速度(1-10)

聚焦近

26：PTZ_LENS_FOCAL_FAR

2：连续模式

速度(1-10)

聚焦远

27：PTZ_AUX_OPEN

1：雨刷

2：灯光

空值

打开辅助设备

28：PTZ_AUX_STOP

1：雨刷

2：灯光

空值

关闭辅助设备

29：MODE_SET_START

模式序号

空值

模式设置开始

30：MODE_SET_STOP

模式序号

空值

模式设置停止

31：PTZ_FAST_LOCATE

框选区域的左上角坐标（格式为：x，y），其中x为横坐标，y为纵坐标

框选区域的右下角坐标（格式为：x，y），其中x为横坐标，y为纵坐标

快速定位对焦。在显示窗口中框选关注区域参数1和参数2分别是框选区域的左上角点坐标和右下角点坐标。坐标以CIF分辨率为基准(352 * 288)

32：PTZ_HORIZONTAL_SCAN

空值

空值

开始水平扫描。使用1-PTZ_STOP停止扫描

33：PTZ_VERTICAL_SCAN

空值

空值

开始垂直扫描。使用1-PTZ_STOP停止扫描

34：PTZ_LOCK

空值

空值

云台加锁

父主题： 云台管理


订阅接口

  • 用户与摄像机信息变更订阅请求


用户与摄像机信息变更订阅请求

接口描述

摄像机和用户变更订阅请求。

摄像机和用户变更订阅成功后，当视频监控平台产生摄像机和用户变更时，会推送给调用方，推送信息内容参见IVS_EVENT_REPORT_USER_INFO CHANGE（用户与摄像机信息变更事件10310）。下级域的使用场景，先订阅再获取下级域的用户列表，该订阅才会生效。

使用说明

请求方法 | POST
请求URL | /usercamera/subscription/v1.0
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /usercamera/subscription/v1.0 HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | domainCode | String | 必选 | 域编码，示例：4f297e89479e4867bf38ec5af75679d8 注：domainCode如果传空订阅当前域和下级域；如果填实际的值将只订阅当前
2 | subscribeID | Integer | 必选 | 订阅者ID：用户ID（通过获取用户ID接口获取）
3 | subscribeType | Integer | 必选 | 订阅类型： 1 用户； 2 摄像机； 3 用户摄像机同时订阅

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 成功返回0，失败返回错误码

使用示例

接口请求消息示例数据如下：

{

"domainCode": "4f297e89479e4867bf38ec5af75679d8",

"subscribeID": 1,

"subscribeType": 3

}

接口返回消息示例数据如下：

{

"resultCode": 0,

}

父主题： 订阅接口


附录

  • 数据类型
  • 告警类型
  • 事件定义类型
  • 设备编码规则
  • 证书替换


数据类型

  • AlarmBriefInfo

参数

类型

可选/必选

描述

deviceGroupCode

string

必选

所属设备组编码

例如：根设备编码为0，其他设备组从1开始递增，长度限制128字节，详见设备编码规则

alarmCode

string

必选

告警设备编码

例如：32010300100201030301#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节，详见设备编码规则

domainCode

string

必选

所属域编码

例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节

alarmName

string

必选

告警通道名称

汉字和字母（a-z和A-Z）、数字、中划线和下划线，长度限制260字节

channelType

Integer

必选

通道类型：

  • 0：告警输入
  • 1：告警输出

parentCode

string

必选

主设备编码

例如：32010300100201030000#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节，详见设备编码规则

isExDomain

Integer

必选

是否为外域设备：

  • 0：否
  • 1：是

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • AccountRule

参数

类型

可选/必选

描述

enable

int

必选

是否启用：

  • 0：不启用
  • 1：启用

pwdConsist

PwdConsist

必选

密码复杂性要求

firstModify

int

必选

首次登录是否需要修改密码：

  • 0：不需要
  • 1：需要

checkOldPwd

int

必选

修改密码时是否需要验证旧密码：

  • 0：不需要
  • 1：需要

accountNotFit

int

必选

口令是否可以和帐号相同：

  • 0：不可以
  • 1：可以

accountBackNotFit

int

必选

口令是否可以和帐号的倒写相同：

  • 0-不可以
  • 1-可以

domainAccCheckPwd

int

必选

Windows本地账号登录是否需要输入密码：

  • 0：不需要
  • 1：需要

pwdMinLen

int

必选

密码长度最小值，取值范围为6~64

pwdDifferentNum

int

必选

新旧密码不相同字符个数，取值范围为0~密码长度

accountLockNum

int

必选

账号锁定阈值，0表示无锁定限制，最大999

accountLockElapse

int

必选

账号锁定时长，取值范围为1~1440（单位：分钟）

accountLockInterval

int

必选

账号锁定间隔，取值范围为0~999（单位：分钟）

0表示不自动清零，锁定后需要管理员手动解锁，关于账号锁定间隔具体说明如下：

说明：

例如：accountLockNum=3（次），accountLockElapse=10（分钟），accountLockInterval=5（分钟），即5分钟内，用户连续鉴权错误超过3次，该鉴权账号将被锁定10分钟，10分钟后自动解锁，解锁后，表示用户还可以再次尝试3次鉴权。

如果5分钟内，用户鉴权错误低于3次（假定用户鉴权错误2次），该账号将不会被锁定，5分钟后，该用户还可以再尝试3次，因为前一个5分钟内用户鉴权错误的2次记录被自动清零。

如果accountLockInterval为0，表示用户只要鉴权错误次数超过3次，该账号就会被锁定，且不会自动解锁，需要管理员手动解锁。

pwdExpireTime

int

必选

密码过期时间，密码创建或修改后开始计时，取值范围为0~999（单位：天）

pwdExpireNotifyTime

int

必选

密码过期提醒时间

密码即将过期前，到达提醒时间设定值时系统提醒用户密码即将过期，取值范围为0~99（单位：天）

pwdExpireForceNotify

int

必选

密码过期后是否强制修改：

  • 0：否
  • 1：是

reserve

string

必选

保留字段，长度限制32字节，必须保留该字段，字段内容可以置空
  • AlarmBriefInfos
参数 | 类型 | 可选/必选 | 描述
total | int | 必选 | 总记录数
indexRange | IndexRange | 必选 | 分页信息
reserve | string | 必选 | 保留字段 长度限制32字节，必须保留该字段，字段内容可以置空
alarmBriefInfoList | AlarmBriefInfoList | 必选 | 告警子设备简要信息列表
  • AlarmBriefInfoList
参数 | 类型 | 可选/必选 | 描述
alarmBriefInfo | AlarmBriefInfo | 可选 | 告警子设备简要信息

  • AlarmInConfig

参数

类型

可选/必选

描述

alarmInName

string

必选

告警输入设备名称

汉字和字母（a-z和A-Z）、数字、中划线和下划线，长度限制260字节

alarmInChanIndex

int

必选

告警输入通道索引

switchType

int

必选

设备开关类型：

  • 0：常闭
  • 1：常开

autoClearAlarmTime

int

必选

告警检测时间间隔

取值范围为1~255，单位：秒。默认为120。即每隔120秒检测一次是否在告警状态并上报

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • AlarmOutConfig

参数

类型

可选/必选

描述

alarmOutName

string

必选

告警输出设备名称

汉字和字母（a-z和A-Z）、数字、中划线和下划线，长度限制128字节

alarmOutChanIndex

int

必选

告警输出通道索引

switchType

int

必选

设备开关类型：

  • 0：常闭
  • 1：常开

alarmOutMode

int

必选

告警输出模式：

  • 0：单稳态
  • 1：双稳态

holdTime

int

必选

延迟时间，分为如下两种情况：

  • 单稳态时有效，取值范围为1~600，单位：秒，默认为10
  • 双稳态时无效，默认为10

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • AlarmLinkageInfo

    参数

    类型

    可选/必选

    描述

    linkageId

    Integer

    必选

    联动策略id

    actionList

    List<ActionLinkageModel>

    必选

    告警联动动作列表
  • ActionLinkageModel

    参数

    类型

    可选/必选

    描述

    actionType

    Integer

    必选

    告警动作类型。 具体信息如下：

    • 1：用户交互
    • 2：联动录像
    • 3：联动前端录像
    • 4：联动抓拍
    • 5：联动预置位
    • 6：联动开关量输出
    • 7：联动客户端弹出实况
    • 8：联动实况上墙
    • 9：联动Email
    • 10：联动短信
    • 11：联动彩信
    • 12：联动录像备份

    globalParam

    String

    必选

    全局动作参数

    actionBranch

    Integer

    必选

    执行分支：

    • 0：总是执行
    • 1：确认后执行
    • 2：延时未确认执行

    devList

    List<DevInfo>

    可选

    执行动作的设备列表，不涉及动作设备的可以为空

    userList

    List<LinkageUserInfo>

    可选

    动作目标用户，不涉及目标的可以为空。涉及目标的动作有： 联动短信、联动彩信、联动Email、联动实况、联动上墙
  • AudioBriefInfo

参数

类型

可选/必选

描述

deviceGroupId

Integer

必选

设备组ID

audioCode

string

必选

语音设备编码

例如：32010300100201030401#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节，详见设备编码规则

domainCode

string

必选

所属域编码

例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节

audioName

string

必选

语音设备名称

汉字和字母（a-z和A-Z）、数字、中划线和下划线，长度限制128字节

channelType

Integer

必选

通道类型：

  • 0：语音输入
  • 1：语音输出

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空

  • AudioBriefInfos
参数 | 类型 | 可选/必选 | 描述
total | Integer | 必选 | 总记录数
indexRange | IndexRange | 必选 | 分页信息
reserve | string | 必选 | 保留字段，长度限制32字节，必须保留该字段，字段内容可以置空
audioBriefInfoList | AudioBriefInfosList | 必选 | 语音子设备简要信息列表
  • AudioBriefInfosList
参数 | 类型 | 可选/必选 | 描述
audioBriefInfo | AudioBriefInfo | 可选 | 语音子设备简要信息
  • AudioConfig

参数

类型

可选/必选

描述

audioName

string

必选

音频子设备名称长度，键盘可见字符和中文，长度限制128字节

channelType

int

必选

通道类型：

  • 0：语音输入
  • 1：语音输出

audioIndex

int

必选

语音通道索引，正整数，取值范围根据设备协议类型确定

audioParam

AudioParam

必选

音频参数

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空

  • AudioParam

参数

类型

可选/必选

描述

pitch

int

必选

定调

volume

int

必选

声道

inputType

int

必选

输入类型

dataFormat

int

必选

数据格式：

  • 1：G711的A率
  • 2：G711的U率
  • 3：G726

sampleRate

int

必选

采样率

channel

int

必选

频道

gain

int

必选

增益

sampleBits

int

必选

比特率

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • Backlight

参数

类型

可选/必选

描述

backlightMode

int

必选

背光补偿模式：

  • 0：关闭
  • 1：开启

backlightLevel

int

必选

背光补偿等级

取值范围为0~3，0为最低等级，3为最高等级

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • BookmarkInfo
参数 | 类型 | 可选/必选 | 描述
bookmarkId | int | 必选 | 录像标签ID
bookmarkName | string | 必选 | 录像标签名称 由汉字和字母（a-z和A-Z）、数字、中划线和下划线组成，长度限制612字节
bookmarkTime | string | 必选 | 标签时间 时间格式为yyyyMMddHHmmss，例如：20121207102035，长度限制20字节
cameraCode | string | 必选 | 摄像机编码 例如：32010300100201030101#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节
cameraName | string | 必选 | 摄像机名称 键盘可见字符和中文，长度限制128字节
userDomain | string | 必选 | 添加该录像标签的用户所在域编码 例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节
bookmarkCreatorId | int | 必选 | 添加该录像标签的用户ID
bookmarkCreatorName | string | 必选 | 添加该录像标签的用户名 键盘可见字符和中文，长度限制128字节
nvrCode | string | 必选 | NVR编码 查询平台录像的标签时，该字段有值 例如：9145a3f7c4164d3ab9e161fcb4221426，长度限制32字节
mbuDomain | string | 必选 | 备份服务器域编码 查询备份录像的标签时，该字段有值 例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节
reserve | string | 必选 | 保留字段 长度限制32字节，必须保留该字段，字段内容可以置空

  • BroadcastInfo
参数 | 类型 | 可选/必选 | 描述
ip | IPInfo | 必选 | 组播地址
port | int | 必选 | 组播端口
timeToLive | int | 必选 | 生存时间（TTL），单位秒 取值范围为1~255，一般情况下为128
reserve | string | 必选 | 保留字段 长度限制32字节，必须保留该字段，字段内容可以置空
  • CameraCodeList
参数 | 类型 | 可选/必选 | 描述
cameraCode | String | 必选 | 摄像机编码#域编码 示例：51277777770000000101#d9808a7bfff94de09ecc47a6baa3bf5d
  • CameraConfig

参数

类型

可选/必选

描述

videoChannel

int

必选

视频输入通道号

取值范围根据主设备协议类型确定，一般从1开始

cameraCode

string

必选

摄像机编码

例如：32010300100201030101#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节

cameraName

string

必选

摄像机名称

键盘可见字符和中文，长度限制192字节

cameraPosition

CameraPosition

必选

摄像头位置信息

isSupportBroadcast

int

必选

是否支持组播：

  • 0：不支持
  • 1：支持

broadcastInfo

BroadcastInfo

必选

组播信息

enableVoice

int

必选

是否启用随路音频：

  • 0：不启用
  • 1：启用

voiceOutCode

string

必选

摄像机绑定的音频输出通道

只能为相同主设备上的音频输出通道，例如：32010300100201030401#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节

parentCode

string

必选

主设备编码

例如：32010300100201030000#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节，详见设备编码规则

nvrCode

string

必选

设备所属NVR编码

表示该设备被该NVR管理，例如：9145a3f7c4164d3ab9e161fcb4221426，长度限制32字节，详见设备编码规则

cameraType

int

必选

摄像机类型：

  • 0：固定枪机
  • 1：有云台枪机
  • 2：球机
  • 3：半球-固定摄像机

cameraStatus

int

必选

摄像机扩展状态：

  • 1：正常
  • 2：视频丢失

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • CameraDisplayConfig
参数 | 类型 | 可选/必选 | 描述
brightness | int | 必选 | 亮度，取值范围为0~255
contrast | int | 必选 | 对比度，取值范围为0~255
hue | int | 必选 | 色度，取值范围为0~255
saturation | int | 必选 | 饱和度，取值范围为0~255
reserve | string | 必选 | 保留字段 长度限制32字节，必须保留该字段，字段内容可以置空
  • CameraExtendConfig

参数

类型

可选/必选

描述

enableWatermark

int

必选

是否启用水印：

  • 0：不启用
  • 1：启用

reliableTransmission

int

必选

可靠传输类型：

  • 0：NONE
  • 1：FEC
  • 2：ARQ
  • 3：HARQ

fecMatrix

int

必选

可靠传输类型FEC模式下有效，其他类型时该字段值为0

矩阵模式为：

  • 0：5x5矩阵
  • 1：7x7矩阵
  • 2：8x4矩阵
  • 3：9x6矩阵
  • 4：10x4矩阵
  • 5：11x4矩阵
  • 6：12x6矩阵
  • 7：15x5矩阵
  • 8：18x6矩阵
  • 9：19x5矩阵
  • 10：24x7矩阵
  • 11：26x6矩阵
  • 12：34x1矩阵

enableBandwidthAdaptive

int

必选

是否启用带宽自适应：

  • 0：不启用
  • 1：启用

enableCache

int

必选

是否启用缓存：

  • 0：不启用
  • 1：启用

mediaSecURItyConfig

MediaSecURItyConfig

必选

媒体安全参数

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空

  • CameraImagingConfig

参数

类型

可选/必选

描述

backlight

Backlight

必选

背光参数

exposure

Exposure

必选

曝光参数

focus

Focus

必选

变焦参数

wideDynamic

WideDynamic

必选

宽动态参数

whiteBalance

WhiteBalance

必选

白平衡参数

stabilization

Stabilization

必选

防抖动参数

irCutFilter

int

必选

是否开启红外过滤：

  • 0：不开启
  • 1：开启
  • 2：自动

sharpness

int

必选

锐度

取值范围为0~100，0为最低等级，100为最高等级

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • CameraBriefInfo

参数

类型

可选/必选

描述

code

string

必选

设备编码

长度限制64字节，详见设备编码规则

name

string

必选

摄像机名称

键盘可见字符和中文，长度限制192字节

deviceGroupCode

string

必选

所属设备组编码

长度限制128字节

parentCode

string

必选

父设备编码

一般为主设备编码，例如：32010300100201030000#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节，详见设备编码规则

domainCode

string

必选

设备归属域的域编码

例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节

deviceModelType

string

必选

主设备型号

由各设备厂家提供，长度限制32字节

vendorType

string

必选

设备提供商类型：（长度限制32字节）

  • HW
  • HIK
  • DAHUA
  • SUNELL
  • CANON
  • CHANGHONG
  • TIANDY
  • PANASONIC
  • AXIS

deviceFormType

Integer

必选

主设备类型：

  • 1：IPC
  • 2：DVS
  • 3：DVR
  • 4：eNVR

type

Integer

必选

摄像机类型：

  • 0：固定枪机
  • 1：有云台枪机
  • 2：球机
  • 3：半球-固定摄像机
  • 4：筒机

cameraLocation

string

必选

摄像机安装位置描述

键盘可见字符和中文，长度限制256字节

cameraStatus

Integer

必选

摄像机扩展状态：

  • 1：正常
  • 2：视频丢失

status

Integer

必选

设备状态：

  • 0：离线
  • 1：在线
  • 2：休眠

netType

Integer

必选

网络类型：

  • 0：有线
  • 1：无线

isSupportIntelligent

Integer

必选

是否支持智能分析：

  • 0：不支持
  • 1：支持

enableVoice

Integer

必选

是否启用随路音频：

  • 0：停用
  • 1：启用

nvrCode

string

必选

设备所属NVR编码

表示该设备被该NVR管理，例如：9145a3f7c4164d3ab9e161fcb4221426，长度限制32字节

deviceCreateTime

string

必选

设备创建时间

格式为yyyyMMddHHmmss，如20121207102035，长度限制20字节

isExDomain

Integer

必选

是否为外域：

  • 0：否
  • 1：是

deviceIP

string

必选

前端IP

点分十进制格式，例如：10.166.166.126，长度限制64字节

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • CameraBriefInfos
参数 | 类型 | 可选/必选 | 描述
total | Integer | 必选 | 总记录数
indexRange | IndexRange | 必选 | 分页信息
cameraBriefInfoList | CameraBriefInfoList | 必选 | 视频子设备简要信息
  • CameraBriefInfoList
参数 | 类型 | 可选/必选 | 描述
cameraBriefInfo | CameraBriefInfo | 可选 | 视频子设备信息
  • CameraBriefInfoV2

参数

类型

可选/必选

描述

code

string

必选

设备编码

长度限制64字节，详见设备编码规则

name

string

必选

摄像机名称

键盘可见字符和中文，长度限制192字节

deviceGroupCode

string

必选

所属设备组编码

长度限制128字节

parentCode

string

必选

父设备编码

一般为主设备编码，例如：32010300100201030000#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节，详见设备编码规则

domainCode

string

必选

设备归属域的域编码

例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节

deviceModelType

string

必选

主设备型号

由各设备厂家提供，长度限制32字节

vendorType

string

必选

设备提供商类型：（长度限制32字节）

  • HW
  • HIK
  • DAHUA
  • SUNELL
  • CANON
  • CHANGHONG
  • TIANDY
  • PANASONIC
  • AXIS

deviceFormType

Integer

必选

主设备类型：

  • 1：IPC
  • 2：DVS
  • 3：DVR
  • 4：eNVR

type

Integer

必选

摄像机类型：

  • 0：固定枪机
  • 1：有云台枪机
  • 2：球机
  • 3：半球-固定摄像机
  • 4：筒机

cameraLocation

string

必选

摄像机安装位置描述

键盘可见字符和中文，长度限制256字节

cameraStatus

Integer

必选

摄像机扩展状态：

  • 1：正常
  • 2：视频丢失

status

Integer

必选

设备状态：

  • 0：离线
  • 1：在线
  • 2：休眠

netType

Integer

必选

网络类型：

  • 0：有线
  • 1：无线

isSupportIntelligent

Integer

必选

是否支持智能分析：

  • 0：不支持
  • 1：支持

enableVoice

Integer

必选

是否启用随路音频：

  • 0：停用
  • 1：启用

nvrCode

string

必选

设备所属NVR编码

表示该设备被该NVR管理，例如：9145a3f7c4164d3ab9e161fcb4221426，长度限制32字节

deviceCreateTime

string

必选

设备创建时间

格式为yyyyMMddHHmmss，如20121207102035，长度限制20字节

isExDomain

Integer

必选

是否为外域：

  • 0：否
  • 1：是

deviceIP

string

必选

前端IP

点分十进制格式，例如：10.166.166.126，长度限制64字节

longitude

string

必选

经度，长度限制20字节

latitude

string

必选

纬度，长度限制20字节

height

Float

必选

摄像机安装高度

isShadowDev

Integer

必选

是否为影子摄像机

  • 0：否
  • 1：是

origDevCode

string

必选

原始设备编码，长度限制64字节

origParentDevCode

string

必选

原始父设备编码，长度限制64字节

oriDevDomainCode

string

必选

原始域编码，长度限制32字节

haveAlarmLinkage

Integer

必选

是否配置告警联动计划

  • 0：否
  • 1：是

deleteStatus

Integer

必选

删除状态

  • 0：待彻底删除
  • 1：设备正常

connectCode

string

必选

互联编码，长度限制64字节

supportGA1400

Integer

必选

1400支持能力：

  • 0：不支持1400协议，即作为视频子设备
  • 1：仅支持1400协议，即作为视图子设备
  • 2：同时支持1400协议和视频能力

reserve

string

必选

保留字段

长度限制252字节，必须保留该字段，字段内容可以置空
  • CameraBriefInfosV2
参数 | 类型 | 可选/必选 | 描述
total | Integer | 必选 | 总记录数
indexRange | IndexRange | 必选 | 分页信息
cameraBriefInfoListV2 | CameraBriefInfoListV2 | 必选 | 视频子设备简要信息
  • CameraBriefInfoListV2
参数 | 类型 | 可选/必选 | 描述
cameraBriefInfoV2 | CameraBriefInfoV2 | 可选 | 视频子设备信息
  • CameraOSDConfig

参数

类型

可选/必选

描述

enableOSD

int

必选

注：此字段暂未启用

是否启用OSD：

  • 0：不启用
  • 1：启用

osdTime

OSDTime

必选

OSD时间信息

osdName

OSDName

必选

OSD文字信息

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • CameraRecordStreamConfig

参数

类型

可选/必选

描述

streamType

int

必选

码流类型：

  • 0：不指定流
  • 1：主码流
  • 2：辅码流1
  • 3：辅码流2

reserve

string

必选

保留字段

长度限制8字节，必须保留该字段，字段内容可以置空

  • CameraPosition
参数 | 类型 | 可选/必选 | 描述
longitude | double | 必选 | 安装经度 最多12位小数，单位：度，取值范围为180~180，位数限制20 例如：经度120°59′59″转换为小数显示为120.999722222222
latitude | double | 必选 | 安装纬度 最多12位小数，单位：度，取值范围-180~180，位数限制20 例如：维度32°33′0″转换为小数显示为32.55
height | double | 必选 | 安装高度 位数限制5，单位为m，取值范围0-99.99，例如：安装杆位高度为10.55
cameraLocationDesc | string | 必选 | 摄像机安装位置描述 键盘可见字符和中文，长度限制256字节
reserve | string | 必选 | 保留字段 长度限制32字节，必须保留该字段，字段内容可以置空
  • CameraSnapshotConfig
参数 | 类型 | 可选/必选 | 描述
snapCount | int | 必选 | 抓拍数量，取值范围为1~5
snapInterval | int | 必选 | 抓拍时间间隔，取值范围为1~5，单位：秒
reserve | string | 必选 | 保留字段 长度限制8字节，必须保留该字段，字段内容可以置空
  • CameraStreamConfig
参数 | 类型 | 可选/必选 | 描述
streamInfoNum | int | 必选 | 有效视频流信息数目 取值范围0~8
streamInfoList | StreamInfoList | 必选 | 视频流信息列表 最大视频流信息个数8
reserve | string | 必选 | 保留字段 长度限制32字节，必须保留该字段，字段内容可以置空
  • ClusterInfo
参数 | 类型 | 可选/必选 | 描述
clusterName | String | 必选 | 集群名称
clusterCode | Integer | 必选 | 集群编码
domainCode | String | 必选 | 域编码（查询集群编码时，此字段返回为空）
productType | String | 必选 | 产品类型,有VCN3000、VCN500和VCN520类型。
status | Integer | 必选 | 设备状态： 0 离线(暂无) 1 在线 2 休眠(暂无)
reserve | String | 必选 | 保留字段
  • Clusters
参数 | 类型 | 可选/必选 | 描述
total | Integer | 必选 | 集群个数
clusterInfos | ClusterInfo | 必选 | 集群信息
  • ChannelBean
参数 | 类型 | 可选/必选 | 描述
channelCode | String | 必选 | 通道编码
channelIndex | int | 必选 | 通道序号
  • DeviceBasicInfo

参数

类型

可选/必选

描述

type

int

必选

主设备类型：

  • 1：IPC
  • 2：DVS
  • 3：DVR
  • 4：eNVR

serialNumber

string

必选

序列号（SN/IMEI），长度限制64字节

code

string

必选

设备编码

例如：32010300100201030000#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节，详见设备编码规则

name

string

必选

设备名称

键盘可见字符和中文，长度限制128字节

parentCode

string

必选

父设备编码：

  • 为空：没有父设备
  • 非空：表示该设备被eNVR管理

例如：32010300100204010000#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节，详见设备编码规则

domainCode

string

必选

域编码，例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节

vendorType

string

必选

设备提供商类型：（长度限制32字节）

  • HW
  • HIK
  • DAHUA
  • SUNELL
  • CANON
  • CHANGHONG
  • TIANDY
  • PANASONIC
  • AXIS

model

string

必选

设备型号

由各设备厂家提供，长度限制32字节

ipInfo

IPInfo

必选

设备IP信息

port

int

必选

设备连接端口

reserve

string

可选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空

注：调用添加设备接口时，请求中不添加该字段
  • DeviceBean
参数 | 类型 | 可选/必选 | 描述
orgCode | String | 必选 | 摄像机所属组织编码
camCode | String | 必选 | 摄像机编码
camName | String | 必选 | 摄像机名称
cameraType | int | 必选 | 摄像机类型，必填(整型) 1-标清固定摄像机 2-标清云台摄像机 3-高清固定摄像机 4-高清云台摄像机 5-多通道摄像机
longitude | Double | 必选 | 经度
latitude | Double | 必选 | 纬度
userName | String | 必选 | 用户名
password | String | 必选 | 密码
isAutofit | int | 必选 | 流媒体选择的适应策略 0-为指定流媒体服务器 1-为自适应 2-为不经过流媒体服务器
channels | ChannelBean | 可选 | 可选 摄像机类型为5需下发此字段，其他摄像机类型可不下发
  • DeviceChannel
参数 | 类型 | 可选/必选 | 描述
maxVideoNum | int | 必选 | 最大视频通道数，根据主设备协议类型确定。具体取值如下： protocolType为TEYES：1 protocolType为HIKSDK：16 protocolType为T28181：1 protocolType为HIKSDK2：16 protocolType为ONVIF：1 protocolType为HWSDK：1 protocolType为DHSDK：8 protocolType为DHSDK2：1 protocolType为HBSDK：8 protocolType为HESDK：8
maxAudioInNum | int | 必选 | 最大音频输入通道数为1
maxAudioOutNum | int | 必选 | 最大音频输出通道数为1
maxAlarmInNum | int | 必选 | 最大告警输入通道数为1
maxAlarmOutNum | int | 必选 | 最大告警输出通道数，根据主设备协议类型确定。具体取值如下： protocolType为TEYES：1 protocolType为HIKSDK：1 protocolType为T28181：1 protocolType为HIKSDK2：1 protocolType为ONVIF：2 protocolType为HWSDK：1 protocolType为DHSDK：1 protocolType为DHSDK2：1 protocolType为HBSDK：1 protocolType为HESDK：1
maxSerialNum | int | 必选 | 最大串口通道数，根据主设备协议类型确定。具体取值如下： protocolType为TEYES：1 protocolType为HIKSDK：2 protocolType为T28181：0 protocolType为HIKSDK2：2 protocolType为ONVIF：0 protocolType为HWSDK：1 protocolType为DHSDK：1 protocolType为DHSDK2：1 protocolType为HBSDK：1 protocolType为HESDK：1
reserve | string | 可选 | 保留字段 长度限制32字节，必须保留该字段，字段内容可以置空 注：调用添加设备接口时，请求中不添加该字段
  • DeviceCodeList
参数 | 类型 | 可选/必选 | 描述
deviceCode | String | 必选 | 设备编码 示例：51266666660000000000
  • DeviceConfig

参数

类型

可选/必选

描述

deviceBasicInfo

DeviceBasicInfo

必选

主设备基本信息

protocolType

string

必选

主设备协议类型：（长度限制64字节）

  • TEYES：千里眼
  • ONVIF：开放型网络视频接口协议
  • HWSDK：华为SDK
  • HIKSDK：海康SDK
  • T28181
  • DHSDK：大华SDK
  • HBSDK
  • HESDK
  • HIKSDK2：海康SDK2
  • DHSDK2：大华SDK2

loginType

int

必选

认证类型。

主设备协议类型非ONVIF时，值为0（None）

主设备协议类型是ONVIF时，认证类型有如下三种：

  • 0：None（无需密码验证）
  • 1：HTTP Digest
  • 2：WS-Usernametoken Authentication

enableAlarm

int

必选

是否启用设备告警：

  • 1：启用
  • 0：不启用

videoFormat

int

必选

视频制式：

  • 1：PAL
  • 2：NTSC

directConnectFirst

int

必选

是否直连优先：

  • 0：非直连优先
  • 1：直连优先

maxDirectConnectNum

int

必选

最大直连数目，根据主设备协议类型确定。具体取值如下：

  • protocolType为TEYES、HIKSDK、T28181、HIKSDK2时：4
  • protocolType为ONVIF时：10
  • protocolType为HWSDK、DHSDK、DHSDK2、HBSDK、HESDK时：3

enableSchedule

int

必选

是否启用集群调度：

  • 0：不启用
  • 1：启用（nvrCode不能为空）

nvrCode

string

必选

设备所属NVR编码

表示该设备被该NVR管理，例如：9145a3f7c4164d3ab9e161fcb4221426，长度限制32字节。

tasCode

string

必选

设备所属TAS编码

当设备是被TAS管理时使用，例如：9145a3f7c4164d3ab9e161fcb4221426，长度限制32字节。

deviceUser

string

必选

IVS平台向设备登录用户名

键盘可见字符，长度限制128字节。

devicePassword

string

必选

IVS平台向设备登录密码。

键盘可见字符，长度限制64字节。

deviceRegPassword

string

必选

设备向IVS平台注册密码。

键盘可见字符，长度限制64字节。

deviceChannel

DeviceChannel

必选

设备通道信息

tasIP

IPInfo

必选

设备所属TAS的IP地址

reserve

string

可选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空

注：调用添加设备接口时，请求中不添加该字段
  • DeviceGroup

参数

类型

可选/必选

描述

groupCode

string

必选

设备组编码，为从1开始递增的正整数

例如：1，长度限制128字节

groupName

string

必选

设备组名称

由汉字和字母（a-z和A-Z），数字，中划线和下划线组合，长度限制128字节

parentGroupCode

string

必选

父设备组编码，为从0开始递增的正整数

例如：0，长度限制128字节

domainCode

string

必选

域编码

例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节

isExDomain

int

必选

是否外域设备组：

  • 0：否
  • 1：是

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • DeviceGroupInfos
参数 | 类型 | 可选/必选 | 描述
total | int | 必选 | 总记录数
indexRange | IndexRange | 必选 | 分页信息
deviceGroupList | DeviceGroupList | 必选 | 设备组列表
  • DeviceGroupList
参数 | 类型 | 可选/必选 | 描述
deviceGroup | DeviceGroup | 可选，可多选 | 设备组信息
  • DevInfo

    参数

    类型

    可选/必选

    描述

    devCode

    String

    可选

    设备编码

    param

    String

    可选

    动作参数。联动预置位：预置位ID
  • DeviceNetConfig
参数 | 类型 | 可选/必选 | 描述
puIP | IPInfo | 必选 | 前端IP
puGateway | IPInfo | 必选 | 前端网关（ONVIF设备）
puPort | int | 必选 | 设备端口
maxMtu | int | 必选 | 最大MTU值，根据实际网络情况设定
subNetMask | IPInfo | 必选 | 子网掩码
reserve | string | 必选 | 保留字段 长度限制32字节，必须保留该字段，字段内容可以置空
  • DeviceOperInfo
参数 | 类型 | 可选/必选 | 描述
sequence | Integer | 必选 | 批量操作序列号
deviceConfig | DeviceConfig | 必选 | 主设备配置参数
  • DeviceOperInfos
参数 | 类型 | 可选/必选 | 描述
deviceOperInfo | DeviceOperInfo | 必选 | 设备信息
  • DeviceOperResult
参数 | 类型 | 可选/必选 | 描述
deviceCode | String | 必选 | 设备编码 示例：51277777770000000000
nvrCode | String | 必选 | 设备所属NVR编码
sequence | Integer | 必选 | 批量操作序号
result | Integer | 必选 | 操作是否成功的标识 0：表示成功 其他值：失败，详见错误码
  • DeviceOperResultInfos
参数 | 类型 | 可选/必选 | 描述
number | Integer | 必选 | 添加设备操作失败的结果个数
deviceOperResultList | DeviceOperResultList | 必选 | 批量添加设备操作结果列表
  • DeviceOperResultList
参数 | 类型 | 可选/必选 | 描述
deviceOperResult | DeviceOperResult | 必选 | 批量添加设备操作结果
  • DeviceTimeConfig

参数

类型

可选/必选

描述

备注

enableNTP

int

必选

是否启用NTP同步（CSP全局NTP处于开或关时，设置NTP相关参数无效，不返回错误码。全局NTP处于缺省状态，设置NTP相关参数有效。当CSP全局NTP由缺省状态切换其它状态后，用户请求后全局NTP参数会覆盖原有NTP的参数）：

  • 0：不启用（手动设置时间）
  • 1：启用（自动同步时间）

注：该参数可能存在设备不支持配置的情况，最终设置结果以前端设备为准。

无论字段是否有效，用户都必须输入字段的正确值，否则，返回错误码。

ntp

NTPInfo

必选

NTP信息（当enableNTP值为1即自动同步时间时，该字段有效）

timezone

int

必选

设备所在时区：

根据设备所在时区，计算该时区与零时区的偏移量，取值范围是-50400~50400，东区为正数，西区为负数，数字以秒为单位。例如：中国时区为+8时区，则该字段值为8*3600 ，具体可设置数值与产品支持的时区有关。

注：该参数可能存在设备不支持配置的情况，最终设置结果以前端设备为准。

enableDST

int

必选

是否启用夏令时：

  • 0：不启用
  • 1：启用

注：该参数可能存在设备不支持配置的情况，最终设置结果以前端设备为准。

reserve

string

必选

保留字段，长度限制32字节，必须保留该字段，字段内容可以置空
  • DomainRouteInfos
参数 | 类型 | 可选/必选 | 描述
total | Integer | 是 | 系统实际域路由个数
domainRouteList | DomainRouteList | 否 | 域路由信息集合
  • DomainRouteList
参数 | 类型 | 可选/必选 | 描述
domainRoute | List<•DomainRoute> | 是 | 域路由信息集合
  • DomainRoute
参数 | 类型 | 可选/必选 | 描述
domaintype | Integer | 是 | SMU工作模式：1：堆叠2：集群3：单机
isAgent | Integer | 是 | 是否为代理：0：否1：是
domainCode | String | 是 | 域编码，长度限制32字节
domainName | String | 是 | 域名称
domainIPInfo | IPInfo | 否 | 域IP地址
domainPort | domainCode | 是 | 域端口
superDomain | domainName | 是 | 上级域编码
isLocalDomain | domainIPInfo | 是 | 是否为本域：0：否,1：是
reserve | ipType | 否 | 保留字段
isProgressionTransmit | Integer | 否 | 获取域路由扩展信息返回次字段,否则不返回此字段；是否是转发域：0：否；1：是

  • domainInfo
参数 | 类型 | 可选/必选 | 描述
domainCode | String | 必选 | 外域编码， 外域唯一标识
domainName | String | 必选 | 外域名称
outerDomainType | int | 必选 | 外域类型 1:上级域 2:下级域 3:平级域
domainParentCode | String | 必选 | 父域节点编码。如果无父节点，则填空串
domainPort | String | 必选 | SIP端口，其他厂商按需配置
domainAddr | String | 必选 | 外域IP地址
inTrunkNum | int | 必选 | 本域向外域转发的视频路数上限，取值范围为0~9999，区县平台可暂不实现
protocolType | int | 必选 | 域间通讯协议类型 1:国标
interDomainCode | String | 必选 | 跨域互联域编码
interUserCode | String | 必选 | 跨域互联用户编码
streamTransProtocol | enum | 必选 | 域间流媒体的协议类型，取值为 IMOS_TT_UDP = 0， IMOS_TT_TCP = 1， IMOS_TT_RTP = 2， IMOS_TT_RTP_NO_RTCP = 3， IMOS_TT_AUTO = 4。 注：目前外域只支持自适应和TCP
  • Exposure

参数

类型

可选/必选

描述

exposureMode

int

必选

曝光模式：

  • 0：自动
  • 1：手动

exposurePriority

  • DeviceTimeConfig

int

必选

曝光优先模式：

  • 0：低噪优先
  • 1：帧率优先

rectWindow

RectInfo

必选

曝光窗口

exposureTime

int

必选

曝光时间，单位微秒us

exposureGain

int

必选

曝光增益，单位dB

exposureIris

int

必选

光圈

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • Focus

参数

类型

可选/必选

描述

focusMode

int

必选

变焦模式：

  • 0：自动
  • 1：手动

focusSpeed

int

必选

变焦速度

nearLimit

int

必选

最小变焦

farLimit

int

必选

最大变焦

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • GuardPosInfo
参数 | 类型 | 可选/必选 | 描述
presetIndex | Integet | 必选 | 预置位索引
enableGuardPosition | Integer | 必选 | 启用标识： 0：不启用 1：启用
waitTime | Integer | 必选 | 自动归位等待时长，30秒~3600秒
  • BackupTaskList

    参数

    类型

    可选/必选

    描述

    cameraCode

    String

    必选

    摄像机编码

    taskType

    Integer

    必选

    任务类型：

    • 0：计划任务
    • 1：手动备份
    • 2：告警联动备份

    startTime

    String

    必选

    录像/实况的开始时间，格式为YYYYMMDDHHMMSS

    endTime

    String

    必选

    录像/实况的结束时间，格式为YYYYMMDDHHMMSS

    percent

    String

    必选

    完成百分比

    taskStatus

    Integer

    必选

    任务状态：

    • 0：待执行
    • 1：正在备份
    • 2：暂停
    • 3：备份失败(断流无法完成任务)
    • 9：完成

    taskId

    Integer

    必选

    备份任务ID，唯一标识一个备份任务

    totalSize

    Long

    可选

    文件总大小

    backupSpeed

    String

    可选

    下载速度

    leftTime

    String

    可选

    剩余时间

  • IndexRange
参数 | 类型 | 可选/必选 | 描述
fromIndex | Integer | 必选 | 开始索引 正整数，取值范围为1~1000
toIndex | Integer | 必选 | 结束索引 正整数，取值范围为1~1000，且结束索引必须大于或者等于开始索引
  • IPInfo

参数

类型

可选/必选

描述

ipType

int

是

IP地址类型：

  • 0：IP_V4
  • 1：IP_V6

ip

String

是

IP地址，长度限制64字节
  • LockInfo
参数 | 类型 | 可选/必选 | 描述
lockId | int | 必选 | 录像锁定ID
lockTime | string | 必选 | 执行锁定操作的时间 时间格式为yyyyMMddHHmmss，例如：20121207102035，长度限制20字节
lockTimeSpan | TimeSpan | 必选 | 被锁定的录像的时间段
lockDesc | string | 必选 | 录像锁定描述 键盘可见字符和中文，长度限制260字节
operatorId | int | 必选 | 执行该录像锁定操作的用户ID
operatorName | string | 必选 | 执行该录像锁定操作的用户名 键盘可见字符和中文，长度限制128字节
reserve | string | 必选 | 保留字段 长度限制64字节，必须保留该字段，字段内容可以置空
  • Linkage
参数 | 类型 | 可选/必选 | 描述
domainCode | String | 必选 | 域编码
linkageId | int | 必选 | 联动策略ID
alarmInCode | string | 必选 | 告警源编码
alarmInType | string | 可选 | 告警类型名称可能为空字符串
alarmTypeName | string | 可选 | 告警类型名称
alarmType | string | 必选 | 告警类型
  • MediaAddress
参数 | 类型 | 可选/必选 | 描述
dstIP | IPInfo | 必选 | 媒体流目的IP
audioPort | int | 必选 | 媒体流目的音频端口
videoPort | int | 必选 | 媒体流目的视频端口
reserve | string | 必选 | 保留字段 长度限制32字节，必须保留该字段，字段内容可以置空
  • MediaInfo
参数 | 类型 | 可选/必选 | 描述
winID | Integer | 必选 | 窗口ID
audioStatus | Integer | 必选 | 声音状态
videoFrameRate | Integer | 必选 | 视频当前帧率，单位(fps)，取值范围是1~60
videoBitrate | Integer | 必选 | 视频当前码率
videoAverageBitrate | Integer | 必选 | 视频平均码率
audioBitRate | Integer | 必选 | 音频当前码率，单位(kbps)
audioAverageBitRate | Integer | 必选 | 音频平均码率，单位(kbps)
videoCodec | Integer | 必选 | 视频编码格式
videoWidth | Integer | 必选 | 视频画面宽
videoHeight | Integer | 必选 | 视频画面高
fLossTolerance | Float | 必选 | 丢包率
uiInfoLocationX | Integer | 必选 | i按钮在屏幕上的右下角X坐标
uiInfoLocationY | Integer | 必选 | i按钮在屏幕上的右下角Y坐标
stMediaSourceIP | IPInfo | 必选 | 媒体流发送端IP
reserve | String | 可选 | 保留字段
  • MediaSecURItyConfig

参数

类型

可选/必选

描述

enableMediaSecURIty

int

必选

是否启用媒体安全：

  • 0：不启用
  • 1：启用

enableSecureStorage

int

必选

是否启用安全存储：

  • 0：不启用
  • 1：启用

mediaSecURItyAlgorithm

int

必选

媒体安全算法：

  • 1：AES256
  • 2：媒体扰码

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • MotionDetection

参数

类型

可选/必选

描述

motionDetectionEnable

int

必选

是否启用设备运动检测告警：

  • 0：不启用
  • 1：启用

platformMotionDetection

int

必选

是否启用平台运动检测告警：

  • 0：不启用
  • 1：启用

detectInterval

int

必选

运动监测的时间间隔

在该时间间隔内的所有运动都视为同一个运动。取值范围为1~30，单位：秒，默认为：10

sensitivity

int

必选

运动监测的灵敏度

取值范围为1~5，1表示灵敏度最低，5表示灵敏度最高

autoClearAlarmTime

int

必选

告警检测时间间隔

取值范围为1~255，单位：秒，默认为120秒，即每隔120秒检测一次是否存在告警

rectNum

int

必选

有效区域信息的个数，取值范围为0~8

rectDetectionList

RectInfoList

必选

运动检测区域列表，最大运动检测区域个数为8

reserve

string

必选

保留字段，长度限制32字节，必须保留该字段，字段内容可以置空
  • NTPInfo

参数

类型

可选/必选

描述

ntpType

int

必选

NTP同步方式：

  • 0：DHCP
  • 1：手动指定服务器

ntpServerIP

IPInfo

必选

NTP服务器地址

dnsIP

IPInfo

必选

DNS地址（DNS的ipType值必须与NTP的ipType值保持一致）

reserve

string

必选

保留字段，长度限制32字节，必须保留该字段，字段内容可以置空
  • OSDName

参数

类型

可选/必选

描述

enableOSDName

int

必选

是否显示文字：

  • 0：不显示
  • 1：显示

osdNameText

string

必选

注：实际结果取决于前端设备

键盘可见字符和中文，长度限制256字符

rectText

RectInfo

必选

文字区域

enableSwitch

int

必选

注：该字段暂未启用

文字是否交替显示，即与背景色呈反色显示：

  • 0：不交替
  • 1：交替

switchInterval

int

必选

注：该字段暂未启用

文字交替显示时间间隔，单位为秒

enableTextBlink

int

必选

注：该字段暂未启用

文字是否闪烁显示：

  • 0：不闪烁
  • 1：闪烁

enableTextTranslucent

int

必选

注：该字段暂未启用

文字是否透明显示：

  • 0：不透明
  • 1：透明

textTranslucentPercent

int

必选

注：该字段暂未启用

文字透明度

取值范围为0~100，0为完全透明，100为不透明

reserve

string

必选

保留字段

长度限制64字节，必须保留该字段，字段内容可以置空
  • OSDTime

参数

类型

可选/必选

描述

enableOSDTime

int

必选

是否显示时间：

  • 0：不显示
  • 1：显示

timeFormat

int

必选

时间显示格式：

  • 1：YYYY-MM-DD HH:MM:SS，例如：2009-09-09 09:09:09
  • 2：YYYY年MM月DD日HH :MM:SS，例如：2009年09月09日09 :09 :09

timeX

float

必选

时间X坐标，以显示图像左上角为原点，相对坐标，全图片宽度视为S，X坐标取值0.2表示X轴方向离原点距离为0.2S处，X取值范围为[0，1）

timeY

float

必选

时间Y坐标，以显示图像左上角为原点，相对坐标，全图片高度度视为S，Y坐标取值0.2表示Y轴方向离原点距离为0.2S处，Y取值范围为[0，1）

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • orgNodesInfo
参数 | 类型 | 可选/必选 | 描述
orgCode | String | 必选 | 组织节点编码
orgName | String | 必选 | 组织节点名称
orgParentCode | String | 必选 | 父(上级)组织节点编码
orgDesc | String | 必选 | 组织节点描述
userInfo | String | 必选 | 扩展信息
orgContact | String | 必选 | 联系人
orgMobile | String | 必选 | 移动电话号码
orgAddr | String | 必选 | 联系地址
orgFax | String | 必选 | 传真号码
orgTel | String | 必选 | 座机号码
orgEmail | String | 必选 | 电子邮箱
orgPostalCode | String | 必选 | 邮政编码
  • OperationLogInfos
参数 | 类型 | 可选/必选 | 描述
total | int | 必选 | 总记录数
indexRange | IndexRange | 必选 | 分页信息
operationLogInfoList | OperationLogInfoList | 必选 | 用户操作日志信息列表
  • OperationLogInfoList
参数 | 类型 | 可选/必选 | 描述
operationLogInfo | OperationLogInfo | 可选 | 用户操作日志信息
  • OperationLogInfo
参数 | 类型 | 可选/必选 | 描述
account | string | 必选 | 操作用户账号，长度限制128字节
clientIp | string | 必选 | 客户端IP，点分十进制格式，例如：10.166.166.126。长度限制64字节
logGrade | int | 必选 | 日志级别
serviceCode | string | 必选 | 业务代码，IVS平台写“IVS”，长度限制256字节
moduleType | string | 必选 | 模块类型，譬如“SMU”、“SCU”，长度限制256字节
moduleCode | string | 必选 | 模块唯一代码，指当前模块对应的机器编号，长度限制64字节
operationCode | string | 必选 | 操作代码用来唯一标示一个操作，长度限制64字节
operationObjectCode | string | 必选 | 操作对象代码，用来标示本次操作实施的对象，长度限制256字节
occurTime | string | 必选 | 日志发生时间，长度限制20字节
errorCode | string | 必选 | 错误码，长度限制64字节
result | int | 必选 | 操作结果
additionalInfo | string | 必选 | 附加信息，长度限制256字节
reserve | string | 必选 | 保留字段，长度限制32字节，必须保留该字段，字段内容可以置空
  • PageInfo4Backup
参数 | 类型 | 可选/必选 | 描述
realNum | Integer | 必选 | 总的符合条件的记录数
fromIndex | Integer | 必选 | 从第几条记录开始返回，第1条记录的索引值为1
toIndex | Integer | 必选 | 截止第几条记录
  • PlanInfo
参数 | 类型 | 可选/必选 | 描述
dayType | Integer | 必选 | 日计划时表示每天重复执行）： 0：每天 1：周一 2：周二 3：周三 4：周四 5：周五 6：周六 7：周日
timeSpanInfoNum | Integer | 必选 | 时间段数量，取值范围为0~24
timeSpanInfoList | RecordPlanTimeSpanList | 必选 | 时间段信息列表，最多24条时间段信息
  • PlanInfoList
参数 | 类型 | 可选/必选 | 描述
planInfo | PlanInfo | 必选 | 录像计划时间信息。最多可选7个
  • PlaybackParam

参数

类型

可选/必选

描述

protocolType

int

必选

协议类型：（默认为1）

  • 1：UDP
  • 2：TCP

recordTime

TimeSpan

必选

录像的开始和结束时间

speed

Integer

必选

回放速率

NVRCode

string

必选

要回放的录像文件所在的NVR的NVRCode，长度限制32字节
  • PlaybackTime
参数 | 类型 | 可选/必选 | 描述
playBackTime | String | 是 | 当前回放时间，格式为YYYYMMDDHHMMSS
playBackStartTime | String | 是 | 当前开始时间，格式为YYYYMMDDHHMMSS(本地文件为空)
playBackEndTime | String | 是 | 当前结束时间，格式为YYYYMMDDHHMMSS(本地文件为空)
reserve | String | 否 | 保留字段
  • PTZConfig

参数

类型

可选/必选

描述

decoderType

int

必选

云台解码器类型：

  • 1：pelco_p
  • 2：pelco_d
  • 3：yaan
  • 4：三星
  • 5：新加红苹果5052协议
  • 6：台塑协议
  • 7：红苹果5010协议
  • 99：自定义

decoderAddress

int

必选

云台解码器地址，取值范围为1~15

posNegDirectControl

int

必选

正反向控制：

  • 0：正向
  • 1：反向

serialCode

string

必选

串口编码，长度限制64字节

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • PTZPresetInfo
参数 | 类型 | 可选/必选 | 描述
presetIndex | int | 必选 | 预置位索引号
presetName | string | 必选 | 预置位名称 由汉字和字母（a-z和A-Z）、数字、中划线和下划线组成，长度限制84字节
reserve | string | 可选 | 保留字段 长度限制32字节，必须保留该字段，字段内容可以置空 注：调用修改预置位接口时，请求中不添加该字段
  • PTZPresetInfoList
参数 | 类型 | 可选/必选 | 描述
ptzPresetInfo | PTZPresetInfo | 可选 | 预置位信息，最多可选128个
  • RoleInfos
参数 | 类型 | 可选/必选 | 描述
total | int | 必选 | 总记录数
indexRange | IndexRange | 必选 | 分页信息
roleInfoList | RoleInfoList | 必选 | 角色信息列表
  • RoleInfoList
参数 | 类型 | 可选/必选 | 描述
roleInfo | •RoleInfoEx | 可选 | 角色信息
  • RoleInfoEx

参数

类型

可选/必选

描述

roleId

int

必选

角色ID

roleName

string

必选

角色名称，长度限制128字节

roleType

string

必选

角色类型：

  • 0：用户自定义角色
  • 1：系统预置默认角色
  • 2：超级管理员角色
  • RoleInfo

参数

类型

可选/必选

描述

domainCode

string

必选

角色所属域编码

例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节

roleID

int

必选

角色ID

roleName

string

必选

角色名称，长度限制128字节

roleDescribe

string

必选

角色描述，长度限制256字节

roleType

string

必选

角色类型：

  • 0：用户自定义角色
  • 1：系统预置默认角色
  • 2：超级管理员角色

right

string

必选

角色权限数组，长度为128字节的固定字符串，每一个字节位代表一种权限

角色权限数组示例：“11110010110000000001111110000000000000011011111110000000000000000000000000000000000000000000000000000000000000000000000000000000”

关于每一个字节位上0，1的说明如下：

  • 0：不具备该权限
  • 1：具备该权限

每一位字节对应一种权限。例如：示例中字符串第一位字符为1表示该用户拥有设备管理权限，字符串第五位字符为0表示该用户没有智能分析管理权限。

典型的字节位对应的权限的说明如下：

  1. 默认管理角色
    • 1：设备管理，具体说明如下：

      设备的增、删、改、查；

      子设备启动；

      设备组管理；

      设备参数配置，包含高级参数配置，其中主要包括：码率、分辨率、重启；

      基本参数配置（OSD、亮度、对比度等）

    • 2：用户管理：用户管理、角色管理、权限管理、用户签退、告警订阅（其他用户）
    • 3：录像管理：录像空间、计划配置、预录、补录、录像归档管理（视频归档）
    • 4：录像备份管理：平台、前端录像备份管理、配置备份策略、手动录像备份
    • 5：智能分析管理：智能分析规则设置
    • 7：告警管理：告警订阅、联动策略、防区管理、告警级别
    • 8：网管：客户端网管（含设备类告警通知）
    • 9：录像锁定管理
    • 10：录像书签管理
    • 12：外域管理权限
    • 13：电子地图管理权限
  2. 特殊业务角色
    • 20：电视墙：上墙实况、上墙回放
    • 21：告警处理：告警确认、查询告警、导出告警、撤销、授权告警、本地告警参数配置
    • 22：智能分析操作
    • 23：防区布撤防
    • 24：水印篡改校验
    • 25：手机模拟前端权限
  3. 一般业务角色
    • 40：平台抓拍管理权限（配置、下载、预览、删除）
    • 41：日志查询、导出
    • 42：电子地图操作
    • 43：软解、叠加智能分析结果、局部放大、轮巡/组轮巡、轮巡计划、布局管理、场景管理
    • 44：平台、前端录像回放、局部放大、同步回放、录像检索（包括备份录像）、VCR控制、录像书签
    • 45：平台、前端录像下载、录像检索
    • 46：语音：对讲和广播
    • 47：云台控制：云台预置位、巡航、云台控制、看守位设置、云台加解锁、3D定位、本地云台参数配置
    • 48：手动录像：平台、前端、本地手动录像
    • 49：抓拍操作（包括本地、平台）

accountRule

AccountRule

必选

账号规则ID

reserve

string

必选

保留字段。长度限制32字节，必须保留该字段，字段内容可以置空
  • RealplayParam

参数

类型

可选/必选

描述

streamType

int

必选

码流类型：

  • 0：不指定流
  • 1：主码流
  • 2：辅码流1
  • 3：辅码流2

protocolType

int

必选

协议类型(默认为1)：

  • 1：UDP
  • 2：TCP

directFirst

int

必选

是否直连优先(默认为0)：

  • 0：否，表示中转模式）
  • 1：是，表示直连模式

multiCast

int

必选

是否开启组播(默认为0)：

  • 0：不开启，表示单播
  • 1：开启，表示组播

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • RecordInfo

参数

类型

可选/必选

描述

recordFileName

string

必选

录像文件名

由汉字和字母（a-z和A-Z）、数字、中划线和下划线组成，长度限制256字节

recordMethod

int

必选

录像方式：

  • 0：平台录像
  • 1：前端录像
  • 2：备份服务器
  • 3：容灾录像

nvrCode

string

必选

NVR编码

查询平台录像时，该字段有值。例如：9145a3f7c4164d3ab9e161fcb4221426，长度限制32字节

mbuDomain

string

必选

备份服务器域编码

查询备份录像时，该字段有值。例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节

recordType

int

必选

录像类型：

  • 100：手动录像
  • 010：计划录像
  • 001：告警录像
    说明：

    录像类型可叠加，如：110标识查询手动录像和计划录像。

alarmType

string

必选

告警类型，长度限制64字节，详见告警类型

recordTime

TimeSpan

必选

录像起止时间

frameExtractionTimes

int

必选

录像抽帧次数：

  • 0：完整
  • 1：不完整（抽帧一次）
  • 2：不完整（抽帧二次）
  • 3：不完整（抽帧三次）

bookmarkInfo

BookmarkInfo

必选

录像标签信息（查询方式为按书签时有效）

lockInfo

LockInfo

必选

录像锁定信息（查询方式为按锁定信息时有效）

ptzPresetInfo

PTZPresetInfo

必选

录像预置位信息（查询方式为按预置位查询时有效）

reserve

string

必选

保留字段

长度限制64字节，必须保留该字段，字段内容可以置空

  • RecordInfos
参数 | 类型 | 可选/必选 | 描述
total | int | 必选 | 总记录数
indexRange | IndexRange | 必选 | 分页信息
reserve | string | 必选 | 保留字段 长度限制32字节，必须保留该字段，字段内容可以置空
recordInfoList | RecordInfoList | 必选 | 录像信息列表
  • RecordInfoList
参数 | 类型 | 可选/必选 | 描述
recordInfo | RecordInfo | 可选 | 录像信息
  • RecordPlan
参数 | 类型 | 可选/必选 | 描述
recordMethod | Integer | 必选 | 录像存储位置： 0：平台录像 1：前端录像 2：备份服务器（预留） 3：容灾录像（预留）
enableRecordPlan | Integer | 必选 | 是否启用录像计划： 0：未启用 1：启用
recordPlanType | Integer | 必选 | 录像计划方式： 0：周计划 1：日计划（周一到周日计划相同） 2：全程录像
planInfoNum | Integer | 必选 | 录像计划信息条数，取值范围如下： 周计划时：0~7 日计划时：0~1 全程录像时：0
planInfoList | PlanInfoList | 必选 | 录像计划信息列表： 周计划时最多7个计划时间信息 日计划时最多1个计划时间信息 全程录像时无计划时间信息
  • RecordPlanTimeSpan
参数 | 类型 | 可选/必选 | 描述
startTime | String | 必选 | 开始时间 格式如HHmmss
endTime | String | 必选 | 结束时间 格式如HHmmss
  • RecordPlanTimeSpanList
参数 | 类型 | 可选/必选 | 描述
timeSpan | RecordPlanTimeSpan | 必选 | 时间段
  • RecordPolicy
参数 | 类型 | 可选/必选 | 描述
recordMode | Integer | 必选 | 存储类型 0：全量存储
time | Integer | 必选 | 视频留存天数，单位：天,正整数
planStreamType | Integer | 必选 | 计划录像使用的流： 0：不指定码流 1：主码流 2：辅码流1 3：辅码流2
alarmStreamType | Integer | 必选 | 告警录像使用的流： 0：不指定码流 1：主码流 2：辅码流1 3：辅码流2
alarmRecordTTL | Integer | 必选 | 告警录像留存期，非负整数，单位：天 0：永久 其他值：留存期
manualRecordTTL | Integer | 必选 | 手动录像留存期，非负整数，单位：天 0：永久 其他值：留存期
preRecord | Integer | 必选 | 预录设置，仅对告警录像有效，默认不预录： 0：不预录 2：前端预录
preRecordTime | Integer | 必选 | 预录时长，preRecord=2（前端预录）时必填，单位：秒，范围1～300
associatedAudio | Integer | 必选 | 随路音频叠加选项： 0：不叠加 1：叠加

  • RectInfoList
参数 | 类型 | 可选/必选 | 描述
rectInfo | RectInfo | 可选 | 多个区域列表信息
  • RectInfo

    注：1. 由于左上两个坐标就能固定文字区域矩形框在屏幕中位置，所以右下两个坐标不会起作用。

    2. 矩形框里的文字也不会根据矩形框的宽度变化进行换行调整，统一会单行显示。

参数 | 类型 | 可选/必选 | 描述
left | double | 必选 | 矩形窗口左上角X轴坐标，取值范围为0~图像宽度
top | double | 必选 | 矩形窗口左上角Y轴坐标，取值范围为0~图像高度
right | double | 必选 | 矩形窗口右下角X轴坐标，取值范围为0~图像宽度
bottom | double | 必选 | 矩形窗口右下角Y轴坐标，取值范围为0~图像高度
注：屏幕窗口坐标系，左上角为原点，横向为X轴，纵向为Y轴。
  • ResultInfo
参数 | 类型 | 可选/必选 | 描述
sequence | Integer | 必选 | 批量操作序号
result | Integer | 必选 | 操作是否成功的标识 0：表示成功 其他值：失败，详见错误码
code | String | 必选 | 设备编码 示例：51277777770000000000
  • ResultInfoList
参数 | 类型 | 可选/必选 | 描述
resultInfo | ResultInfo | 必选 | 操作结果
  • ResultInfos
参数 | 类型 | 可选/必选 | 描述
number | String | 必选 | 操作的所有结果个数
resultInfoList | ResultInfoList | 必选 | 操作结果列表
  • SnapshotInfo

参数

类型

可选/必选

描述

cameraCode

String

必选

摄像机编码

snapTime

String

必选

抓拍图片时间，格式如yyyyMMddHHmmss

snapType

Integer

必选

抓拍类型：

  • 1：智能分析抓拍
  • 2：告警抓拍
  • 4：手动抓拍(包括定时抓拍)
    说明：

    异或标记值，例如0x01 | 0x02=3表示查询类型包括智能分析抓拍和告警抓拍。

pictureID

Integer

必选

抓拍图片ID

pictureName

String

必选

文件名

pictureSize

Integer

必选

图片文件大小

previewUrl

String

必选

抓拍图片缩略图URL

pictureUrl

String

必选

抓怕图片URL

reserve

String

必选

保留字段
  • SnapshotInfoList
参数 | 类型 | 可选/必选 | 描述
total | int | 必选 | 总数记录
indexRange | IndexRange | 必选 | 分页信息
snapshotInfos | SnapshotInfo | 必选 | 抓拍图片信息
  • SerialChannelConfig

参数

类型

可选/必选

描述

serialName

string

必选

串口设备名称

汉字和字母（a-z和A-Z），数字，中划线和下划线，长度限制128字节

serialIndex

int

必选

串口索引

serialType

int

必选

串口类型：

  • 0：RS232
  • 1：RS485
  • 2：RS422

baudRate

int

必选

波特率，单位：bps

取值范围：50、75、110、150、300、600、1200、2400、4800、9600、19200、38400、57600、115200

dataBit

int

必选

数据位

取值范围为5~8

parity

int

必选

校验：

  • 0：无校验
  • 1：奇校验
  • 2：偶校验
  • 3：标记校验
  • 4：空校验

stopBit

int

必选

停止位

取值范围：1、2

flowControl

int

必选

流控：

  • 0：无流控
  • 1：软流控
  • 2：硬流控

rserve

string

必选

保留字段

长度限制32字节

  • Stabilization

参数

类型

可选/必选

描述

stabilizationMode

int

必选

防抖动模式：

  • 0：关闭
  • 1：打开
  • 2：自动
  • 3：扩展

stabilizationLevel

int

必选

防抖动等级

取值范围为1~4，1为最低等级，4为最高等级

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空

  • StreamInfo

参数

类型

可选/必选

描述

streamType

int

必选

码流类型：

  • 0：不指定码流
  • 1：主码流
  • 2：辅码流1
  • 3：辅码流2

encodeType

int

必选

编码格式：

  • 1：H264
  • 2：MJPEG
  • 3：MPEG4
  • 4：MPEG2
  • 5：AVS

profile

int

必选

编码配置模式信息，根据encodeType确定：

  • 编码格式为H.264时：
    • 1：BP
    • 2：EP
    • 3：MP
    • 4：HP
  • 编码格式为MJPEG时：
    • 1：SP
    • 2：ASP
  • 其他编码格式时，取值为0

frameInterval

int

必选

I帧间隔

根据设备协议类型确定，一般情况下为25或者30，取值范围：1~100

resolution

string

必选

分辨率，长度限制16字节

分辨率取值如：176*144，320*240，352*288，528*384，704*288，720*288，640*480，704*576，720*576，800*600，1024*768，1280*720，1280*960，1600*1200，1600*2540，1920*1080，2560*1920，2048*1536，2448*2048

picQuality

int

必选

图像质量：

  • 0：高
  • 1：中
  • 2：低

transProtocol

int

必选

传输协议：

  • 1：RTP_OVER_UDP
  • 2：RTP_OVER_TCP
  • 3：UDP
  • 4：TCP

pktProtocol

int

必选

打包协议：

  • 1：ES
  • 2：PS
  • 3：TS

bitRateType

int

必选

码率类型：

  • 0：定码率
  • 1：变码率

bitRate

int

必选

码率，单位（kbps）

码率取值如：32、48、64、80、96、128、160、192、224、256、320、384、448、512、640、768、896、10...1280、1536、1792、2048、3072、4096、6144

frameRate

int

必选

帧率，单位（fps），取值范围如下：

  • 当主设备为PAL制式时取值为25、22、20、18、16、15、12、10、8、6、4、2、1
  • 当主设备为NTSC制式时取值为30、22、20、18、16、15、12、10、8、6、4、2、1

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • StreamInfoList
参数 | 类型 | 可选/必选 | 描述
streamInfo | StreamInfo | 可选 | 视频流信息，最大视频流信息个数为8
  • TimeSpan
参数 | 类型 | 可选/必选 | 描述
startTime | string | 必选 | 开始时间 格式如yyyyMMddHHmmss，例如：20121207102035，长度限制20字节
endTime | string | 必选 | 结束时间 格式如yyyyMMddHHmmss，例如：20121207202035，长度限制20字节
  • TimeSpanList
参数 | 类型 | 可选/必选 | 描述
timeSpan | TimeSpan | 可选 | 多个时间段
  • UserInfo
参数 | 类型 | 可选/必选 | 描述
domainCode | String | 否 | 用户所属域编码
userId | int | 是 | 用户ID
isFirstLogin | int | 是 | 是否是第一次登录： 1：是 ,0：否
roleId | int | 是 | 角色ID，管理员配置
groupId | int | 是 | 用户组ID
loginName | String | 是 | 登录账号
password | String | 否 | 登录密码
pwdModifyDate | String | 否 | 密码修改日期
userType | int | 是 | 用户类型：0：IVS普通用户1：windows域用户
userDomain | String | 否 | Windows域名
status | int | 是 | 用户状态
registerDate | String | 是 | 创建日期
userDesc | String | 否 | 用户描述
ptzLevel | int | 是 | 云台控制优先级
maxSessionCount | int | 是 | 多点登录数
maxVideoCount | int | 是 | 最大视频路数
lockTime | String | 否 | 账号被锁定的时间
userName | String | 是 | 真实姓名
mail | String | 否 | 邮箱
phone | String | 否 | 电话
sex | int | 是 | 性别：0：女性1：男性
validDateFlag | String | 否 | 是否有账户有效期：1：有0：没有
validDateStart | String | 是 | 账户有效起始日期
validDateEnd | String | 否 | 账户有效结束日期
reserve | String | 否 | 保留字段
  • UserInfos
参数 | 类型 | 可选/必选 | 描述
total | int | 必选 | 总记录数
indexRange | IndexRange | 必选 | 分页信息
userInfoList | UserInfoList | 必选 | 用户信息列表
  • UserInfoList
参数 | 类型 | 可选/必选 | 描述
userInfo | •UserInfoEx | 可选 | 总记录数
  • UserInfoEx
参数 | 类型 | 可选/必选 | 描述
userId | int | 是 | 用户ID
roleId | int | 是 | 角色ID，管理员配置
groupId | int | 是 | 用户组ID
loginName | String | 是 | 登录账号
userType | int | 是 | 用户类型：0：IVS普通用户1：windows域用户
status | int | 是 | 用户状态
userDesc | String | 否 | 用户描述
ptzLevel | int | 是 | 云台控制优先级
userName | String | 是 | 真实姓名
mail | String | 否 | 邮箱
phone | String | 否 | 电话
sex | int | 是 | 性别：0：女性1：男性
validDateFlag | String | 否 | 是否有账户有效期：1：有0：没有
validDateStart | String | 是 | 账户有效起始日期
validDateEnd | String | 否 | 账户有效结束日期
  • UserGroupInfos
参数 | 类型 | 可选/必选 | 描述
total | int | 必选 | 总记录数
indexRange | IndexRange | 必选 | 分页信息
userGroupInfoList | UserGroupInfoList | 必选 | 用户組信息列表
  • UserGroupInfoList
参数 | 类型 | 可选/必选 | 描述
userGroupInfo | UserGroupInfo | 可选 | 用户组信息
  • UserGroupInfo
参数 | 类型 | 可选/必选 | 描述
groupID | int | 是 | 用户组ID
groupName | String | 是 | 用户组名称
parentGroupID | int | 是 | 父用户组ID
level | int | 是 | 用户组层级
groupDesc | String | 是 | 用户组备注

  • VideoHideAlarm

参数

类型

可选/必选

描述

enableVideoHide

int

必选

是否启用视频遮挡告警：

  • 0：不启用
  • 1：启用

sensitivity

int

必选

图像遮挡监测的灵敏度

取值范围：1~5，1表示灵敏度最低，5表示灵敏度最高

autoClearAlarmTime

int

必选

告警检测时间间隔

取值范围：1~255，单位：秒，默认为120秒，即每隔120秒检测一次是否存在告警

guardTimeNum

int

必选

视频遮挡告警时间段个数

取值范围：0~12

guardTimeList

TimeSpanList

必选

视频遮挡时间段列表

最大视频遮挡时间段个数12

areaNum

int

必选

视频遮挡告警区域个数

取值范围：0~5

rectAreaList

RectInfoList

必选

视频遮挡告警区域数组

最大图像遮挡告警区域个数5

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • VideoMask

参数

类型

可选/必选

描述

enableVideoMask

int

必选

是否启用隐私保护：

  • 0：不启用
  • 1：启用

areaNum

int

必选

隐私保护区域个数，取值范围：0~5

rectAreaList

RectInfoList

必选

隐私保护区域列表，最多5个区域

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空

  • WideDynamic

参数

类型

可选/必选

描述

wideDynamicMode

int

必选

宽动态模式：

  • 0：关闭
  • 1：开启

wideDynamicLevel

int

必选

宽动态等级

取值范围：0~20，0为最低等级，20为最高等级

reserve

string

必选

保留字段，长度限制32字节，必须保留该字段，字段内容可以置空
  • WhiteBalance

参数

类型

可选/必选

描述

whiteBalanceMode

int

必选

白平衡模式：

  • 0：自动
  • 1：手动

crGain

int

必选

红色增益

cbGain

int

必选

蓝色增益

reserve

string

必选

保留字段

长度限制32字节，必须保留该字段，字段内容可以置空
  • OrderCondition

参数

类型

可选/必选

描述

enableOrder

Integer

必选

是否启用按字段值排序：

  • 0：不启用
  • 1：启用
  • fieldType

Integer

必选

需要排序的字段类型：（查询的结果集中包含指定的排序字段类型时有效）

  • 0：无排序字段
  • 1：默认按数据库记录的生成时间进行排序
  • 100：用户ID
  • 101：用户的登录账号
  • 102：用户真实姓名
  • 103：用户状态
  • 104：用户名类型
  • 200：摄像机编码
  • 300-设备所属NVR编码
  • 301：设备名称
  • 302：具体设备类型
  • 303：具体厂商类型
  • 304：具体的设备IP地址
  • 305：是否在线
  • 306：设备SN
  • 307：设备型号
  • 500：设备组ID
  • 501：设备所属域编码
  • 600：录像查询方式
  • 601：书签名
  • 602：预置位名称
  • 603：锁定描述
  • 604：锁定操作用户类型
  • 605：按存储位置查询录像
  • 606：按录像方式查询录像
  • 607：录像告警类型
  • 608：录像操作用户域
  • 700：管理员账号
  • 701：操作结果
  • 702：开始时间
  • 703：结束时间
  • 704：操作功能代码
  • 705：操作对象编码
  • 800：告警类型级别
  • 801：告警类型
  • 802：告警源类型
  • 803：告警级别
  • 804：告警源编码
  • 805：告警源名称
  • 806：告警级别下限
  • 807：告警级别上限
  • 808：告警级别
  • 809：告警信息状态
  • 810：告警定位信息
  • 811：确认人ID
  • 812：告警源描述
  • 813-告警类型列表
  • 814：需要过滤的告警类型类别
  • 1000：字典类型
  • 1001：字典名称
  • 1002：父节点ID
  • 1100：执行查询操作的用户ID
  • 1101：网元编码
  • 1300：水印告警状态
  • 1301：当前用户所属域编码
  • 1400：互联域编码
  • 1401：共享方向
  • 1402：共享设备资源类型
  • 1403：父设备编码
  • 1404：设备互联编码
  • 1405：是否查询最新

isAscend

Integer

必选

是否升序：

  • 0：降序
  • 1：升序
  • QueryFieldList
参数 | 类型 | 可选/必选 | 描述
queryField | QueryField | 可选 | 查询字段信息
  • QueryField

参数

类型

可选/必选

描述

fieldType

Integer

必选

需要排序的字段类型：（查询的结果集中包含指定的排序字段类型时有效）

value

String

1

字段值

长度限制2048字节

exactQuery

Integer

1

是否精确查询：

  • 0：否
  • 1：是
  • QueryUnifiedFormat
参数 | 类型 | 可选/必选 | 描述
index | IndexRange | 必选 | 分页信息
orderCondition | OrderCondition | 必选 | 排序信息
fieldNum | Integer | 必选 | 查询需要使用的过滤条件字段的数量 fieldNum为0表示无查询限制条件，fieldNum需要和queryFieldList中查询条件个数保持一致。
queryFieldList | QueryFieldList | 可选 | 查询需要使用的过滤条件字段信息列表 说明： fieldNum为0时，不填写该字段 fieldNum非0时，该字段必填
  • QuerySnapshotParam

参数

类型

可选/必选

描述

timeSpan

TimeSpan

必选

抓拍图片时间范围(UTC时间)

indexRange

IndexRange

必选

分页信息

snapType

int

必选

抓拍类型：

异或标记值，例如0x01 | 0x02=3表示查询类型包括智能分析抓拍和告警抓拍。

  • 1：智能分析抓拍
  • 2：告警抓拍
  • 4：手动抓拍(包括定时抓拍)

reserve

string

必选

保留字段。
  • CDSInfo
参数 | 类型 | 可选/必选 | 描述
cloudIP | String | 必选 | 存储IP，该IP为云存储对外提供存储服务的公网IP
totalSpace | double | 必选 | 总存储空间大小，包含冗余空间，以GB为单位;保留2位小数，参数传递时候不带单位
usedSpace | double | 必选 | 已用空间，以GB为单位，保留2位小数，参数传递时候不带单位
dataUnitNum | int | 必选 | 数据节点总数，若非对称式不包含元数据节点数量
status | int | 必选 | 存储状态返回相关状态的状态码，0-正常，1-异常
  • storePlanInfo
参数 | 类型 | 可选/必选 | 描述
channelCode | String | 必选 | 摄像机通道编码
storeDevCode | String | 必选 | 存储单元编码
diskFlPolicy | int | 必选 | 磁盘满处理策略，取值为 0：磁盘满停止存储； 1：磁盘满覆盖存储
enable | int | 必选 | 存储计划当前是否使能 0否 1是
storageSpace | int | 必选 | 存储空间，单位是GB
  • StorageNodeInfo
参数 | 类型 | 可选/必选 | 描述
storageNodeNum | int | 必选 | 查询到的存储节点的数量
storageNodeInfo | List<•StorageNode> | 必选 | 云存储节点信息列表
  • StorageNode
参数 | 类型 | 可选/必选 | 描述
serverID | String | 必选 | 节点ID，规则如下：区域首拼+现有各区云存储节点资源ID（保持不变）
serverStatus | int | 必选 | 状态（0在线、1离线）
totalCapacity | double | 必选 | 总空间大小
residualCapacity | double | 必选 | 剩余总空间大小
deviceReadRate | int | 必选 | 设备读速率
deviceWriteRate | int | 必选 | 设备写速率
  • OpStorageNodeInfo
参数 | 类型 | 可选/必选 | 描述
storageNodeNum | int | 必选 | 查询到的存储节点的数量
storageNodeInfo | List<•OpStorageNode> | 必选 | 云储存节点运维信息列表
  • OpStorageNode
参数 | 类型 | 可选/必选 | 描述
serverID | String | 必选 | 节点ID, 规则如下：区域首拼+现有各区云存储节点资源ID（保持不变）
controlTemp | int | 必选 | 控制器温度（精确到整数，63，单位：摄氏度）
memUsage | int | 必选 | 内存使用率（百分比，精确到整数，如63）
cpuTemp | int | 必选 | CPU温度（精确到整数，63，单位：摄氏度）
fans | int | 必选 | 风扇状态（0正常，1异常）
power | int | 必选 | 电源状态（0正常，1异常）
logicGroupNum | int | 必选 | 逻辑组单元数(raid或者资源池的数量)
logicGroups | List<•LogicGroup> | 必选 | 逻辑组单元 列表
diskNums | int | 必选 | 磁盘数量
disks | List<•Disk> | 必选 | 磁盘信息列表
networkInterfaceNum | int | 必选 | 网口数量
networkInterfaces | List<•NetworkInterface> | 必选 | 网口信息列表
  • LogicGroup
参数 | 类型 | 可选/必选 | 描述
id | int | 必选 | 组ID，字符串类型
status | int | 必选 | 状态（0正常/1降级/2失效）
totalSpace | double | 必选 | 总空间
availableSpace | double | 必选 | 可用空间
level | int | 必选 | 组级别（0/1/5/6等）
  • Disk
参数 | 类型 | 可选/必选 | 描述
ID | String | 必选 | 磁盘ID
status | int | 必选 | 磁盘状态
groupID | String | 必选 | 磁盘所属逻辑组ID
totalSpace | double | 必选 | 磁盘容量
readSpeed | int | 必选 | 磁盘当前读速度
writeSpeed | int | 必选 | 磁盘当前写速度
  • NetworkInterface
参数 | 类型 | 可选/必选 | 描述
ip | String | 必选 | 查询到的存储节点的数量,整型
mac | String | 必选 | mac地址
flowRate | int | 必选 | 网口速率（精确到整数，63，单位：Mbps）
  • MediaServerInfo
参数 | 类型 | 可选/必选 | 描述
msNum | int | 必选 | 流媒体转发节点总数
msList | List<•MediaInfo> | 必选 | 流媒体信息列表
  • MediaInfo
参数 | 类型 | 可选/必选 | 描述
msCode | String | 必选 | 流媒体节点编码
ipAddr | String | 必选 | 流媒体服务器的IP地址
status | int | 必选 | 流媒体服务器状态：1-在线，2-离线
  • MediaSeverTransfer
参数 | 类型 | 可选/必选 | 描述
currentForwardTimes | String | 必选 | 媒体当前转发数量
maxForwardTimes | String | 必选 | 媒体最大转发数量
serverServiceInfo | List<•MediaSeverTransferInfo> | 必选 | 流媒体节点转发状态
  • MediaSeverTransferInfo
参数 | 类型 | 可选/必选 | 描述
remoteSendIP | String | 必选 | 发流端IP
remoteSendPort | String | 必选 | 发流端端口
localRecvIP | String | 必选 | MS收流IP
localRecvPort | String | 必选 | MS收流端口
localSendIP | String | 必选 | MS发流IP
localSendPort | String | 必选 | MS发流端口
remoteRecvIP | String | 必选 | 收流端IP
remoteRecvPort | String | 必选 | 收流端端口
  • DetectionRecordResponse
参数 | 类型 | 可选/必选 | 描述
channelCode | String | 必选 | 摄像机通道编码
startTime | String | 必选 | 开始时间
endTime | String | 必选 | 截止时间
missingBlockNum | int | 必选 | 缺失的录像段数量
missingBlocks | List<•MissingBlock> | 必选 | 录像缺失时间段信息列表
  • MissingBlock
参数 | 类型 | 可选/必选 | 描述
block_StartTime | String | 必选 | 缺失录像开始时间
block_EndTime | String | 必选 | 缺失录像截止时间
  • pageInfo
参数 | 类型 | 可选/必选 | 描述
curPageIndex | int | 必选 | 当前查询返回的是第几页
totalPageNum | int | 必选 | 总的分页数量
curPageSize | int | 必选 | 当前分页的组织节点数量
pageSize | int | 必选 | 分页的大小，即每个分页包含的最大外域节点数量
  • PlatformStatus
参数 | 类型 | 可选/必选 | 描述
platform | •Platform | 必选 | 平台信息
  • PwdConsist

参数

类型

可选/必选

描述

capital

int

必选

是否必须包含大写字母：

  • 0：否
  • 1：是

lowercase

int

必选

是否必须包含小写字母：

  • 0：否
  • 1：是

figure

int

必选

是否必须包含数字：

  • 0：否
  • 1：是

specialChar

int

必选

是否必须包含特殊字符：

  • 0：否
  • 1：是

reserve

string

必选

保留字段，长度限制32字节，必须保留该字段，字段内容可以置空
  • Platform
参数 | 类型 | 可选/必选 | 描述
platCode | String | 必选 | 平台编码
platOnline | int | 必选 | 平台GB保活状态（0在线，1离线）
platStatus | int | 必选 | 平台服务状态（0正常，1异常）
  • AlarmReportInfo
参数 | 类型 | 可选/必选 | 描述
alarmInCode | String | 必选 | 告警源编码
deviceDomainCode | String | 必选 | 告警源所属域编码
alarmType | String | 必选 | 告警类型，详见告警类型
occurTime | String | 必选 | 告警发生时间
reportTime | String | 必选 | 告警上报时间
action | int | 必选 | 操作类型，0：告警消除，1：告警上报
alarmId | String | 必选 | 告警ID
occurNumber | int | 必选 | 告警发生次数
nvrCode | String | 必选 | 告警源所属NVR编码
alarmDesc | String | 必选 | 告警描述信息
  • AlarmOperateInfo
参数 | 类型 | 可选/必选 | 描述
operatorId | int | 必选 | 处理人ID，即处理人用户ID
operatorName | String | 必选 | 处理人名
operateTime | String | 必选 | 告警处理时间
reserver | String | 必选 | 保留字段
operateInfo | String | 必选 | 告警处理人员输入的描述信息
  • VideoAndImageInfoDbList
参数 | 类型 | 可选/必选 | 描述
domainRouteList | List<•VideoAndImageInfoDb> | 否 | 视图库信息集合
  • VideoAndImageInfoDb
参数 | 类型 | 可选/必选 | 描述
id | String | 必选 | 视图库ID
type | int | 必选 | 视图库类型 0：输入视图库 1：输出视图库
viidCode | String | 必选 | 视图库编码
loginName | String | 必选 | 登录视图库名称
ip | String | 必选 | 视图库IP
port | int | 必选 | 视图库端口
viidName | int | 必选 | 视图库名称
status | int | 必选 | 视图库在线状态 0：离线 1：在线
subscribeStatus | int | 必选 | 视图库订阅标志 0：未订阅 1：订阅
  • AddAlarmLinkageInfo
参数 | 类型 | 可选/必选 | 描述
alarmInCode | String | 必选 | 告警源编码
alarmInType | String | 必选 | 告警源类型（01：摄像机;02：开关量输入;09：第三方开关量输入90：防区）
alarmType | String | 必选 | 告警类型， 详见告警类型
actionList | List<LinkageActionInfo> | 必选 | 告警联动策略信息
  • LinkageActionInfo

参数

类型

可选/必选

描述

globalParam

String

必选

动作参数

  • 联动开关量输出：时长
  • 联动录像：时长
  • 用户交互：超时时间
  • 联动Email：Email地址，使用逗号分隔
  • 联动彩信/短信：手机号码，使用逗号分隔

actionBranch

int

必选

执行分支：

  • 0：总是执行
  • 1：确认后执行
  • 2：延时未确认执行

actionType

int

必选

告警动作类型:1：用户交互,2 联动录像,3：联动前端录像,4：联动抓拍,5：联动预置位,6：联动开关量输出,7：联动客户端弹出实况,8：联动实况上墙,9：联动EMAIL,10：联动短信,11：联动彩信,12：联动录像备份

deviceList

List<LinkageDeviceInfo>

可选

执行动作的设备列表
  • LinkageDeviceInfo
参数 | 类型 | 可选/必选 | 描述
deviceCode | String | 必选 | 设备平台编码
positionId | int | 必选 | 动作参数。联动预置位：预置位ID
  • LinkageUserInfo

    参数

    类型

    可选/必选

    描述

    userId

    int

    必选

    用户ID

    userDomainCode

    String

    必选

    用户所在域编码，本域时留空
  • ModifyAlarmLinkageInfo
参数 | 类型 | 可选/必选 | 描述
alarmInCode | String | 必选 | 告警源编码
alarmInType | String | 必选 | 告警源类型（01：摄像机;02：开关量输入;09：第三方开关量输入90：防区）
alarmType | String | 必选 | 告警类型， 详见告警类型
linkageId | Interge | 必选 | 告警策略联动ID
actionList | List<LinkageActionInfo> | 必选 | 告警联动策略信息
  • DeleteAlarmLinkageInfo
参数 | 类型 | 可选/必选 | 描述
alarmInCode | String | 必选 | 告警源编码
alarmInType | String | 必选 | 告警源类型（01：摄像机;02：开关量输入;09：第三方开关量输入90：防区）
alarmType | String | 必选 | 告警类型， 详见告警类型
linkageId | Interge | 必选 | 告警策略联动ID
deviceDomainCode | String | 必选 | 设备所在域编码
  • DiagnoseTimePlan
参数 | 类型 | 可选/必选 | 描述
startTime | String | 必选 | 计划开始时间，格式：hhmmss
stopTime | String | 必选 | 计划结束时间，格式：hhmmss
  • VdeoDiagnoseInfo
参数 | 类型 | 可选/必选 | 描述
domainCode | String | 必选 | 设备域编码
planList | List<DiagnosePlan> | 必选 | 视频质量诊断计划信息

DiagnosePlan

参数 | 类型 | 可选/必选 | 描述
cameraId | String | 必选 | 设备互联编码
planInfo | DiagnosePlanInfo | 必选 | 计划信息
ruleGroup | DiagnoseRuleGroup | 可选 | 诊断规则
  • DiagnosePlanInfo
参数 | 类型 | 可选/必选 | 描述
planId | String | 必选 | 计划ID
planName | String | 必选 | 计划名称
activeFlag | int | 可选 | 是否启用计划(0：不启用,1：启用)
planStatus | int | 可选 | 计划状态(0：未启动,3：已启动,6：已完成,7：异常)
startFlag | int | 可选 | 启动标志(0：根据计划开始时间启动,1：立即启动)
manuaFlag | int | 可选 | 是否开启手动启动：(0:未开启,1:开启手动启动)
alarmType | int | 可选 | 人脸识别计划中需要带该字段（0：告警,1：事件）
periodType | int | 必选 | 周期类型(0：一次性计划,1：每天,2：每周)
dayPlan | DiagnoseDayPlan | 必选 | 天计划，QD目前只支持天计划，因此必须存在
  • DiagnoseDayPlan
参数 | 类型 | 可选/必选 | 描述
timeList | List<DiagnoseTimePlan> | 必选 | 时间段，支持多个时间段
  • DiagnoseRuleGroup
参数 | 类型 | 可选/必选 | 描述
ruleGroupId | String | 可选 | 规则组ID
streamId | int | 可选 | 码流类型I
ruleType | int | 必选 | 规则类型
qualityDiagnosis | VideoQualityDiagnosis | 可选 | 质量诊断分析规则列表
  • VideoQualityDiagnosis
参数 | 类型 | 可选/必选 | 描述
ruleSize | String | 必选 | 规则个数，1到9
ruleInfoList | List<RuleInfo> | 可选 | 规则信息列表
  • RuleInfo
参数 | 类型 | 可选/必选 | 描述
diagnosisType | String | 必选 | 视频质量诊断类型(0:Brightness亮度,1:Darkness暗度2:Blur清晰度,3:SnowNoise雪花,4:ColourCast偏色,5:StripeNoise条纹,6:FrameFrozen冻结,7:Shake抖动,8:CameraCovered遮挡)
sensitivity | int | 必选 | 告警的阈值，取值范围：0~9，默认取值为4
duration | int | 可选 | 规则类型
  • DeviceBriefInfos
参数 | 类型 | 可选/必选 | 描述
total | int | 必选 | 总记录数
indexRange | IndexRange | 必选 | 分页信息
deviceBriefInfo | DeviceBriefInfoList | 非必选 | 主设备信息列表参数，返回参数根据deviceType确定。详见 DeviceBriefInfoList
deviceBriefInfoV2 | DeviceBriefInfoListV2 | 非必选 | 主设备（带互联编码）信息列表,返回参数根据deviceType确定 详见 •DeviceBriefInfoListV2
reserve | String | 必选 | 保留字段。长度限制32字节，必须保留该字段，字段内容可以置空
  • DeviceBriefInfoList

    参数

    类型

    可选/必选

    描述

    deviceBriefInfo

    List<DeviceBriefInfo>

    必选

    主设备信息。详见 DeviceBriefInfo
  • DeviceBriefInfo

    参数

    类型

    可选/必选

    描述

    deviceBasicInfo

    DeviceBasicInfo

    必选

    主设备信息参数。详见•DeviceBasicInfo

    protocolType

    String

    必选

    主设备协议类型，长度限制64字节：

    • TEYES：千里眼
    • ONVIF
    • HWSDK：华为SDK
    • HIKSDK：海康SDK

    loginType

    int

    必选

    认证类型：

    • loginType为ONVIF时，认证类型有如下三种：
      • 0：None
      • 1：HTTP Digest
      • 2：WS-Usernametoken Authentication
    • cProtocolType不是ONVIF时，取值为0：None

    enableSchedule

    int

    必选

    是否启用集群调度：

    • 0：不启用
    • 1：启用，此时NVRCode不能为空

    说明：

    该字段暂不起作用

    status

    int

    必选

    设备状态：

    • 0：离线
    • 1：在线
    • 2：休眠

    reserve

    String

    必选

    保留字段。长度限制32字节，必须保留该字段，字段内容可以置空
  • DeviceBasicInfo

    参数

    类型

    可选/必选

    描述

    type

    int

    必选

    主设备类型：

    • 1：IPC
    • 2：DVS
    • 3：DVR
    • 4：eNVR

    serialNumber

    String

    必选

    序列号（SN/IMEI），长度限制64字节

    code

    String

    必选

    设备编码，长度限制64字节

    name

    String

    必选

    设备名称，长度限制128字节

    parentCode

    String

    必选

    父设备编码，如果不为空，表示通过eNVR接入

    domainCode

    String

    必选

    域编码，长度限制32字节

    vendorType

    String

    必选

    设备提供商类型，长度限制32字节：

    • HW
    • HIK
    • DAHUA
    • SUNELL
    • CANON
    • CHANGEHONG
    • TIANDY
    • PANASONIC
    • AXIS

    model

    String

    必选

    设备型号，根据各设备提供商确定。长度限制32字节

    ipInfo

    IPInfo

    必选

    设备IP信息。详见 •IPInfo

    port

    int

    必选

    设备连接端口

    connectCode

    String

    非必选

    互联编码

    unifiedAccessCode

    String

    非必选

    设备统一编码

    reserve

    String

    非必选

    保留字段
  • DeviceBriefInfoListV2

    参数

    类型

    可选/必选

    描述

    deviceBriefInfoV2

    List<DeviceBriefInfoV2>

    必选

    主设备(带互联编码)信息。详见 ▪DeviceBriefInfoV2
    • DeviceBriefInfoV2

      参数

      类型

      可选/必选

      描述

      deviceBasicInfoV2

      DeviceBasicInfoV2

      必选

      主设备信息参数。详见 ▪DeviceBasicInfoV2

      protocolType

      String

      必选

      主设备协议类型，长度限制64字节：

      • TEYES：千里眼
      • ONVIF
      • HWSDK：华为SDK
      • HIKSDK：海康SDK

      loginType

      int

      必选

      认证类型：

      • loginType为ONVIF时，认证类型有如下三种：
        • 0：None
        • 1：HTTP Digest
        • 2：WS-Usernametoken Authentication
      • cProtocolType不是ONVIF时，取值为0：None

      enableSchedule

      int

      必选

      是否启用集群调度：

      • 0：不启用
      • 1：启用，此时NVRCode不能为空

      说明：

      该字段暂不起作用

      status

      int

      必选

      设备状态：

      • 0：离线
      • 1：在线
      • 2：休眠

      reserve

      String

      必选

      保留字段。必须保留该字段，字段内容可以置空
    • DeviceBasicInfoV2

      参数

      类型

      可选/必选

      描述

      type

      int

      必选

      主设备类型：

      • 1：IPC
      • 2：DVS
      • 3：DVR
      • 4：eNVR

      serialNumber

      String

      必选

      序列号（SN/IMEI），长度限制64字节

      code

      String

      必选

      设备编码，长度限制64字节

      name

      String

      必选

      设备名称，长度限制128字节

      parentCode

      String

      必选

      父设备编码，如果不为空，表示通过eNVR接入

      domainCode

      String

      必选

      域编码，长度限制32字节

      vendorType

      String

      必选

      设备提供商类型，长度限制32字节：

      • HW
      • HIK
      • DAHUA
      • SUNELL
      • CANON
      • CHANGEHONG
      • TIANDY
      • PANASONIC
      • AXIS

      model

      String

      必选

      设备型号，根据各设备提供商确定。长度限制32字节

      ipInfo

      IPInfo

      必选

      设备IP信息。详见 IPInfo

      port

      int

      必选

      设备连接端口

      connectCode

      String

      必选

      互联编码

      unifiedAccessCode

      String

      必选

      设备统一编码

      reserve

      String

      非必选

      保留字段
    • ShadowCameraBriefInfos

    参数

    类型

    可选/必选

    描述

    total

    int

    必选

    总记录数

    indexRange

    IndexRange

    必选

    分页信息

    reserve

    string

    必选

    保留字段

    长度限制32字节，必须保留该字段，字段内容可以置空

    shadowCameraBriefInfoList

    ShadowCameraBriefInfoList

    必选

    影子摄像机信息列表。详见 •ShadowCameraBriefInfoLi...
  • ShadowCameraBriefInfoList

    参数

    类型

    可选/必选

    描述

    shadowCameraBriefInfo

    List<ShadowCameraBriefInfo>

    必选

    主设备信息。详见 •ShadowCameraBriefInfo
  • ShadowCameraBriefInfo

    参数

    类型

    可选/必选

    描述

    code

    string

    必选

    设备编码

    长度限制64字节，详见设备编码规则

    name

    string

    必选

    摄像机名称

    键盘可见字符和中文，长度限制192字节

    devGroupCode

    string

    必选

    所属设备组编码

    长度限制128字节

    parentCode

    string

    必选

    父设备编码

    一般为主设备编码，例如：32010300100201030000#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节，详见设备编码规则

    domainCode

    string

    必选

    设备归属域的域编码

    例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节

    devModelType

    string

    必选

    主设备型号

    由各设备厂家提供，长度限制32字节

    vendorType

    string

    必选

    设备提供商类型：（长度限制32字节）

    • HW
    • HIK
    • DAHUA
    • SUNELL
    • CANON
    • CHANGHONG
    • TIANDY
    • PANASONIC
    • AXIS

    devFormType

    Integer

    必选

    主设备类型：

    • 1：IPC
    • 2：DVS
    • 3：DVR
    • 4：eNVR

    type

    Integer

    必选

    摄像机类型：

    • 0：固定枪机
    • 1：有云台枪机
    • 2：球机
    • 3：半球-固定摄像机
    • 4：筒机

    cameraLocation

    string

    必选

    摄像机安装位置描述

    键盘可见字符和中文，长度限制256字节

    cameraStatus

    Integer

    必选

    摄像机扩展状态：

    • 1：正常
    • 2：视频丢失

    status

    Integer

    必选

    设备状态：

    • 0：离线
    • 1：在线
    • 2：休眠

    netType

    Integer

    必选

    网络类型：

    • 0：有线
    • 1：无线

    supportIntelligent

    Integer

    必选

    是否支持智能分析：

    • 0：不支持
    • 1：支持

    enableVoice

    Integer

    必选

    是否启用随路音频：

    • 0：停用
    • 1：启用

    nvrCode

    string

    必选

    设备所属NVR编码

    表示该设备被该NVR管理，例如：9145a3f7c4164d3ab9e161fcb4221426，长度限制32字节

    devCreateTime

    string

    必选

    设备创建时间

    格式为yyyyMMddHHmmss，如20121207102035，长度限制20字节

    isExDomain

    Integer

    必选

    是否为外域：

    • 0：否
    • 1：是

    devIP

    string

    必选

    前端IP

    点分十进制格式，例如：10.166.166.126，长度限制64字节

    longitude

    string

    必选

    经度，长度限制20字节

    latitude

    string

    必选

    纬度，长度限制20字节

    height

    Float

    必选

    摄像机安装高度

    isShadowDev

    Integer

    必选

    是否为影子摄像机

    • 0：否
    • 1：是

    origDevCode

    string

    必选

    原始设备编码，长度限制64字节

    origParentDevCode

    string

    必选

    原始父设备编码，长度限制64字节

    oriDevDomainCode

    string

    必选

    原始域编码，长度限制32字节

    haveAlarmLinkage

    Integer

    必选

    是否配置告警联动计划

    • 0：否
    • 1：是

    reserve

    string

    必选

    保留字段

    长度限制252字节，必须保留该字段，字段内容可以置空
  • CameraBriefExInfos

    参数

    类型

    可选/必选

    描述

    total

    int

    必选

    总记录数

    indexRange

    IndexRange

    必选

    分页信息

    reserve

    string

    必选

    保留字段

    长度限制32字节，必须保留该字段，字段内容可以置空

    cameraBriefInfoExList

    CameraBriefInfoExList

    必选

    带有扩展信息的摄像机列表。详见 ▪CameraBriefInfoExList
    • CameraBriefInfoExList

      参数

      类型

      可选/必选

      描述

      cameraBriefInfoExes

      List<CameraBriefInfoEx>

      必选

      主设备信息。详见 ▪CameraBriefInfoEx
    • CameraBriefInfoEx

      参数

      类型

      可选/必选

      描述

      code

      string

      必选

      设备编码

      长度限制64字节，详见设备编码规则

      name

      string

      必选

      摄像机名称

      键盘可见字符和中文，长度限制192字节

      devGroupCode

      string

      必选

      所属设备组编码

      长度限制128字节

      parentCode

      string

      必选

      父设备编码

      一般为主设备编码，例如：32010300100201030000#6bdacabae9c546e9ab5b8688ccd85a59，长度限制64字节，详见设备编码规则

      domainCode

      string

      必选

      设备归属域的域编码

      例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节

      devModelType

      string

      必选

      主设备型号

      由各设备厂家提供，长度限制32字节

      vendorType

      string

      必选

      设备提供商类型：（长度限制32字节）

      • HW
      • HIK
      • DAHUA
      • SUNELL
      • CANON
      • CHANGHONG
      • TIANDY
      • PANASONIC
      • AXIS

      devFormType

      Integer

      必选

      主设备类型：

      • 1：IPC
      • 2：DVS
      • 3：DVR
      • 4：eNVR

      type

      Integer

      必选

      摄像机类型：

      • 0：固定枪机
      • 1：有云台枪机
      • 2：球机
      • 3：半球-固定摄像机
      • 4：筒机

      cameraLocation

      string

      必选

      摄像机安装位置描述

      键盘可见字符和中文，长度限制256字节

      cameraStatus

      Integer

      必选

      摄像机扩展状态：

      • 1：正常
      • 2：视频丢失

      status

      Integer

      必选

      设备状态：

      • 0：离线
      • 1：在线
      • 2：休眠

      netType

      Integer

      必选

      网络类型：

      • 0：有线
      • 1：无线

      supportIntelligent

      Integer

      必选

      是否支持智能分析：

      • 0：不支持
      • 1：支持

      enableVoice

      Integer

      必选

      是否启用随路音频：

      • 0：停用
      • 1：启用

      nvrCode

      string

      必选

      设备所属NVR编码

      表示该设备被该NVR管理，例如：9145a3f7c4164d3ab9e161fcb4221426，长度限制32字节

      devCreateTime

      string

      必选

      设备创建时间

      格式为yyyyMMddHHmmss，如20121207102035，长度限制20字节

      isExDomain

      Integer

      必选

      是否为外域：

      • 0：否
      • 1：是

      devIP

      string

      必选

      前端IP

      点分十进制格式，例如：10.166.166.126，长度限制64字节

      longitude

      string

      必选

      经度，长度限制20字节

      latitude

      string

      必选

      纬度，长度限制20字节

      height

      Float

      必选

      摄像机安装高度

      isShadowDev

      Integer

      必选

      是否为影子摄像机

      • 0：否
      • 1：是

      reserve

      string

      必选

      保留字段

      长度限制252字节，必须保留该字段，字段内容可以置空
    • DeviceAlarmEvents

      参数

      类型

      可选/必选

      描述

      total

      int

      必选

      总记录数

      indexRange

      IndexRange

      必选

      分页信息

      reserve

      string

      必选

      保留字段

      长度限制32字节，必须保留该字段，字段内容可以置空

      deviceAlarmNotifies

      List<DeviceAlarmNotify>

      必选

      设备告警通知列表。详见 ▪DeviceAlarmNotify
    • DeviceAlarmNotify

      参数

      类型

      可选/必选

      描述

      alarmEventID

      long

      必选

      告警事件ID

      alarmInCode

      String

      必选

      告警源编码

      alarmInType

      int

      必选

      告警源类型

      alarmInName

      String

      必选

      告警源名称

      nodeType

      String

      必选

      告警所属网元类型，如30858

      alarmLevelValue

      int

      必选

      告警级别权值

      • 1：提示
      • 50：一般
      • 80：重要
      • 100：紧急

      alarmType

      String

      必选
      • 告警类型，参考告警类型说明

      alarmCategory

      String

      必选

      告警类型类别 ：

      • 01：业务类告警
      • 02：网管类告警
      • 03：状态类告警

      occurFirstTime

      String

      必选

      告警首次发生时间，格式为yyyyMMddHHmmss（告警抑制的第一次告警产生时间）

      occurEndTime

      String

      必选

      告警最后发生时间，格式为yyyyMMddHHmmss（告警抑制的最后一次告警产生时间）

      occurNumber

      int

      必选

      告警发生次数

      reserver

      String

      必选

      保留字段

      locationInfo

      String

      必选

      告警定位信息。

      定位信息字段有格式要求，需要是“以逗号分隔的键值对”的形式，譬如：ip=10.137.97.123,hostname=linux,...可以为空，不能有中文

      netEleID

      String

      必选

      告警产生模块归属的网元ID

      netName

      String

      必选

      所属网元名称

      alarmDest

      String

      必选

      告警描述信息，键盘可见字符和中文，取值范围是0~256字符

      extParam

      String

      必选

      扩展参数
    • CameraInfo

      参数

      类型

      可选/必选

      描述

      total

      int

      必选

      总记录数

      indexRange

      IndexRange

      必选

      分页信息

      reserve

      String

      必选

      保留字段

      cameraBriefInfo

      List<CameraBriefInfo>

      非必选

      摄像机设备信息列表（根据请求中deviceType字段确定返回类型）

      参见类型•CameraBriefInfo

      audioBriefInfo

      List<AudioBriefInfo>

      非必选

      语音设备信息列表（根据请求中deviceType字段确定返回类型）

      参见类型•AudioBriefInfo

      alarmBriefInfo

      List<AlarmBriefInfo>

      非必选

      告警设备/外域告警设备 信息列表（根据请求中deviceType字段确定返回类型）

      参见类型•AlarmBriefInfo

      cameraBriefInfoEx

      List<CameraBriefInfoV2>

      非必选

      带有互联编码的子设备信息V2版本列表（根据请求中deviceType字段确定返回类型）

      参见类型 CameraBriefInfoV2

      shadowCameraBriefInfos

      List<ShadowCameraBriefInfo>

      非必选

      影子摄像机/普通摄像机和影子摄像机 信息列表（根据请求中deviceType字段确定返回类型）

      参见类型•ShadowCameraBriefInfo

      cameraBriefInfoExes

      List<CameraBriefInfoEx>

      非必选

      带有经纬度扩展信息的摄像机信息列表（根据请求中deviceType字段确定返回类型）

      参见类型 ▪CameraBriefInfoEx
    • CameraPassThroughInfo

      参数

      类型

      可选/必选

      描述

      requestUrl

      String

      必选

      SDC URL。参见 SDC REST接口文档例：

      "GET /SDCAPI/V1.0/VideoIaas/Channels/Capability"

      param

      Object

      可选

      参见 SDC REST接口文档body体内容
  • IpNoRelationList
参数 | 类型 | 可选/必选 | 描述
ipNoRelation | List< IpNoRelation> | 必选 | 摄像机互联编码
  • IpNoRelation
参数 | 类型 | 可选/必选 | 描述
connectCode | string | 必选 | 摄像机国标编码
ip | string | 必选 | 设备IP（IPV4）
channelNo | int | 必选 | 通道号 1: 通道1，2: 通道2（双仓摄像机存在2个通道）
  • CameraResultList
参数 | 类型 | 可选/必选 | 描述
cameraResult | List< CameraResult> | 必选 | 摄像机互联编码
  • CameraResult
参数 | 类型 | 可选/必选 | 描述
connectCode | string | 必选 | 摄像机互联编码
resultCode | int | 必选 | 单个设备操作错误码
  • CameraInfoList
参数 | 类型 | 可选/必选 | 描述
cameraInfo | List< CameraInfo> | 必选 | 摄像机信息列表
  • CameraInfo
参数 | 类型 | 可选/必选 | 描述
cameraCode | string | 必选 | 摄像机编码
connectCode | string | 必选 | 摄像机国标编码
ip | string | 必选 | 前端IP。点分十进制格式，例如：10.166.166.126
createTime | string | 必选 | 设备创建时间，格式为yyyyMMddHHmmss，如20191107102035
domainCode | string | 必选 | 设备归属域的域编码 例如：6bdacabae9c546e9ab5b8688ccd85a59，长度限制32字节
domainName | string | 必选 | 设备归属域的域名称 例如：杭州市滨江区
  • ImageInfo
参数 | 类型 | 可选/必选 | 描述
videoPreprocessTimeout | String | 必选 | 视频预处理超时时间（秒）
videoTranscodeTimeout | String | 必选 | 视频转码超时时间（秒）
immeDownloadCameraslimit | String | 必选 | IVS立即采集摄像机限制数
downloadPolicyOverdaysLimit | String | 必选 | 跨天采集天数
immeDownloadTimeoutLimit | String | 必选 | 历史录像采集过期时长（分钟）
humanDbDataValidity | String | 必选 | 过人数据库留存期（天）
faceDbDataValidity | String | 必选 | 过脸数据库留存期（天）
lprDbDataValidity | String | 必选 | 过车数据库留存期（天）
humanFileDataValidity | String | 必选 | 过人文件留存期（天）
faceFileDataValidity | String | 必选 | 过脸文件留存期（天）
lprFileDataValidity | String | 必选 | 过车文件留存期（天）
baAlarmDbDataValidity | String | 必选 | 行为分析告警数据库留存期（天）
baAlarmFileDataValidity | String | 必选 | 行为分析告警文件留存期（天）
caseFileValidity | String | 必选 | 资料留存期（天）
vehicleFlowRateDataValidity | String | 必选 | 违章流量元数据留存期（天）
vehicleItsDataValidity | String | 必选 | 违章元数据留存期（天）
onlineFileValidity | String | 必选 | 默认文档有效期（天）
alarmFileValidity | String | 必选 | 告警文档有效期（天）
  • Platform
参数 | 类型 | 可选/必选 | 描述
platformName | String | 必选 | 平台名称
ip | String | 必选 | 平台ip地址
outIp | String | 必选 | 外部IP
username | String | 必选 | 用户名称
password | String | 必选 | 用户密码
port | String | 必选 | 平台端口
outPort | String | 必选 | 平台外部端口
type | String | 必选 | 平台类型
status | String | 必选 | 平台状态信息
  • FileUpdateDownload
参数 | 类型 | 可选/必选 | 描述
uploadFilesize | String | 必选 | 上传文件个数
flesize | String | 必选 | 单个文件个数
maxdownload | String | 必选 | 最大下载速度
maxupload | String | 必选 | 最大上传速度
netWidth | String | 必选 | 系统带宽
  • Bayonet
参数 | 类型 | 可选/必选 | 描述
maxCameraNumber | String | 必选 | 摄像机卡口添加摄像机最大值
  • VcmRspResult
参数 | 类型 | 描述
resultCode | String | VCM返回响应错误码
errorMessage | String | 错误消息
  • VcmResourceInfo
参数 | 类型 | 描述
cpuRatio | String |
gpuNum | String |
gpuUtility | String |
memUtility | String |
memoryRatio | String |
networkRatio | String |
storageLoad | String |
storageTotal | String |
storageUsed | String |
  • ClusterStatisticsRequestContent
参数 | 类型 | 描述
containerId | String |
startTime | String |
endTime | String |
  • QueryClusterStatisticsContent
参数 | 类型 | 描述
cupRatioList | List<VcmStatisticsInfo> | •VcmStatisticsInfo
gpuUtilityList | List<VcmStatisticsInfo> | •VcmStatisticsInfo
memUtilityList | List<VcmStatisticsInfo> | VcmStatisticsInfo
memoryRatioList | List<VcmStatisticsInfo> | VcmStatisticsInfo
networkRatioList | List<VcmStatisticsInfo> | VcmStatisticsInfo
storageLoadList | List<VcmStatisticsInfo> | VcmStatisticsInfo
storageTotalList | List<VcmStatisticsInfo> | VcmStatisticsInfo
storageUsedList | List<VcmStatisticsInfo> | VcmStatisticsInfo
  • VcmStatisticsInfo
参数 | 类型 | 描述
id | String |
licenseCount | String |
licenseType | String |
queryDateTime | String |
queryTime | String |
systemIp | String |
systemRate | String |
systemType | String |
  • LicenseStatisticsRequestContent
参数 | 类型 | 描述
startTime | String |
endTime | String |
  • QueryLicenseStatisticsContent
参数 | 类型 | 描述
abstractLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
behaviorLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
cloudWalkFacePictureLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
cloudWalkPicFacePictureLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
cwImageFacialRecognition | List<VcmStatisticsInfo> | VcmStatisticsInfo
cwVideoFacialRecognition | List<VcmStatisticsInfo> | VcmStatisticsInfo
faceLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
faceN2Nlicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
facePicLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
faceQueryLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
imageFacialRecognition | List<VcmStatisticsInfo> | VcmStatisticsInfo
indexLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
plateLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
sbiFeatureLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
sbiFeatureQueryLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
sbiVehicleLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
vehicleGlobalLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
vehicleLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
vehicleQueryLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
vehicleSearchGlobalLicense | List<VcmStatisticsInfo> | VcmStatisticsInfo
videoFacialRecognition | List<VcmStatisticsInfo> | VcmStatisticsInfo
  • QueryLicenseNumberContent
参数 | 类型 | 描述
licenseStatusInfo | VcmLicenseStatusInfo | •VcmLicenseStatusInfo
licenseThirdTotalList | List<VcmLicenseThirdTotalInfo> | •VcmLicenseThirdTotalInf...
licenseThirdUsedList | List<VcmLicenseThirdUsedInfo> | •VcmLicenseThirdUsedInfo
licenseTotalInfo | VcmLicenseTotalInfo | •VcmLicenseTotalInfo
licenseUsedInfo | VcmLicenseTotalInfo | •VcmLicenseTotalInfo
  • VcmLicenseStatusInfo
参数 | 类型 | 描述
endDate | String |
keepDate | String |
status | String |
  • VcmLicenseThirdTotalInfo
参数 | 类型 | 描述
code | String |
type | String |
total | String |
  • VcmLicenseThirdUsedInfo
参数 | 类型 | 描述
code | String |
type | String |
total | String |
  • VcmLicenseTotalInfo
参数 | 类型 | 描述
behaviorLicense | Integer | 行为分析License
vehicleLicense | Integer | 车辆识别License
vehicleGlobalLicense | Integer | 中国港澳台和非中国区车辆检索基础包（每百万条）
sbiVehicleLicense | Integer | 人车License
plateLicense | Integer | CPU车牌识别License
indexLicense | Integer | 索引License
faceLicense | Integer | 人脸License
facePicLicense | Integer | 人脸图片License
sbiFeatureLicense | Integer | 以图搜图License
abstractLicense | Integer | 摘要License
faceQueryLicense | Integer | 人脸检索基础包license
faceSearchLicense | Integer | 人脸检索基础包（每百万条）
sbiFeatureQueryLicense | Long | 人体检索基础包license
bodySearchLicense | Integer | 人体检索基础包（每百万条）
vehicleQueryLicense | Long | 车辆检索基础包
vehicleSearchChinaLicense | Integer | 中国大陆车辆检索基础包（每百万条）
vehicleSearchGlobalLicense | Long | 中国港澳台和非中国区车辆检索基础包（每百万条）
cloudWalkPicFacePictureLicense | Integer | 云从人脸图片模式license
cloudWalkFacePictureLicense | Integer | 云从人脸视频模式license
faceSnapLicense | Integer | 人脸检测抓拍（每路）
faceYituLicense | Integer | 人脸依图算法管理软件(每路)
cwImageFacialRecognition | Integer | 人脸识别图片模式算法管理软件-FaceA(张/秒)
cwVideoFacialRecognition | Integer | 人脸识别视频模式算法管理软件-FaceA(每路)
imageFacialRecognition | Integer | 人脸识别图片模式算法基础包-FaceX(张/秒)
videoFacialRecognition | Integer | 人脸识别视频模式算法基础包-FaceX(每路)
vehicleRecognition | Integer | 车辆识别算法基础包-中国港澳台和非中国区(每路)
faceN2Nlicense | Integer | 人脸NVN，license
eagle1604000100Image | Integer | Eagle 1604000100人脸识别图片模式算法，license8
eagle1604000100Video | Integer | Eagle 1604000100人脸识别视频模式算法，license
  • Result
参数 | 类型 | 可选/必选 | 描述
resultCode | String | 是 | 成功返回0，失败返回•SDK内部转换或处理异常
errorMessage | String | 是 | 操作结果描述
  • EditConfigRequest
参数 | 类型 | 可选/必选 | 描述
config | UserConfig | 是 | •UserConfig
  • UserConfig
参数 | 类型 | 可选/必选 | 描述
maxOnlineUser | Int | 是 | 在线数
  • AdConfig
参数 | 类型 | 可选/必选 | 描述
domain | String | 必选 | AD域域名
ip | String | 必选 | AD域IP
port | String | 必选 | AD域端口
  • AdConfigRequest
参数 | 类型 | 可选/必选 | 描述
adConfig | AdConfig | 必选 | AD域设置信息•AdConfig
  • VcnAccountValidateRequest
参数 | 类型 | 可选/必选 | 描述
account | String | 必选 | 用户名
password | String | 必选 | 密码
ip | String | 必选 | IP地址
port | int | 必选 | 端口号
  • SearchSpecialThreshold：
参数 | 类型 | 可选/必选 | 描述
id | String | 是 |
type | String | 是 | 名单类型 当前仅支持红名单：4
algorithmThresholds | Array | 是 | 算法阈值列表 参考•SearchAlgorithmThreshol...
  • SearchAlgorithmThreshold：
参数 | 类型 | 可选/必选 | 描述
algorithmCode | String | 是 | 人脸算法编码
similarityThreshold | String | 是 | 相似度阈值
algorithmName | String | 是 | 算法名称
  • SpecialThresholdUpdateRequest：
参数 | 类型 | 可选/必选 | 描述
specialThreshold | SearchSpecialThreshold | 是 | •SearchSpecialThreshold：
  • DataDictionaryType：
参数 | 类型 | 可选/必选 | 描述
typeCode | String | 是 |
dataDictionarys | Array | 是 | 见•DataDictionary
  • DataDictionary
参数 | 类型 | 可选/必选 | 描述
id | Long | 是 |
typeCode | String | 是 | 类别code
name | String | 是 | 字典名称
value | String | 是 | 字典值
description | String | 否 | 备注
  • AddDataDictionaryRequestEx
参数 | 类型 | 可选/必选 | 描述
typeCode | String | 是 |
dataDictionaryList | Array | 是 | 见•Dictionary
  • Dictionary
参数 | 类型 | 可选/必选 | 描述
value | String | 是 |
dictionaryNameList | Array | 是 | 见•DictionaryName
  • DictionaryName
参数 | 类型 | 可选/必选 | 描述
name | String | 是 |
languageCode | String | 是 |
  • UpdateDataDictionaryRequestEx
参数 | 类型 | 可选/必选 | 描述
dataDictionaryList | Array | 是 | 见•DataDictionary
  • DeleteDataDictionaryRequestEx
参数 | 类型 | 可选/必选 | 描述
ids | Array<String> | 是 |
  • GetGisTokenContent
参数 | 类型 | 可选/必选 | 描述
gisTokenInfo | GisTokenInfo | 必选 | 见•GisTokenInfo
  • GisTokenInfo
参数 | 类型 | 可选/必选 | 描述
gisToken | String | 必选 |
expiration | String | 必选 |
  • GisServerInfo
参数 | 字段类型 | 可选/必选 | 描述
isEnableConfig | String | 必选 |
gisServerCode | String |  |
gisServerName | String |  |
gisServerIP | String |  |
gisServerPort | String |  |
gisUsername | String |  |
gisPassword | String |  |
gisServerType | String |  |
expiration | String |  |
isNeedLogin | String |  |
  • AddLayerInfoContent
参数 | 类型 | 可选/必选 | 描述
layerCode | String | 必选 |
  • GetLayerInfoContent
参数 | 类型 | 可选/必选 | 描述
layerInfoList | Array | 必选 | 见•MapLayerInfo
  • MapLayerInfo
参数 | 类型 | 可选/必选 | 描述
layerCode | String | 必选 |
gisServerInfo | GisServerInfo | 必选 | 见•GisServerInfo
layerInfo | String | 必选 |
  • GetSystemFileContent
参数 | 类型 | 可选/必选 | 描述
fileInfoList | Array | 必选 | 见•SystemFileInfo
  • SystemFileInfo
参数 | 类型 | 可选/必选 | 描述
fileName | String | 必选 |
fileContent | String | 必选 |
  • GetUserFileContent
参数 | 类型 | 可选/必选 | 描述
fileInfoList | Array | 必选 | 见•UserFileInfo
  • UserFileInfo
参数 | 类型 | 可选/必选 | 描述
fileName | String | 必选 |
filePath | String | 必选 |
fileBase64Value | String | 必选 |
shaValue | String | 必选 |
  • GetShaContent
参数 | 类型 | 可选/必选 | 描述
shaValue | String | 必选 |
  • UserInfoOfId
参数 | 类型 | 可选/必选 | 描述
userId | int | 必选 | 被授权用户ID
domainCode | String | 必选 | 用户所属域编码
  • AlarmEvent
参数 | 类型 | 可选/必选 | 描述
alarmNotify | ▪AlarmNotifyInfo | 必选 | •AlarmNotifyInfo
operateInfo | ▪AlarmOperateInfo2 | 必选 | 告警处理信息•AlarmOperateInfo2
  • AlarmOperateInfo2
参数 | 类型 | 可选/必选 | 描述
operatorName | String | 可选 | 处理人名
operateTime | String | 必选 | 告警处理时间
operateInfo | String | 必选 | 告警处理人员输入的描述信息，内容可以为空
  • ResultInfo
参数 | 类型 | 可选/必选 | 描述
sequence | int | 必选 | 顺序
result | int | 必选 | •SDK内部转换或处理异常
code | String | 必选 | 编码
  • UserDevInfo

参数

类型

可选/必选

描述

devGroupCode

String

必选

设备组编码，数字字符串，长度不超过20

devCode

String

必选

设备编码，设备编码格式

devDomainCode

String

必选

设备域编码，设备域编码格式

isExDomain

Integer

必选

是否外部域设备/组

  • 0：否
  • 1：是

isTotalGroup

Integer

必选

是否绑定设备组

  • 0：绑定的是设备组中的设备
  • 1：绑定整个设备组（设备组扩容后自动更新组内设备），此时：DevCode、DomainCode、ChanelType为空

reserve

String

可选

保留字段
  • AlarmNotifyInfo

alarmEventId

long

必选

告警事件ID

alarmInCode

String

必选

告警源编码

deviceDomainCode

String

可选

设备所属域编码

alarmInType

int

必选

告警源类型

alarmInName

String

必选

告警源名称

alarmLevelValue

String

必选

告警级别权值，取值范围为1～100

alarmLevelName

String

必选

告警级别名称，可以包含汉字、字母（a-z和A-Z）、数字、中划线和下划线，长度为1～20个字符

alarmLevelColor

String

必选

告警级别颜色，使用颜色字符串表示ARGB，例如#FFFF0000表示红色，不透明

alarmType

String

必选

告警类型

alarmTypeName

String

可选

告警类型名称，可以包含汉字、字母（a-z和A-Z）、数字、中划线和下划线，长度为1～64个字符

alarmCategory

String

必选

告警类型类别

occurTime

String

必选

告警发生时间，格式为yyyyMMddHHmmss

occurNumber

int

必选

告警发生次数

alarmStatus

int

必选

告警状态

isCommission

int

必选

是否为授权告警信息：

  • 0：否
  • 1：是

previewUrl

String

必选

在存在联动抓拍或者智能分析时的图片预览URL地

existsRecord

int

必选

是否存在告警录像：

  • 0：否
  • 1：是

nvrCode

String

可选

NVR编码，可用于更新NVR路由

alarmDesc

String

必选

告警描述信息，键盘可见字符和中文，长度为0～256字符

reserve

String

可选

保留字段

extParam

String

可选

扩展参数，暂不使用
  • ImageDBConfig
参数 | 类型 | 描述
videoPreprocessTimeout | String | 视频预处理超时时间（秒）
videoTranscodeTimeout | String | 视频转码超时时间（秒）
immeDownloadCameraslimit | String | IVS立即采集摄像机限制数
downloadPolicyOverdaysLimit | String | 跨天采集天数
immeDownloadTimeoutLimit | String | 历史录像采集过期时长（分钟）
onlineFileValidity | String | 默认文档有效期（天）
alarmFileValidity | String | 告警文档有效期（天）
humanDbDataValidity | String | 过人数据库留存期（天）
faceDbDataValidity | String | 过脸数据库留存期（天）
lprDbDataValidity | String | 过车数据库留存期（天）
humanFileDataValidity | String | 过人文件留存期（天）
faceFileDataValidity | String | 过脸文件留存期（天）
lprFileDataValidity | String | 过车文件留存期（天）
baAlarmDbDataValidity | String | 行为分析告警数据库留存期（天）
baAlarmFileDataValidity | String | 行为分析告警文件留存期（天）
caseFileValidity | String | 资料留存期（天）
vehicleItsDataValidity | String | 违章元数据留存期（天）
vehicleFlowRateDataValidity | String | 车流量数据留存期（天）
  • DataSubscribeQueryResponse

    请求字段

    字段类型

    字段名称

    domainCode

    String

    所属域编码

    count

    String

    返回请求参数page内的可见摄像机

    totalCount

    String

    查询到的总数

    subscribeInfoList

    List<SubscribeInfo>

    数据订阅信息列表•SubscribeInfo

    subscribeAllInfoList

    List<SubscribeAllInfo>

    全量订阅信息表
  • SubscribeInfo

    请求字段

    字段类型

    字段名称

    id

    String

    数据订阅信息主键ID，未订阅时该值为空

    cameraSn

    String

    摄像机SN

    cameraName

    String

    摄像机名称

    subscribeType

    List<SubscribeInfo>

    订阅类型

    subscribeStatus

    List<SubscribeAllInfo>

    订阅状态

    subscribeFlag

    String

    订阅标识

    subscribeId

    String

    数据订阅ID（域内唯一）

    isFeature

    String

    是否推送特征值

    algorithmName

    String

    算法名称

    algorithmCode

    String

    算法code

    cameraStatus

    String

    订阅的摄像机状态

    dataPassbackType

    String

    数据回传类型

    isDomainTopic

    String

    订阅类型
  • SubscribeAllInfo

    请求字段

    字段类型

    字段名称

    subscribeType

    String

    标签类型

    alarmType

    String

    告警类型

    enableAllSubscribe

    String

    0表示不启用全量订阅，1代表启用全量订阅
  • DomainSubscribeAllBean

    请求字段

    字段类型

    可选/必选

    字段名称

    subscribeType

    String

    必选

    标签类型

    alarmType

    String

    必选

    告警类型

    enableAllSubscribe

    String

    必选

    0表示不启用全量订阅，1代表启用全量订阅
父主题： 附录


告警类型

表1 业务类告警类型

分类

告警类型

告警类型描述

设备类型

告警级别

类别

告警输入

ALARM_TYPE_DI

开关量设备告警

2

100

101

摄像机

ALARM_NO_SIGNAL

视频丢失告警

1

100

101

ALARM_SHIELD

视频遮挡告警

1

100

101

ALARM_TYPE_MOVE_DECTION

移动侦测告警

1

100

101

ALARM_VIDEO_G

视频报警（外域）

1

100

101

ALARM_INTRUSION

入侵告警

1

100

10201

ALARM_TRIP_LINE

绊线告警

1

100

10201

ALARM_OBJECT_ABANDONED

物体滞留告警

1

100

10201

ALARM_OBJECT_REMOVAL

移走物体告警

1

100

10201

ALARM_PRESENCE

突然出现告警

1

100

10201

ALARM_PATH

路径检测告警

1

100

10201

ALARM_DIRECTION_MOVE

定向移动告警

1

100

10201

ALARM_SPEED

突然加速告警

1

100

10201

ALARM_SPEED_MONITOR

超速/低速告警

1

100

10201

ALARM_OBJECT_WANDER

徘徊告警

1

100

10201

ALARM_DENSITY_MONITOR

密度监测告警

1

100

10201

ALARM_FACE_RECOGNITION_WARNING

人脸识别预警

1

100

10202

ALARM_FACE_RECOGNITION

人脸识别告警

1

100

10202

ALARM_FACE_CAPTURE

人脸检测抓拍告警

1

100

10202

视频诊断

ALARM_MAU_VQD_BRIGHTNESS

视频过亮告警

1

80

10203

ALARM_MAU_VQD_DARKNESS

视频过暗告警

1

80

10203

ALARM_MAU_VQD_BLUR

视频模糊告警

1

80

10203

ALARM_MAU_VQD_SNOWNOISE

视频雪花噪声告警

1

80

10203

ALARM_MAU_VQD_COLORCAST

视频色偏告警

1

80

10203

ALARM_MAU_VQD_STRIPENOISE

视频条纹干扰告警

1

80

10203

ALARM_MAU_VQD_FRAMEFROZEN

视频冻结告警

1

80

10203

ALARM_MAU_VQD_SHAKE

视频抖动告警

1

80

10203

ALARM_MAU_VQD_CAMERACOVERD

视频遮挡告警(质量诊断)

1

80

10203

ALARM_MAU_VIDEO_LOST

视频丢失告警(质量诊断)

1

80

10203

外部系统告警类型

EXSYS_ALARM_EMERGENCY_ON

紧急告警(外部系统)

9

100

103

EXSYS_ALARM_EMERGENCY_OFF

紧急报警恢复(外部系统)

9

1

103

EXSYS_ALARM_FIRE_ALERT_ON

火警(外部系统)

9

100

103

EXSYS_ALARM_FIRE_ALERT_OFF

火警恢复(外部系统)

9

1

103

EXSYS_ALARM_ROBBERY_ON

劫警(外部系统)

9

100

103

EXSYS_ALARM_ROBBERY_OFF

劫警恢复(外部系统)

9

1

103

EXSYS_ALARM_STEAL_ON

盗警(外部系统)

9

100

103

EXSYS_ALARM_STEAL_OFF

盗警恢复(外部系统)

9

1

103

EXSYS_ALARM_ALERT_ON

警报告警(外部系统)

9

100

103

EXSYS_ALARM_ALERT_OFF

警报恢复(外部系统)

9

1

103

EXSYS_ALARM_MONITOR_ON

监控告警(外部系统)

9

100

103

EXSYS_ALARM_MONITOR_OFF

监控报警恢复(外部系统)

9

1

103

EXSYS_ALARM_FAILURE_ON

故障告警(外部系统)

9

80

103

EXSYS_ALARM_FAILURE_OFF

故障恢复(外部系统)

9

1

103

EXSYS_ALARM_DEFENCE_ON

布防(外部系统)

9

80

103

EXSYS_ALARM_DEFENCE_OFF

撤防(外部系统)

9

1

103

EXSYS_ALARM_REMOTE_CONTROL_ON

遥控告警(外部系统)

9

50

103

EXSYS_ALARM_REMOTE_CONTROL_OFF

遥控恢复(外部系统)

9

1

103

EXSYS_ALARM_ENTER_EXIT_ON

开门告警(外部系统)

9

50

103

EXSYS_ALARM_ENTER_EXIT_OFF

关门告警(外部系统)

9

1

103

EXSYS_ALARM_STATUS_ON

状态告警(外部系统)

9

1

103

EXSYS_ALARM_STATUS_OFF

状态恢复(外部系统)

9

1

103

EXSYS_ALARM_SHUTDOWN_ON

停用/离线告警(外部系统)

9

1

103

EXSYS_ALARM_SHUTDOWN_OFF

启用/上线告警(外部系统)

9

1

103

EXSYS_ALARM_BYPASS_ON

旁路(外部系统)

9

1

103

EXSYS_ALARM_BYPASS_OFF

取消旁路(外部系统)

9

1

103

EXSYS_ALARM_TEST_ON

进入测试(外部系统)

9

1

103

EXSYS_ALARM_TEST_OFF

退出测试(外部系统)

9

1

103

EXSYS_ALARM_USER_OPERATION_ON

用户操作告警(外部系统)

9

1

103

EXSYS_ALARM_USER_OPERATION_OFF

用户告警恢复(外部系统)

9

1

103

EXSYS_ALARM_ERROR_ON

错误告警(外部系统)

9

1

103

EXSYS_ALARM_ERROR_OFF

错误恢复(外部系统)

9

1

103

EXSYS_ALARM_SCADA

SCADA系统告警

9

80

103

注：

  • ALARM_PATH：千里眼协议接入的前端告警类型
  • ALARM_DIRECTION_MOVE：平台告警类型
  • ALARM_SPEED：前端告警类型
  • ALARM_SPEED_MONITOR：平台告警类型

表2 状态通知类告警类型

分类 | 告警类型 | 告警类型描述 | 设备类型 | 告警级别 | 类别
设备在线状态告警 | ALARM_IPC_ONLINE | 摄像机设备上线 | 0 | 100 | 3
 | ALARM_IPC_OFFLINE | 摄像机设备下线 | 0 | 100 | 3
 | ALARM_IPC_SCHEDULE | 摄像机调度 | 0 | 100 | 3
 | ALARM_DVR_ONLINE | 硬盘录像机设备上线 | 0 | 100 | 3
 | ALARM_DVR_OFFLINE | 硬盘录像机设备下线 | 0 | 100 | 3
 | ALARM_DVS_ONLINE | 网络视频服务器设备上线 | 0 | 100 | 3
 | ALARM_DVS_OFFLINE | 网络视频服务器设备下线 | 0 | 100 | 3
 | ALARM_eNVR_ONLINE | 嵌入式NVR设备上线 | 0 | 100 | 3
 | ALARM_eNVR_OFFLINE | 嵌入式NVR设备下线 | 0 | 100 | 3

表3 设备类告警类型

分类 | 告警类型 | 告警类型描述 | 设备类型 | 告警级别 | 类别
IPC | ALARM_IPC_DISK_FULL_ON | 摄像机SD卡满告警 | 0 | 100 | 2
 | ALARM_IPC_DISK_FULL_OFF | 摄像机SD卡满恢复 | 0 | 1 | 2
 | ALARM_IPC_SD_CARD_FAULT_ON | 摄像机SD卡故障 | 0 | 100 | 2
 | ALARM_IPC_SD_CARD_FAULT_OFF | 摄像机SD卡故障恢复 | 0 | 1 | 2
 | ALARM_IPC_TEMPERATURE_ON | 摄像机温度告警 | 0 | 100 | 2
 | ALARM_IPC_TEMPERATURE_OFF | 摄像机温度恢复 | 0 | 1 | 2
 | ALARM_IPC_CPU_HIGH | 摄像机CPU占用率过高告警 | 0 | 100 | 2
 | ALARM_IPC_MEMORY_HIGH | 摄像机内存占用率过高告警 | 0 | 100 | 2
DVR | ALARM_DVR_DISK_FULL_ON | 硬盘录像机硬盘满告警 | 0 | 100 | 2
 | ALARM_DVR_DISK_FULL_OFF | 硬盘录像机硬盘满恢复 | 0 | 1 | 2
 | ALARM_DVR_DISK_FAULT_ON | 硬盘录像机硬盘故障 | 0 | 100 | 2
 | ALARM_DVR_DISK_FAULT_OFF | 硬盘录像机硬盘故障恢复 | 0 | 1 | 2
DVS | ALARM_DVS_DISK_FULL_ON | 网络视频服务器硬盘满告警 | 0 | 100 | 2
 | ALARM_DVS_DISK_FULL_OFF | 网络视频服务器硬盘满恢复 | 0 | 1 | 2
 | ALARM_DVS_DISK_FAULT_ON | 网络视频服务器硬盘故障 | 0 | 100 | 2
 | ALARM_DVS_DISK_FAULT_OFF | 网络视频服务器硬盘故障恢复 | 0 | 1 | 2
eNVR | ALARM_eNVR_DISK_FULL_ON | 嵌入式NVR硬盘满告警 | 0 | 100 | 2
 | ALARM_eNVR_DISK_FULL_OFF | 嵌入式NVR硬盘满恢复 | 0 | 1 | 2
 | ALARM_eNVR_DISK_FAULT_ON | 嵌入式NVR硬盘故障 | 0 | 100 | 2
 | ALARM_eNVR_DISK_FAULT_OFF | 嵌入式NVR硬盘故障恢复 | 0 | 1 | 2
MU | ALARM_MU_OVERLOAD_ON | 媒体转发服务器满负载告警 | 10 | 80 | 2
 | ALARM_RECORD_SECURE_TRANS_FAIL | 录像转为不安全传输方式告警 | 10 | 80 | 2
 | ALARM_RECORD_DISK_FULL_ON | 媒体服务器录像空间满告警 | 10 | 100 | 2
 | ALARM_RECORD_DISK_FULL_OFF | 媒体服务器录像空间满恢复 | 10 | 1 | 2
 | ALARM_BACKUP_DISK_FULL_ON | 媒体服务器备份空间满告警 | 10 | 100 | 2
 | ALARM_BACKUP_DISK_FULL_OFF | 媒体服务器备份空间满恢复 | 10 | 1 | 2
 | ALARM_RECORD_DISK_FAULT_ON | 媒体服务器硬盘故障告警 | 10 | 100 | 2
 | ALARM_RECORD_DISK_FAULT_OFF | 媒体服务器硬盘故障恢复 | 10 | 1 | 2
 | ALARM_RECORD_FULL_STOP_ON | 媒体服务器满停止录像告警 | 10 | 100 | 2
 | ALARM_RECORD_FULL_STOP_OFF | 媒体服务器满停止录像恢复 | 10 | 1 | 2
 | ALARM_BACKUP_FULL_STOP_ON | 媒体服务器满停止备份告警 | 10 | 100 | 2
 | ALARM_BACKUP_FULL_STOP_OFF | 媒体服务器满停止备份恢复 | 10 | 1 | 2
 | ALARM_RECORD_WRITE_INDEX_DATA_FAILE | 录像索引文件写失败告警 | 10 | 100 | 2
 | ALARM_BACKUP_WRITE_INDEX_DATA_FAILE | 备份索引文件写失败告警 | 10 | 100 | 2
 | ALARM_RECORD_IO_OVERLOAD_ON | 录像磁盘性能不足告警 | 10 | 80 | 2
 | ALARM_RECORD_IO_OVERLOAD_OFF | 录像磁盘性能不足告警恢复 | 10 | 1 | 2
 | ALARM_BACKUP_IO_OVERLOAD_ON | 备份磁盘性能不足告警 | 10 | 80 | 2
 | ALARM_BACKUP_IO_OVERLOAD_OFF | 备份磁盘性能不足告警恢复 | 10 | 1 | 2
 | ALARM_RECORD_LUN_FAULT_ON | 录像单个LUN故障告警 | 10 | 100 | 2
 | ALARM_RECORD_LUN_FAULT_OFF | 录像单个LUN故障告警恢复 | 10 | 1 | 2
 | ALARM_BACKUP_LUN_FAULT_ON | 备份单个LUN故障告警 | 10 | 100 | 2
 | ALARM_BACKUP_LUN_FAULT_OFF | 备份单个LUN故障告警恢复 | 10 | 1 | 2
 | ALARM_RECORD_STREAM_ERROR_GENERAL_ON | 媒体服务器存储流请求异常告警 | 10 | 100 | 2
 | ALARM_RECORD_STREAM_ERROR_GENERAL_OFF | 媒体服务器存储流请求异常恢复 | 10 | 1 | 2
 | ALARM_RECORD_STREAM_ERROR_TIMEOUT_ON | 媒体服务器存储流请求超时异常告警 | 10 | 100 | 2
 | ALARM_RECORD_STREAM_ERROR_TIMEOUT_OFF | 媒体服务器存储流请求超时异常恢复 | 10 | 1 | 2
 | ALARM_MU_ONLINE | 媒体服务器上线 | 10 | 1 | 2
 | ALARM_MU_OFFLINE | 媒体服务器下线 | 10 | 100 | 2
 | ALARM_MU_LOG_BCK_FAIL_ON | 媒体服务器日志备份失败告警 | 10 | 100 | 2
 | ALARM_MU_LOG_BCK_FAIL_OFF | 媒体服务器日志备份失败恢复 | 10 | 1 | 2
 | ALARM_MU_ALARM_RECORD_FAIL_ON | 媒体服务器告警状态文件记录失败告警 | 10 | 100 | 2
 | ALARM_MU_ALARM_RECORD_FAIL_OFF | 媒体服务器告警状态文件记录失败恢复 | 10 | 1 | 2
 | ALARM_MU_LOG_RECORD_FAIL_ON | 媒体服务器日志记录失败告警 | 10 | 100 | 2
 | ALARM_MU_LOG_RECORD_FAIL_OFF | 媒体服务器日志记录失败恢复 | 10 | 1 | 2
 | ALARM_MU_CONFIG_READ_FAIL | 媒体服务器配置文件异常告警 | 10 | 100 | 2
 | ALARM_MU_DB_CONNECT_FAIL_ON | 媒体服务器数据库访问异常告警 | 10 | 100 | 2
 | ALARM_MU_DB_CONNECT_FAIL_OFF | 媒体服务器数据库访问异常告警恢复 | 10 | 1 | 3
 | ALARM_MU_FRAME_EXTRACTION_FAIL | 抽帧存储异常失败告警 | 10 | 100 | 2
 | ALARM_SAFEVIDEO_ONLINE | Safevideo上线 | 11 | 1 | 2
 | ALARM_SAFEVIDEO_OFFLINE | Safevideo下线 | 11 | 100 | 2
 | ALARM_SCU_MU_LINK_ERROR_ON | 业务控制单元与媒体单元断连告警 | 10 | 100 | 2
 | ALARM_SCU_MU_LINK_ERROR_OFF | 业务控制单元与媒体单元断连告警恢复 | 10 | 1 | 2
 | SMIO_RAID_MTR_FS_ERROR | 数据盘文件系统错误 | 11 | 100 | 2
 | SMIO_RAID_MTR_FS_RECOVER | 数据盘文件系统错误恢复 | 11 | 1 | 2
 | SMIO_RAID_MTR_ERR_CAPACITY | RAID组的硬盘容量小于阈值告警 | 11 | 1 | 2
 | SMIO_JBOD_SYS_DISK_OUT | 系统盘拔出 | 11 | 100 | 2
 | SMIO_JBOD_SYS_DISK_IN | 系统盘插入 | 11 | 1 | 2
 | SMIO_JBOD_DATA_DISK_OUT | 数据盘拔出 | 11 | 100 | 2
 | SMIO_JBOD_DATA_DISK_IN | 数据盘插入 | 11 | 1 | 2
 | SMIO_JBOD_RAID_DISK_IN | 系统盘插入数据raid盘槽位 | 11 | 1 | 2
 | SMIO_JBOD_RAID_DISK_OUT | 系统盘插入数据raid盘槽位，被重新拔出 | 11 | 80 | 2
 | SMIO_JBOD_DISK_FAIL_IMPEND | 硬盘即将失效 | 11 | 80 | 2
 | SMIO_JBOD_DISK_FAIL_RECOVER | 硬盘由即将失效变为正常 | 11 | 1 | 2
 | SMIO_JBOD_DISK_FAULT | 硬盘故障 | 11 | 100 | 2
 | SMIO_FORMAT_NO_DISK | 硬盘不在线导致格式化失败 | 11 | 100 | 2
 | SMIO_FORMAT_BAD_DISK | 硬盘故障导致格式化失败 | 11 | 100 | 2
 | SMIO_FORMAT_FAILIMPEND_DISK | 硬盘即将失效导致格式化失败 | 11 | 100 | 2
 | SMIO_JBOD_SLOW_DISK | 慢盘告警 | 11 | 80 | 2
OMU | SMIO_GROUP_DEGRADE | 数据盘RAID组降级 | 11 | 50 | 2
 | SMIO_GROUP_DATA_RECOVER | 数据盘RAID组开始重构 | 11 | 1 | 2
 | SMIO_GROUP_DATA_RECOVER_OVER | 数据盘RAID组重构完成 | 11 | 1 | 2
 | SMIO_GROUP_DATA_COPYBACK | 数据盘RAID组开始回拷 | 11 | 1 | 2
 | SMIO_GROUP_DATA_COPYBACK_OVER | 数据盘RAID组回拷完成 | 11 | 1 | 2
 | SMIO_GROUP_NO_SPARE | 热备盘缺失 | 11 | 100 | 2
 | SMIO_GROUP_RESUME_SPARE | 热备盘恢复 | 11 | 1 | 2
 | SMIO_GROUP_RECOVER_FAIL | 硬盘故障导致Raid组重构失败 | 11 | 80 | 2
 | SMIO_JBOD_BUSY_DISK | 硬盘忙 | 11 | 50 | 2
 | SMIO_JBOD_RAID_SYS_DISK_DEGRADE | 系统盘RAID降级 | 11 | 100 | 2
 | SMIO_JBOD_RAID_SYS_DISK_RECOVER_OVER | 系统盘RAID重构完成 | 11 | 1 | 2
 | SMIO_GROUP_INIT_FAIL | RAID组初始化失败 | 11 | 100 | 2
 | SMIO_GROUP_INIT_OK | RAID组初始化成功 | 11 | 1 | 2
 | SMIO_JBOD_RAID_SYS_DISK_RECOVER | 系统盘RAID开始重构 | 11 | 1 | 2
 | SMIO_GROUP_NOT_AVAIL | RAID组只读 | 11 | 100 | 2
 | SMIO_GROUP_AVAIL | RAID组从只读恢复正常 | 11 | 1 | 2
DCG | ALARM_DCG_ONLINE | 设备接入网关上线 | 12 | 1 | 2
 | ALARM_DCG_OFFLINE | 设备接入网关下线 | 12 | 100 | 2
 | ALARM_DCG_SYS_PORT_CONFLICT | 外部系统端口冲突告警 | 12 | 100 | 2
 | ALARM_DCG_LOG_BCK_FAIL_ON | 设备接入网关日志备份失败告警 | 12 | 100 | 2
 | ALARM_DCG_LOG_BCK_FAIL_OFF | 设备接入网关日志备份失败恢复 | 12 | 1 | 2
 | ALARM_DCG_LOG_RECORD_FAIL_ON | 设备接入网关日志记录失败告警 | 12 | 100 | 2
 | ALARM_DCG_LOG_RECORD_FAIL_OFF | 设备接入网关日志记录失败恢复 | 12 | 1 | 2
 | ALARM_DCG_ALARM_RECORD_FAIL_ON | 设备接入网关告警状态文件记录失败告警 | 12 | 100 | 2
 | ALARM_DCG_ALARM_RECORD_FAIL_OFF | 设备接入网关告警状态文件记录失败恢复 | 12 | 1 | 2
 | ALARM_DCG_CONFIG_READ_FAIL | 设备接入网关配置文件异常告警 | 12 | 100 | 2
 | ALARM_DCG_FLOW_CONTROL_ERROR_ON | 设备接入网关流控故障告警 | 12 | 100 | 2
 | ALARM_DCG_FLOW_CONTROL_ERROR_OFF | 设备接入网关流控故障告警恢复 | 12 | 1 | 2
 | ALARM_EXTEND_SYSTEM_ONLINE | 外部告警系统上线 | 12 | 1 | 3
 | ALARM_EXTEND_SYSTEM_OFFLINE | 外部告警系统下线 | 12 | 100 | 3
SMU | ALARM_REACH_ALL_LOACL_LENS | 接入路数将达到镜头总数告警 | 13 | 80 | 2
 | ALARM_REACHED_ALL_LOACL_LENS | 接入路数已达到镜头总数告警 | 13 | 100 | 2
 | ALARM_SMU_LOG_BCK_FAIL_ON | 业务管理单元日志备份失败告警 | 17 | 100 | 2
 | ALARM_SMU_LOG_BCK_FAIL_OFF | 业务管理单元日志备份失败恢复 | 17 | 1 | 2
 | ALARM_SMU_LOG_RECORD_FAIL_ON | 业务管理单元日志记录失败告警 | 17 | 100 | 2
 | ALARM_SMU_LOG_RECORD_FAIL_OFF | 业务管理单元日志记录失败恢复 | 17 | 1 | 2
 | ALARM_SMU_ALARM_RECORD_FAIL_ON | 业务管理单元告警状态文件记录失败告警 | 17 | 100 | 2
 | ALARM_SMU_ALARM_RECORD_FAIL_OFF | 业务管理单元告警状态文件记录失败恢复 | 17 | 1 | 2
 | ALARM_SMU_CONFIG_READ_FAIL | 业务管理单元配置文件异常告警 | 17 | 100 | 2
 | ALARM_SMU_ONLINE | 业务管理单元上线 | 17 | 1 | 2
 | ALARM_SMU_OFFLINE | 业务管理单元下线 | 17 | 100 | 2
 | ALARM_SMU_DB_CONNECT_FAIL_ON | 业务管理单元数据库访问异常 | 17 | 100 | 2
 | ALARM_SMU_DB_CONNECT_FAIL_OFF | 业务管理单元数据库访问异常恢复 | 17 | 1 | 3
 | ALARM_SMU_FLOW_CONTROL_ERROR_ON | 业务管理单元流控故障告警 | 17 | 100 | 2
 | ALARM_SMU_FLOW_CONTROL_ERROR_OFF | 业务管理单元流控故障告警恢复 | 17 | 1 | 2
 | ALARM_SMU_MULTI_PCG_ERROR | 多个平台接入网关模块重复注册告警 | 17 | 100 | 2
 | ALARM_SMU_DEV_SYNC_ERROR | 设备信息同步异常告警 | 17 | 100 | 2
SCU | ALARM_SCU_LOG_BCK_FAIL_ON | 业务控制单元日志备份失败告警 | 18 | 100 | 2
 | ALARM_SCU_LOG_BCK_FAIL_OFF | 业务控制单元日志备份失败恢复 | 18 | 1 | 2
 | ALARM_SCU_LOG_RECORD_FAIL_ON | 业务控制单元日志记录失败告警 | 18 | 100 | 2
 | ALARM_SCU_LOG_RECORD_FAIL_OFF | 业务控制单元日志记录失败恢复 | 18 | 1 | 2
 | ALARM_SCU_ALARM_RECORD_FAIL_ON | 业务控制单元告警状态文件记录失败告警 | 18 | 100 | 2
 | ALARM_SCU_ALARM_RECORD_FAIL_OFF | 业务控制单元告警状态文件记录失败恢复 | 18 | 1 | 2
 | ALARM_SCU_CONFIG_READ_FAIL | 业务控制单元配置文件异常告警 | 18 | 100 | 2
 | ALARM_SCU_ONLINE | 业务控制单元上线 | 18 | 1 | 2
 | ALARM_SCU_OFFLINE | 业务控制单元下线 | 18 | 100 | 2
 | ALARM_SCU_DB_CONNECT_FAIL_ON | 业务控制单元数据库访问异常 | 18 | 100 | 2
 | ALARM_SCU_DB_CONNECT_FAIL_OFF | 业务控制单元数据库访问异常恢复 | 18 | 1 | 2
 | ALARM_SCU_SMU_LINK_ERROR_ON | 业务控制单元与业务管理单元断连告警 | 18 | 100 | 2
 | ALARM_SCU_SMU_LINK_ERROR_OFF | 业务控制单元与业务管理单元断连告警恢复 | 18 | 1 | 2
 | ALARM_SCU_DCG_LINK_ERROR_ON | 业务控制单元与设备接入网关断连告警 | 18 | 100 | 2
 | ALARM_SCU_DCG_LINK_ERROR_OFF | 业务控制单元与设备接入网关断连告警恢复 | 18 | 1 | 2
 | ALARM_SCU_FLOW_CONTROL_ERROR_ON | 业务控制单元流控故障告警 | 18 | 100 | 2
 | ALARM_SCU_FLOW_CONTROL_ERROR_OFF | 业务控制单元流控故障告警恢复 | 18 | 1 | 2
 | ALARM_SCU_SNAPSHOT_DISK_FULL_ON | 业务控制单元抓拍空间满告警 |  | 100 | 2
 | ALARM_SCU_SNAPSHOT_DISK_FULL_OFF | 业务控制单元抓拍空间满恢复 |  | 1 | 2
 | ALARM_SCU_DEV_OFFLINE_CONFIG_FAIL | 设备离线参数下发失败告警 | 18 | 100 | 2
PCG | ALARM_PCG_LOG_BCK_FAIL_ON | 平台接入网关日志备份失败告警 | 15 | 100 | 2
 | ALARM_PCG_LOG_BCK_FAIL_OFF | 平台接入网关日志备份失败恢复 | 15 | 1 | 2
 | ALARM_PCG_LOG_RECORD_FAIL_ON | 平台接入网关日志记录失败告警 | 15 | 100 | 2
 | ALARM_PCG_LOG_RECORD_FAIL_OFF | 平台接入网关日志记录失败恢复 | 15 | 1 | 2
 | ALARM_PCG_CONFIG_READ_FAIL | 平台接入网关配置文件异常告警 | 15 | 100 | 2
 | ALARM_PCG_ALARM_RECORD_FAIL_ON | 平台接入网关告警状态文件记录失败告警 | 15 | 100 | 2
 | ALARM_PCG_ALARM_RECORD_FAIL_OFF | 平台接入网关告警状态文件记录失败恢复 | 15 | 1 | 2
 | ALARM_PCG_ONLINE | 平台接入网关上线 | 15 | 1 | 2
 | ALARM_PCG_OFFLINE | 平台接入网关下线 | 15 | 100 | 2
 | ALARM_PCG_EXDOMAIN_ONLINE | 第三方外域上线 | 15 | 1 | 2
 | ALARM_PCG_EXDOMAIN_OFFLINE | 第三方外域下线 | 15 | 100 | 2
 | ALARM_PCG_REGISTER_FAIL_ON | 平台向第三方外域注册失败 | 15 | 80 | 2
 | ALARM_PCG_REGISTER_FAIL_OFF | 平台向第三方外域注册失败恢复 | 15 | 1 | 2
MTU | ALARM_MTU_HTTPS_ONLINE | HTTPS模块上线 | 29 | 1 | 2
 | ALARM_MTU_HTTPS_OFFLINE | HTTPTS模块下线 | 29 | 100 | 2
 | ALARM_MTU_RTSP_ONLINE | RTSP模块上线 | 30 | 1 | 2
 | ALARM_MTU_RTSP_OFFLINE | RTSP模块下线 | 30 | 100 | 2
 | ALARM_MTU_NO_IDLE_LICENSE_ON | 无可用转码license告警 | 13 | 100 | 2
 | ALARM_MTU_NO_IDLE_LICENSE_OFF | 无可用转码license告警恢复 | 13 | 1 | 2
 | ALARM_MTU_ONLINE | 媒体转码单元上线 | 14 | 1 | 2
 | ALARM_MTU_OFFLINE | 媒体转码单元下线 | 14 | 100 | 2
MAU | ALARM_MAUS_ONLINE | 智能分析负载均衡单元上线 | 16 | 1 | 2
 | ALARM_MAUS_OFFLINE | 智能分析负载均衡单元下线 | 16 | 100 | 2
 | ALARM_MAUTS_ONLINE | 智能分析任务调度中心上线 | 16 | 1 | 2
 | ALARM_MAUTS_OFFLINE | 智能分析任务调度中心下线 | 16 | 100 | 2
 | ALARM_MAULM_ONLINE | 智能分析轨迹管理单元上线 | 16 | 1 | 2
 | ALARM_MAULM_OFFLINE | 智能分析轨迹管理单元下线 | 16 | 100 | 2
 | ALARM_MAUQD_ONLINE | 智能分析视频质量诊断单元上线 | 16 | 1 | 2
 | ALARM_MAUQD_OFFLINE | 智能分析视频质量诊断单元下线 | 16 | 100 | 2
 | ALARM_MAUBA_ONLINE | 智能分析行为分析单元上线 | 16 | 1 | 2
 | ALARM_MAUBA_OFFLINE | 智能分析行为分析单元下线 | 16 | 100 | 2
 | ALARM_MAUFR_ONLINE | 智能分析人脸识别单元上线 | 16 | 1 | 2
 | ALARM_MAUFR_OFFLINE | 智能分析人脸识别单元下线 | 16 | 100 | 2
 | ALARM_MAU_DISCONNECT_WITH_DB_ON | 连接数据库失败告警 | 16 | 100 | 2
 | ALARM_MAU_DISCONNECT_WITH_DB_OFF | 连接数据库失败告警恢复 | 16 | 1 | 3
 | ALARM_MAU_BA_NO_IDLE_LICENSE_ON | 无可用行为分析license告警 | 13 | 100 | 2
 | ALARM_MAU_BA_NO_IDLE_LICENSE_OFF | 无可用行为分析license告警恢复 | 13 | 1 | 2
 | ALARM_MAU_FR_NO_IDLE_LICENSE_ON | 无可用人脸识别license告警 | 13 | 100 | 2
 | ALARM_MAU_FR_NO_IDLE_LICENSE_OFF | 无可用人脸识别license告警恢复 | 13 | 1 | 2
 | ALARM_MAU_START_TASK_FAIL | 启动任务失败告警 | 16 | 100 | 2
 | ALARM_MAU_LOG_BCK_FAIL_ON | 智能分析调度中心日志备份失败告警 | 16 | 100 | 2
 | ALARM_MAU_LOG_BCK_FAIL_OFF | 智能分析调度中心日志备份失败恢复 | 16 | 1 | 2
 | ALARM_MAU_LOG_RECORD_FAIL_ON | 智能分析调度中心日志记录失败告警 | 16 | 100 | 2
 | ALARM_MAU_LOG_RECORD_FAIL_OFF | 智能分析调度中心日志记录失败恢复 | 16 | 1 | 2
 | ALARM_MAU_ALARM_RECORD_FAIL_ON | 智能分析调度中心告警状态文件记录失败告警 | 16 | 100 | 2
 | ALARM_MAU_ALARM_RECORD_FAIL_OFF | 智能分析调度中心告警状态文件记录失败恢复 | 16 | 1 | 2
 | ALARM_MAU_CONFIG_READ_FAIL | 智能分析调度中心配置文件异常告警 | 16 | 100 | 2
 | ALARM_MAU_QD_LOG_BCK_FAIL_ON | 视频质量诊断日志备份失败告警 | 21 | 100 | 2
 | ALARM_MAU_QD_LOG_BCK_FAIL_OFF | 视频质量诊断日志备份失败恢复 | 21 | 1 | 2
 | ALARM_MAU_QD_LOG_RECORD_FAIL_ON | 视频质量诊断日志记录失败告警 | 21 | 100 | 2
 | ALARM_MAU_QD_LOG_RECORD_FAIL_OFF | 视频质量诊断日志记录失败恢复 | 21 | 1 | 2
 | ALARM_MAU_QD_ALARM_RECORD_FAIL_ON | 视频质量诊断告警状态文件记录失败告警 | 21 | 100 | 2
 | ALARM_MAU_QD_ALARM_RECORD_FAIL_OFF | 视频质量诊断告警状态文件记录失败恢复 | 21 | 1 | 2
 | ALARM_MAU_QD_CONFIG_READ_FAIL | 视频质量诊断配置文件异常告警 | 21 | 100 | 2
 | ALARM_MAU_LM_LOG_BCK_FAIL_ON | 轨迹管理模块日志备份失败告警 | 19 | 100 | 2
 | ALARM_MAU_LM_LOG_BCK_FAIL_OFF | 轨迹管理模块日志备份失败恢复 | 19 | 1 | 2
 | ALARM_MAU_LM_LOG_RECORD_FAIL_ON | 轨迹管理日志记录失败告警 | 19 | 100 | 2
 | ALARM_MAU_LM_LOG_RECORD_FAIL_OFF | 轨迹管理日志记录失败恢复 | 19 | 1 | 2
 | ALARM_MAU_LM_ALARM_RECORD_FAIL_ON | 轨迹管理告警状态文件记录失败告警 | 19 | 100 | 2
 | ALARM_MAU_LM_ALARM_RECORD_FAIL_OFF | 轨迹管理告警状态文件记录失败恢复 | 19 | 1 | 2
 | ALARM_MAU_LM_CONFIG_READ_FAIL | 轨迹管理配置文件异常告警 | 19 | 100 | 2
OMU | ALARM_OMU_ONLINE | 运营维护单元上线 | 25 | 1 | 2
 | ALARM_OMU_OFFLINE | 运营维护单元下线 | 25 | 100 | 2
 | ALARM_OMU_DB_CONNECT_FAIL_ON | 运营维护单元数据库访问异常 | 25 | 100 | 2
 | ALARM_OMU_DB_CONNECT_FAIL_OFF | 运营维护单元数据库访问异常恢复 | 25 | 1 | 3
 | ALARM_OMU_LOG_BCK_FAIL_ON | 运营维护单元日志备份失败告警 | 25 | 100 | 2
 | ALARM_OMU_LOG_BCK_FAIL_OFF | 运营维护单元日志备份失败恢复 | 25 | 1 | 2
 | ALARM_OMU_LOG_RECORD_FAIL_ON | 运营维护单元日志记录失败告警 | 25 | 100 | 2
 | ALARM_OMU_LOG_RECORD_FAIL_OFF | 运营维护单元日志记录失败恢复 | 25 | 1 | 2
 | ALARM_OMU_ALARM_RECORD_FAIL_ON | 运营维护单元告警状态文件记录失败告警 | 25 | 100 | 2
 | ALARM_OMU_ALARM_RECORD_FAIL_OFF | 运营维护单元告警状态文件记录失败恢复 | 25 | 1 | 2
 | ALARM_OMU_CONFIG_READ_FAIL | 运营维护单元配置文件异常告警 | 25 | 100 | 2
 | ALARM_OMU_NOTICE_FAIL | 运营维护单元消息通知失败告警 | 25 | 100 | 2
 | ALARM_OMU_FLOW_CONTROL_ERROR_ON | 运营维护单元流控故障告警 | 25 | 100 | 2
 | ALARM_OMU_FLOW_CONTROL_ERROR_OFF | 运营维护单元流控故障告警恢复 | 25 | 1 | 2
 | ALARM_OMU_PROC_REBOOT | 子系统进程重启告警 | 25 | 100 | 2
 | ALARM_OMU_HA_SWITCH | 双机切换告警 | 25 | 100 | 2
 | ALARM_OMU_HEARTBEAT_UNCONN_ON | 双机心跳断连告警 | 25 | 100 | 2
 | ALARM_OMU_HEARTBEAT_UNCONN_OFF | 双机心跳断连告警恢复 | 25 | 1 | 2
 | ALARM_OMU_HARDDISK_FULL_ON | 磁盘分区满告警 | 25 | 100 | 2
 | ALARM_OMU_HARDDISK_FULL_OFF | 磁盘分区满告警恢复 | 25 | 1 | 2
 | ALARM_OMU_DRBD_BRAIN_SPLIT | 双机数据不一致告警 | 25 | 100 | 2
 | ALARM_OMU_DB_BACKUP_ERROR | 数据库备份异常告警 | 25 | 100 | 2
 | ALARM_OMU_DATASAFE_BACKUP_ERROR | 数据保险箱备份异常告警 | 25 | 100 | 2
CMU | ALARM_CMU_ONLINE | 集群管理单元上线 | 28 | 1 | 2
 | ALARM_CMU_OFFLINE | 集群管理单元下线 | 28 | 100 | 2
 | ALARM_CMU_LOG_BCK_FAIL_ON | 集群管理单元日志备份失败告警 | 28 | 100 | 2
 | ALARM_CMU_LOG_BCK_FAIL_OFF | 集群管理单元日志备份失败恢复 | 28 | 1 | 2
 | ALARM_CMU_LOG_RECORD_FAIL_ON | 集群管理单元日志记录失败告警 | 28 | 100 | 2
 | ALARM_CMU_LOG_RECORD_FAIL_OFF | 集群管理单元日志记录失败恢复 | 28 | 1 | 2
 | ALARM_CMU_ALARM_RECORD_FAIL_ON | 集群管理单元告警状态文件记录失败告警 | 28 | 100 | 2
 | ALARM_CMU_ALARM_RECORD_FAIL_OFF | 集群管理单元告警状态文件记录失败恢复 | 28 | 1 | 2
 | ALARM_CMU_CONFIG_READ_FAIL | 集群管理单元配置文件异常告警 | 28 | 100 | 2
 | ALARM_CMU_MEMBER_OFFLINE | 集群成员下线告警 | 28 | 100 | 2
 | ALARM_CMU_MEMBER_ONLINE | 集群成员下线告警恢复 | 28 | 1 | 2
 | ALARM_CMU_CLUSTER_OVERLOAD | 全系统负载过高告警 | 28 | 100 | 2
 | ALARM_CMU_MEMBER_OVERLOAD | 集群成员负载过高告警 | 28 | 100 | 2
 | ALARM_CMU_MEMBER_UNDERLOAD | 集群成员负载过高恢复 | 28 | 1 | 2
 | ALARM_CMU_MEMBER_FAIL_ON | 集群成员异常告警 | 28 | 100 | 2
 | ALARM_CMU_MEMBER_FAIL_OFF | 集群成员异常告警恢复 | 28 | 1 | 2
 | ALARM_CMU_FLOW_CONTROL_ERROR_ON | 集群管理单元流控故障告警 | 28 | 100 | 2
 | ALARM_CMU_FLOW_CONTROL_ERROR_OFF | 集群管理单元流控故障告警恢复 | 28 | 1 | 2

父主题： 附录


事件定义类型

  • IVS_EVENT_REPORT_USER_INFO CHANGE（用户与摄像机信息变更事件10310）
  • IVS_EVENT_AUTO_CONNECT_SUCCEED（重新登录成功事件上报10001）
  • IVS_EVENT_KEEP_ALIVE_FAILED（保活失败事件上报10002）
  • IVS_EVENT_REMOTE_PLAYBACK_FAILED（远程录像回放异常事件上报10006）
  • IVS_EVENT_REPORT_ALARM（告警上报10013）
  • IVS_EVENT_REPORT_ALARM_STATUS（告警信息状态通知10017）
  • IVS_EVENT_USER_OFFLINE（用户下线通知10019）
  • IVS_EVENT_FIND_DEVICE（前端设备发现事件10025）
  • IVS_EVENT_REPORT_SUBSCRIBE_PICTURES_STATISTICS（订阅图片实时统计10316）
  • IVS_EVENT_REPORT_USER_INFO CHANGEV2（用户与摄像机信息变更事件V2版本 10315）
父主题： 附录


IVS_EVENT_REPORT_USER_INFO CHANGE（用户与摄像机信息变更事件10310）

服务端按照用户订阅的信息向用户端推送摄像机和用户变更消息。

属性

M/O

描述

Content

M

消息体根节点

Total

M

总记录数

UserCameraInfoChange

M

用户与摄像机信息

NotifyType

M

通知事件ID：

1用户信息变更；

2摄像机信息变更；

3用户组信息变更；

4摄像组信息变更

OperType

M

操作类型：

1新增操作；

2删除操作；

3修改操作；

4将摄像机添加到摄像机组；

5将摄像机从摄像机组中删除；

DomainCode

M

所属域编码

CodeId

M

用户或摄像机ID

UserInfo

M

用户的详细信息

DomainCode

用户所属域编码

Id

用户ID。新增用户的时候由eSpace IVS系统分配，从1开始递增，可以不填或者填0；修改用户的时候必须填写

IsFirstLogin

是否是第一次登录：

  • 1：是
  • 0：否

RoleId

角色ID，管理员配置

GroupId

用户组ID

LoginName

登录账号：登录账号，字母（a-z和A-Z），数字，中划线和下划线，取值范围是1~20个字符

Password

登录密码：登录密码，键盘可见字符，取值范围是1~16个字符。

PwdModifyDate

密码修改日期，格式为格式为

YYYYMMDDHHMMSS

UserType

用户类型：

  • 0：IVS普通用户
  • 1：Windows域用户

UserDomain

Windows域名

Status

用户状态：

  • 1：激活
  • 2：停用
  • 3：无效登录锁定

RegiterDate

创建日期，格式为格式为

YYYYMMDDHHMMSS

UserDesc

用户描述，键盘可见字符和中文，取值范围是0~64字符。

PtzLevel

云台控制优先级。取值范围0~9，最低级别为9，最高级别为0

MaxSessionCount

多点登录数,最大长度3字符，数字

MaxVideoCount

最大视频路数，最大长度3字符，数字

LockTime

账号被锁定的时间

UserName

真实姓名，汉字和字母（a-z和A-Z），数字，中划线和下划线，1~20个字符

Email

邮箱，参考网易163邮箱限制。

Phone

电话，取值范围是0~25位数字，中划线

Sex

性别：

  • 0：女性
  • 1：男性

ValidDateFlag

是否有账户有效期：

  • 1：有
  • 0：没有

ValidDateStart

账户有效起始日期，格式

为YYYYMMDDHHMMSS

ValidDateEnd

账户有效结束日期，格式

为YYYYMMDDHHMMSS

Reserve

保留字段

CameraBriefInfoAll

M

摄像机的详细信息

Code

设备编码

Name

摄像机名称

DeviceGroupCode

所属设备组编码

ParentCode

父设备编码

DomainCode

域编码

DeviceModelType

主设备型号

VendorType

设备提供商类型：

  • HW
  • HIK
  • DAHUA

DeviceFormType

主设备类型：

  • 1：摄像机
  • 2：DVS
  • 3：DVR
  • 4：eNVR

Type

摄像机类型

  • 0：固定枪机
  • 1：有云台枪机
  • 2：球机
  • 3：半球-固定摄像机
  • 4：筒机
  • 非球机类型摄像机不调用云台相关接口

CameraLocation

摄像机安装位置描述

CameraStatus

摄像机扩展状态：

  • 1 ： 正常
  • 2 ： 视频丢失

Status

设备状态：

  • 0：离线
  • 1：在线
  • 2：休眠

NetType

网络类型：

  • 0：有线
  • 1：无

SupportIntelligent

是否支持智能分析 ：

  • 0：不支持
  • 1：支持

EnableVoice

随路音频是否启用 ：

  • 0：停用
  • 1：启用

NvrCode

设备所属NVR编码，表示该设备被该NVR管理

DeviceCreateTime

设备创建时间，时间格式

为YYYYMMDDHHMMSS

IsExDomain

是否为外部域

  • 0：否
  • 1：是

DeviceIp

前端IP

Longitude

经度

Latitude

纬度

Height

摄像机安装高度

IsShadowDev

是否为影子摄像机 ：

  • 0：否
  • 1：是

OrigDevCode

原始设备编码

OrigParentDevCode

原始父设备编码

OriDevDomainCode

原始域编码

DeleteStatus

设备删除状态 ：

  • 0：设备已经软删除，

待彻底删除状态

  • 1：设备正常状态

Reserve

保留字段

UserGroupInfo

M

用户组的详细信息

DomainCode

域编码

GroupID

用户组ID

GroupName

用户组名称

ParentGroupID

父用户组ID

Level

用户组层级，最多支持4层

（包含根组在内）

Reserve

保留字段

DeviceGroup

M

摄像机组的详细信息

GroupCode

设备组编码

GroupName

设备组名称

ParentGroupCode

父设备组编码

DomainCode

域编码

IsExDomin

是否为外部域/组：

  • 0：否
  • 1：是

Reserve

保留字段
父主题： 事件定义类型


IVS_EVENT_AUTO_CONNECT_SUCCEED（重新登录成功事件上报10001）

当发生网络短时间中断时，系统会启动自动保活功能，网络恢复重新登录服务端成功后推送该消息。

无消息体

父主题： 事件定义类型


IVS_EVENT_KEEP_ALIVE_FAILED（保活失败事件上报10002）

当发生网络短时间中断时，系统会启动自动保活功能，并按一定周期推送该消息。

无消息体。

父主题： 事件定义类型


IVS_EVENT_REMOTE_PLAYBACK_FAILED（远程录像回放异常事件上报10006）

远程录像回放异常时，服务端返回该事件

属性 |  | M/O | 描述
Content |  | M | 消息体根节点
 | eSDKSessionId | M | eSDK IVS会话ID
 | handle | M | 媒体流句柄
 | exceptionCode | M | 备用字段
 | reseved | M | 保留字段
 | deviceCode | M | 设备编码
父主题： 事件定义类型


IVS_EVENT_REPORT_ALARM（告警上报10013）

服务端按照用户订阅的告警信息向用户端推送告警消息

属性

M/O

描述

Content

M

消息体根节点

AlarmEventId

M

告警事件ID

AlarmInCode

M

告警源编码，参见设备编码规则

DevDomainCode

M

设备所在域编码

AlarmInType

M

告警源类型

AlarmInName

M

告警源名称

AlarmLevelValue

M

告警级别

AlarmLevelName

M

告警级别名称

AlarmLevelColor

M

告警级别对应的相应颜色取值

AlarmType

M

告警类型

AlarmTypeName

M

告警类型名称

AlarmCategory

M

告警类别：

01：业务类告警
  • 0101：一般业务告警
  • 0102：智能分析告警
    • 010201：行为分析告警
    • 010202：人脸识别告警
  • 0103：第三方接入告警

OccurTime

M

告警发生时间，格式如：yyyyMMddHHmmss

OccurNumber

M

告警发生次数

AlarmStatus

M

告警状态：

  • 0：未处理
  • 1：待确认
  • 2：已确认
  • 3：已撤销
  • 4：已恢复

IsCommission

M

是否为授权告警信息：

  • 1：是
  • 0：否

PreviewUrl

M

在存在联动抓拍或者智能分析时的图片预览URL：

http://ip:port/scu/imageprocess.do ?imageid=<imageid> &tokenid=<tokenid>&regtype=1

可为空

ExistsRecord

M

是否存在告警录像：

  • 0：否
  • 1：是

NVRCode

M

NVR编码

AlarmDesc

M

告警描述信息，取值范围是0~256字符

ExtParam

O

扩展参数

注：如果是XML，则以<![CDATA[ ]]>形式返回
父主题： 事件定义类型


IVS_EVENT_REPORT_ALARM_STATUS（告警信息状态通知10017）

服务端按照用户订阅的告警类型用户端推送告警信息，当告警状态发生改变时服务端返回该消息

属性 |  |  | M/O | 描述
Content |  |  | M | 消息体根节点
 | AlarmEventId |  | M | 告警事件ID
 | AlarmInCode |  | M | 告警源编码
 | DevDomainCode |  | M | 告警源域编码
 | AlarmType |  | M | 告警类型
 | OccurentNumber |  | M | 告警发生次数
 | OlarmStatus |  | M | 告警状态： 0 未操作 1 待确定 2 已确认 3 已撤销 4 已恢复
 | Reserve |  | M | 保留字段
 | AlarmOperateInfo |  | M | 告警处理信息
 |  | OperatorId | M | 处理人ID,参考 UserInfo
 |  | OperatorName | M | 处理人名
 |  | OperateTime | M | 告警处理人员输入的信息
 |  | Reserver | M | 保留字段
 |  | OperateInfo | M | 告警处理人员输入的信息
父主题： 事件定义类型


IVS_EVENT_USER_OFFLINE（用户下线通知10019）

管理员使用签退用户（修改用户密码也会触发签退）、锁定用户、删除用户时，系统向该用户所有已经登录的终端推送该消息，意思是该用户的已经被强制下线。

属性 |  | M/O | 描述
Content |  | M | 消息体根节点
 | LoginID | M | 登录用户名
 | OfflineType | M | 下线类型: 0 账号被管理员锁定 1 账号被管理员删除 2 登录会话被管理员签退
父主题： 事件定义类型


IVS_EVENT_FIND_DEVICE（前端设备发现事件10025）

前端设备发现事件。当执行启动搜索前端设备startSearchDevice接口后，服务端开始返回该事件。根据搜索IP地址数量不同，该事件按顺序回多次返回消息体。根据消息体中完成百分比来判断进度。

属性

M/O

描述

Content

M

消息体根节点

Percent

M

完成百分比

ServerCode

M

接入服务器

DevList

M

设备列表

DevInfo

O

设备信息

DevProtocolType

M

主设备协议类型(从设备模板中获取类型编码):

  • ONVIF
  • HWSDK-华为SDK
  • HIKSDK-海康SDK

DevIP

M

设备IP地址

DevPort

M

设备端口

DevVendor

M

设备厂商

DevModelType

M

设备型号

DevSN

M

设备SN号
父主题： 事件定义类型


IVS_EVENT_REPORT_SUBSCRIBE_PICTURES_STATISTICS（订阅图片实时统计10316）

订阅图片实时统计事件，主要给用户实时发送图片信息，给用户推送数据为json格式，示例如下（推送数据为json字符串，会有转义字符"\"）

{"eventData":"{

\"domainCode\": \"51b1ff9380b6409fae0de2132ac46db7\",

\"pageInfo\": {

\"pageSum\": 0,

\"pageIndex\": 0

},

\"cameraList\": [

{

\"cameraInfo\": {

\"cameraCode\": \"07910254570076540101\",

\"tlvList\": [

{

\"tlvInfo\": {

\"snapType\": 1,

\"picType\": 2,

\"tranType\": 1,

\"tlvSuccessNum\": 3139,

\"tlvSuccessNum_today\": 1383

}

},

{

\"tlvInfo\": {

\"snapType\": 1,

\"picType\": 1,

\"tranType\": 1,

\"tlvSuccessNum\": 3139,

\"tlvSuccessNum_today\": 1383

}

}

]

}

}

]

}"

}

推送各个字段含义表

属性 |  |  |  |  |  | M/O | 描述
eventData |  |  |  |  |  | M | 推送数据
 | domainCode |  |  |  |  | M | 域编码
 | pageInfo |  |  |  |  | M | 图片传输统计数据列表
 |  | pageSum |  |  |  | M | 总页数
 |  | pageIndex |  |  |  | M | 当前页数。第一次返回以第一页开始。
 | cameraList |  |  |  |  | M | 摄像机列表信息
 |  | cameraInfo |  |  |  | M | 以摄像机为维度的历史图片统计数据。每一秒返回当次此页的摄像机实时的数据。当前每页数据为400个摄像机数据。如果有2w个摄像机，预计要50秒整体返回一遍。
 |  |  | cameraCode |  |  | M | 摄像机编码 备注：如果是影子摄像机，以原始摄像机cameraCode+“#”domainId展示，即：备份原始摄像机的编码+”#”+原始摄像机域Id（非本域）来推送数据。
 |  |  | tlvList |  |  | M | 历史图片信息列表
 |  |  |  | tlvInfo |  | M | 历史图片信息
 |  |  |  |  | snapType | M | 图片类型，1 人脸 2过车 3人体
 |  |  |  |  | picType | M | 大小图片类型，1小图 2大图
 |  |  |  |  | tranType | M | 图片传输统计类型，1 存储 2 转发 （转发包括实时转发和历史转发，记录的时间是具体转发时间做统计）
 |  |  |  |  | tlvSuccessNum | M | 历史成功累加值。从开启统计截止到当前时间此摄像机的成功图片总数量。
 |  |  |  |  | tlvSuccessNum_today | M | 今日成功累加值。从昨日截止到当前时间此摄像机的成功图片总数量。今日是以本地时间凌晨为分割。
父主题： 事件定义类型


IVS_EVENT_REPORT_USER_INFO CHANGEV2（用户与摄像机信息变更事件V2版本 10315）

IVS_EVENT_REPORT_USER_INFO CHANGEV2（用户与摄像机信息变更事件V2版本10315）

服务端按照用户订阅的信息向用户端推送摄像机和用户变更消息。

属性

M/O

描述

Content

M

消息体根节点

Total

M

总记录数

UserCameraInfoChange

M

用户与摄像机信息

NotifyType

M

通知事件ID：

1用户信息变更；

2摄像机信息变更；

3用户组信息变更；

4摄像组信息变更

OperType

M

操作类型：

1新增操作；

2删除操作；

3修改操作；

4将摄像机添加到摄像机组；

5将摄像机从摄像机组中删除；

DomainCode

M

所属域编码

CodeId

M

用户或摄像机ID

UserInfo

M

用户的详细信息

DomainCode

用户所属域编码

Id

用户ID。新增用户的时候由eSpace IVS系统分配，从1开始递增，可以不填或者填0；修改用户的时候必须填写

IsFirstLogin

是否是第一次登录：

  • 1：是
  • 0：否

RoleId

角色ID，管理员配置

GroupId

用户组ID

LoginName

登录账号：登录账号，字母（a-z和A-Z），数字，中划线和下划线，取值范围是1~20个字符

Password

登录密码：登录密码，键盘可见字符，取值范围是1~16个字符。

PwdModifyDate

密码修改日期，格式为格式为

YYYYMMDDHHMMSS

UserType

用户类型：

  • 0：IVS普通用户
  • 1：Windows域用户

UserDomain

Windows域名

Status

用户状态：

  • 1：激活
  • 2：停用
  • 3：无效登录锁定

RegiterDate

创建日期，格式为格式为

YYYYMMDDHHMMSS

UserDesc

用户描述，键盘可见字符和中文，取值范围是0~64字符。

PtzLevel

云台控制优先级。取值范围0~9，最低级别为9，最高级别为0

MaxSessionCount

多点登录数,最大长度3字符，数字

MaxVideoCount

最大视频路数，最大长度3字符，数字

LockTime

账号被锁定的时间

UserName

真实姓名，汉字和字母（a-z和A-Z），数字，中划线和下划线，1~20个字符

Email

邮箱，参考网易163邮箱限制。

Phone

电话，取值范围是0~25位数字，中划线

Sex

性别：

  • 0：女性
  • 1：男性

ValidDateFlag

是否有账户有效期：

  • 1：有
  • 0：没有

ValidDateStart

账户有效起始日期，格式

为YYYYMMDDHHMMSS

ValidDateEnd

账户有效结束日期，格式

为YYYYMMDDHHMMSS

Reserve

保留字段

CameraBriefInfoAllV2

M

摄像机的详细信息

Code

设备编码

Name

摄像机名称

DeviceGroupCode

所属设备组编码

ParentCode

父设备编码

DomainCode

域编码

DeviceModelType

主设备型号

VendorType

设备提供商类型：

  • HW
  • HIK
  • DAHUA

DeviceFormType

主设备类型：

  • 1：摄像机
  • 2：DVS
  • 3：DVR
  • 4：eNVR

Type

摄像机类型

  • 0：固定枪机
  • 1：有云台枪机
  • 2：球机
  • 3：半球-固定摄像机
  • 4：筒机
  • 非球机类型摄像机不调用云台相关接口

CameraLocation

摄像机安装位置描述

CameraStatus

摄像机扩展状态：

  • 1 ： 正常
  • 2 ： 视频丢失

Status

设备状态：

  • 0：离线
  • 1：在线
  • 2：休眠

NetType

网络类型：

  • 0：有线
  • 1：无

SupportIntelligent

是否支持智能分析 ：

  • 0：不支持
  • 1：支持

EnableVoice

随路音频是否启用 ：

  • 0：停用
  • 1：启用

NvrCode

设备所属NVR编码，表示该设备被该NVR管理

DeviceCreateTime

设备创建时间，时间格式

为YYYYMMDDHHMMSS

IsExDomain

是否为外部域

  • 0：否
  • 1：是

DeviceIp

前端IP

Longitude

经度

Latitude

纬度

Height

摄像机安装高度

IsShadowDev

是否为影子摄像机 ：

  • 0：否
  • 1：是

OrigDevCode

原始设备编码

OrigParentDevCode

原始父设备编码

OriDevDomainCode

原始域编码

DeleteStatus

设备删除状态 ：

  • 0：设备已经软删除，

待彻底删除状态

  • 1：设备正常状态

ConnectCode

互联编码

SupportGA1400

1400支持能力：

  • 0：不支持1400协议，作为视频设备
  • 1：仅支持1400协议，作为视图设备
  • 2：同时支持1400协议和视频能力

Reserve

保留字段

UserGroupInfo

M

用户组的详细信息

DomainCode

域编码

GroupID

用户组ID

GroupName

用户组名称

ParentGroupID

父用户组ID

Level

用户组层级，最多支持4层

（包含根组在内）

Reserve

保留字段

DeviceGroup

M

摄像机组的详细信息

GroupCode

设备组编码

GroupName

设备组名称

ParentGroupCode

父设备组编码

DomainCode

域编码

IsExDomin

是否为外部域/组：

  • 0：否
  • 1：是

Reserve

保留字段

Reserve

保留字段
父主题： 事件定义类型


设备编码规则

IVS平台设备编码规则

IVS平台设备编码规则为：ID类型+序列号+eNVR下设备序号预留+扩展位+设备类型+通道序号（1+6+4+5+2+2，其中1等数值代表位数）

以一个IPC为例：

  • 主设备：0 001234 0001 00000 00 00
  • 镜头设备：0 001234 0001 00000 01 01
  • 开关量输入：0 001234 0001 00000 02 01
  • 开关量输出：0 001234 0001 00000 03 01
  • 音频输入：0 001234 0001 00000 04 01
  • 音频输出：0 001234 0001 00000 05 01
  • 串口设备：0 001234 0001 00000 06 01

特殊协议编码说明-千里眼协议（TEYES协议）接入设备编码规则

千里眼协议接入设备受11位长度限制，设备上所输入设备ID为平台的设备ID去除5位扩展位、2位设备类型、2位通道序号。

以上一个例子中的IPC编码为例，如果是千里眼设备，其在设备上输入的设备ID就为：0 001234 0001。在新增设备时，千里眼设备只能输入前7位，后13位由系统自动生成，组成20位IVS平台设备编码。

特殊协议编码说明-T28181协议接入设备编码规则

编码共20位：中心码(8位)、行业编码(2位)、类型编码(3位)、序号(7位)

  • 添加主设备时，编码规则如下：
    • 1-10位中心码+行业编码由用户自行维护输入
    • 11-13位类型码由系统自动生成：111-DVR，113-DVS，132-IPC
    • 14-18位系统自动生成安全随机数
    • 19-20位表示主设备序号，从01开始
  • 生成子设备时，编码规则如下：
    • 1-10位、14-18位保持与主设备一致
    • 11-13位类型码为对应子设备：131-摄像机，134-告警输入，135-告警输出，136-语音输入，137-语音输出，140-串口
    • 19-20位表示子设备序号，从01开始
  • 以一个DVR为例：
    • 主设备：1234567890 111 01234 01
    • 摄像机子设备：12345678901310123401，12345678901310123402
    • 告警输入子设备：12345678901340123401，12345678901340123402
    • 告警输出子设备：12345678901350123401，12345678901350123402
    • 语音输入子设备：12345678901360123401，12345678901360123402
    • 语音输出子设备：12345678901370123401，12345678901370123402
    • 串口子设备：12345678901400123401，12345678901400123402
父主题： 附录


证书替换

  1. 制作证书。
  2. 更新原始密钥库文件。

    1. 备份原始密钥库文件，原始密钥库文件所在位置：/home/ivs_restful/config。
    2. 将新生成的密钥库文件“keystore.p12”复制到“/home/ivs_restful/config”目录下，替换原有密钥库文件。

  3. 修改“/home/ivs_restful/config/application.properties”文件。

    关于修改项的说明如下：

    • server.ssl.key-store：生成密钥库文件时填写的密钥库文件名，本例中为/home/ivs_restful/config/server.keystore。

  4. 修改“/home/ivs_restful/config/keystore.properties”文件。

    1. 加密工具加密密钥库密码：调用/home/ivs_restful/tools/encrypt_tool.sh

      具体命令如下所示：

    2. 修改项说明如下：
      • server.ssl.key-store-password：密钥库加密密文
      • server.ssl.keyStoreType：密钥库生成时实际填写的类型。
      • server.ssl.keyAlias:密钥库生成时实际填写的别名。。

  5. 完成配置后重启服务，执行命令/home/ivstool/bin/service.sh restart restful，若重启成功，证明更换证书成功。

keytool命令不可用解决方法

出现keytool不是内部或外部命令，也不是可运行的程序或批处理文件提示信息，则表明keytool命令不可用，可能由下述两个原因引起：

  1. 未安装JDK。

    需到Oracle官方网站下载JDK并执行安装，安装完成后，系统默认配置环境变量。如若版本原因系统未自动配置环境变量，可参见下述步骤进行环境变量的配置。

    需要确保JDK版本为1.7及以上。

  2. 安装JDK但未配置环境变量。
父主题： 附录


错误码

  • 错误码
  • HTTP响应代码表


错误码

错误码

错误描述

可能原因

处理步骤

0

成功

操作成功

无需处理

2130000010

SDK内部服务错误
  • SDK内部转换或处理异常
  • 输入参数的字节数超过系统设定长度限制值
  • 必填参数置空，请检查具体参数
  • 根据日志定位
  • 将输入参数字节数调整为设定长度内
  • 将置空的必填参数填入相应内容

2130000022

参数不能为null

用户输入参数为null

必填参数不能为null，请检查参数是否输入正确

2130000023

应用与eSDK之间连接网络异常

sdk server已停用或者sdkserver.url配置的url错误

检查sdk server是否开启，或者sdkserver.url中的url是否正确，并确认native是否开启支持ssl

2130000024

配置文件参数非法

配置文件找不到或者中的参数不合法

对照SDK安装说明，检查配置文件的位置及各个配置参数的合法性

2130000026

取消注册回调失败

调用接口是参数不合法

传入正确类型的参数

2130000027

账户被锁定

密码输入错误次数超过限定值

检查密码，待达到锁定时间后重新尝试

2130000028

系统繁忙

稍后再次尝试

稍后再次尝试

2130000030

eSDK解密失败

参数中解密失败

参数解密失败

2130000031

eSDK加密失败

加密失败

加密失败

2130000038

系统暂不支持该算法

系统暂不支持该算法

参考接口文档中相关接口的说明，核对接口入参

2130000039

必填参数不全

必填参数不全

参考接口文档中相关接口的说明，核对接口入参

2130000040

数值非法或超过取值范围

数值非法或超过取值范围

参考接口文档中相关接口的说明，核对接口入参

2130000041

session id无效

session id无效

使用有效的session id调用接口

2130000044

工作密钥协商失败

工作密钥协商失败

根据日志定位

2130000046

session超时

用户未登录或连接超时

调用登录接口获取sessionID

请确认会话是否过期，或者检查HTTP Header中携带的JSESSIONID是否正确

2130000047

批量操作全部失败

用户操作失败

检查传入域名是否合法，用于用户图片订阅，根据日志定位

2130000048

批量操作部分失败

用户部分操作失败

根据日志定位

2130000049

国标编码格式错误

20位国标编码，要求11~13位为131或132

检查国标编码长度和格式

2130000050

IP格式错误
  • IP_V4
  • IP_V6

检查IP格式非法性

2130000051

时间格式错误

时间格式yyyyMMDDhhmmss

检查时间格式合法性

2130000052

XML解析失败

XML解析失败

检查输入XML合法性，或联系华为工程师定位

570462209

数据类型错误

输入的参数类型错误

请参见接口文档相关章节，核对输入的参数类型

570462210

必填参数不全

缺少必要的输入参数

请参见接口文档相关章节，核对输入的参数，补充填写未填的必填项

570462211

参数超范围

输入的参数值超出有效范围

请参见接口文档相关章节，核对输入的参数值，确保填入的参数值在有效范围内

570462213

该用户已登录

系统不允许重复登录

更换用户登录

1342177281

参数错误

输入的参数错误

请参见接口文档相关章节，核对输入的参数

错误信息 | 错误码 | 错误描述
IVS_SUCCEED | 0 | 成功
IVS_FAIL | 1 | 失败
IVS_PARA_INVALID | 2 | 输入参数非法
IVS_PASSWORD_ERROR | 109100000 | 用户名密码错误，登录时输入的用户名或密码错误
IVS_USER_NOT_EXIST | 109100001 | 用户不存在，注册的用户ID已注销或不可用
IVS_NO_ENOUGH_RIGHT | 109100002 | 权限不足，无此操作权限
IVS_NOT_INIT | 109100003 | 未初始化
IVS_ALLOC_MEMORY_ERROR | 109100004 | 分配内存失败
IVS_OPERATE_MEMORY_ERROR | 109100005 | 操作内存失败
IVS_NO_ENOUGH_BUF | 109100006 | 缓冲区太小，接收数据的缓冲区或存放数据的缓冲区不足
IVS_SYS_NO_SUPPORT | 109100007 | 系统不支持
IVS_INIT_DB_ERROR | 109100008 | 初始化数据库失败
IVS_CONNECT_DB_ERROR | 109100009 | 连接数据库失败（用于获取数据库连接失败、数据库连接指针为NULL）
IVS_OPERATE_DB_ERROR | 109100010 | 数据库操作失败（用于各种数据库操作失败、数据库中内容不存在、数据库结果集指针为空等）
IVS_DIR_ERROR | 109100011 | 路径错误
IVS_CREATE_DIR_ERROR | 109100012 | 创建文件目录失败
IVS_FILE_FORMAT_ERROR | 109100013 | 文件格式不正确
IVS_CREATE_FILE_ERROR | 109100014 | 创建文件失败
IVS_OPEN_FILE_ERROR | 109100015 | 打开文件失败
IVS_WRITE_FILE_ERROR | 109100016 | 写文件失败
IVS_DISK_FULL | 109100017 | 硬盘空间满
IVS_DISK_ERROR | 109100018 | 硬盘出错
IVS_NET_CONNECT_ERROR | 109100019 | 网络连接失败,服务器不在线或者网络原因引起连接超时等
IVS_NET_OVER_MAXLINK | 109100020 | 连接数超过最大限制
IVS_NET_SEND_ERROR | 109100021 | 网络发送数据失败
IVS_NET_RECV_ERROR | 109100022 | 网络接收数据失败
IVS_NET_RECV_TIMEOUT | 109100023 | 网络接收数据超时
IVS_NET_DATA_ERRORs | 109100024 | 网络传送的数据有误
IVS_JOIN_MULTICAST_ERROR | 109100025 | 加入多播组失败
IVS_CREATE_THREAD_ERROR | 109100026 | 创建线程失败
IVS_XML_INVALID | 109100027 | XML消息体非法(用于XML消息体为NULL、XML解析失败)
IVS_XML_PACK_ERROR | 109100028 | XML组装失败
IVS_XML_DEV_TEMPLATE_INVALID | 109100029 | 设备模板XML非法
IVS_SECURITY_INIT_ERROR | 109100030 | 安全操作类初始化失败
IVS_BATCH_OPERATE_ALL_ERROR | 109100031 | 批量操作全部失败
IVS_BATCH_OPERATE_PART_SUCCEED | 109100032 | 批量操作部分成功
IVS_MU_OFF_LINE | 109100033 | MU不在线
IVS_CMU_OFF_LINE | 109100034 | CMU不在线
IVS_DCG_OFF_LINE | 109100035 | DCG不在线
IVS_OMU_OFF_LINE | 109100036 | OMU不在线
IVS_SMU_OFF_LINE | 109100037 | SMU不在线
IVS_SCU_OFF_LINE | 109100038 | SCU不在线
IVS_MULM_OFF_LINE | 109100039 | MULM不在线
IVS_GET_LOCALIP_ERROR | 109100040 | 获取本地IP失败
IVS_SET_LOCALIP_ERROR | 109100041 | 设置本地IP失败
IVS_SCRIPT_RUN_ERROR | 109100042 | 脚本执行出错
IVS_USERNAME_INVALID | 109100043 | 用户名长度非法或包含非法字符
IVS_PASSWORD_INVALID | 109100044 | 用户密码长度非法或包含非法字符
IVS_NAME_INVALID | 109100045 | 名称长度非法或包含非法字符（用于设备名称，计划名称等）
IVS_DESCRIBE_INVALID | 109100046 | 描述长度非法或包含非法字符
IVS_CODE_INVALID | 109100047 | 编码长度非法或包含非法字符（用于设备编码，域编码等）
IVS_IP_INVALID | 109100048 | IP地址非法
IVS_PORT_INVALID | 109100049 | 端口非法
IVS_TIME_INVALID | 109100050 | 时间非法
IVS_EMAIL_INVALID | 109100051 | e-mail非法
IVS_TELEPHONE_INVALID | 109100052 | 电话非法
IVS_DATA_INVALID | 109100053 | 数值非法或超过取值范围
IVS_MAU_OFF_LINE | 109100054 | MAU不在线
IVS_URL_INVALID | 109100055 | URL非法
IVS_DOWNLOAD_ERROR | 109100056 | 下载失败
IVS_DOMAIN_TYPE_ERROR | 109100057 | 域模式错误
IVS_DATA_ENCRYPT_ERROR | 109100058 | 数据加密失败
IVS_DATA_DECRYPT_ERROR | 109100059 | 数据解密失败
IVS_IP_INVALID_SAMEAS_PHYSICAL_IP | 109100060 | IP地址非法:浮动ip和物理ip相同
IVS_IP_INVALID_BEING_USED | 109100061 | IP地址非法:浮动ip地址冲突
IVS_IP_INVALID_NETWORK_SEGMENT | 109100062 | IP地址非法:浮动ip非同网段IP
IVS_NOT_SUPPORT_MSG | 109100063 | 不支持的消息类型
IVS_GET_RECORD_LIST_TIMEOUT | 109100064 | 查询录像超时，请缩小时间范围
IVS_LINK_NOT_AUTH | 109100065 | 连接未鉴权
IVS_PASSWORD_WEAK | 109100066 | 输入的密码属于弱口令，请重新输入
IVS_PASSWD_EQUAL_LAST_N | 109100067 | 密码与前N次相同
IVS_SMU_ROLE_WITH_USER_DELETE_ERROR | 119105123 | 删除存在用户的角色失败，不允许删除存在用户的角色
IVS_SMU_OLD_NEW_PWD_THE_SAME | 119105351 | 新密码不能和原来的相同
IVS_SMU_XML_INVALID | 119108001 | XML数据不合法
IVS_SMU_DEVICE_TIMEOUT | 119108002 | 处理设备管理业务超时
IVS_SMU_GETURL_TIMEOUT | 119108003 | 获取geturl超时
IVS_SMU_RECORDINQUIRY_TIMEOUT | 119108004 | 录像查询超时
IVS_SMU_DEVICE_EXIST | 119108005 | 设备已存在
IVS_SMU_DEVICE_NOTEXIST | 119108006 | 设备不存在
IVS_SMU_DEVICE_UPDATEMAP_FAIL | 119108007 | 更新内存失败
IVS_SMU_DEVICE_ADDMAP_FAIL | 119108008 | 添加内存数据失败
IVS_SMU_PTZ_CONTROL_TIMEOUT | 119108009 | 云镜控制超时
IVS_SMU_ROUTE_NVR_FAIL | 119108010 | 路由nvr失败
IVS_DB_RESULT_SET_NULL_POINTER | 119108011 | 数据库结果集指针为空
IVS_SMU_CMD_XML_IS_NULL | 119108012 | cmd中的xml指针为空
IVS_SMU_DR_RELATON_TIMEOUT | 119108013 | 容灾备份操作超时
IVS_SMU_OPERATE_TIME_OUT | 119108014 | 操作超时
IVS_SMU_MD_DATA_TIME_OUT | 119108015 | 查询移动侦测数据超时
IVS_SMU_LOAD_SQL_ERROR | 119108016 | SMU加载数据库语句失败
IVS_SMU_SQL_DATA_NULL | 119108017 | SMU查询数据库为空
IVS_SMU_DEVICE_CONNECT_CODE_EXIST | 119108021 | 互联编码已存在
IVS_SMU_DEV_TIMEOUT | 119108100 | 处理设备管理业务超时
IVS_SMU_DEV_CMD_INVALID | 119108101 | CMD不可用
IVS_SMU_DEV_REQ_XML_INVALID | 119108102 | 所请求的XML非法
IVS_SMU_DEV_REQ_XML_GROUPID_NOEXIST | 119108103 | 所请求的XML报文GroupId节点不存在
IVS_SMU_DEV_REQ_XML_GROUPNAME_NOEXIST | 119108104 | 所请求的XML报文GroupName节点不存在
IVS_SMU_DEV_DB_CONNECT_ERROR | 119108105 | 数据库连接错误
IVS_SMU_DEV_DB_EXECUTE_ERROR | 119108106 | 数据库操作失败
IVS_SMU_DEV_GROUPID_NOEXIST | 119108107 | 设备组ID不存在
IVS_SMU_DEV_SAME_GROUPNAME_EXIST | 119108108 | 父设备组下存在同名子设置组
IVS_SMU_DEV_ADD_ALL_FAIL | 119108109 | 添加主设备全部失败
IVS_SMU_DEV_ADD_PART_SUCCEED | 119108110 | 添加主设备部分成功
IVS_SMU_DEV_TYPES_CHANGE_ERROR | 119108111 | 设备类型强制转换错误
IVS_SMU_DEV_XML_CHANNELNAME_NOEXIST | 119108112 | 所请求的XML报文ChannelName节点不存在
IVS_SMU_DEV_XML_CHANNELTYPE_NOEXIST | 119108113 | 所请求的XML报文ChannelType节点不存在
IVS_SMU_DEV_XML_CHANNELCODE_NOEXIST | 119108114 | 所请求的XML报文ChannelCode节点不存在
IVS_SMU_DEV_CREATE_SUBDEVICE_FAIL | 119108115 | 创建子设备失败
IVS_SMU_DEV_GET_ROUTING_ERROR | 119108116 | 获取NVR路由失败
IVS_SMU_DEV_REQ_XML_TARGROUPID_NOEXIST | 119108117 | 所请求的XML报文TargetGroup节点不存在
IVS_SMU_DEV_DB_GROUPID_NOEXIST | 119108118 | 数据库GroupId无记录
IVS_SMU_DEV_GROUP_LEVEL_EXCEED | 119108119 | GroupLevel超出最大值
IVS_SMU_DEV_ADD_TO_GROUP_ERROR | 119108120 | 添加设备组下设备失败
IVS_SMU_DEV_NOEXIST | 119108121 | 设备不存在
IVS_SMU_DEV_FROM_GRP_ID_ZERO | 119108122 | 父设备组已经为根组
IVS_SMU_DEV_PROTOCOL_TYPE_ERROR | 119108123 | 主设备协议类型错误
IVS_SMU_DEV_NVRCODE_CANNOT_MOD | 119108124 | 不可修改设备的nvrcode
IVS_SMU_DEV_XML_LOGINID_NOEXIST | 119108125 | 所请求的XML报文LoginId节点不存在
IVS_SMU_DEV_CONNOT_DEL | 119108126 | 该设备只在根组下，不能移除
IVS_SMU_DEV_DELETE_FAIL | 119108127 | 删除设备失败
IVS_SMU_DEV_NVR_ROUTING_OFFLINE | 119108128 | NVR不在线
IVS_SMU_DEV_GROUP_TARGET_SAME_FAIL | 119108129 | 与目标设备组相同
IVS_SMU_DEV_NVR_NOT_EXIST | 119108130 | nvrcode不存在
IVS_SMU_DEV_GROUP_TOTAL_EXCEED | 119108131 | 设备组总数达到最大值
IVS_SMU_DEV_GROUP_CHILE_EXCEED | 119108132 | 子设备组达到最大值
IVS_SMU_DEV_GROUP_EXIST_RECU | 119108133 | 设备组存在递归
IVS_SMU_DEV_GROUPNAME_LENGTH_INVALID | 119108134 | 设备组长度无效
IVS_SMU_DEV_GROUPNAME_STRING_INVALID | 119108135 | 设备组名称包含非法字符
IVS_SMU_DEV_XML_PARENRGROUPID_NOEXIST | 119108136 | 所请求的PARENRGROUPID节点不存在
IVS_SMU_DEV_GROUPREMARK_LENGTH_INVALID | 119108137 | 设备组长度无效
IVS_SMU_DEV_GROUPREMARK_STRING_INVALID | 119108138 | 设备组名称包含非法字符
IVS_SMU_DEV_BUILD_DEVICE_CODE_FAIL | 119108139 | 生成设备编码失败
IVS_SMU_DEV_PART_NOEXIST | 119108140 | 设备列表中部分设备不存在
IVS_SMU_DEV_DR_TABLE_IS_EMPTY | 119108141 | 容灾关系表为空
IVS_SMU_DEVICE_IP_EXIST | 119108142 | 设备IP已存在
IVS_SMU_ONLY_SUPPORT_LOCAL_DOAMIN | 119108143 | 只支持本域设备
IVS_SMU_QD_NO_LICENSE | 119108144 | 视频质量诊断无license
IVS_SMU_QD_NO_SUPPORT_SYSTEM | 119108145 | 视频质量诊断不支持的系统(VCN500不支持)
IVS_SMU_USER_EXPIRED | 119101302 | 账号已经过期
IVS_SMU_USER_STOPPED | 119101303 | 用户被停用
IVS_SMU_USER_LOCKED | 119101304 | 用户被锁定
IVS_SMU_USER_PWD_NEED_MOD | 119101305 | 用户密码已过期，需要修改
IVS_SMU_EXCEED_SAME_USER_ONLINE_MAXNUM | 119101306 | 超过同一账户同时在线的最大用户个数
IVS_SMU_EXCEED_ONLINE_USER_MAXNUM | 119101307 | 同时在线总用户数超过系统支持的最大数量
IVS_SMU_USER_FIRST_LOGIN | 119101308 | 用户首次登录需要修改密码
IVS_SMU_USER_OFF_LINE | 119101309 | 用户已离线
IVS_SMU_BASIC_LOGIN_NOT_NEED_DOMAIN_NAME | 119101310 | 基本身份登录不能带域名信息
IVS_SMU_DOMAIN_LOGIN_NEED_DOMAIN_NAME | 119101311 | 域身份登录必须带域名信息
IVS_SMU_NO_MATCH_ACC_RULE | 119101312 | 没找到账户匹配的角色规则信息
IVS_SMU_NO_MATCH_OPER_RIGHT | 119101313 | 没找到账户匹配的操作权限信息
IVS_SMU_LOGIN_WITH_EXIST_LINKID | 119101314 | 不能使用旧的TCP连接重复发送登录请求
IVS_SMU_VERIFY_WITH_DIFFERENT_LINKID | 119101315 | 认证请求所使用的TCP连接与在线用户的TCP连接不同
IVS_SMU_PWD_IS_EMPTY | 119101316 | 密码为空
IVS_SMU_CU_IP_IS_ILLEGAL | 119101317 | 登录Xml的CUIP非法
IVS_SMU_CU_PORT_IS_ILLEGAL | 119101318 | 登录Xml的CU端口非法
IVS_SMU_LOGIN_TYPE_ILLEGAL | 119101319 | Login_Type非法
IVS_SMU_LDAP_INIT_FAIL | 119101320 | 域账户验证时，LDAP协议初始化失败
IVS_SMU_LDAP_SEARCH_ACCOUNT_FAIL | 119101321 | 在域服务器上查找账户失败
IVS_SMU_MACHINE_NAME_ILLEGAL | 119101322 | 机器名非法
IVS_SMU_CLIENT_TYPE_ILLEGAL | 119101323 | 客户端类型非法
IVS_SMU_SERVER_IP_IS_ILLEGAL | 119101324 | 登录Xml的服务器IP非法
IVS_SMU_SERVER_PORT_IS_ILLEGAL | 119101325 | 登录Xml的服务器端口非法
IVS_SMU_DOMAIN_LOGIN_SERVER_DISCONNECT | 119101326 | 域账号服务器不在工作
IVS_SMU_CAN_NOT_SIGNOUT_USER_SELF | 119101327 | 不能签退自己
IVS_SMU_RIGHT_LEN_NO_MATCH | 119101328 | 权限长度不匹配
IVS_SMU_ENCRYPT_FAIL | 119101329 | 加密失败
IVS_SMU_DECRYPT_FAIL | 119101331 | 解密失败
IVS_SMU_REQUEST_PUBLIC_KEY_FAIL | 119101332 | 请求公钥失败
IVS_SMU_REQUEST_EXCHANGE_KEY_FAIL | 119101333 | 交换密钥失败
IVS_SMU_SECURITY_CLIENT_INIT_FAIL | 119101334 | 安全Client初始化失败
IVS_SMU_WAIT_ASYNC_RESPONSE | 119101340 | 等待异步响应
IVS_NULL_POINTER | 119101350 | 服务器内部错误，空指针异常;
IVS_SMU_LINKID_FORMAT_ERROR | 119101351 | LinkID格式错误
IVS_SMU_IP_LOCKED | 119101352 | 用户IP被锁定
IVS_SMU_HAS_RESTARED | 119101353 | SMU已重启，原在线用户已不存在，用于sdk重连smu
IVS_SMU_DNSCONFIG_NOT_SET | 119101354 | 域服务器未配置
IVS_SMU_USER_NOT_IN_VALID_TIME | 119101355 | 用户不在有效期中
IVS_SMU_DOMAIN_LOGIN_NOT_SUPPORT | 119101356 | 不支持域登录，当前VCN500不支持
IVS_SMU_ADD_GROUP_ERROR | 119105000 | 新增用户组失败
IVS_SMU_MODIFY_GROUP_ERROR | 119105001 | 修改用户组失败
IVS_SMU_DELETE_GROUP_ERROR | 119105002 | 删除用户组失败
IVS_SMU_MOVE_GROUP_ERROR | 119105003 | 移动用户组失败
IVS_SMU_ADD_GROUP_HAVE_REPEAT_GROUP | 119105004 | 增加用户组时重复
IVS_SMU_ADD_GROUP_PARENT_NOT_EXIST | 119105005 | 父节点不存在
IVS_SMU_ADD_GROUP_PARENT_LEVEL_INVALID | 119105006 | 父节点层级非法
IVS_SMU_MOIDFY_GROUP_GROUP_NOT_EXIST | 119105007 | 被修改的用户组不存在
IVS_SMU_MOIDFY_GROUP_HAVE_REPEAT_GROUP | 119105008 | 修改用户组后重命名
IVS_SMU_MOVE_GROUP_TARGET_NOT_EXIST | 119105009 | 移向的目标不存在
IVS_SMU_MOVE_GROUP_TARGET_LEVEL_INVALID | 119105010 | 移动后会超过3级
IVS_SMU_MOVE_GROUP_BEMOVED_NOT_EXIST | 119105011 | 被移动的用户组不存在
IVS_SMU_MOVE_GROUP_HAVE_REPEAT_GROUP | 119105012 | 移动后用重命名用户组
IVS_SMU_DEL_GROUP_GROUP_NOT_EXIST | 119105013 | 要被删除的用户组不存在
IVS_SMU_CAN_NOT_DELETE_ROOT_GROUP | 119105016 | 不能删除根组
IVS_SMU_OVER_MAX_GROUP_NUM | 119105017 | 用户组个数超过最大限额
IVS_SMU_CAN_NOT_MOVE_ROOT_GROUP | 119105018 | 根组不能移动
IVS_SMU_CAN_NOT_MOVE_TO_SELF | 119105019 | 组不能移动到自己
IVS_SMU_GROUP_NUM_OVER_MAX | 119105020 | 用户组个数达到上限,超过1000
IVS_SMU_GROUP_CHILDREN_NUM_OVER_MAX | 119105021 | 子用户组个数超过99
IVS_SMU_PARAM_INVALID_FOR_GROUP | 119105022 | 用户组参数错误
IVS_SMU_RESET_PWD_SWITCH_OFF | 119105023 | 重置密码开关关闭
IVS_SMU_CAN_NOT_DEL_USER_IN_SELFGRP | 119105024 | 不能删除自己所在的用户组
IVS_SMU_CAN_NOT_DEL_ROLE_IN_SELF | 119105025 | 不能删除自己的角色
IVS_SMU_USER_GROUP_DESC_LENGTH_INVALID | 119105026 | 用户组备注长度非法
IVS_SMU_ADD_ROLE_ERROR | 119105100 | 新增角色失败
IVS_SMU_MODIFY_ROLE_ERROR | 119105101 | 修改角色失败
IVS_SMU_DELETE_ROLE_ERROR | 119105102 | 删除角色失败
IVS_SMU_GET_ROLE_LIST_ERROR | 119105103 | 查询角色失败
IVS_SMU_ACC_PARAM_ERROR | 119105104 | 帐号规则参数非法
IVS_SMU_ADD_ROLE_HAVE_REPEAT_ROLE | 119105105 | 角色重命名
IVS_SMU_DELETE_ROLE_ROLE_NOT_EXIST | 119105106 | 删除的角色不存在
IVS_SMU_DELETE_DEFAULT_ROLE_ERROR | 119105107 | 不能删除默认角色
IVS_SMU_MODIFY_ROLE_ROLE_NOT_EXIST | 119105108 | 修改的角色不存在
IVS_SMU_GET_DEFAULT_RULE_ERROR | 119105109 | 获取默认帐号规则失败
IVS_SMU_GET_ROLE_BY_ID_ERROR | 119105110 | 根据id获取角色失败
IVS_SMU_GET_ROLE_BY_ID_ROLE_NOT_EXIST | 119105111 | 角色id对应的角色不存在
IVS_SMU_GET_USER_ROLE_USER_NOT_HAVE_ROLE | 119105112 | 用户没有分配角色
IVS_SMU_GET_USER_ROLE_USER_NOT_EXIST | 119105113 | 用户没有分配角色
IVS_SMU_GET_USER_ROLE_OP_ERROR | 119105114 | 获取角色操作权限失败
IVS_SMU_FILE_OP_ERROR | 119105116 | 上传下载文件失败
IVS_SMU_FILE_OVER_MAX | 119105117 | 文件大小太大，超过20m
IVS_SMU_FILE_BUILD_CMD_ERROR | 119105118 | 拼装cmd时错误
IVS_SMU_PARAM_INVALID_FOR_ROLE | 119105119 | 角色参数错误
IVS_SMU_ROLE_NUM_OVER_MAX | 119105120 | 角色个数达到上限,超过128
IVS_SMU_GROUP_NUM_OVER_MAX_VCN500 | 119105121 | VCN500用户组个数达到上限，超过16
IVS_SMU_ROLE_NUM_OVER_MAX_VCN500 | 119105122 | VCN500角色个数达到上限,超过32
IVS_SMU_MODIFY_PWD_OLD_PWD_WRONG | 119105200 | 修改密码时旧密码错误
IVS_SMU_ADD_USER_ERROR | 119105201 | 增加用户错误
IVS_SMU_DELETE_USER_ERROR | 119105202 | 删除用户错误
IVS_SMU_MODIFY_USER_ERROR | 119105203 | 修改用户错误
IVS_SMU_INQUIRY_USER_ERROR | 119105204 | 查询用户错误
IVS_SMU_INQUIR_ONLINE_USER_ERROR | 119105205 | 查询在线用户错误
IVS_SMU_INQUIR_DEVLIST_ERROR | 119105206 | 查询用户设备错误
IVS_SMU_USER_NOT_EXIST | 119105207 | 用户不存在
IVS_SMU_USER_EXIST | 119105208 | 用户已存在
IVS_SMU_EXIST_SAME_ITEM | 119105211 | 数据库已存在相同的内容
IVS_SMU_DB_NOT_EXIST_ITEM | 119105212 | 数据库不存在内容
IVS_SMU_FROM_GREATERTHAN_INDEX_ERROR | 119105214 | 用户查询FROM索引大于TO索引
IVS_SMU_XML_UNIFIEDQUERY_LIMIT_ERROR | 119105215 | 统一查询参数中的limit不正确
IVS_SMU_XML_UNIFIEDQUERY_INDEX_ERROR | 119105216 | 统一查询参数中的Fromindex、Toindex不正确
IVS_SMU_USER_ID_INVALID | 119105218 | 数据库ID不合法
IVS_SMU_ID_GENERATE_ERROR | 119105222 | 数据库id生成错误
IVS_SMU_ADD_USER_ROLE_RELATION_ERROR | 119105223 | 添加用户角色关联表错误
IVS_SMU_ADD_USER_GROUP_RELATION_ERROR | 119105224 | 添加用户用户组关联表错误
IVS_SMU_ROLE_NOT_EXIST | 119105225 | 角色表中角色不存在
IVS_SMU_GROUP_NOT_EXIST | 119105226 | 用户组不存在
IVS_SMU_DEV_EXIST_SAME_ITEM | 119105227 | 设备已存在
IVS_SMU_DELETE_USER_USERGROUP_ERROR | 119105228 | 删除用户用户组表错误
IVS_SMU_DELETE_USER_ONLINE_ERROR | 119105229 | 删除在线用户错误
IVS_SMU_DELETE_USER_ROLE_ERROR | 119105230 | 删除用户角色对应表错误
IVS_SMU_DELETE_USER_DEVICE_ERROR | 119105231 | 删除用户设备对应表错误
IVS_SMU_DELETE_USER_INFO_ERROR | 119105232 | 删除用户基本表错误
IVS_SMU_MODIFY_USER_ROLE_ERROR | 119105234 | 修改用户角色对应表错误
IVS_SMU_MODIFY_USER_USERGROUP_ERROR | 119105235 | 修改用户用户组表错误
IVS_SMU_MODIFY_USER_USEINFO_ERROR | 119105236 | 用户修改基本信息表错误
IVS_SMU_MODIFY_ADMIN_USEINFO_ERROR | 119105237 | 管理员修改基本信息表错误
IVS_SMU_POINTER_IS_NULL | 119105238 | 指针为空
IVS_SMU_GET_TIMEZONE_ERROR | 119105239 | 获取时区失败
IVS_SMU_ADD_SBUSCRIBE_INFO_ERROR | 119105240 | 增加订阅告警信息错误
IVS_SMU_PAGEINFO_INVALID | 119105241 | 分页信息不合法
IVS_SMU_USER_TYPE_INVALID | 119105246 | 用户类型不合法
IVS_SMU_DB_ID_INVALID | 119105247 | 数据库id不合法
IVS_SMU_USER_REGINSTER_DATE_INVALID | 119105249 | 用户注册时间不合法
IVS_SMU_USER_STATUS_INVALID | 119105250 | 用户状态不合法
IVS_SMU_USER_SEX_INVALID | 119105253 | 用户SEX不合法
IVS_SMU_USER_ROLEID_INVALID | 119105254 | 用户角色ID不合法
IVS_SMU_USER_GROUPID_INVALID | 119105255 | 用户组ID不合法
IVS_SMU_GET_USER_ID_NAME_ERROR | 119105256 | 获取用户id和登录名错误
IVS_SMU_SELECT_COUNT_ERROR | 119105257 | 获取查询总量错误
IVS_SMU_OVER_MAX_USER_NUM | 119105258 | 超过用户最大限
IVS_SMU_SEARCH_CODE_INVALID | 119105259 | 搜索条件信息不合法
IVS_SMU_OVER_MAX_USER_NUM_VCN500 | 119105260 | 超过用户最大限(VCN500)
IVS_SMU_STATEMENT_FILE_OPEN_ERROR | 119105262 | 声明文件打开失败(文件不存在)
IVS_SMU_STATEMENT_FILE_TOO_LARGE | 119105263 | 声明文件太大
IVS_SMU_STATEMENT_FILE_INVALID | 119105264 | 声明文件不合法
IVS_SMU_READ_STATEMENT_ERROR | 119105265 | 读取声明文件失败
IVS_SMU_PARSE_STATEMENT_FILE_TOO_LARGE | 119105266 | 解析声明文件失败
IVS_SMU_DELETE_USERSELF_ERROR | 119105267 | 用户删除用户本身失败(自己删除自己失败)
IVS_SMU_PARAMETER_INVALID | 119105268 | 分页信息中的用户参数不合法
IVS_SMU_USERGROUP_NOT_EXIST | 119105270 | 用户组不存在
IVS_SMU_USER_MODIFY_INFO_INVALID | 119105271 | 用户修改信息不合法
IVS_SMU_ADD_USER_SUBSCRIBEINFO_ERROR | 119105272 | 增加用户订阅表信息失败
IVS_SMU_DB_EXIST_SAME_ITEM | 119105273 | 数据库存在相同记录
IVS_SMU_DELETE_SUBSCRIBE_LEVEL_ERROR | 119105274 | 删除订阅级别失败
IVS_SMU_DELETE_SUBSCRIBE_TYPE_ERROR | 119105275 | 删除订阅类型失败
IVS_SMU_SELF_LOCK_ERROR | 119105276 | 自己锁定自己不允许
IVS_SMU_SELF_DELETE_ERROR | 119105277 | 自己删除自己不允许
IVS_SMU_DEV_GROUP_DOMAIN_CODE_TOO_LONG | 119105284 | 设备组域编码太长
IVS_SMU_DELETE_SUPER_INVALID | 119105285 | 删除super不允许
IVS_SMU_RESET_SUPER_INVALID | 119105286 | 重置super密码不允许
IVS_SMU_ADD_USER_DEV_ERROR | 119105287 | 增加用户设备失败
IVS_SMU_DEV_NOT_EXIST | 119105288 | 设备不存在
IVS_SMU_PCRE_PATTERN_TOO_LONG | 119105289 | PCRE规则太长
IVS_SMU_PCRE_TEXT_TOO_LONG | 119105290 | 需要PCRE判断的文本太长
IVS_SMU_PCRE_COMPILE_ERROR | 119105291 | PCRE编译出错
IVS_SMU_PCRE_NOT_COMPELETLY_MATCH | 119105292 | PCRE规则不完全匹配
IVS_SMU_PCRE_NOT_MATCH_OR_ERROR | 119105293 | PCRE完全不匹配或者出错
IVS_SMU_PCRE_NOT_MATCH | 119105294 | PCRE规则完全不匹配
IVS_SMU_PCRE_ERROR | 119105295 | PCRE执行出错
IVS_SMU_PCRE_TEXT_IS_NULL | 119105296 | 需要PCRE判断的文本为空
IVS_SMU_READ_UNICODE_TXT_ERROR | 119105297 | 读Unicode文件失败
IVS_SMU_SEARCH_CONDITION_TOO_LONG | 119105298 | 搜索条件太长
IVS_SMU_XML_NVR_CODE_INVALID | 119105299 | 设备编码错误
IVS_SMU_PWD_PCRE_INVALID | 119105300 | 密码不符合PCRE规则
IVS_SMU_PWD_PCRE_NO_CAPTIAL | 119105301 | 密码中没有包含大写
IVS_SMU_PWD_PCRE_NO_LOWERCASE | 119105302 | 密码中没有包含小写
IVS_SMU_PWD_PCRE_NO_FIGURE | 119105303 | 密码中没有包含数字
IVS_SMU_PWD_PCRE_NO_SPECIAL_CHAR | 119105304 | 密码中没有包含特殊字符
IVS_SMU_IS_TOTAL_GROUP_INVALID | 119105305 | IS_TOTAL_GROUP标记不合法
IVS_SMU_GENERATE_PWD_ERROR | 119105306 | 生成密码失败
IVS_SMU_NEW_OLD_PWD_DIFF_NUM_INVALID | 119105307 | 新旧密码不同字符数目不合法
IVS_SMU_USER_PWD_RESET_ERROR | 119105308 | 重置密码错误
IVS_SMU_PWD_REVERSE_ERROR | 119105313 | 密码反转失败
IVS_SMU_PWD_LOGNINAME_REVERSE_SAME | 119105314 | 密码与登录名反转相同
IVS_SMU_PWD_LOGNINAME_SAME | 119105315 | 密码与登录名相同
IVS_SMU_OLD_PWD_DIFFERENT | 119105316 | 旧密码与真实密码不一致
IVS_SMU_DECRYPT_PWD_ERROR | 119105317 | 用户密码解密失败
IVS_SMU_ENCRYPT_PWD_ERROR | 119105318 | 用户密码加密失败
IVS_SMU_DOMAIN_USER_MODIFY_PWD_ERROR | 119105319 | 域用户不可修改密码
IVS_SMU_USER_MODIFY_LOGINNAME_INVALID | 119105322 | 用户登录名不能修改
IVS_SMU_USER_MODIFY_DOMAINNAME_INVALID | 119105323 | 用户域名不能修改
IVS_SMU_USER_ID_TOO_LONG | 119105333 | ID长度不合法
IVS_SMU_GROUP_ID_NOT_NUMBER | 119105334 | 组ID不是有效数字
IVS_SMU_GROUP_ID_TOO_LONG | 119105335 | 组ID太长
IVS_SMU_USER_ROLE_ID_NOT_NUMBER | 119105336 | 角色ID不是有效数字
IVS_SMU_ROLE_ID_TOO_LONG | 119105337 | 角色ID太长
IVS_SMU_DELETE_USER_SUBINFO_ERROR | 119105345 | 删除订阅信息错误
IVS_SMU_INQUIRY_USER_GROUP_LIST_ERROR | 119105346 | 获取用户组列表失败
IVS_SMU_NO_LANGUAGE_EXIST | 119105347 | 系统不支持该语言
IVS_SMU_STATEMENT_FILE_FSEEK_ERROR | 119105348 | 声明文件fseek操作失败
IVS_SMU_RESET_SELF_INVALID | 119105349 | 重置自身密码不允许
IVS_SMU_ROLE_BEYOND_LIMITED | 119105350 | 权限不足
IVS_SMU_DB_HAD_SAME_ALARM_LEVEL | 119120000 | 数据库中已经存在相同的告警级别了
IVS_SMU_DB_MAX_ALARM_LEVEL_NUM | 119120001 | 数据库中告警级别的个数已经达到最大值
IVS_SMU_DB_ALARM_NO_DATA | 119120002 | 在数据库中没有查到匹配查询条件的数据
IVS_SMU_DB_HAD_SAME_ALARM_HELP | 119120003 | 数据库中已经存在相同的告警帮助了
IVS_SMU_ALARM_DB_NO_AREA | 119120004 | 数据库中不存在指定的防区
IVS_SMU_ALARM_AREA_HAS_GUARD_PLAN | 119120005 | 指定的防区已经有防区计划了
IVS_SMU_ALARM_DB_NO_ALARM_LEVEL | 119120006 | 数据库中不存在指定的告警级别
IVS_SMU_ALARM_SUB_ALARM_TYPE_ERROR | 119120007 | 按告警类型订阅，告警类型不可为空
IVS_SMU_ALARM_SUB_ALARM_LEVEL_ERROR | 119120008 | 按告警级别订阅，告警级别大小错误
IVS_SMU_ALARM_SUB_OVER_MAX | 119120009 | 告警订阅请求数，超过1000
IVS_SMU_ALARM_DB_NO_ALARM_TYPE | 119120010 | 在数据库中没有指定的告警类型
IVS_SMU_ALARM_CONFIRMED | 119120011 | 告警已确认
IVS_SMU_ALARM_REVOKED | 119120012 | 告警已撤销
IVS_SMU_ALARM_RECOVERY | 119120013 | 告警已恢复
IVS_SMU_MSGBLOCK_INVALID | 119120014 | 请求CMD不合法
IVS_SMU_DEV_CODE_NOT_FOUND | 119120015 | 设备已删除或不存在
IVS_SMU_ALARM_EVENT_ID_NOT_EXIST | 119120016 | 告警事件id不存在
IVS_SMU_DB_HAD_SAME_ALARM_TYPE | 119120017 | 数据库中已经存在相同的告警类型了
IVS_SMU_DB_HAD_SAME_ALARM_TYPE_NAME | 119120018 | 数据库中已经存在相同的告警类型名称了
IVS_SMU_ALL_USERS_OF_ALARM_COMMISSION_ILLEGAL | 119120019 | 告警授权用户全部不合法
IVS_SMU_ALARM_AREA_NOTEXIST | 119120020 | 设备不存在
IVS_SMU_ALARM_AREA_GUARD_OVER_MAX | 119120021 | 防区超过了最大数(1000)
IVS_SMU_ALARM_AREA_GUARD_DEV_OVER_MAX | 119120022 | 防区设备超过了最大数(128)
IVS_SMU_ALARM_AREA_NAME_GUARD_EXIST | 119120023 | 防区名称已经存在
IVS_SMU_ALARM_SUB_STYLE_OVER_MAX | 119120024 | 告警订阅类型超过了最大数(5000)
IVS_SMU_ALARM_INFO_NOT_FOUND | 119120025 | 未查找到告警信息
IVS_SMU_LINKAGE_ACTION_NOT_EXIST | 119120026 | 联动动作不存在
IVS_SMU_AREA_ID_NOT_EXIST | 119120027 | 提示该防区已被删除
IVS_SMU_AREA_NO_DEV | 119120028 | 指定防区里没有设备
IVS_SMU_PART_USERS_OF_ALARM_COMMISSION_ILLEGAL | 119120029 | 告警授权用户部分不合法
IVS_SMU_ALARM_AREA_DEVICE_INVALID | 119120030 | 防区中不能添加外域设备
IVS_SMU_CAMERA_CODE_NOT_EXIST | 119125001 | 摄像机编码不存在
IVS_SMU_LINKID_NOT_EXIST | 119125002 | TCP连接不存在
IVS_SMU_RECORD_TIMEOUT | 119125003 | 录像模块超时
IVS_SMU_RECORD_LABEL_TIMEOUT | 119125004 | 录像书签超时
IVS_SMU_RECORD_LOCK_TIMEOUT | 119125005 | 录像锁定模块超时
IVS_SMU_MEDIA_SAFE_TIMEOUT | 119125006 | 媒体安全超时
IVS_SMU_BACK_RECORD_PLAN_TIMEOUT | 119125007 | 备份录像计划超时
IVS_SMU_GET_CLUSTER_RECORD_PLAN_FAIL | 119125008 | 集群下查询录像计划失败
IVS_SMU_GET_RECORD_TASK_FAIL | 119125009 | 查询录像任务失败
IVS_SMU_GET_CLUSTER_RECORD_POLICY_FAIL | 119125010 | 集群下查询录像策略失败
IVS_SMU_GET_CLUSTER_RECORD_STATE_FAIL | 119125011 | 集群下查询平台录像状态失败
IVS_SMU_CLUSTER_START_RECORD_FAIL | 119125012 | 集群下手动启动录像失败
IVS_SMU_CLUSTER_STOP_RECORD_FAIL | 119125013 | 集群下手动停止录像失败
IVS_SMU_GET_BACK_MBU_TIMEOUT | 119125014 | 查询备份服务器信息超时
IVS_SMU_GET_PRERECORD_CAMERA_LIST_TIMEOUT | 119125015 | 查询开启预录的摄像机列表超时
IVS_SMU_GET_PRERECORD_CAMERA_LIST_FAIL | 119125016 | 查询开启预录的摄像机列表全部失败
IVS_SMU_GET_CAMERA_BACKUP_CFG_FAIL | 119125017 | 集群下查询摄像机备份参数失败
IVS_SMU_BACKUP_SETTING_TIMEOUT | 119125018 | 备份录像参数超时
IVS_SMU_GET_BACKUP_PLAN_FAIL | 119125019 | 集群下查询备份录像计划失败
IVS_SMU_GET_MBU_CHANGE_HISTORY_FAIL | 119125020 | 集群下查询备份服务器变更记录失败
IVS_SMU_TRANSPARENT_NOT_RUN | 119125021 | 透明通道没有启用
IVS_SMU_GET_PRERECORD_CAMERA_LIST_PART_FAIL | 119125022 | 查询开启预录的摄像机列表部分失败
IVS_SMU_GET_RECORD_TASK_PART_FAIL | 119125023 | 查询录像任务失败
IVS_SMU_GET_RECORD_LIST_FAIL | 119125024 | 查询录像列表失败
IVS_SMU_FROM_TO_TIME_ERROR | 119125030 | 开始结束时间错误
IVS_SMU_TIME_FORMAT_ERROR | 119125031 | 时间格式错误
IVS_SMU_NVR_LIST_EMPTY | 119126000 | NVR列表为空
IVS_SMU_NVR_SERVER_CNT_IS_ZERO | 119126001 | serverNVR个数为0
IVS_SMU_NOT_FOUND_LEADER | 119126002 | 没找到Leader
IVS_SMU_GET_MEMBER_STATUS_TIME_OUT | 119126003 | 获取成员状态超时
IVS_SMU_BE_IN_CREATE_CLUSTER | 119126004 | 正在组建集群
IVS_SMU_BE_IN_DISSOLVE_CLUSTER | 119126005 | 正在解散集群
IVS_SMU_CLUSTER_SYNCING | 119126006 | 正在集群同步，不允许集群操作
IVS_SMU_CLEAR_BLACK_LIST_IS_NULL | 119126007 | ClearBlackList结点为空
IVS_SMU_CREATE_CLUSTER_TIME_OUT | 119126008 | 组建集群超时
IVS_SMU_NVR_LIST_NODE_NOT_EXIST | 119126009 | NvrList结点不存在
IVS_SMU_NVR_INFO_NODE_NOT_EXIST | 119126010 | NvrInfo结点不存在
IVS_SMU_NVR_CODE_OR_IP_INVALID | 119126011 | NvrCode或IP结点不合法
IVS_SMU_NVR_ROLE_INVALID | 119126012 | Nvr角色结点不合法
IVS_SMU_NVR_INFO_CONTENT_INVALID | 119126013 | NvrInfo结点内容不合法
IVS_SMU_NODE_MAP_IS_EMPTY | 119126014 | NVR列表为空
IVS_SMU_FIND_NVR_TRANS_ID_NULL | 119126015 | 查询NVR时事务ID为空
IVS_SMU_FIND_NVR_CAMERA_LIST_EMPTY | 119126016 | 查询NVR时摄像机列表为空
IVS_SMU_CLUSTER_OFFLINE | 119126017 | 集群不在线
IVS_SMU_CLUSTER_ROLE_NOT_CLIENT | 119126018 | 角色不为Client
IVS_SMU_CLUSTER_SIZE_IS_MIN | 119126019 | 集群个数已经是最小
IVS_SMU_NVR_CODE_NOT_EXIST | 119126020 | 该NVR不存在
IVS_SMU_SEND_CLUSTER_FAIL | 119126021 | 下发集群失败
IVS_SMU_CLUSTER_CODE_HAS_EXIST | 119126022 | 该集群编码已经存在
IVS_SMU_NVR_NOT_CLEAR | 119126023 | 该NVR未清理干净
IVS_SMU_CLUSTER_NOT_EXIST | 119126024 | 该集群不存在
IVS_SMU_BE_IN_ADD_CLIENT | 119126025 | 正在添加client
IVS_SMU_BE_IN_DEL_CLIENT | 119126026 | 正在删除client
IVS_SMU_CLUSTER_SCHEDULING | 119126027 | 集群正在调度或者删除成员，请稍后再试
IVS_SMU_CLUSTER_CG_DEV_EXIST | 119126028 | 浮动网关上存在接入设备
IVS_SMU_CLUSTER_CG_DEV_BEYOND_LIMITED | 119126029 | 浮动网关上的设备超出接入能力
IVS_SMU_GET_CONFIG_PATH_ERROR | 119127000 | 获取配置路径失败
IVS_SMU_LOAD_NET_XML_ERROR | 119127001 | 加载net.xml失败
IVS_SMU_NET_ELEMENTS_NODE_NOT_EXIST | 119127002 | NetElement结点不存在
IVS_SMU_SAVE_NET_XML_ERROR | 119127003 | 保存net.xml失败
IVS_SMU_LOCAL_IP_IS_NULL | 119127004 | 本机信令IP为空
IVS_SMU_MEDIA_IP_IS_NULL | 119127005 | 本机媒体IP为空
IVS_SMU_DOMAIN_IS_NOT_ONLIE | 119127006 | 域不在线
IVS_SMU_SET_LOG_LEVEL_ERROR | 119130000 | 设置日志级别失败
IVS_SMU_NO_PCG_NODE_ERROR | 119139000 | 无PCG连接信息
IVS_SMU_LICENSE_FILE_NOEXIST | 119132001 | license文件不存在
IVS_SMU_LICENSE_ACCESS_LIMITED | 119132002 | License接入入数受限
IVS_SMU_LICENSE_ESN_MISMATCH | 119132003 | License导入ESN不匹配
IVS_SMU_LICENSE_ACTIVATION_FAIL | 119132004 | License激活失败
IVS_SMU_DEV_NOT_EXIST_OR_LICENSE_ACCESS_LIMITED | 119132005 | 设备不存在或者License受限
IVS_SMU_DEVICE_NUM_LIMITED | 119132006 | 设备接入数受限
IVS_SMU_DEVICE_NUM_MAY_LIMITED | 119132007 | 其他用户正在添加设备，可能超过最大接入能力，请稍后
IVS_SMU_SNAPSHOT_ID_NOT_EXIST | 119135001 | 抓拍图片ID不存在
IVS_SMU_IMG_STATIC_RIGHT_NOT_ENOUTH | 119135109 | 用户订阅实时图片统计权限不足
IVS_SMU_CANNOT_UNSUB_IMG_STAT_BEFORE_SUB | 119135110 | 未订阅图片流量统计不可退订
IVS_SMU_EXCEED_MAX_IMG_STAT_SUBSCRIPTIONS | 119135111 | 超过实时图片流量统计最大订阅数
IVS_SMU_HISTORY_IMAGE_FROM_TO_TIME_ERROR | 119135112 | 查询历史失败图片详细信息列表起始时间过长
IVS_SMU_EXCEED_MAX_FAIL_IMG_NUM | 119135113 | 查询相机历史失败图片返回数目超过最大值
IVS_SCU_LINKAGE_DEV_SIZE_ILLEGAL | 129123002 | 联动设备的个数非法(不能超过4个)
IVS_SCU_LINKAGE_POLICY_ID_NOT_EXIST | 129123003 | 联动策略ID不存在
IVS_SCU_LINKAGE_POLICY_ID_EXIST | 129123004 | 联动策略ID已经存在
IVS_SCU_LINKAGE_POLICY_EXIST | 129123005 | 联动策略已经存在
IVS_SCU_LINKAGE_POLICY_COUNT_OVER | 129123006 | 告警联动策略超过了最大数(3000)
IVS_SCU_LINKAGE_ACTION_ILLEGAL | 129123007 | 告警联动动作不能重复
IVS_SCU_SEND_ALARM_CONFIRM_SMU_FAIL | 129123008 | 发送告警确认请求到SMU失败
IVS_SCU_LINKAGE_DEV_COUNT_ERROR | 129123010 | 联动设备个数超过上限
IVS_SCU_LINKAGE_DEV_NOT_EXIST | 129123011 | 联动目标设备不存在或者已删除
IVS_SCU_LINKAGE_ACTION_NOT_EXIST | 129123012 | 联动动作不存在
IVS_SCU_ONLINE_USER_EXPIRE | 129105001 | 登录信息已失效，请重新登录
IVS_SCU_DEV_OFFLINE | 129108001 | 设备不在线
IVS_SCU_DEV_NOT_EXIST | 129108002 | 设备不存在或者已删除
IVS_SCU_DEV_NOT_EXIST_CLUSTER | 129108003 | (集群使用)设备不存在当前NVR，可能已迁移
IVS_SCU_DEV_MODULE_ERROR | 129108004 | 模板校验失败
IVS_SCU_DEV_PROTOCALTYPE_ERROR | 129108005 | 设备协议类型校验失败
IVS_SCU_DEV_VENDORTYPE_ERROR | 129108006 | 供应商类型校验失败
IVS_SCU_DEV_FORMTYPE_ERROR | 129108007 | 产品形态类型校验失败
IVS_SCU_DEV_MODELTYPE_ERROR | 129108008 | 设备型号类型校验失败
IVS_SCU_DEV_ALARMENABLE_ERROR | 129108009 | 告警使能校验失败
IVS_SCU_DEV_VIDEOFORMAT_ERROR | 129108010 | 视频制式校验失败
IVS_SCU_DEV_REGPASSWORD_ERROR | 129108011 | 注册密码为空
IVS_SCU_DEV_MAXDIRCONNECTNUM_ERROR | 129108012 | 最大直连数失败
IVS_SCU_DEV_NVRCODE_ERROR | 129108013 | NVR为不合法
IVS_SCU_DCG_RESPONSE_FAIL | 129108018 | DCG响应失败
IVS_SCU_MAIN_DEV_GURAD_SET_FAIL | 129108021 | 主设备布撤防失败
IVS_SCU_DEV_NOT_IN_WHITE_LIST_CLUSTER | 129108022 | 设备不属于当前NVR，可能已移除,集群使用
IVS_SCU_DEV_NOT_IN_WHITE_LIST | 129108023 | 设备不属于当前NVR，可能已移除,非集群使用
IVS_SCU_VIDEO_STREAM_NUM_ERROR | 129108024 | 视频流数不正确
IVS_SCU_SENDTODCG_FAIL | 129108026 | 下发DCG失败
IVS_SCU_ADD_AUDIO_PARA_FAIL | 129108027 | 增加音频参数失败
IVS_SCU_GET_LOGIN_ID_FAIL | 129108029 | 获取用户ID失败
IVS_SCU_DEV_TEMPLATE_NONEXISTENT | 129108031 | 设备模板不存在
IVS_SCU_DEV_IS_ONLINE | 129108032 | 设备已在线
IVS_SCU_SUB_DEV_INFO_NOT_EXIST | 129108033 | 子设备参数信息不存在
IVS_SCU_ADD_SUBDEVICE_FAIL | 129108035 | 添加子设备失败失败
IVS_SCU_SEND_MSG_TO_SMU_FAIL | 129108036 | 发送smu响应失败
IVS_SCU_ADD_ENVR_SUBDEVICE_FAIL | 129108037 | 添加ENVR设备失败
IVS_SCU_ENVR_DEV_NOT_EXIST | 129108038 | eNVR设备不存在或者已删除
IVS_SCU_MAIN_DEV_NOT_EXIST | 129108039 | 主设备不存在或者已删除
IVS_SCU_DEV_OFFLINE_CFG_NOT_EXIST | 129108040 | 设备离线配置不存在
IVS_SCU_DEV_TYPE_IS_NULL | 129108041 | 设备设备形态不合法
IVS_SCU_DEV_OSD_PARA_NOT_EXIST | 129108042 | 设备OSD参数不存在
IVS_SCU_DEL_ENVR_DEVICE_FAIL | 129108043 | 删除ENVR设备失败
IVS_SCU_SEL_SHARE_DEVICE_INVALID | 129108044 | 查询共享设备参数不合法
IVS_SCU_MODEL_TEMPLATE_IS_NULL | 129108045 | 设备模板数量为空
IVS_SCU_DR_MAIN_DEV_NOT_EXIST | 129108046 | 容灾设备信息不存在
IVS_SCU_DEV_UPDATE_TEMPATE_MAIN_DEV | 129108047 | 设备模板更新主设备信息失败
IVS_SCU_PRE_RECORD_DEV_NOT_EXIST | 129108048 | 开启预录设备不存在
IVS_SCU_PU_NOT_SUPPORT_GET_PARAM | 129108049 | 前端不支持前端参数获取
IVS_SCU_MOD_ENVR_SUBDEVICE_FAIL | 129108050 | 修改ENVR设备失败
IVS_SCU_MOD_T28181_LENGTH_INVALID | 129108051 | T28181长度不合法
IVS_SCU_LOGIN_TYPE_INVALID | 129108053 | 认证类型不合法
IVS_SCU_BLANCE_SUPPORT_INVALID | 129108054 | 是否支持集群参数不合法
IVS_SCU_DIRECTCONNECT_FIRST_INVALID | 129108055 | 是否支持直连优先参数不合法
IVS_SCU_DECRYPT_PASSWORD_INVALID | 129108056 | smu发送密码加密失败
IVS_SCU_DECRYPT_REGPASSWORD_INVALID | 129108057 | smu发送注册密码加密失败
IVS_SCU_PASSWORD_LENGTH_INVALID | 129108058 | 密码长度或者复杂度不满足要求
IVS_SCU_PARSE_CAMERA_TYPE_FAILED | 129108060 | 摄像机类型转换失败
IVS_SCU_MAIN_DEV_SEQUENCE_TYPE_INVALID | 129108061 | 主设备序列号不合法
IVS_SCU_TAS_CODE_INVALID | 129108062 | TASCode不合法
IVS_SCU_DEV_SN_INVALID | 129108063 | DevSN不合法
IVS_SCU_DEV_REG_PASSWORD_INVALID | 129108064 | 注册密码不合法
IVS_SCU_DEV_IP_TYPE_INVALID | 129108065 | 设备Ip类型不合法
IVS_SCU_GET_DEV_LIST_FAILED | 129108066 | 获取主设备列表失败
IVS_SCU_PATCH_PARSE_MAIN_DEV_FAILED | 129108067 | 批量解析主设备全部失败
IVS_SCU_PWD_STRENGTH_WEAK | 129108068 | 密码强度不够
IVS_SCU_DEVICE_IP_EXIST | 129108069 | 设备IP已存在
IVS_SCU_DEV_REG_PWD_INVALID | 129108070 | 密码复杂度不满足要求，如需关闭密码复杂度校验，请查看配置指南
IVS_SCU_SET_LOG_LEVEL_RSP_FAIL | 129108071 | 因服务器时间比本地时间快导致各模块日志级别设置失败
IVS_SCU_CAMERA_NOT_EXIST | 129109003 | 摄像机子设备不存在或者已删除
IVS_SCU_MOTION_DETECTION_NOT_EXIST | 129109004 | 移动侦测信息不存在
IVS_SCU_VIDEO_HIDE_NOT_EXIST | 129109005 | 图像遮挡信息不存在
IVS_SCU_VIDEO_MASK_NOT_EXIST | 129109006 | 隐私保护信息不存在
IVS_SCU_CONF_PTZ_DB_ERROR | 129109007 | 配置云台参数成功但数据保存到数据库失败
IVS_SCU_BROADCAST_IP_PORT_EXIST | 129109008 | 组播IP端口已存在或已被占用
IVS_SCU_CONF_VOICE_CHAN_TIMEOUT | 129112001 | 配置语音参数超时
IVS_SCU_CONF_VOICE_CHAN_DB_ERROR | 129112002 | 配置语音参数成功但数据保存到数据库失败
IVS_SCU_GETURL_ERROR | 129115001 | 获取媒体URL失败
IVS_SCU_GETURL_TIMEOUT | 129115002 | 获取媒体URL会话超时
IVS_SCU_GETURL_SESSION_EXIST | 129115003 | 获取媒体URL的请求已存在
IVS_SCU_PTZ_LOCKED | 129116001 | 云台已锁定
IVS_SCU_PTZ_CONTROLED | 129116002 | 云台被同优先级或者高优先级用户控制
IVS_SCU_PRESET_NOT_EXIST | 129117004 | 预置位不存在
IVS_SCU_EXDEV_NUM_EXCEED | 129128003 | 外部告警设备数达到最大值
IVS_SCU_EXDEV_CODE_GEN_FAIL | 129128004 | 外部告警设备编码生成失败
IVS_SCU_EXSYS_TYPE_INVALID | 129128005 | 系统类型长度非法或包含非法字符
IVS_SCU_EXDEV_TYPE_INVALID | 129128006 | 设备类型长度非法或包含非法字符
IVS_SCU_EXDEV_TYPE_ERROR | 129128007 | 设备类型非法
IVS_SCU_WATERMARK_SECURITY_FAIL | 129147000 | DCG通知PU添加水印失败、MU切换媒体安全策略失败
IVS_SCU_WATERMARK_FAIL | 129147001 | DCG通知PU添加水印失败
IVS_SCU_SECURITY_FAIL | 129147002 | MU切换媒体安全策略失败
IVS_CMU_FIND_LEADER_ERROR | 149107001 | 查找Leader失败
IVS_CMU_ZNODE_NOT_EXIST | 149107002 | 集群节点不存在
IVS_CMU_PARAMETER_ERROR | 149112016 | 参数错误
IVS_CMU_SCHEDULE_GET_IPC_LIST_ERROR | 149112017 | 调度时获取IPC列表失败
IVS_CMU_SCHEDULE_LENS_MANAGE_ERROR | 149112018 | 调度镜头动作失败
IVS_CMU_SCHEDULE_SET_IPC_NVR_ERROR | 149112019 | 调度成功，设置IPC和NVR绑定关系失败
IVS_CMU_SCHEDULE_SET_IPC_TRACK_ERROR | 149112020 | 调度成功，设置IPC历史轨迹失败
IVS_CMU_SCHEDULE_ARITHMETIC_ERROR | 149112021 | 调度算法失败
IVS_CMU_SEND_SYNC_MSG_PART_ERROR | 149112022 | 发送同步消息失败
IVS_CMU_GET_NON_NVR_STUATUS_ERROR | 149112023 | 未查找到任何NVR的状态
IVS_CMU_SET_CLUSTER_MEMBER_ERROR | 149112024 | 设置集群成员失败
IVS_CMU_SET_RIGHT_ERROR | 149112025 | 集群设置操作无权限（用于向非Leader成员发送集群设置消息返回错误）
IVS_CMU_SET_CLUSTER_INFO_ERROR | 149112026 | 设置集群信息失败
IVS_CMU_GET_USABLE_NVR_INFO_ERROR | 149112027 | 可用NVR列表为空
IVS_CMU_SEND_CLEAN_MSG_ERROR | 149112028 | 发送摄像机历史轨迹消息失败
IVS_CMU_GET_DFS_LOCK_ERROR | 149112029 | 获取分布式文件锁失败
IVS_CMU_GET_DFS_LOCK_TIMEOUT_ERROR | 149112030 | 获取分布式文件锁超时失败
IVS_CMU_PLUGIN_NOT_FOUND_ERROR | 149112031 | 找不到对应的插件
IVS_CMU_NO_AVAILABLE_CONTAINER_ERROR | 149112032 | 调度时没有可用容器
IVS_CMU_DISCONNECT_WITH_ZK_ERROR | 149112033 | 与ZK断开连接
IVS_CMU_TASK_SHIFT_IN_ERROR | 149112034 | 任务迁入失败（框架中）
IVS_CMU_ADD_MAIN_DEV_OUT_OF_CONTENT | 149113001 | 超出集群负载能力部分，设备添加失败
IVS_CMU_ADD_MAIN_DEV_WRITE_ZK_ERROR | 149113002 | 保存数据出错，设备添加失败
IVS_CMU_ADD_MAIN_DEV_SCHEDULE_ERROR | 149113003 | 调度设备出错，设备添加失败
IVS_CMU_ADD_MAIN_DEV_READ_ZK_ERROR | 149113004 | 读取数据出错，设备添加失败
IVS_CMU_ADD_MAIN_DEV_DUPLICATE | 149113005 | 设备已存在，设备添加失败
IVS_CMU_ADD_DEV_ERROR | 149113006 | 添加设备失败
IVS_CMU_ADD_DEVS_ALL_ERROR | 149113007 | 添加所有设备失败
IVS_CMU_DEVICE_IP_EXIST | 149113008 | 设备IP已存在，添加失败
IVS_CMU_DEVICE_IP_DUPLICATE | 149113009 | 重复添加IP相同的设备
IVS_CMU_DEVICE_CODE_DUPLICATE | 149113010 | 重复添加相同编码的设备，请确认需要添加的设备
IVS_CMU_IPC_CODE_NOT_FOUND_ERROR | 149114001 | 摄像机已删除或不存在
IVS_CMU_GET_NVR_ID_ERROR | 149114002 | 读取数据出错，定位摄像机失败
IVS_CMU_GET_NVR_DATA_ERROR | 149114003 | 读取数据出错，定位摄像机失败
IVS_CMU_CONFIG_TYPE_NOT_FOUND_ERROR | 149115001 | 配置项类型不存在
IVS_CMU_CONFIG_NAME_NOT_FOUND_ERROR | 149115002 | 配置项名称不存在
IVS_CMU_CONFIG_VALUE_INVALID_ERROR | 149115003 | 配置项参数无效
IVS_CMU_READ_LOG_SFTP_CONF_ERROR | 149115004 | 获取日志参数项失败
IVS_CMU_WRITE_LOG_SFTP_CONF_ERROR | 149115005 | 修改日志参数项失败
IVS_CMU_CAMERA_CODE_NOT_FOUND_ERROR | 149116001 | 摄像机已删除或不存在
IVS_CMU_GET_CAMERA_TRACE_ERROR | 149116002 | 获取摄像机轨迹信息失败
IVS_CMU_LINKAGE_ACTION_ILLEGAL | 149120001 | 告警联动动作不能重复
IVS_CMU_LINKAGE_POLICY_ID_EXIST | 149120002 | 联动策略ID已经存在
IVS_CMU_LINKAGE_POLICY_EXIST | 149120003 | 联动策略已经存在
IVS_CMU_PTR_NULL_ERROR | 149131001 | 入参指针为空
IVS_CMU_OBJ_TO_XML_ERROR | 149131002 | 消息类转换xml失败
IVS_CMU_XML_TO_OBJ_ERROR | 149131003 | xml转换消息类失败
IVS_CMU_CAN_NOT_FIND_LINKID_ERROR | 149131004 | 找不到LinkID
IVS_CMU_NETELEMENT_TYPE_NULL_ERROR | 149131005 | 网元类型为空
IVS_CMU_NSS_ENCODE_ERROR | 149131006 | NSS消息编码失败
IVS_CMU_NSS_DECODE_ERROR | 149131007 | NSS消息解码失败
IVS_CMU_SEND_SYNC_MSG_ERROR | 149131008 | 发送同步消息失败
IVS_CMU_SEND_MSG_ERROR | 149131009 | 发送异步消息失败
IVS_CMU_XML_PARSE_STREAM_ERROR | 149131010 | XMLParse流失败
IVS_CMU_DELETE_NET_LINK_ERROR | 149131011 | 删除网元link失败
IVS_CMU_CREATE_LINK_ERROR | 149131012 | 动态创建网元连接失败
IVS_CMU_DELETE_TRANSID_ERROR | 149131013 | 发送给自己的消息删除TransID失败
IVS_CMU_SET_SCHEDUE_MODE_FAIL | 149131014 | 禁制调度失败消息返回码
IVS_CMU_CREATE_SESSION_ERROR | 149131015 | 创建会话失败
IVS_CMU_REMOVE_WAIT_IMPORT_DATA_FLAG_ERROR | 149131016 | 删除待导回标志文件失败;
IVS_CMU_IMPORT_NVR_DATA_ERROR | 149131018 | 保留数据组建集群失败
IVS_CMU_NOT_LEADER_ERROR | 149131019 | 当Leader的业务发送给非leader节点的时候
IVS_CMU_FCG_CODE_EXIST | 149132000 | 浮动网关编码已存在
IVS_CMU_FCG_IP_EXIST | 149132001 | 浮动网关IP已存在
IVS_CMU_NODE_HAS_BEEN_CG | 149132002 | 集群成员已经被设置成浮动网关
IVS_CMU_FCG_EXCEED_MAX | 149132003 | 浮动网关的数量已经达到最大值
IVS_CMU_CG_NODE_NOT_EXIST | 149132004 | 节点不存在
IVS_OMU_FILE_NOT_FOUND | 159100000 | OMU文件找不到
IVS_OMU_PIPE_CREATION_FAILED | 159100001 | OMU管道创建失败
IVS_OMU_FORK_ERROR | 159100002 | OMU创建子进程失败
IVS_OMU_FILE_RENAME_ERROR | 159100003 | 文件重命名失败
IVS_OMU_FILE_EXIST_ERROR | 159100016 | 上传文件已存在
IVS_OMU_ROUTE_MSG_ERROR | 159100006 | 消息路由失败;
IVS_OMU_SESSION_TIME_OUT | 159100008 | session超时;
IVS_OMU_NODE_OFFLINE | 159101001 | 节点离线;
IVS_OMU_MODULE_CFG_NOT_FOUND | 159101005 | OMU模块配置不存在
IVS_OMU_MODULE_CMD_NOT_FOUND | 159101006 | OMU模块指令不存在
IVS_OMU_MODULE_OPER_LIST_NOT_FOUND | 159101007 | OMU元操作符为空
IVS_OMU_NOT_DOWN_DOMAIN | 159101008 | 当前域包含子域，无法组建集群;
IVS_OMU_HAS_NO_LICENSE | 159101009 | 无授权许可，不可组建集群
IVS_OMU_NOT_SINGLE_MODE | 159101010 | 不是单机模式，无法切换
IVS_OMU_MSG_TRACE_REPORT_FAIL | 159147001 | 添加消息跟踪结果到上报队列失败;
IVS_OMU_REGISTER_PWD_INVALID | 159103001 | OMU注册密码错误
IVS_OMU_RE_REGISTER_INVALID | 159103002 | 不允许自己向自己注册
IVS_OMU_REGISTER_LOOP_ERR | 159103003 | 注册存在回路，不允许注册
IVS_OMU_REGISTER_RULE_ERR | 159103004 | 注册不符合规则
IVS_OMU_MAX_MPU_COUNT_ERR | 159103006 | MPU达到最大上限
IVS_OMU_MAX_VMU_COUNT_ERR | 159103007 | VMU达到最大上限
IVS_OMU_MAX_PAS_COUNT_ERR | 159103008 | PAS达到最大上限
IVS_OMU_NO_ACCEPT_NEW_NODE | 159103009 | 不允许新设备注册
IVS_OMU_CLUSTER_NOT_ALLOW_SUB_DOMAIN | 159103010 | 集群下不允许对接子域
IVS_OMU_REPORT_PWD_ERR | 159103011 | 报表查询密码错误
IVS_OMU_CLUSTER_SERVER_MUMBER_ERR | 159103012 | 组建集群server数量不足
IVS_OMU_CLUSTER_MUMBER_ERR | 159103013 | 组建集群的NVR数量错误
IVS_OMU_CLUSTER_SUBNODE_SUPPORT_ERR | 159103014 | 组建集群,域从版本不支持R2集群
IVS_OMU_PORTAL_RESP_SUCCESS | 159102001 | 登录成功
IVS_OMU_PORTAL_PASSWD_WRONG | 159102002 | 用户名或密码输错
IVS_OMU_PORTAL_RESP_DB_ERROR | 159102003 | 数据库错误
IVS_OMU_PORTAL_RESP_XMLPRASE_ERROR | 159102004 | xml解析失败
IVS_OMU_PORTAL_USER_LOCKED | 159102005 | 用户锁定
IVS_OMU_PORTAL_RESP_SUCCESS_FIRST | 159102006 | 初始登录成功
IVS_OMU_CAN_NOT_ADD_NVR_ERROR | 159102007 | 不能新增NVR
IVS_OMU_CAN_NOT_ADD_I_ERROR | 159102008 | 新增NVR不能是自己
IVS_OMU_CAN_NOT_READ_CFG_ERROR | 159102009 | 驱动包配置文件读取失败
IVS_OMU_PORTAL_PASS_TIMEOUT | 159102010 | 强制清除密码
IVS_OMU_VERSION_EXIST_ERR | 159104001 | 版本文件已存在错误
IVS_OMU_NO_DATA_ERR | 159101012 | 查询数据为空
IVS_OMU_DIST_MONT_ISRUNNING | 159128001 | 磁盘管理正在划分中
IVS_OMU_CHANGE_NODE_TYPE_ERR | 159129001 | 存在上级或下级OMU，不允许改变节点属性
IVS_OMU_PCG_OFF_LINE_ERR | 159130001 | PCG离线
IVS_OMU_MAUS_OFF_LINE_ERR | 159130002 | MAUS离线
IVS_OMU_HTTPS_OFF_LINE_ERR | 159130003 | HTTPS离线
IVS_OMU_IS_SUBDOMAIN_ERR | 159140001 | 是域从，不允许改变IP
IVS_OMU_IP_CONFIGING_ERR | 159140002 | IP地址修改中，不允许再次修改
IVS_OMU_FAULT_RUNNING | 159140003 | 故障收集正在运行
IVS_OMU_NOT_SUPPORT_CLUSTER | 159140004 | 不支持集群
IVS_OMU_QD_HAVE_LICENCE | 159140005 | QD有licence
IVS_OMU_QD_HAVE_NO_LICENCE | 159140006 | QD没有licence
IVS_OMU_FAIL_FOR_WITH_SLAVE | 159140007 | 有域从不允许切单机
IVS_OMU_WEAK_PASSWD | 159140008 | 弱口令
IVS_OMU_CLOSE_DOMAIN_IN_NTP | 159140009 | 先清除全网NTP
IVS_OMU_CLOSE_DOMAIN_BT_NTP | 159140010 | 设置NTP的时候，请先关闭全网NTP
IVS_OMU_STOP_MU_FIRST | 159140011 | 停止smartdata的时候先停止mu
IVS_OMU_RECORD_PLAN_PART_SUCCESS | 159140012 | 检查录像计划执行率，部分域从查询失败
IVS_OMU_IP_LOCKED | 159140013 | 错误次数太多，IP被锁定
IVS_OMU_CLUSTER_RESTORE_MGR_DATA_FAIL | 159140014 | 还原中心数据库失败
IVS_OMU_LICE_DISABLE_ALREADY | 159140015 | licence已经失效
IVS_OMU_NO_HALICE | 159140016 | 没有双击licence
IVS_MU_ERR_CODE_BEGIN | 169100001 | BSM错误码起始值
IVS_MU_EXIST_AUDIO | 169100044 | 音频通道已被使用
IVS_MU_RESTOR_XFS_FAILED | 169100045 | 恢复xfs文件系统失败
IVS_MU_KEY_FILE_OPERATER_FAILED | 169100046 | 关键文件操作失败
IVS_MU_ERROR_BLOCK_STATUS | 169100047 | 块状态错误.
IVS_MU_ERROR_INVALID_BLOCK | 169100048 | 无效块号
IVS_MU_DEVICE_STATUS_ERROR | 169100049 | 存储设备状态不正确
IVS_MU_NEED_REBOOT_SYSTEM | 169100050 | 需要重启服务器
IVS_MU_DEVICE_EXISTS | 169100051 | 设备已存在
IVS_MU_UNKNOWN_FILE_SYSTEM | 169100052 | 未知文件系统
IVS_MU_MOUNT_ERROR | 169100053 | bsm挂载盘失败
IVS_MU_INVALID_PARAMETER | 169100054 | 无效的输入参数
IVS_MU_SCAN_SLOT_FAILED | 169100055 | BSM扫描槽位出错
IVS_MU_RAID_FAILED | 169100056 | RAID模块未加载
IVS_MU_SLEEPWAKEUPFAILED | 169100057 | 休眠失败
IVS_MU_RAIDREBUILDING | 169100058 | raid重构中
IVS_MU_DB_DUP_ERROR | 169100059 | 数据库主键冲突
IVS_MU_STREAM_PACKET_LEN_FAIL | 169100060 | 视频数据帧长度无效
IVS_MU_INVALID_DISKNUM | 169100061 | 无效的盘号
IVS_MU_LOCK_OTHER_ERROR | 169100062 | 锁操作失败
IVS_MU_SAVE_INDEX_FAILED | 169100063 | 保存索引失败
IVS_MU_DISK_FAILED | 169100064 | 磁盘错误(整盘失效)
IVS_MU_NO_ENOUGH_RESERVESPACE | 169100065 | 没有足够的预留空间
IVS_MU_INDEX_OUTDATED | 169100066 | 已经循环覆盖的索引
IVS_MU_INDEX_UNFOUND | 169100067 | savesession查询索引失败
IVS_MU_DB_NO_DATA | 169100068 | 数据库中没有相关数据
IVS_MU_DB_EXCEPTION | 169100069 | 数据库操作异常
IVS_MU_INIT_DB_POLL_FAILED | 169100070 | 初始化数据连接池失败
IVS_MU_DELETE_DB_BLOCKINFO_ERROR | 169100071 | 删除数据中块信息失败
IVS_MU_OPERATING_RECLAIMED_IPC | 169100072 | 试图打开正在删除的摄像头
IVS_MU_LOCK_MULTI_LOCK | 169100073 | 试图多次锁定非递归锁
IVS_MU_LOCK_RECURSIVE_EXCEED | 169100074 | 线程递归锁已经到达最大递归数限制
IVS_MU_LOCK_NOT_INIT_OK | 169100075 | 线程互斥锁没有初始化
IVS_MU_TOO_LARGE_DATA_SIZE | 169100076 | 图片尺寸超过1M,超出BSM预留的1M
IVS_MU_INVALID_ID | 169100077 | 无效摄像头ID
IVS_MU_CREATE_FOLDER_FAILED | 169100078 | 创建文件夹失败
IVS_MU_WRONG_SESSION_TYPE | 169100079 | 所要求的操作和当前会话类型不匹配
IVS_MU_INVALID_SESSION_ID | 169100080 | 无效的会话ID
IVS_MU_INVALID_SESSION_TYPE | 169100081 | 无效的会话类型
IVS_MU_INVALID_POINTER | 169100082 | 无效指针
IVS_MU_NEW_FAILED | 169100083 | new操作失败
IVS_MU_NO_BLOCK | 169100084 | Spaces无法分配数据块
IVS_MU_NO_PHOTO_DATA | 169100085 | 没有相关图片数据
IVS_MU_INVALID_TIME | 169100086 | 无效时间
IVS_MU_PHOTO_RTTI_ERROR | 169100087 | 存储图片校验标志
IVS_MU_END_FLAG_ERROR | 169100088 | 存储空间尾标志错误
IVS_MU_START_FLAG_ERROR | 169100089 | 存储空间头标志错误
IVS_MU_INVALID_SIZE | 169100090 | 无效长度
IVS_MU_BUFFER_NOT_ENOUGH | 169100091 | 缓存空间不足
IVS_MU_UNKNOW_EXCEPTION | 169100092 | 未知异常
IVS_MU_ISTREAM_CREATE_FAILED | 169100093 | 输入流创建错误
IVS_MU_OSTREAM_CREATE_FAILED | 169100094 | 输出流创建错误
IVS_MU_SEEK_FAILED | 169100095 | 文件定位错误
IVS_MU_OPEN_FAILED | 169100096 | 打开存储文件错误
IVS_MU_READ_FAILED | 169100097 | 读磁盘错误
IVS_MU_WRITE_FAILED | 169100098 | 写磁盘错误
IVS_MU_ERR_CODE | 169100100 | BSM错误码起始值
IVS_MU_RECORD_SEARCH_INDEX_ERROR | 169100200 | 录像检索索引错误
IVS_MU_FROM_TO_TIME_ERROR | 169100201 | 录像检索开始结束时间错误
IVS_MU_TIME_FORMAT_ERROR | 169100202 | 录像检索时间格式错误
IVS_MU_RECORD_METHOD_ERROR | 169100203 | 录像检索方式错误
IVS_MU_CAMERA_CODE_ERROR | 169100204 | 录像检索摄像机编码错误
IVS_MU_RECORD_SEARCH_NSS_ERROR | 169100205 | 录像检索NSS消息错误
IVS_MU_REPORT_DISK_RATE_ERROR | 169100206 | 查询磁盘信息失败错误
IVS_MU_MBU_OVERLOAD | 169100300 | mbu已经过载
IVS_MU_NOTENOUGH_BANDWIDTH | 169100301 | 媒体服务器带宽不足
IVS_MU_NOTENOUGH_CPU_DILE | 169100302 | CPU资源不足90%
IVS_MU_VIRTUAL_IPC_SIZE_OVERLOAD | 169100303 | 虚拟IPC超出最大值
IVS_MU_DEVICE_DELETE | 169100304 | 设备被删除
IVS_DCG_SET_RECORD_ERROR | 189125001 | 设置录像计划错误
IVS_DCG_GET_RECORD_ERROR | 189125002 | 获取录像计划错误
IVS_DCG_SET_LAYER_CODE_ERROR | 189125003 | 分层编码设置错误
IVS_DCG_RECORD_PLAN_NOT_EXIST | 189125004 | 录像计划为空
IVS_DCG_CREATE_RECORD_STREAM_SMP_ERROR | 189125005 | 创建录像流对象错误
IVS_DCG_CONTROL_PTZ_ERROR | 189116001 | 云台控制错误
IVS_DCG_GET_PTZ_PARAM_ERROR | 189116002 | 获取云台参数错误
IVS_DCG_SET_PTZ_PARAM_ERROR | 189116003 | 设置云台参数错误
IVS_DCG_GET_PTZ_PROTOCOL_ERROR | 189116004 | 获取云台解码器协议错误
IVS_DCG_GET_CRUISE_TRACK_ERROR | 189116005 | 获取巡航轨迹参数错误
IVS_DCG_SET_CRUISE_TRACK_ERROR | 189116006 | 设置巡航轨迹参数错误
IVS_DCG_CLEAL_CRUISE_TRACK_ERROR | 189116007 | 清空巡航列表错误
IVS_DCG_TRACK_COMMAND_ERROR | 189116008 | 云台PTZ轨迹控制失败
IVS_DCG_CRUISE_NUMBER_ERROR | 189116009 | 设置的巡航轨迹序号超过设备支持范围
IVS_DCG_UNSUPPORT_PTZ_CMD | 189116010 | 不支持的云台控制命令
IVS_DCG_TRACK_INDEX_ERROR | 189116011 | 设置的PTZ录制轨迹序号超过设备支持范围
IVS_DCG_GET_ABS_POSITION_ERROR | 189116012 | 获取云台坐标参数
IVS_DCG_CUISE_NAME_TOO_LONG | 189116013 | 设置巡航轨迹名称超长
IVS_DCG_SET_PRESET_ERROR | 189117001 | 设置预置位参数错误
IVS_DCG_GET_PRESET_ERROR | 189117002 | 查询预置位参数错误
IVS_DCG_DEL_PRESET_ERROR | 189117003 | 删除预置位参数错误
IVS_DCG_SET_GUARD_ERROR | 189117004 | 设置看守位请求错误
IVS_DCG_GET_GUARD_ERROR | 189117005 | 查询看守位请求错误
IVS_DCG_CANNOT_OVERITE_HOME_POSITION | 189117006 | 当前位置可能为保留预置位，不能设置成看守位
IVS_DCG_CANNOT_SET_HOME_POS_WHILE_PTZ_MOVING | 189117007 | ptz正在转动,不能设置看守位
IVS_DCG_PRESET_NAME_TOO_LONG | 189117008 | 设置预置位名称超长
IVS_DCG_CREAT_PRESETTOUR_NOT_ENOUGH_SPACE | 189117009 | 巡航轨迹超过最大个数(TooManyPresetTours)
IVS_DCG_SET_ALARM_GUARD_ERROR | 189120001 | 设置告警布撤防错误
IVS_DCG_GET_ALARM_GUARD_ERROR | 189120002 | 获取镜头布撤防参数错误
IVS_DCG_MAIN_DEV_ALARM_GUARD_ERROR | 189120003 | 主设备告警布防错误
IVS_DCG_MAIN_DEV_ALARM_UNGUARD_ERROR | 189120004 | 主设备告警撤防错误
IVS_DCG_MAIN_DEV_SET_ALARM_CALLBACK_ERROR | 189120005 | 主设备设置告警回调错误
IVS_DCG_SET_VIDEO_MASK_ERROR | 189120006 | 设置隐私保护请求错误
IVS_DCG_GET_VIDEO_MASK_ERROR | 189120007 | 查询隐私保护请求错误
IVS_DCG_SET_MOTION_DETECTION_ERROR | 189120008 | 设置移动侦测请求错误
IVS_DCG_GET_MOTION_DETECTION_ERROR | 189120009 | 查询移动侦测请求错误
IVS_DCG_SET_MASK_PROTECT_ERROR | 189120010 | 设置视频遮盖请求错误
IVS_DCG_GET_MASK_PROTECT_ERROR | 189120011 | 查询视频遮盖请求错误
IVS_DCG_SET_IGT_COMMEM_PARA_ERROR | 189120012 | 设置智能分析公共参数错误
IVS_DCG_SET_IGT_TRIPWIRE_PARA_ERROR | 189120013 | 设置智能分析绊线规则参数错误
IVS_DCG_SET_IGT_INTRUSION_PARA_ERROR | 189120014 | 设置智能分析入侵检测参数错误
IVS_DCG_SET_IGT_HOVER_PARA_ERROR | 189120015 | 设置智能分析徘徊检测参数错误
IVS_DCG_SET_IGT_LEGACY_PARA_ERROR | 189120016 | 设置智能分析遗留检测参数错误
IVS_DCG_SET_IGT_REMOVE_PARA_ERROR | 189120017 | 设置智能分析移走检测参数错误
IVS_DCG_GET_IGT_COMMEM_PARA_ERROR | 189120018 | 获取智能分析公共参数错误
IVS_DCG_GET_IGT_TRIPWIRE_PARA_ERROR | 189120019 | 获取智能分析绊线规则参数错误
IVS_DCG_GET_IGT_INTRUSION_PARA_ERROR | 189120020 | 获取智能分析入侵检测参数错误
IVS_DCG_GET_IGT_HOVER_PARA_ERROR | 189120021 | 获取智能分析徘徊检测参数错误
IVS_DCG_GET_IGT_LEGACY_PARA_ERROR | 189120022 | 获取智能分析遗留检测参数错误
IVS_DCG_GET_IGT_REMOVE_PARA_ERROR | 189120023 | 获取智能分析移走检测参数错误
IVS_DCG_SET_ALARM_LINK_PARAM_ERROR | 189120024 | 设置告警联动策略参数错误
IVS_DCG_ALARM_LINK_CANT_FIND_CHANNEL | 189120025 | 摄像头编码找不到对应的通道
IVS_DCG_SET_ANALYTICS_ERROR | 189120026 | 设置智能分析错误
IVS_DCG_ANALYTICS_UNSUPPORT | 189120027 | 该设备智能分析不支持平台设置，请到WEB页面设置
IVS_DCG_FIND_MAIN_DEV_EXIST | 189108001 | 查找主设备已经存在
IVS_DCG_ADD_MAIN_DEV_ERROR | 189108002 | 添加主设备错误
IVS_DCG_LOAD_PLUGIN_ERROR | 189108003 | 加载设备插件错误
IVS_DCG_GET_DEV_PORT_ERROR | 189108004 | 获取设备端口错误
IVS_DCG_FIND_MAIN_DEV_ERROR | 189108005 | 查找主设备不存在
IVS_DCG_DEL_SUB_DEV_ERROR | 189108006 | 删除子设备错误
IVS_DCG_DEL_MAIN_DEV_ERROR | 189108007 | 删除主设备错误
IVS_DCG_REBOOT_MAIN_DEV_ERROR | 189108008 | 重启主设备错误
IVS_DCG_OPEN_DLL_ERROR | 189108009 | Open动态库错误
IVS_DCG_SYMBOL_DLL_ERROR | 189108010 | 动态库symbol错误
IVS_DCG_CREATE_SDK_DLL_ERROR | 189108011 | 动态库CreateSdk错误
IVS_DCG_SDK_INIT_ERROR | 189108012 | Sdk初始化错误
IVS_DCG_DEV_LOGIN_ERROR | 189108013 | 主设备登录错误
IVS_DCG_DEV_LOGIN_PASSWORD_ERROR | 189108014 | 主设备登录密码错误
IVS_DCG_DEV_GET_ABILITY_ERROR | 189108015 | 主设备获取设备能力错误
IVS_DCG_DEV_SDK_INIT_ERROR | 189108016 | 初始化设备SDK错误
IVS_DCG_CREATE_LENS_ERROR | 189108017 | 创建镜头失败
IVS_DCG_GET_TIME_PARAM_ERROR | 189108018 | 获取时间参数失败
IVS_DCG_SET_TIME_PARAM_ERROR | 189108019 | 设置时间参数失败
IVS_DCG_GET_NET_PARAM_ERROR | 189108020 | 获取网络参数失败
IVS_DCG_SET_NET_PARAM_ERROR | 189108021 | 设置网络参数失败
IVS_DCG_BIND_TRANSID_AND_SEARCHD_DEV_TASK_ERROR | 189108022 | 绑定事物ID与查找设备业务失败
IVS_DCG_UNBIND_TRANSID_AND_SEARCHD_DEV_TASK_ERROR | 189108023 | 解除事物ID与查找设备业务绑定失败
IVS_DCG_SEARCH_DEVICE_ERROR | 189108024 | 搜索设备失败
IVS_DCG_CAN_NOT_FIND_SERACHDEVTASK | 189108025 | 查找不到搜索设备的事物
IVS_DCG_STOP_SEARCH_DEVICE_ERROR | 189108026 | 停止搜索设备失败
IVS_DCG_CREATE_VENDER_DEV_ERROR | 189108027 | 创建适配层设备失败
IVS_DCG_UN_SUPPORT_PROTOCOL | 189108028 | 不支持的协议类型
IVS_DCG_VERSION_NO_MATCH | 189108029 | SDK与设备版本不匹配(针对自研SDK)
IVS_DCG_DEV_DISCOVERY_RUNNING | 189108030 | 设备自动发现服务已经在运行
IVS_DCG_VENDOR_DEV_INVALID | 189108031 | 主设备句柄无效
IVS_DCG_DEV_LOGIN_HANDLE_INVALID | 189108032 | 设备登录句柄无效
IVS_DCG_DEV_UN_SUPPORT | 189108033 | 设备不支持
IVS_DCG_DEV_UPDATE_ERROR | 189108034 | 设备升级失败
IVS_DCG_UNAUTHORIZED | 189108035 | 未鉴权
IVS_DCG_HTTP_DIGEST_AUTHORIZE_ERROR | 189108036 | Http-Digest鉴权错误
IVS_DCG_WSSE_AUTHORIZE_ERROR | 189108037 | WSSE鉴权错误
IVS_DCG_ONVIF_SOAP_OBJECT_INVALID | 189108038 | SOAP对象无效
IVS_DCG_ONVIF_SOAP_OPER_FAIL | 189108039 | SOAP请求失败
IVS_DCG_REGIST_EVENT_CALL_BACK_ERROR | 189108040 | sdk注册前端异常回调错误
IVS_DCG_ONVIF_APP_OBJECT_INVALID | 189108041 | ONVIFApp对象无效
IVS_DCG_FIND_SUB_DEV_EXIST | 189108042 | 查找子设备已经存在
IVS_DCG_HTTP_NOT_IMPLEMENTED | 189108043 | HTTP访问501错误
IVS_DCG_SET_CONFIG_FILE_ERROR | 189108044 | 设置配置文件错误
IVS_DCG_GET_CONFIG_FILE_ERROR | 189108045 | 获取配置文件错误
IVS_DCG_ONVIF_NO_CONF | 189108046 | ONVIF无相关配置信息
IVS_DCG_MAIN_DEV_REBOOTING | 189108047 | 主设备重启中
IVS_DCG_DEV_LOGIN_USER_LOCKED | 189108048 | 主设备登录锁定
IVS_DCG_TIMEZONE_SHIFT_INVALID | 189108049 | 时区偏移量不合法
IVS_DCG_FRAMERATE_INVALID | 189108050 | 帧率不合法
IVS_DCG_BITRATE_INVALID | 189108051 | 码率不合法
IVS_DCG_RESOLUTION_INVALID | 189108052 | 分辨率不合法
IVS_DCG_PROFILE_INVALID | 189108053 | profile不合法
IVS_DCG_IFRAMEINTERVAL_INVALID | 189108054 | I帧间隔不合法
IVS_DCG_PU_LOG_NOT_FOUND | 189108055 | 前端日志未找到
IVS_DCG_PU_SET_VEDIO_FORMAT_ERROR | 189108056 | 设置前端PN制式失败
IVS_DCG_HTTP_BASIC_AUTHORIZE_ERROR | 189108057 | Basic鉴权错误
IVS_DCG_ADD_STREAM_PARAM_ERROR | 189115001 | 添加请求码流参数错误
IVS_DCG_FIND_STREAM_PARAM_EXIST | 189115002 | 查找码流参数已经存在
IVS_DCG_FIND_STREAM_PARAM_ERROR | 189115003 | 查找码流参数错误、不存在
IVS_DCG_OPEN_SOCKET_ERROR | 189115004 | 初始化socket错误
IVS_DCG_START_STREAM_ERROR | 189115005 | 开始取流错误
IVS_DCG_TCP_OPEN_SOCKET_ERROR | 189115006 | TCP-socket打开错误
IVS_DCG_TCP_SOCKET_CONNECT_ERROR | 189115007 | TCP-socket连接错误
IVS_DCG_UDP_OPEN_SOCKET_ERROR | 189115008 | UDP-socket打开错误
IVS_DCG_STOP_REAL_STREAM_ERROR | 189115009 | 停止流错误
IVS_DCG_REQUEST_IFRAME_ERROR | 189115010 | 请求I帧错误
IVS_DCG_STREAM_HANDLE_INVALID | 189115011 | 流句柄无效
IVS_DCG_SEND_SIP_INVITE_ERROR | 189115012 | 向千里眼设备发送sipinvite错误
IVS_DCG_SIP_INVITE_RESPONSE_ERROR | 189115013 | 千里眼设备回复sipinvite响应错误
IVS_DCG_MEDIA_BUF_WITH_RTP_INVALID | 189115014 | 带RTP头的海康、大华流需要使用该指针，为空时报错
IVS_DCG_BIND_SERVICE_ID_AND_MU_LINK_ID_ERROR | 189115015 | 绑定ServiceID和MULinkID出错
IVS_DCG_UNBIND_SERVICE_ID_AND_MU_LINK_ID_ERROR | 189115016 | 解除绑定ServiceID和MULinkID出错
IVS_DCG_BIND_SERVICE_ID_AND_MSGKEY_ERROR | 189115017 | 千里眼流请求的时候绑定ServiceID和MsgKey错误
IVS_DCG_UNBIND_SERVICE_ID_AND_MSGKEY_ERROR | 189115018 | 千里眼流请求的时候解除绑定ServiceID
IVS_DCG_BIND_SERVICE_ID_AND_SESSION_ID_ERROR | 189115019 | 千里眼流请求的时候绑定ServiceID和千里眼消息中的会话ID错误
IVS_DCG_UNBIND_SERVICE_ID_AND_SESSION_ID_ERROR | 189115020 | 千里眼流请求的时候解除绑定ServiceID和千里眼消息中的会话ID错误
IVS_DCG_TRANSFER_PAYLOADTYPE_FAILED | 189115021 | payloadtype转换错误
IVS_DCG_STREAM_UNSTARTED | 189115022 | 流未启动
IVS_DCG_SET_WATERMARK_ERROR | 189115023 | 设置水印错误
IVS_DCG_TCP_SOCKET_ACCEPT_ERROR | 189115024 | TCP-SOCKET-Accept错误
IVS_DCG_TCP_SOCKET_ACCEPTOR_CLOSE_ERROR | 189115025 | TCP-SOCKET-Acceptorclose错误
IVS_DCG_REV_STREAM_REQUEST_ERROR | 189115026 | 处理流请求错误，主要是千里眼设备发送Invt消息的时候错误
IVS_DCG_UNSUPPORTED_ENCODE_MODE | 189115028 | 不支持的编码格式
IVS_DCG_UNSUPPORTED_PROFILE | 189115029 | 不支持的Profile
IVS_DCG_DECRYPT_SECURITY_ERROR | 189115030 | 解密失败
IVS_DCG_STREAM_HAS_STOPED | 189115031 | 实况流已停止
IVS_DCG_WRONG_STOPPING_STREAM_WITH_DEV | 189115032 | 设备停流失败
IVS_DCG_IS_IN_START | 189115033 | 此流业务还处于流请求和ACK中
IVS_DCG_IS_IN_STOP | 189115034 | 此流业务还处于流停止中
IVS_DCG_GET_ALARM_IN_PARAM_ERROR | 189110001 | 获取开关量子设备参数错误
IVS_DCG_SET_ALARM_IN_PARAM_ERROR | 189110002 | 设置开关量子设备参数错误
IVS_DCG_GET_ALARM_OUT_PARAM_ERROR | 189111001 | 获取开关量子设备参数错误
IVS_DCG_SET_ALARM_OUT_PARAM_ERROR | 189111002 | 设置开关量子设备参数错误
IVS_DCG_GET_ALARM_OUT_STATE_ERROR | 189111003 | 获取开关量子设备参数错误
IVS_DCG_SET_ALARM_OUT_STATE_ERROR | 189111004 | 设置开关量子设备参数错误
IVS_DCG_GET_CAMERA_STREAM_PARAM_ERROR | 189109001 | 获取摄像机码流参数错误
IVS_DCG_SET_CAMERA_STREAM_PARAM_ERROR | 189109002 | 设置摄像机码流参数错误
IVS_DCG_GET_IMAGING_PARAM_ERROR | 189109003 | 获取摄像机基本图像参数错误
IVS_DCG_SET_IMAGING_PARAM_ERROR | 189109004 | 设置摄像机基本图像参数错误
IVS_DCG_GET_VIDEO_PARAM_ERROR | 189109005 | 获取前端视频子设备参数错误
IVS_DCG_SET_VIDEO_PARAM_ERROR | 189109006 | 设置前端视频子设备参数错误
IVS_DCG_GET_VIDEO_EFFECT_PARAM_ERROR | 189109007 | 获取前端视频效果参数错误
IVS_DCG_SET_VIDEO_EFFECT_PARAM_ERROR | 189109008 | 设置前端视频效果参数错误
IVS_DCG_GET_VIDEO_ANALOG_FORMAT_ERROR | 189109009 | 获取前端视频制式错误
IVS_DCG_SET_VIDEO_ANALOG_FORMAT_ERROR | 189109010 | 设置前端视频制式错误
IVS_DCG_SET_OSD_ERROR | 189109011 | 设置OSD参数错误
IVS_DCG_GET_OSD_ERROR | 189109012 | 获取OSD参数错误
IVS_DCG_GET_EXTIMAGING_PARAM_ERROR | 189109013 | 获取摄像机扩展图像参数错误
IVS_DCG_SET_EXTIMAGING_PARAM_ERROR | 189109014 | 设置摄像机扩展图像参数错误
IVS_DCG_FIND_LENS_INVALID | 189109015 | 未查找到摄像机子设备
IVS_DCG_VENDOR_LENS_INVALID | 189109016 | 摄像机子设备句柄无效
IVS_DCG_SET_FEC_ERROR | 189109017 | 设置FEC参数错误
IVS_DCG_GET_FEC_ERROR | 189109018 | 获取FEC参数错误
IVS_DCG_SET_VIDEO_ENCODE_FORMAT_ERROR | 189109019 | 设置视频编码格式错误
IVS_DCG_GET_AUDIO_PARAM_ERROR | 189112001 | 获取音频子设备参数错误
IVS_DCG_SET_AUDIO_PARAM_ERROR | 189112002 | 设置音频子设备参数错误
IVS_DCG_GET_SERIAL_PARAM_ERROR | 189113001 | 获取串口子设备参数错误
IVS_DCG_SET_SERIAL_PARAM_ERROR | 189113002 | 设置串口子设备参数错误
IVS_DCG_START_VOICE_STREAM_ERROR | 189145001 | 开始音频对讲错误
IVS_DCG_STOP_VOICE_STREAM_ERROR | 189145002 | 停止音频对讲错误
IVS_DCG_START_REVERSE_AUDIO_THREAD_ERROR | 189145003 | 开启接受CU客户端语音数据线程失败
IVS_DCG_SET_LOG_CONFIG_ERROR | 189130001 | 设置日志开关参数错误
IVS_DCG_GET_LOG_SFTP_CONF_ERROR | 189130002 | 获取日志统一配置错误
IVS_DCG_SET_LOG_SFTP_CONF_ERROR | 189130003 | 设置日志统一配置错误
IVS_DCG_GET_PU_LOG_ERROR | 189130004 | 获取前端日志失败
IVS_DCG_START_PU_RECORD_ERROR | 189140001 | 开启前端手动录像错误
IVS_DCG_STOP_PU_RECORD_ERROR | 189140002 | 停止前端手动录像错误
IVS_DCG_GET_PU_RECORD_STATE_ERROR | 189140003 | 获取前端录像状态错误
IVS_DCG_GET_PU_RECORD_LIST_ERROR | 189140004 | 检索前端录像错误
IVS_DCG_STOP_PLAYBACK_STREAM_ERROR | 189140005 | 停止前端录像回放错误
IVS_DCG_START_PLAYBACK_STREAM_ERROR | 189140006 | 开启前端录像回放错误
IVS_DCG_SET_RECORD_STREAM_ERROR | 189140007 | 设置前端录像码流类型错误
IVS_DCG_PLAYBACK_BY_NAME_ERROR | 189119001 | 根据录像文件名错误
IVS_DCG_SET_PLAYBACK_CALLBACK_ERROR | 189119002 | 设置录像回放回调函数错误
IVS_DCG_PLAYBACK_START_PLAYBACK_ERROR | 189119003 | 启动录像回调错误
IVS_DCG_PLAYBACK_PLAYRESTART_ERROR | 189119004 | 回放恢复播放错误
IVS_DCG_PLAYBACK_PLAYPAUSE_ERROR | 189119005 | 回放暂停错误
IVS_DCG_PLAYBACK_PLAYFAST_ERROR | 189119006 | 回放快进错误
IVS_DCG_PLAYBACK_PLAYSLOW_ERROR | 189119007 | 回放慢放错误
IVS_DCG_PLAYBACK_PLAYSETTIME_ERROR | 189119008 | 回放设置播放时间错误
IVS_DCG_PLAYBACK_LIST_IS_EMPTY_ERROR | 189119009 | 录像回放录像下标list为空错误
IVS_DCG_PLAYBACK_INDEX_VALUE_ERROR | 189119010 | 从录像list拿出来的index错误
IVS_DCG_STRTEAM_CONTROL_TIME_INVALID | 189119011 | 时间拖动，下发时间超过录像长度
IVS_DCG_PLEASE_RESEARCH_RECORD_LIST | 189119012 | 请重新检索录像
IVS_DCG_MOD_DEV_PASSWORD_ERROR | 189126001 | 修改前端密码错误
IVS_DCG_GET_SNAP_SHOT_ERROR | 189146001 | 平台抓拍失败
IVS_DCG_PU_HAVE_NO_STORAGE_DEVICE | 189146002 | 前端设备没有存储设备
IVS_DCG_DEAL_SESSION_TIME_OUT | 189138001 | 处理消息超时
IVS_DCG_GET_EXTERN_DEV_LIST_ERROR | 189139001 | 获取外部系统设备列表错误
IVS_DCG_SET_EXTERN_DEV_LIST_ERROR | 189139002 | 设置外部系统设备列表错误
IVS_DCG_GET_SIPASS_UNIT_TABLE_ERROR | 189139003 | 获取西门子unit表错误
IVS_DCG_GET_SIPASS_DEVICE_TABLE_ERROR | 189139004 | 获取西门子deviec表错误
IVS_DCG_GET_SIPASS_POINT_TABLE_ERROR | 189139005 | 获取西门子point表错误
IVS_DCG_GET_SIPASS_FLN_TABLE_ERROR | 189139006 | 获取西门子FLN表错误
IVS_DCG_FIND_EXT_DEV_ERROR | 189139007 | 获取map中，外部设备错误
IVS_DCG_ADD_EXTSUBDEV_ECHO_ERROR | 189139008 | 添加外部设备时，设备已经存在
IVS_DCG_SIPASS_CON_SER_REG_ERROR | 189139009 | 连接服务器注册表错误
IVS_DCG_SIPASS_OPERATE_REGEDIT_ERROR | 189139010 | 操作注册表错误
IVS_DCG_SIPASS_GET_LO_REG_CLSID_ERROR | 189139011 | 获取本地注册表，CLSID错误
IVS_DCG_SIPASS_CREATE_INSTANCE_ERROR | 189139012 | 创建COM对象错误
IVS_DCG_SIPASS_SET_ATL_ADVISE_ERROR | 189139013 | 设置告警上报接口错误
IVS_DCG_EXT_SYS_IS_NOT_ONLINE_ERROR | 189139014 | 外部系统还未注册上线
IVS_PCG_XML_DECODE_ERROR | 279139001 | xml解析错误
IVS_PCG_ERROR | 279139000 | 服务器内部错误
IVS_PCG_PARA_ERROR | 279140000 | 参数校验失败
IVS_PCG_CONN_CODE_ALREADY_EXIST | 279139003 | 域编码已经存在
IVS_PCG_EXCEED_EXTERN_MAX_NUM | 279139004 | 外域数量超过128
IVS_PCG_DEVICEID_REPEAT | 279139005 | 设备互联编码重复
IVS_PCG_EXIST_EXTERN_DOMAIN_PROTOCOL | 279139006 | 存在该协议类型的外域
IVS_PCG_SHARE_RES_ITSELF_FAIL | 279139012 | 外域设备不能再次共享给外域本身
IVS_PCG_EXDOMAIN_PWD_VALIDATE | 279139013 | 外域密码不符合密码设置规则，校验失败
IVS_PCG_NOT_SUPPORT_REQUEST_FUNCTION | 279139014 | 外域设备不支持请求的功能
IVS_PCG_SC_BUSY_HERE | 279142002 | 外域带宽超出最大限制
IVS_MAU_ERR_CODE | 299133200 | MAU通用错误起始值
IVS_MAU_FAILURE | 299133201 | 响应失败
IVS_MAU_SUCCESS_FIRST | 299133210 | 首次登陆成功
IVS_MAU_USER_LOCKED | 299133211 | 用户锁定
IVS_MAU_NO_ANALYSIS_UNIT | 299133212 | MAU未连接分析单元
IVS_MAU_AUTHENTICATE_FAILURE | 299133301 | 登陆认证失败
IVS_MAU_TRANS_NOT_EXIST | 299133501 | 事务不存在，指定的事务不存在
IVS_MAU_FRONTDEV_NOT_EXIST | 299133502 | 主设备不存在，在查询主设备参数时，如果主设备不存在返回，其它错误情况，没有特别说明的，都返回
IVS_MAU_LENS_NOT_EXIST | 299133503 | 镜头设备不存在，在查询镜头设备参数时，如果镜头设备不存在返回，其它错误情况，没有特别说明的，都返回
IVS_MAU_OTHER_ERROR | 299133601 | 其他错误
IVS_MAU_DB_ERROR | 299133602 | 数据库操作异常
IVS_MAU_PARAM_ERROR | 299133603 | 参数异常
IVS_MAU_RUNTIME_ERROR | 299133604 | 运行时异常
IVS_MAU_XMLPRASE_ERROR | 299133605 | XML解析异常
IVS_MAU_OVERLOAD_ERROR | 299133607 | 过载异常
IVS_MAU_RULEGROUP_NOTEXIST | 299133608 | 规则不存在
IVS_MAU_PLANID_NOTEXIST | 299133609 | 计划信息不存在
IVS_MAU_PLAN_TIME_CONFLICT | 299133613 | analyzePlan时间段重叠RESP_PLANANA_TSCONFL_ERROR
IVS_MAU_PLAN_STARTORSTOPPING | 299133614 | 计划正在启停RESP_PLAN_STARTSTOPING
IVS_MAU_REPEAT_OPRATION_ERROR | 299133615 | 重复操作
IVS_MAU_FACEDBTYPE_NOT_EXIST | 299133616 | 人脸类型库不存在
IVS_MAU_FACEDBTYPE_EXIST | 299133617 | 人脸库类型已经存在
IVS_MAU_FACEDBNAME_EXIST | 299133618 | 人脸库类型名称已经存在
IVS_MAU_FACE_NOT_DETECT | 299133619 | 未检测到人脸
IVS_MAU_REQ_ENROLL2FACESRV_FAIL | 299133620 | 请求中转服务器注册人像模板失败
IVS_MAU_REQ_ENROLL2FACESRV_EXCP | 299133621 | 请求中转服务器注册人像模板异常
IVS_MAU_REQ_DELFROMFACESRV_EXCP | 299133622 | 请求节点服务器删除人像模板异常
IVS_MAU_REQ_DELFROMFACESRV_FAIL | 299133623 | 请求节点服务器删除人像模板失败
IVS_MAU_IMAGE_FORMAT_INVALIDATE | 299133624 | 图片格式不对
IVS_MAU_REQ_UPDATE2FACESRV_EXCP | 299133625 | 请求中转服务器更新人像模板失败
IVS_MAU_REQ_MEDIAANATYPE_ERR | 299133626 | 智能分析请求类型不正确
IVS_MAU_NOT_FIND_MATCHD_FACE | 299133628 | 未找到相似的人脸
IVS_MAU_FACEID_EXIST | 299133629 | 人脸ID已存在
IVS_MAU_FACEID_NOEXIST | 299133630 | 人脸ID不存在
IVS_LDU_SET_LOG_LEVEL_ERROR | 339100000 | 设置日志级别失败
IVS_BP_SUCCEED | 979199000 | 成功
IVS_BP_ERROR | 979199001 | 失败
IVS_BP_PARA_INVALID | 979199002 | 输入参数非法
IVS_BP_THREAD_BUSY | 979199003 | 线程繁忙
IVS_BP_NOT_SUPPORT | 979199004 | 消息类型不支持
IVS_BP_FAIL_CACHECK_FAIL | 979199010 | 客户端校验服务端证书失败
IVS_OCX_SDK_INIT_FAIL | 999115003 | OCX初始化SDK失败
IVS_OCX_RET_SET_DEVNAME_ERROR | 999115005 | 设置设备名称失败
IVS_OCX_RET_VIDEOPANE_IS_PLAYING_ERROR | 999115006 | 窗格正在播放视频错误
IVS_OCX_RET_GET_ACTIVE_WND_ID_ERROR | 999115007 | 获取活动窗格ID失败
IVS_OCX_RET_RESET_PANE_INFO_ERROR | 999115010 | 复位窗格信息失败
IVS_OCX_RET_SET_WND_LAYOUT_ERROR | 999115011 | 设置窗格布局失败
IVS_OCX_RET_CAPTURE_CREATE_THREAD_ERROR | 999115025 | 抓图创建线程错误
IVS_OCX_RET_SET_WARN_STATE_ERROR | 999115026 | 设置警告状态失败
IVS_OCX_RET_VIDEOPANE_ISNOT_PLAYING_ERROR | 999115030 | 窗格没有播放视频
IVS_OCX_RET_VIDEOPANE_ISNOT_ALARM_ERROR | 999115035 | 窗格不是告警窗格
IVS_OCX_RET_GET_INFO_ERROR | 999115038 | 获取信息失败
IVS_OCX_RET_SKIN_INIT_ERROR | 999115041 | OCX初始化皮肤失败
IVS_OCX_RET_FIND_PLAY_HANDLE_ERROR | 999115042 | OCX不存在该播放句柄
IVS_OCX_RET_NO_PLAY_HANDLE | 999115044 | 没有播放句柄
IVS_OCX_RET_POINT_OUT_CLIENT | 999115047 | 鼠标点在OCX以外
IVS_SDK_RET_INIT_RTSPCLIENT_ERROR | 999115200 | 初始化RtspClient库失败
IVS_SDK_RET_SET_LOG_LEVEL_ERROR | 999115201 | 设置日志级别失败
IVS_SDK_RET_BP_CMD_REQ_INVALID | 999115305 | SDK调用BP创建命令非法
IVS_SDK_RET_BP_CMD_RSP_INVALID | 999115306 | SDK调用BP应答命令非法
IVS_SDK_RET_INVALID_SESSION_ID | 999115312 | 无效的SessionID
IVS_SDK_ERR_FINDVIDEOHANDLE_FAILED | 999115313 | 获取视频句柄失败
IVS_SDK_ERR_ERR_MAX_USERNUM | 999115314 | 达到最大用用户
IVS_SDK_ERR_CHEACKMD5_FAILED | 999115319 | 检测zip文件时发生错误;
IVS_SDK_ERR_DELETEZIPFILE_FAILED | 999115320 | 删除zip时发生错误;
IVS_SDK_ERR_CREATEZIPFILE_FAILED | 999115321 | 创建zip时发生错误;
IVS_SDK_ERR_DOMAINCODE_NOT_EXIST | 999115322 | 域编码不存在
IVS_SDK_PLAYBACK_ERR_GET_REMOTE_DATAINFO | 999119211 | 获取远端播放信息失败
IVS_SDK_SET_CLUSTER_MSG_FAILED | 999119218 | 下发集群失败
IVS_SDK_ERR_FINDAUDIOHANDLE_FAILED | 999119219 | 获取对讲句柄失败
IVS_SDK_TALKBACK_ERR_ALREADY_OPENED | 999119220 | 已经开启一路对讲或广播
IVS_SDK_BROADCASE_ERR_NO_DEVICE | 999119222 | 设备组中没有设备
IVS_SDK_BROADCASE_ERR_ALREADY_OPENED | 999119223 | 广播已经开启
IVS_SDK_BROADCASE_ERR_NOT_OPENED | 999119224 | 广播没有开启
IVS_SDK_VOICE_ERR_INVALID_USEROBJ | 999119225 | 用户对象为空，无法获取用户信息
IVS_SDK_VOICE_ERR_INVALID_USERINFO | 999119226 | 用户信息为空
IVS_SDK_VOICE_ERR_GET_URL_FAIL | 999119227 | 获取URL失败
IVS_SDK_VOICE_ERR_SET_IP_FAIL | 999119228 | 设置接收IP失败
IVS_SDK_VOICE_ERR_CALL_MLIB_FAIL | 999119229 | 调用Mlib层接口返回失败
IVS_SDK_VOICE_ERR_DEV_ALREADY_IN | 999119230 | 设备已加入设备组
IVS_SDK_VOICE_ERR_DEV_NOT_IN | 999119231 | 设备组中没有该设备
IVS_SDK_VOICE_ERR_STOP_BROADCAST_FAIL | 999119232 | 删除设备时停止对应设备的广播失败
IVS_SDK_VOICE_ERR_TOO_MUCH_DEVICES | 999119233 | 广播组中的设备数超过最大值256
IVS_SDK_VOICE_ERR_GET_HANDLE_FAIL | 999119234 | 根据设备ID查找广播handle失败
IVS_SDK_VOICE_ERR_FILE_NOT_EXIST | 999119235 | 文件不存在
IVS_SDK_VOICE_ERR_FILE_NOT_RIGHT_TYPE | 999119236 | 不是wav格式的音频文件
IVS_SDK_VOICE_ERR_CANNOT_REPORT_FAIL | 999119237 | 获取用户对象的回调函数失败
IVS_SDK_VOICE_ERR_ALL_BROADCAST_FAIL | 999119238 | 广播开启\关闭全部失败
IVS_SDK_VOICE_ERR_AUDIO_TYPE_CONFLICT | 999119239 | 音频格式和之前的镜头冲突
IVS_SDK_EXCHANGE_KEY_ERR_GET_KEY_FAIL | 999119240 | 密钥协商交换失败、获取密钥失败
IVS_SDK_LOCALRECORD_UNSUPPORTED_MJPEG | 999119241 | 本地录像不支持MJPEG格式
IVS_SDK_LOCALRECORD_UNSUPPORTED_VIDEODECTYPE | 999119242 | 本地录像不支持该视频编码格式
IVS_SDK_NOT_CLUSTER_MODE | 999119243 | 服务器异常或模式错误
IVS_SDK_NOT_PLAY_TVWALL | 999119244 | 没有电视上墙(在关闭电视上墙的时候返回)
IVS_SDK_NET_REDIRECT_FAILED | 999119245 | 网络或者服务器原因，重定向失败
IVS_SDK_PROXY_ROUTE_REDIRECT_FAILED | 999119246 | 重定向失败,代理域不需要重定向
IVS_SDK_HAVE_SAME_CHANNEL | 999119247 | 有相同通道
IVS_PLAYER_RET_GET_CHANNEL_ERROR | 999115400 | 获取通道失败
IVS_PLAYER_RET_ALL_PORT_BUSY_ERROR | 999115401 | 所有端口均被占用
IVS_PLAYER_RET_WSA_START_ERROR | 999115402 | 启用SOCKET的DLL库错误
IVS_PLAYER_RET_CONNECT_SOCKET_ERROR | 999115403 | 建立socket连接失败
IVS_PLAYER_RET_ALLOC_MEM_ERROR | 999115404 | 缓存分配失败
IVS_PLAYER_RET_RECV_DATA_ERROR | 999115405 | 数据流错误
IVS_PLAYER_RET_RECV_DATA_TIMEOUT | 999115406 | 连接超时
IVS_PLAYER_RET_CREATE_THREAD_ERROR | 999115407 | 创建线程失败
IVS_PLAYER_RET_CREATE_DECODER_ERROR | 999115408 | 创建解码库失败
IVS_PLAYER_RET_ORDER_ERROR | 999115409 | 调用顺序不对
IVS_PLAYER_RET_DECODER_ERROR | 999115410 | 解码失败
IVS_PLAYER_RET_WATER_MARK_OK | 999115411 | 水印数据正常
IVS_PLAYER_RET_WATER_MARK_ERROR | 999115412 | 水印数据被篡改
IVS_PLAYER_RET_UNSUPPORT_OPERATION | 999115413 | 当前版本不支持此操作
IVS_PLAYER_RET_DECODER_BUFFER_FULL | 999115414 | 缓冲区满
IVS_PLAYER_RET_RTSP_GET_HANDLE_FAIL | 999115415 | 获取rtsp的handle失败
IVS_PLAYER_RET_RTSP_SEND_SETUP_FAIL | 999115416 | 发送rtsp的Setup请求失败
IVS_PLAYER_RET_RTSP_SEND_PLAY_FAIL | 999115417 | 发送rtsp的Play请求失败
IVS_PLAYER_RET_RTSP_SEND_PAUSE_FAIL | 999115418 | 发送rtsp的Pause请求失败
IVS_PLAYER_RET_RTSP_SEND_TEARDOWN_FAIL | 999115419 | 发送rtsp的Teardown请求失败
IVS_PLAYER_RET_RTSP_NORMAL_STOP | 999115420 | RTSP连接收到正常结束
IVS_PLAYER_RET_RTSP_ABNORMAL_STOP | 999115421 | RTSP连接收到异常结束
IVS_PLAYER_RET_RTSP_DATA_ERROR | 999115422 | RTSP码流不符合要求
IVS_PLAYER_RET_RTSP_DISCONNECT | 999115423 | RTSP码流断开
IVS_PLAYER_RET_NET_OPEN_STREAM_FAIL | 999115424 | 网络库打开网络流失败
IVS_PLAYER_RET_MP_OPEN_STREAM_FAIL | 999115425 | 播放库打开网络流失败
IVS_PLAYER_RET_MP_START_PLAY_FAIL | 999115426 | 播放库启动播放失败
IVS_PLAYER_RET_NET_START_RECEIVE_FAIL | 999115427 | 网络库启动收流失败
IVS_PLAYER_RET_INIT_NETSOURCE_ERROR | 999115428 | 初始化网络收流库失败
IVS_PLAYER_RET_INIT_PLAY_ERROR | 999115429 | 初始化播放收流库失败
IVS_PLAYER_RET_FILE_ACCESS_ERROR | 999115430 | 访问文件或目录错误
IVS_PLAYER_RET_DISK_SPACE_ERROR | 999115431 | 磁盘空间满错误
IVS_PLAYER_RET_MIXER_OPEN_STATE_ERROR | 999115432 | 混音器打开状态错误
IVS_PLAYER_RET_MIXER_ERROR | 999115433 | 混音器操作错误
IVS_PLAYER_RET_VOICE_TALKBACK_STATUS_ERROR | 999115434 | 语音对讲状态失败
IVS_PLAYER_RET_BROADCAST_FILE_IS_END | 999115435 | 语音广播文件播放结束
IVS_PLAYER_RET_BROADCAST_NOT_SUPPORTED_FORMAT | 999115436 | 语音广播传入的文件格式不支持
IVS_PLAYER_RET_BROADCAST_OPEN_FILE_ERROR | 999115437 | 语音广播读文件失败
IVS_PLAYER_RET_GET_STREAM_OPEN_MODE_ERROR | 999115438 | 获取数据流打开模式失败
IVS_PLAYER_RET_GET_AUDIO_VOLUMN_ERROR | 999115439 | 获取音量失败
IVS_PLAYER_RET_WAVE_OUT_ERROR | 999115440 | 打开音频输出失败
IVS_PLAYER_RET_CAPTURE_OPEN_STATE_ERROR | 999115441 | 音频收集状态错误
IVS_PLAYER_RET_WAVE_IN_ERROR | 999115442 | 打开音频输入失败
IVS_PLAYER_RET_AUDIO_DEVICE_NOT_FIND | 99911518531 | 未找到音频设备
IVS_PLAYER_RET_MEDIA_TYPE_UNSUPPORT | 999115444 | 不支持该媒体类型
IVS_PLAYER_RET_VOICE_BROADCAST_STATUS_ERROR | 999115445 | 语音广播状态失败
IVS_PLAYER_RET_CHANNEL_NOT_EXIST_ERROR | 999115446 | 通道不存在
IVS_PLAYER_RET_RTSP_ERR_NOT_EXIST | 999115447 | 连接句柄不存在
IVS_PLAYER_RET_RTSP_ERR_DISCONNECT | 999115448 | 连接失败
IVS_PLAYER_RET_RTSP_ERR_RESPONSE | 999115449 | 响应消息错误
IVS_PLAYER_RET_RTSP_ERR_TIMEOUT | 999115450 | 响应超时
IVS_PLAYER_RET_RTSP_ERR_STAUTS_ABNORMAL | 999115451 | 连接状态异常
IVS_PLAYER_RET_RTSP_ERR_SEND_FAIL | 999115452 | 发送出错
IVS_PLAYER_RET_RTSP_ERR_RECV_FAIL | 999115453 | 接收出错
IVS_PLAYER_RET_RTSP_ERR_PARAMETER | 999115454 | 参数检查出错
IVS_PLAYER_RET_RTSP_ERR_NORMAL_STOP | 999115455 | 正常结束，ANNOUNCE正常结束请求
IVS_PLAYER_RET_RTSP_ERR_ABNORMAL_STOP | 999115456 | 异常结束，ANNOUNCE异常结束请求
IVS_PLAYER_RET_RTSP_ERR_RET_SYS | 999115457 | 通用系统错误
IVS_PLAYER_RET_NET_BIND_PORT_FAIL | 999115458 | 绑定端口失败
IVS_PLAYER_RET_RTSP_ERR_SERVICE_500_RSP | 999115459 | 服务器500响应
IVS_PLAYER_RET_RTSP_ERR_SERVICE_UNAVAILABLE_RSP | 999115460 | 服务不可用
IVS_PLAYER_RET_DISK_WRITE_ERROR | 999115461 | 录像文件写入失败，请检查文件夹权限设置;
IVS_PLAYER_RET_ERR_FILE_NOT_EXIST | 999115462 | 录像文件不存在
IVS_PLAYER_RET_TALKBACK_OPENED_ERROR | 999115463 | 语音对讲已经开启
IVS_PLAYER_RET_NOTENOUGH_BANDWIDTH | 999115464 | 媒体服务器带宽不足
IVS_TVWALL_MEMORY_NULL | 999115600 | 指针为空
IVS_TVWALL_CREATE_THREAD_FAIL | 999115601 | 创建线程失败
IVS_TVWALL_BUSINESS_ID_NO_EXIST | 999115602 | 业务ID不存在
IVS_TVWALL_SEND_FAIL | 999115603 | 发送消息失败
IVS_TVWALL_INIT_NO | 999115607 | 尚未初始化
IVS_TVWALL_INIT_ALREADY | 999115608 | 已经初始化
IVS_TVWALL_TV_WALL_SRC_RUNING | 999115609 | 电视墙服务已经运行
IVS_TVWALL_TV_WALL_SRC_STOPED | 999115610 | 电视墙服务尚未运行
IVS_TVWALL_DECODER_OFFLINE | 999115611 | 解码器不在线
IVS_TVWALL_DECODER_NO_CHANNEL | 999115612 | 解码器没有该通道
IVS_TVWALL_DECODER_INIT_CHANNEL_FAIL | 999115613 | 初始化解码器通道失败
IVS_TVWALL_STOP_FLAG | 999115614 | 正在启动上墙的过程中，收到停止的命令（内部使用）
IVS_TVWALL_DECODER_NO_CAPABILITY | 999115615 | 解码器不具备无缝切换能力
IVS_SDK_DOWNLOAD_RECORD_UNSUPPORTED_VIDEODECTYPE | 999119249 | 录像下载不支持该视频编码格式
父主题： 错误码


HTTP响应代码表

方法 | 典型用法 | 典型状态码 | 安全 | 幂等
GET | - 获取表示 - 变更时获取表示(缓存) | 200(OK) - 表示已在响应中发出 204(无内容) - 资源有空表示 301(Moved Permanently) - 资源的URI已被更新 303(See Other) - 其他(如，负载均衡) 304(not modified)- 资源未更改(缓存) 400 (bad request)- 指代坏请求(如，参数错误) 404 (not found)- 资源不存在 406 (not acceptable)- 服务端不支持所需表示 500 (internal server error)- 通用错误响应 503 (Service Unavailable)- 服务端当前无法处理请求 | 是 | 是
DELETE | - 删除资源 | 200 (OK)- 资源已被删除 301 (Moved Permanently)- 资源的URI已更改 303 (See Other)- 其他，如负载均衡 400 (bad request)- 指代坏请求t 404 (not found)- 资源不存在 409 (conflict)- 通用冲突 500 (internal server error)- 通用错误响应 503 (Service Unavailable)- 服务端当前无法处理请求 | 否 | 是
PUT | - 用客户端管理的实例号创建一个资源 - 通过替换的方式更新资源 - 如果未被修改，则更新资源(乐观锁) | 200 (OK)- 如果已存在资源被更改 201 (created)- 如果新资源被创建 301(Moved Permanently)- 资源的URI已更改 303 (See Other)- 其他(如，负载均衡) 400 (bad request)- 指代坏请求 404 (not found)- 资源不存在 406 (not acceptable)- 服务端不支持所需表示/p> 409 (conflict)- 通用冲突 412 (Precondition Failed)- 前置条件失败(如执行条件更新时的冲突) 415 (unsupported media type)- 接受到的表示不受支持 500 (internal server error)- 通用错误响应 503 (Service Unavailable)- 服务当前无法处理请求 | 否 | 是
POST | - 使用服务端管理的(自动产生)的实例号创建资源 - 创建子资源 - 部分更新资源 - 如果没有被修改，则不过更新资源(乐观锁) | 200(OK)- 如果现有资源已被更改 201(created)- 如果新资源被创建 202(accepted)- 已接受处理请求但尚未完成(异步处理) 301(Moved Permanently)- 资源的URI被更新 303(See Other)- 其他(如，负载均衡) 400(bad request)- 指代坏请求 404 (not found)- 资源不存在 406 (not acceptable)- 服务端不支持所需表示 409 (conflict)- 通用冲突 412 (Precondition Failed)- 前置条件失败(如执行条件更新时的冲突) 415 (unsupported media type)- 接受到的表示不受支持 500 (internal server error)- 通用错误响应 503 (Service Unavailable)- 服务当前无法处理请求 | 否 | 否

父主题： 错误码


合肥异构

  • 管理接口
  • 运维接口


管理接口

  • 用户管理接口
  • 存储计划管理接口
  • 组织管理接口
  • 外域管理接口
  • 摄像机管理接口
  • 存储灾备管理接口
父主题： 合肥异构


用户管理接口

  • 获取Token
  • 用户登录
  • 用户保活
  • 用户退出
父主题： 管理接口


获取Token

接口描述

客户端向服务端获取token令牌，有效期可配置，默认5秒，超期后再登陆需要重新获取token，同时返回一个nonce字段，用于后面交互时作为随机算法的种子

使用说明

请求方法 | GET
请求URL | /RM/GetToken
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /RM/GetToken HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

无参

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/GetToken

接口返回消息示例数据如下：

{

"token": "Lnxzm2nvXazMSpJH0EjmwNS3f2KEa2xZ",

"nonce": "9a8c08"

}

父主题： 用户管理接口


用户登录

接口描述

客户端获取Token返回的nonce值为随机种子，以线性同余算法（参考附录A.1）为随机算法，确定随机序列（其中线性同余算法的系数取值214013LL，余数取值2531011LL），然后通过以下公式计算response的值response=”ToString(sha256(owner+passwd+随机序列的下一个值)) ”，最后将owner，response和token字段携带在http的Authorization字段中，向服务器发起用户登陆请求，服务端收到请求后，先验证客户端token的有效性，有效性验证通过后，再根据对应的方法进行用户账户认证。

客户端根据token，发起用户认证，服务端认证token有效后，再进行用户认证，认证通过后，服务端以根据客户端发送的nonce字段为种子，根据线性同余算法建立随机序列（其中系数取值214013LL，余数取值2531011LL），然后按照示例所示的算法计算response的值，最后向服务端发起用户登陆认证，登陆认证通过后，token失效

使用说明

请求方法 | GET
请求URL | /RM/Login
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /RM/Login HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin, response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9",token="1zQEoRKY5xqUue26QOXUcJmGnOF4ynuo"

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Login

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 用户管理接口


用户保活

接口描述

用于保活用户登陆，防止服务端在客户端长期无操作的情况下，清理用户控制块，调用频率小于2小时。保活操作和其他用户操作无区别，

必须携带Authorization字段

使用说明

请求方法 | GET
请求URL | /RM/KeepAlive
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET/RM/KeepAlive HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/KeepAlive

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 用户管理接口


用户退出

接口描述

登出接口，用于注销服务端的用户控制块，假如用户登陆后服务端长期没有收到此用户操作请求，默认最短2小时之后自动释放用户控制块，后续用户操作会返回401错误，此时客户端必须重新进行登陆认证后才能进行操作。登出操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | GET
请求URL | /RM/Logout
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /RM/Logout HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Logtout

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 用户管理接口


存储计划管理接口

  • 添加存储计划
  • 修改存储计划
  • 查询存储计划
  • 删除存储计划
父主题： 管理接口


添加存储计划

接口描述

用于向平台添加存储计划，基于之前会议讨论的结论，录像是7*24小时连续存储的，当空间不足时进行循环覆盖，故不需要对录像存储进行时间模板的配置。

此操作和其他用户操作无区别，必须携带Authorization字段

使用说明

请求方法 | POST
请求URL | /RM/StorePlan/Add
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /RM/StorePlan/Add HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | channelCode | String | 必选 | 摄像机互联编码,必填,字符串类型
2 | storeDevCode | String | 必选 | 存储单元编码；（字段必须存在）
3 | diskFlPolicy | Integer | 必选 | 磁盘满处理策略：0 磁盘满停止存储；1 磁盘满覆盖存储；（字段必须存在）
4 | enable | Integer | 必选 | 是否添加后直接使能存储计划：0 否；1 是；（字段必须存在）
5 | storageSpace | Integer | 必选 | 存储空间，单位是GB；（字段必须存在）

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/StorePlan/Add

接口请求消息示例如下：

{

"channelCode":"09261931105214550101",

"storeDevCode":"",

"diskFlPolicy":1,

"enable":1,

"storageSpace":100

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 存储计划管理接口


修改存储计划

接口描述

用于向平台修改存储计划信息。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法↵ | POST↵
请求URL↵ | /RM/StorePlan/Modify
请求数据↵ | application/json;charset=UTF-8↵

↵

HTTP Header示例如下：↵

POST /RM/StorePlan/Modify HTTP/1.1↵

Host: 192.168.203.36:18531↵

Content-Type: application/json↵

Cache-Control: no-cache↵

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | channelCode | String | 必选 | 摄像机互联编码,必填,字符串类型
2 | diskFlPolicy | Integer | 必选 | 磁盘满处理策略：0 磁盘满停止存储；1 磁盘满覆盖存储（字段必须存在）
3 | enable | Integer | 必选 | 是否添加后直接使能存储计划：0 否；1 是
4 | storageExtend | Integer | 必选 | 扩展存储空间，单位是GB（字段必须存在）

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/StorePlan/Modify

接口请求消息示例如下：

{

"channelCode":"01581912772177330101",

"diskFlPolicy":0,

"enable":1,

"storageExtend": 100

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 存储计划管理接口


查询存储计划

接口描述

用于向平台查询指定摄像机的存储计划。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/StorePlan/Query
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /RM/StorePlan/Query HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 |  | 字段类型 |  | 必选/可选 | 字段名称
1 | channelCode |  | String |  | 可选 | 摄像机互联编码,为空时批量查询
2 | pageInfo | pageIndex |  | int | 必选 | 返回查询结果中的第几页
 |  | pageSize |  | int | 必选 | 分页的大小，即每个分页包含的最大摄像机节点数量

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败
3 | response | Object | 响应信息•pageInfo，•storePlanInfo
  • QueryPlanResponse
请求字段 | 字段类型 | 必选/可选 | 字段描述
storePlanInfoList | storePlanInfoList | 必选 | 存储计划信息
PageInfoReturn | object | 必须 | 分页对象
  • StorePlanBean
请求字段 | 字段类型 | 必选/可选 | 字段描述
channelCode | String | 必选 | 摄像机互联编码
storeDevCode | String | 必须 | 存储单元编码
diskFlPolicy | Integer | 必选 | 磁盘满处理策略: 0 磁盘满停止存储 1 磁盘满覆盖存储
enable | Integer | 必须 | 存储计划当前是否使能： 0 否 1 是
storageSpace | Integer | 必选 | 存储空间，单位 GB

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/StorePlan/Query

接口请求消息示例如下：

{

"channelCode":"",

"pageInfo":

{

"pageIndex":1,

"pageSize":200

}

}

接口返回消息示例数据如下：

{

"errCode":0,

"errMsg":"成功",

"response":

{

"pageInfo":

{

"curPageIndex":当前查询返回的是第几页,

"totalPageNum":总的分页数量,

"curPageSize":当前分页的组织节点数量,

"pageSize":分页的大小，即每个分页包含的最大外域节点数量

},

"storePlanInfo":[{

"channelCode":""|

"storeDevCode":存储单元编码

"diskFlPolicy":磁盘满处理策略，取值为0：磁盘满停止存储；1：磁盘满覆盖存储

"enable":存储计划当前是否使能，0否，1是

"storageSpace":存储空间，单位是GB,必填

}]

}

}

父主题： 存储计划管理接口


删除存储计划

接口描述

用于向平台删除存储计划。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | DELETE
请求URL | /RM/StorePlan/Del
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

DELETE /RM/StorePlan/Del HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | channelCode | String | 必选 | 摄像机互联编码,必填,字符串类型

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/StorePlan/Del

接口请求消息示例如下：

{

"channelCode":"09261931105214550101",

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 存储计划管理接口


组织管理接口

  • 添加组织
  • 删除组织
  • 修改组织
  • 查询组织
父主题： 管理接口


添加组织

接口描述

用于向平台添加组织。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/Org/Add
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /RM/Org/Add HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | orgCode | String | 必选 | 组织节点编码（该编码为唯一编码，需要手动填写
2 | orgName | String | 必选 | 组织节点名称
3 | orgParentCode | String | 必选 | 父(上级)组织节点编码，字符串类型
4 | orgMobile | String | 可选 | 移动电话号码
5 | orgAddr | String | 可选 | 联系地址
6 | orgDesc | String | 可选 | 组织节点描述
7 | userInfo | String | 可选 | 扩展信息
8 | orgContact | String | 可选 | 联系人
9 | orgFax | String | 可选 | 传真号码
10 | orgTel | String | 可选 | 座机号码
9 | orgEmail | String | 可选 | 电子邮箱
10 | orgPostalCode | String | 可选 | 邮政编码

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Org/Add

接口请求消息示例如下：

{

"orgCode":"123456789x",

"orgName":"lbaa",

"orgParentCode":"root"

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 组织管理接口


删除组织

接口描述

用于向平台删除组织，当删除此组织时，会同步删除其下的子组织，那么当前组织下的所有资源需要自动挂载到根节点下。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | DELETE
请求URL | /RM/Org/Del
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

DELETE /RM/Org/Del HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | orgCode | String | 必选 | 待删除组织节点编码

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Org/Del

接口请求消息示例如下：

{

"orgCode":"123456789x"

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 组织管理接口


修改组织

接口描述

用于向平台修改组织。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/Org/Modify
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /RM/Org/Modify HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号↵ | 请求字段↵ | 字段类型↵ | 必选/可选↵ | 字段名称↵
1↵ | orgCode↵ | String↵ | 必选↵ | 组织节点编码（该编码为唯一编码，需要手动填写↵
2↵ | orgName↵ | String↵ | 必选↵ | 组织节点名称↵
3↵ | orgParentCode↵ | String↵ | 必选↵ | 父(上级)组织节点编码，字符串类型↵
4↵ | orgMobile↵ | String↵ | 可选↵ | 移动电话号码↵
5↵ | orgAddr↵ | String↵ | 可选↵ | 联系地址↵
6↵ | orgDesc↵ | String↵ | 可选↵ | 组织节点描述↵
7↵ | userInfo↵ | String↵ | 可选↵ | 扩展信息↵
8↵ | orgContact↵ | String↵ | 可选↵ | 联系人↵
9↵ | orgFax↵ | String↵ | 可选↵ | 传真号码↵
10↵ | orgTel↵ | String↵ | 可选↵ | 座机号码↵
9↵ | orgEmail↵ | String↵ | 可选↵ | 电子邮箱↵
10↵ | orgPostalCode↵ | String↵ | 可选↵ | 邮政编码↵

↵

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Org/Modify

接口请求消息示例如下：

{

"orgCode":"123456789x",

"orgName":"lbaa",

"orgParentCode":"root"

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 组织管理接口


查询组织

接口描述

使用说明

请求方法 | POST
请求URL | RM/Org/Query
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST RM/Org/Query HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 |  | 字段类型 |  | 必选/可选 | 字段名称
1 | orgCode |  | String |  | 必须 | 组织节点编码，参数为空字符串时表示查询所有组织信息
2 | pageInfo | pageIndex |  | int | 必选 | 返回查询结果中的第几页
 |  | pageSize |  | int | 必选 | 分页的大小，即每个分页包含的最大摄像机节点数量

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败
3 | response | Object | •pageInfo，•orgNodesInfo

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Org/Query

接口请求消息示例如下：

{

"orgCode":"xxxx",

"pageInfo":

{

"pageIndex":1,

"pageSize":20

}

}

接口返回消息示例数据如下：

{

"errCode":0,

"errMsg":"成功",

"response":

{

"pageInfo":

{

"curPageIndex":当前查询返回的是第几页,整型

"totalPageNum":总的分页数量, ,整型

"curPageSize":当前分页的组织节点数量, ,整型

"pageSize":分页的大小，即每个分页包含的最大组织节点数量,整型

},

"orgNodesInfo":[{

"orgCode":组织节点编码,字符串类型

"orgName":组织节点名称,字符串类型

"orgParentCode":父(上级)组织节点编码,字符串类型

"orgDesc":组织节点描述,字符串类型

"userInfo":扩展信息,字符串类型

"orgContact":联系人,字符串类型

"orgMobile":移动电话号码,字符串类型

"orgAddr":联系地址,字符串类型

"orgFax":传真号码,字符串类型

"orgTel":座机号码,字符串类型

"orgEmail":电子邮箱,字符串类型

"orgPostalCode":邮政编码,字符串类型

}]

}

父主题： 组织管理接口


外域管理接口

  • 添加外域
  • 删除外域
  • 修改外域
  • 查询外域
父主题： 管理接口


添加外域

接口描述

用于向平台添加外域。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/Domain/Add
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /RM/Domain/Add HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | domainCode | String | 必选 | 外域编码
2 | domainName | String | 必选 | 存储单元编码
1 | outerDomainType | Integer | 必选 | 外域类型： 1 上级域 2 下级域 3 平级域
2 | domainParentCode | String | 可选 | 父域节点编码。如果无父节点，则填空串
1 | domainPort | Integer | 必选 | SIP端口，其他厂商按需配置
2 | domainAddr | String | 必选 | 外域IP地址
1 | inTrunkNum | Integer | 必选 | 本域向外域转发的视频路数上限，取值范围为0~9999，区县平台可暂不实现
2 | protocolType | Integer | 必选 | 域间通讯协议类型： 1 国标
1 | interDomainCode | String | 必选 | 跨域互联域编码
2 | interUserCode | String | 必选 | 跨域互联用户编码
2 | streamTransProtocol | Integer | 必选 | 域间流媒体的协议类型： IMOS_TT_TCP = 1, IMOS_TT_RTP = 2, IMOS_TT_RTP_NO_RTCP = 3, IMOS_TT_AUTO = 4,自适应

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Domain/Add

接口请求消息示例如下：

{

"domainCode":"16400110222222228189",

"domainName":"lcs_domain9",

"outerDomainType":1,

"domainParentCode":"",

"domainPort":5061,

"domainAddr":"10.5.66.30",

"domainPassword":"pcg123456",

"inTrunkNum":5000,

"protocolType":1,

"interDomainCode":"",

"interUserCode":"",

"streamTransProtocol":1

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 外域管理接口


删除外域

接口描述

用于向平台删除外域。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | DELETE
请求URL | /RM/Domain/Del
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

DELETE/RM/Domain/Del HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | domainCode | String | 必选 | 外域编码

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Domain/Del

接口请求消息示例如下：

{

"domainCode":"51400111002000028282"

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 外域管理接口


修改外域

接口描述

用于向平台修改外域信息。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/Domain/Modify
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /RM/Domain/Modify HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | domainCode | String | 必选 | 外域编码
2 | domainName | String | 必选 | 存储单元编码
1 | outerDomainType | Integer | 必选 | 外域类型： 1 上级域 2 下级域 3 平级域
2 | domainParentCode | String | 可选 | 父域节点编码。如果无父节点，则填空串
1 | domainPort | String | 必选 | SIP端口，其他厂商按需配置
2 | domainAddr | String | 必选 | 外域IP地址
1 | inTrunkNum | Integer | 必选 | 本域向外域转发的视频路数上限，取值范围为0~9999，区县平台可暂不实现
2 | protocolType | Integer | 必选 | 域间通讯协议类型： 1 国标
1 | interDomainCode | String | 必选 | 跨域互联域编码
2 | interUserCode | String | 必选 | 跨域互联用户编码
2 | streamTransProtocol | Integer | 必选 | 域间流媒体的协议类型： IMOS_TT_TCP = 1, IMOS_TT_RTP = 2, IMOS_TT_RTP_NO_RTCP = 3, IMOS_TT_AUTO = 4,自适应

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Domain/Modify

接口请求消息示例如下：

{

"domainCode":"16400110222222228189",

"domainName":"lcs_domain9",

"outerDomainType":1,

"domainParentCode":"",

"domainPort":5061,

"domainAddr":"10.5.66.30",

"domainPassword":"pcg123456",

"inTrunkNum":5000,

"protocolType":1,

"interDomainCode":"",

"interUserCode":"",

"streamTransProtocol":1

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 外域管理接口


查询外域

接口描述

用于向平台查询组织，这里包含两种情况，一种是针对性的查询，另一种是无差别的查询，针对性的查询是指查询某个具体的组织节点信息，无差别的查询是查询所有的组织节点信息。

针对性的查询需要携带OrgCode参数，而无差别的查询，则无需携带参数。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/Domain/Query
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /RM/Domain/Query HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | domainCode | String | 可选 | 外域编码，为空时查所有外域信息

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败
2 | response | Object | •domainInfo

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Domain/Query

接口请求消息示例如下：

{

"domainCode":""

}

接口返回消息示例数据如下：

{

"errCode":0,

"errMsg":"成功",

"response":

{

"domainInfo":[{

"domainCode":外域编码，外域唯一标识，不可为空

"domainName":外域名称

"outerDomainType；外域类型(1:上级域，2:下级域，3:平级域)

"domainParentCode":父域节点编码。如果无父节点，则填空串

"domainPort":SIP端口，其他厂商按需配置

"domainAddr":外域IP地址

"inTrunkNum":本域向外域转发的视频路数上限，取值范围为0~9999，区县平台可暂不实现

"protocolType":域间通讯协议类型，1:国标；

"interDomainCode":跨域互联域编码

"interUserCode":跨域互联用户编码

"streamTransProtocol":域间流媒体的协议类型，取值为

IMOS_TT_UDP = 0，

IMOS_TT_TCP = 1，

IMOS_TT_RTP = 2，

IMOS_TT_RTP_NO_RTCP = 3，

IMOS_TT_AUTO = 4。目前外域只支持自适应和TCP

}]

}

}

父主题： 外域管理接口


摄像机管理接口

  • 添加摄像机
  • 删除摄像机
  • 修改摄像机
  • 查询摄像机
父主题： 管理接口


添加摄像机

接口描述

用于向平台添加摄像机。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/Camera/Add
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /RM/Camera/Add HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cach

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | orgCode | String | 必选 | 摄像机所属组织编码
2 | camCode | String | 必选 | 摄像机编码
3 | camName | String | 必选 | 摄像机名称
4 | cameraType | int | 必选 | 摄像机类型，必填(整型) 1-标清固定摄像机 2-标清云台摄像机 3-高清固定摄像机 4-高清云台摄像机 5-多通道摄像机
5 | longitude | Double | 必选 | 经度
6 | latitude | Double | 必选 | 纬度
7 | userName | String | 必选 | 用户名
8 | password | String | 必选 | 密码
9 | isAutofit | int | 可选 | 流媒体选择的适应策略 0-为指定流媒体服务器 1-为自适应 2-为不经过流媒体服务器
10 | channels | ChannelBean | 可选 | 摄像机类型为5需下发此字段，其他摄像机类型可不下发

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Camera/Add

接口请求消息示例如下：

{

"orgCode":"1225936190x",

"camCode":"21345678902134567897",

"camName":"ssjds",

"cameraType":1,

"longitude":20.34,

"latitude":30.12,

"userName":"admin",

"password":"super123"

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 摄像机管理接口


删除摄像机

接口描述

用于向平台删除摄像机。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | DELETE
请求URL | /RM/Camera/Del
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

DELETE /RM/Camera/Del HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cach

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | camCode | String | 必选 | 待删除相机的编码
2 | cameraType | int | 必选 | 摄像机类型，必填(整型) 1-标清固定摄像机 2-标清云台摄像机 3-高清固定摄像机 4-高清云台摄像机 5-多通道摄像机

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Camera/Del

接口请求消息示例如下：

{

"camCode":"71614565727565710101",

"cameraType":1

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 摄像机管理接口


修改摄像机

接口描述

用于向平台修改摄像机信息。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/Camera/Modify
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /RM/Camera/Modify HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cach

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | orgCode | String | 必选 | 摄像机所属组织编码
2 | camCode | String | 必选 | 摄像机编码
3 | camName | String | 必选 | 摄像机名称
4 | cameraType | int | 必选 | 摄像机类型，必填(整型) 1-标清固定摄像机 2-标清云台摄像机 3-高清固定摄像机 4-高清云台摄像机 5-多通道摄像机 注：只区分3,4
5 | longitude | Double | 必选 | 经度
6 | latitude | Double | 必选 | 纬度
7 | userName | String | 必选 | 用户名（不支持）
8 | password | String | 必选 | 密码（不支持）
9 | isAutofit | int | 必选 | 流媒体选择的适应策略（不支持，默认为1） 0-为指定流媒体服务器 1-为自适应 2-为不经过流媒体服务器
10 | channels | ChannelBean | 可选 | 摄像机类型为5需下发此字段，其他摄像机类型可不下发（不支持）

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Camera/Modify

接口请求消息示例如下：

{

"orgCode":"1225936190x",

"camCode":"21345678902134567897",

"camName":"ssjds",

"cameraType":1,

"longitude":20.34,

"latitude":30.12,

"userName":"admin",

"password":"super123"

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 摄像机管理接口


查询摄像机

接口描述

用于向平台查询摄像机，这里包含两个条件：组织编码、摄像机编码。这两个条件可以组合使用，详见参数描述。

此操作和其他用户操作无区别，必须携带Authorization字段

使用说明

请求方法 | POST
请求URL | /RM/Camera/Query
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /RM/Camera/Query HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cach

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 |  | 字段类型 | 必选/可选 | 字段名称
1 | orgCode |  | String | 必选 | 组织编码，当不为空时，表示查询范围为当前组织，否则查询范围为整个平台
2 | camCode |  | int | 必选 | 待查询摄像机编码，无此参数时表示查询当前组织下的所有摄像机
3 | pageInfo | pageIndex | int | 必选 | 返回查询结果中的第几页
 |  | pageSize | int | 必选 | 分页的大小，即每个分页包含的最大摄像机节点数量

响应参数

序号 | 参数 |  |  | 类型 | 描述
1 | errCode |  |  | Integer | 成功返回0，失败返回错误码
2 | errMsg |  |  | String | 成功/失败
3 | response | pageInfo | curPageIndex | int | 当前查询返回的是第几页
 |  |  | totalPageNum | int | 总的分页数量
 |  |  | curPageSize | int | 当前分页的组织节点数量
 |  |  | pageSize | int | 分页的大小，即每个分页包含的最大摄像机节点数量
 |  | cameraInfo | DeviceBean | DeviceBean | 摄像机相关信息

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/Camera/Query

接口请求消息示例如下：

{

"orgCode":"",

"camCode":"",

"pageInfo":

{

"pageIndex":1,

"pageSize":1

}

}

接口返回消息示例数据如下：

{

"errCode":0,

"errMsg":"成功",

"response":{

"pageInfo":{

"curPageIndex":1,

"totalPageNum":9,

"curPageSize":1,

"pageSize":1

},

"cameraInfo":[

{

"orgCode":"root",

"camCode":"06669345503491080000",

"camName":"baoan",

"cameraType":3,

"longitude":"",

"latitude":"",

"userName":"",

"password":"",

"isAutofit":1,

"devAddr":"3.4.40.199",

"devPort":"0",

"channels":null

}

]

}

}

父主题： 摄像机管理接口


存储灾备管理接口

  • 录像下载
父主题： 管理接口


录像下载

接口描述

使用说明

请求方法 | POST
请求URL | /RM/VideoRecord/Download
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST RM//VideoRecord/Download HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | channelCode | String | 必选 | 摄像机互联编码
2 | recordID | String | 可选 | 录像段的唯一编码
3 | startTime | String | 必选 | 录像开始时间,格式:yyyy-mm-DD HH:MM:SS
4 | endTime | String | 必选 | 录像结束时间 ,格式 yyyy-mm-DD HH:MM:SS
5 | recordLink | String | 必选 | 像下载链接,形如：RTSP:\\192.168.1.1:8088\xxxxx

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/RM/StorePlan/Add

接口请求消息示例如下：

{

"channelCode":"34020000001310000001",

"recordID":"1",

"startTime":"2019-09-04 12:00:10",

"endTime":"2019-09-04 14:30:20",

"recordLink":"rtspsfffkk://3.4.64u.200:554/Replay/Recorqding1"

}

接口返回消息示例数据如下：

{

"errCode": 0,

"errMsg": "成功"

}

父主题： 存储灾备管理接口


运维接口

  • 云存储管理接口
  • 流媒体管理接口
  • 录像管理接口
  • 查询监控平台运维信息
父主题： 合肥异构


云存储管理接口

  • 查询云存储
  • 查询云存储节点状态
  • 查询云存储节点运维信息
父主题： 运维接口


查询云存储

接口描述

用于向平台查询云存储相关信息。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | GET
请求URL | /RM/CDS/Query
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

GET /RM/CDS/Query HTTP/1.1

Host:192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败
3 | response | Object | 云存储信息•CDSInfo

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/RM/CDS/Query

接口返回消息示例数据如下：

{

"errCode":0,

"errMsg":"成功"

"response":

{

"cloudIP":存储IP，该IP为云存储对外提供存储服务的公网IP,字符串

"totalSpace":总存储空间大小，包含冗余空间，以GB为单位;保留2位小数，参数传递时候不带单位，浮点型

"usedSpace":总已用空间，以GB为单位，保留2位小数，参数传递时候不带单位，浮点型

"dataUnitNum":数据节点总数，若非对称式不包含元数据节点数量，整型

"status":存储状态返回相关状态的状态码，0-正常，1-异常，整型

}

}

父主题： 云存储管理接口


查询云存储节点状态

接口描述

用于查询云存储节点状态。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/StorageNode/Query
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /RM/StorageNode/Query HTTP/1.1

Host:192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败
3 | response | Object | 云存储节点状态信息•StorageNodeInfo

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/RM/StorageNode/Query

接口返回消息示例数据如下：

{

"errCode":0,

"errMsg":"成功",

"response":

{

"storageNodeNum":查询到的存储节点的数量，整型

"storageNodeInfo":[{

"serverID":节点ID, 规则如下：区域首拼+现有各区云存储节点资源ID（保持不变），字符串类型

瑶海：YH 庐阳：LY 蜀山：SS 包河：BH 高新：GX 新站：XZ 经开：JK

"serverStatus":状态（0在线、1离线），整型

"totalCapacity":总空间大小，浮点型

"residualCapacity":剩余总空间大小，浮点型

"deviceReadRate":设备读速率，浮点型

"deviceWriteRate":设备写速率，浮点型

}]

}

}

父主题： 云存储管理接口


查询云存储节点运维信息

接口描述

用于查询云存储节点运维信息。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/StorageNode/OpQuery
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /RM/StorageNode/OpQuery HTTP/1.1

Host:192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | serverID | String | 必选 | 节点ID，规则如下：区域首拼+现有各区云存储节点资源ID（保持不变）

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败
3 | response | Object | 云存储节点运维信息•OpStorageNodeInfo

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/RM/MS/MediaServer/Query

接口请求消息示例如下：

{

"serverID":节点ID， 规则如下：区域首拼+现有各区云存储节点资源ID（保持不变）；

瑶海：YH 庐阳：LY 蜀山：SS 包河：BH 高新：GX 新站：XZ 经开：JK

}

接口返回消息示例数据如下：

{

"errCode":0,

"errMsg":"成功",

"response":

{

"storageNodeNum":查询到的存储节点的数量

"storageNodeInfo":[

{

"serverID":节点ID，规则如下：区域首拼+现有各区云存储节点资源ID（保持不变）；

瑶海：YH 庐阳：LY 蜀山：SS 包河：BH 高新：GX 新站：XZ 经开：JK

"controlTemp":控制器温度（精确到整数，63，单位：摄氏度）

"memUsage"：内存使用率（百分比，精确到整数，如63）

"cpuTemp":CPU温度（精确到整数，63，单位：摄氏度）

"fans":风扇状态（0正常，1异常）

"power":电源状态（0正常，1异常）

"logicGroupNum":逻辑组单元数(raid或者资源池的数量)

"logicGroups":[

{

"id":组ID, 字符串类型

"status": （0正常/1降级/2失效）

"totalSpace":总空间,（浮点型）

"availableSpace":可用空间（浮点型）

"level":组级别（0/1/5/6等）

}],

"diskNums":磁盘数量

"disks":[

{

"ID":磁盘ID，字符串类型

"status":磁盘状态（0正常/1异常/2离线）

"groupID":磁盘所属逻辑组ID,字符串类型

"totalSpace":磁盘容量（浮点型，单位：GB）

"readSpeed":磁盘当前读速度（精确到整数，单位：MB/s）

"writeSpeed":磁盘当前写速度（精确到整数，单位：MB/s）

}],

"networkInterfaceNum":网口数量

"networkInterfaces":[

{

"ip":网口IP，字符串类型

"mac":Mac地址，字符串类型

"flowRate":网口速率（精确到整数，63，单位：Mbps）

}]

}]

}

}

父主题： 云存储管理接口


流媒体管理接口

  • 查询流媒体
  • 查询流媒体节点转发状态
父主题： 运维接口


查询流媒体

接口描述

用于向平台查询流媒体相关信息。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | GET
请求URL | /RM/MS/MediaServer/Query
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

GET /RM/MS/MediaServer/Query HTTP/1.1

Host:192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败
3 | response | Object | 流媒体信息•MediaServerInfo

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/RM/MS/MediaServer/Query

接口返回消息示例数据如下：

{

"errCode":0,

"errMsg":"成功"

"response":

{

"mediaServerInfo":{

"msNum":流媒体转发节点总数，整型

"msList":[

{

"msCode":流媒体节点编码，字符串类型

"ipAddr":流媒体服务器的IP地址,，字符串类型

"status":流媒体服务器状态：1-在线，2-离线，整型

}]

}

}

}

父主题： 流媒体管理接口


查询流媒体节点转发状态

接口描述

用于向平台查询流媒体转发相关信息。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/MS/MediaTransfer/Query
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /RM/MS/MediaTransfer/Query HTTP/1.1

Host:192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | msCode | String | 必选 | 流媒体节点编码

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败
3 | response | Object | 流媒体节点转发信息•MediaSeverTransfer

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/RM/MS/MediaTransfer/Query

接口请求消息示例如下：

{

"msCode":流媒体节点编码，字符串格式

}

接口返回消息示例数据如下：

{

"errCode":0,

"errMsg":"成功",

"response":

{

"currentForwardTimes":媒体当前转发数量,

"maxForwardTimes":媒体最大转发梳理,

"serverServiceInfo"[

{

"remoteSendIP":发流端IP,

"remoteSendPort":发流端端口,

"localRecvIP":MS收流IP,

"localRecvPort":MS收流端口,

"localSendIP":MS发流IP,

"localSendPort":MS发流端口,

"remoteRecvIP":收流端IP,

"remoteRecvPort":收流端端口

}]

}

}

父主题： 流媒体管理接口


录像管理接口

  • 录像缺失
父主题： 运维接口


录像缺失

接口描述

用于查询指定时间段内平台的录像缺失情况。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/VideoRecord/Detection
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /RM/VideoRecord/Detection HTTP/1.1

Host:192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"
序号 | 请求字段 | 字段类型 | 必选/可选 | 字段名称
1 | channelCode | String | 必选 | 摄像机通道编码
2 | startTime | String | 必选 | 录像开始时间，格式：yyyy-mm-DD HH:MM:SS
3 | endTime | String | 必选 | 录像结束时间 ，格式： yyyy-mm-DD HH:MM:SS

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败
3 | response | Object | 录像缺失信息•DetectionRecordResponse

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/RM/VideoRecord/Detection

接口请求消息示例如下：

{

"channelCode":摄像机通道编码

"startTime":录像开始时间，格式：yyyy-mm-DD HH:MM:SS

"endTime":录像结束时间 ，格式：yyyy-mm-DD HH:MM:SS

}

接口返回消息示例数据如下：

{

"errCode":0,

"errMsg":"成功",

"response":

{

"channelCode":摄像机通道编码

"startTime":"2018-12-30 18:00:00",

"endTime":"2019-01-07 18:00:00",

"missingBlockNum":缺失的录像段数量,

"missingBlocks":[

{

"block_StartTime":"2018-12-30 20:00:00",

"block_EndTime":"2018-12-30 21:00:00"

}]

}

}

父主题： 录像管理接口


查询监控平台运维信息

接口描述

用于查询视频监控平台的运维信息。

此操作和其他用户操作无区别，必须携带Authorization字段。

使用说明

请求方法 | POST
请求URL | /RM/Platform/StatusQuery
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /RM/Platform/StatusQuery HTTP/1.1

Host:192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

通过headers携带
key | 必选/可选 | value
Authorization | 必选 | owner=admin,response="5e56ad53c74b0d6864d9736eb55825a0b4312d5bf533b21898202d8c174337d9"

响应参数

序号 | 参数 | 类型 | 描述
1 | errCode | Integer | 成功返回0，失败返回错误码
2 | errMsg | String | 成功/失败
3 | response | Object | 监控平台信息•PlatformStatus

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/RM/Platform/StatusQuery

接口返回消息示例数据如下：

{

"errCode":0,

"errMsg":"成功",

"response":

{

"platform":{

"platCode":平台编码，字符串类型

"platOnline":平台GB保活状态（0在线，1离线），整型

"platStatus":平台服务状态（0正常，1异常），整型

}

}

}

父主题： 运维接口


内部接口

内部调用接口，仅用于内部业务操作，不推荐使用。

  • 客户端下载接口
  • 单点登录接口
  • 算法加载接口
  • VCM系统配置接口
  • 1400接口
  • VCM数据分析相关接口
  • 域间管理接口
  • 布控任务接口
  • 通用接口
  • GIS服务接口
  • 系统及用户文件处理接口


客户端下载接口

加载客户端门户网站，可以查看客户端版本信息，下载客户端。

  • 加载客户端门户网站
  • 加载客户端门户网站图片
  • 下载客户端
父主题： 内部接口


加载客户端门户网站

接口描述

加载客户端门户网站接口。

使用说明

请求方法 | GET
请求URL | /cuServer/index/downloadWebPage/{language}
请求数据 | 浏览器直接访问即可

HTTP Header示例如下：

GET /cuServer/index/downloadWebPage/{language}

Host: 192.168.203.36:18531

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | language | String | 必选 | 网站显示语言（目前仅支持中文zh）

响应参数

门户网站的HTML代码。

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/index/downloadWebPage/zh

接口返回门户网站的HTML代码。

父主题： 客户端下载接口


加载客户端门户网站图片

接口描述

加载客户端门户网站图片接口。

使用说明

请求方法 | GET
请求URL | /cuServer/index/showImage/{imageFileName}
请求数据 | 浏览器直接访问即可

HTTP Header示例如下：

GET /cuServer/index/showImage/{imageFileName}

Host: 192.168.203.36:18531

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | imageFileName | String | 必选 | 客户端门户网站图片名

响应参数

加载图片文件流。

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/index/showImage/pic

接口返回加载图片文件流。

父主题： 客户端下载接口


下载客户端

接口描述

下载客户端接口。

使用说明

请求方法 | GET
请求URL | /cuServer/index/downloadFile/{fileName}
请求数据 | 浏览器直接访问即可

HTTP Header示例如下：

GET /cuServer/index/downloadWebPage/{language}

Host: 192.168.203.36:18531

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | fileName | String | 必选 | 客户端安装包文件名

响应参数

客户端安装包文件流。

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/index/downloadWebPage/IVSClient101

接口返回客户端安装包文件流。

父主题： 客户端下载接口


单点登录接口

  • 单点登录
父主题： 内部接口


单点登录

接口描述

单点登录IVS平台接口。

使用说明

请求方法 | POST
请求URL | /loginInfo/loginByTicket
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /loginInfo/loginByTicket

Host: 192.168.203.36:18531

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | ticket | String | 必选 | IVS系统登录Ticket
2 | isTLS | Integer | 必选 | 是否启用TLS
3 | serverIp | String | 必选 | 系统服务器IP
4 | serverPort | String | 必选 | 系统服务器端口号

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | Integer | 返回状态码：0成功；其余返回错误码

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/loginInfo/loginByTicket

{

"ticket":"11233456adnnsjsssss",

"isTLS": 0,

"serverIp": "192.168.203.36",

"serverPort": "9900"

}

接口返回消息示例数据如下：

{

"resultCode": 0

}

父主题： 单点登录接口


算法加载接口

  • 算法数据加载接口
父主题： 内部接口


算法数据加载接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后算法数据加载接口。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/algorithm/loadAlgorithm
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/algorithm/loadAlgorithm

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | type | String | 必选 | 类型
3 | name | String | 必选 | 名称

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | algorithms | List | 算法列表，含子项参数algorithm
4 | algorithm | String | 具体算法,包含下列属性参数
 | installDate | String | 安装日期
 | status | String | 状态(enable/disable/deleted)
 | license | String | license_key 或者 center_server_ip
 | initParam | String | 插件初始化参数信息
 | chlParam | String | 插件分析时通道的初始化信息
 | Type | String | 算法类型
 | Code | String | 算法编码
 | Name | String | 算法名称
 | supplier | String | 供应商
 | version | String | 版本信息
 | Cpu | Integer | 占用cpu
 | Mem | Integer | 占用内存
 | Disk | Integer | 占用磁盘
 | supportAnalyzeMode | String | 算法插件支持的分析模式 0:只支持视频模式，1:仅支持图片模式，2:支持视频模式和图片模式
 | supportScenseMode | String | 区分 gate算法

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/algorithm/loadAlgorithm

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"type": "ceshileixing",

"name": "ceshi"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

" algorithms ": [

{

" algorithm ": {

"installDate": "2019-02-19",

"status": "enable",

"license": "DHFEIIEFJLSF5E0DFSAH245SFD3FF4FFDGFG4",

"initParam": "SFD3FF4FF",

"chlParam": "0558",

"type": "2",

"code": "1025656",

"name": "face_002",

"supplier": "hw_025",

"version": "1.2.36",

"cpu": 10,

"mem": 2,

"disk": 7,

"supportAnalyzeMode": "1",

"supportScenseMode": "dsfjlalsdlfjlsa",

"supportAnalyzeContent": "0",

}

}

]

}

父主题： 算法加载接口


VCM系统配置接口

  • 监控平台查询
  • 监控平台同步
  • 监控平台设置
  • 文件上传下载配置
  • 保存图像信息库参数配置
  • 保存设置卡口组的摄像机个数
  • 查询VCM系统信息数据请求处理
  • 查询VCM集群ID数据请求处理
  • 根据ID查询VCM集群信息数据请求处理
  • 根据ID查询集群资源信息数据请求处理
  • 查询VCM License资源信息数据请求处理
  • 查询VCM License数量请求处理
  • 用户在线数配置查询
  • 用户在线数配置管理
  • AD域配置查询
  • AD域配置添加
  • 删除AD域
  • VCN账号检测
  • 特殊名单阈值查询
  • 特殊名单阈值设置
  • 区域信息配置查询
  • 添加区域信息配置
  • 更新区域信息配置
  • 删除区域信息配置
父主题： 内部接口


监控平台查询

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID传入该接口，然后可以查询监控平台信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/getPlatform
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/getPlatform

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | imageInfo | Object | 图像信息库配置•ImageInfo
4 | platform | Object | 平台配置信息 •Platform
5 | fileUpdateDownload | Object | 文件上传下载配置 •FileUpdateDownload
6 | bayonet | Object | 摄像机卡口配置信息•Bayonet

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/getPlatform

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"

}

接口返回消息示例数据如下：

{

"errorMessage": "",

"resultCode": "0",

"imageInfo": {

"caseFileValidity": "90",

"humanDbDataValidity": "90",

"baAlarmDbDataValidity": "90",

"vehicleItsDataValidity": "180",

"onlineFileValidity": "",

"alarmFileValidity": "",

"lprFileDataValidity": "90",

"faceDbDataValidity": "90",

"vehicleFlowRateDataValidity": "180",

"downloadPolicyOverdaysLimit": "3",

"videoPreprocessTimeout": "600",

"baAlarmFileDataValidity": "90",

"faceFileDataValidity": "90",

"immeDownloadCameraslimit": "32",

"videoTranscodeTimeout": "600",

"lprDbDataValidity": "90",

"humanFileDataValidity": "90",

"immeDownloadTimeoutLimit": "30"

},

"fileUpdateDownload": {

"maxupload": "4194304",

"uploadFilesize": "500",

"flesize": "10240",

"netWidth": "104857600",

"maxdownload": "4194304"

},

"bayonet": {

"maxCameraNumber": "1000"

},

"platform": {

"password": "",

"port": "9900",

"outIp": "",

"ip": "192.168.203.36",

"outPort": "",

"platformName": "VCN",

"natPass": "",

"status": "1",

"username": "yanqinglin"

}

}

父主题： VCM系统配置接口


监控平台同步

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID传入该接口，然后可以同步摄像机列表。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/syncCameraList
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /cuServer/vcm/systemInfo/syncCameraList

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/syncCameraList

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： VCM系统配置接口


监控平台设置

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后可以设置监控平台信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/setPlatform
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /cuServer/vcm/systemInfo/setPlatform

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | base64信息

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/setPlatform

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"requestBody": base64信息

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： VCM系统配置接口


文件上传下载配置

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后可以进行文件上传下载配置。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/setfileUploadConfig
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /cuServer/vcm/systemInfo/setfileUploadConfig

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 请求接口的body体
3 | FileUpdateDownload | FileUpdateDownload | 必选 | 文件上传下载配置•FileUpdateDownload

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/setfileUploadConfig

{

requestBody: {

"uploadFilesize": 500,

"flesize": "10240",

"maxupload": "4194304",

"maxdownload": "4194304",

"netWidth": "104857600"

},

vcmSession: "JSESSIONID=2f1319b6-fd0a-494d-aa12-34719278cbf45cfd550a-cbdf-44e4"

}

接口返回消息示例数据如下：

{

"result": {

"errorMessage": "Success.",

"resultCode": "0"

}

}

父主题： VCM系统配置接口


保存图像信息库参数配置

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后可以进行保存图像信息库参数配置。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/setImageInfoConfig
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /cuServer/vcm/systemInfo/setImageInfoConfig

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 请求接口的body体
3 | ImageDBConfig | ImageDBConfig | 必选 | 图像信息库配置•ImageDBConfig

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/setImageInfoConfig

{

requestBody: {

"baAlarmDbDataValidity": "90",

"onlineFileValidity": "90",

"alarmFileValidity": "90",

"lprFileDataValidity": "90",

"faceDbDataValidity": "90",

"baAlarmFileDataValidity": "90",

"faceFileDataValidity": "90",

"immeDownloadCameraslimit": "32",

"lprDbDataValidity": "90",

"downloadPolicyOverdaysLimit": "3",

"immeDownloadTimeoutLimit": "30",

"videoPreprocessTimeout": "600",

"videoTranscodeTimeout": "600",

"humanDbDataValidity": "90",

"humanFileDataValidity": "90",

"caseFileValidity": "90",

"vehicleItsDataValidity": "180",

"vehicleFlowRateDataValidity": "180"

},

vcmSession: "JSESSIONID=2f1319b6-fd0a-494d-aa12-34719278cbf45cfd550a-cbdf-44e4"

}

接口返回消息示例数据如下：

{

"result": {

"errorMessage": "Success.",

"resultCode": "0"

}

}

父主题： VCM系统配置接口


保存设置卡口组的摄像机个数

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后可以进行保存设置卡口组的摄像机个数的。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/setCameraGroupSetting
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /cuServer/vcm/systemInfo/setCameraGroupSetting

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 请求接口的body体
3 | Bayonet | Bayonet | 必选 | 摄像机卡口配置信息•Bayonet

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/setCameraGroupSetting

{

requestBody: {

"maxCameraNumber": "1000"

},

vcmSession: "JSESSIONID=2f1319b6-fd0a-494d-aa12-34719278cbf45cfd550a-cbdf-44e4"

}

接口返回消息示例数据如下：

{

"result": {

"errorMessage": "Success.",

"resultCode": "0"

}

}

父主题： VCM系统配置接口


查询VCM系统信息数据请求处理

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后可以查询VCM系统信息数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/querySystemInfo
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /cuServer/vcm/systemInfo/querySystemInfo

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | VcmRspResult | VCM返回•VcmRspResult
2 | vcmResourceInfo | VcmResourceInfo | •VcmResourceInfo

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/querySystemInfo

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

}

接口返回消息示例数据如下：

{

"resultCode": "0",

"content": {

"cpuRatio": "0.95",

"gpuNum": "0",

"gpuUtility": "0.0",

"memUtility": "0.0",

"memoryRatio": "16.94",

"networkRatio": "0.0",

"storageLoad": "16.94",

"storageTotal": "1486.46",

"storageUsed": "90.69"

}

}

父主题： VCM系统配置接口


查询VCM集群ID数据请求处理

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后可以查询VCM集群ID数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/queryClusteIdList
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /cuServer/vcm/systemInfo/queryClusteIdList

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | VcmRspResult | VCM返回•VcmRspResult
2 | clusterMemberIdList | List |

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/queryClusteIdList

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

}

接口返回消息示例数据如下：

{

"resultCode": "0",

"content": {

"clusterMemberIdList": [

"A_VCMAPI_i_18c345000000400080008807ae18512a-cim:1",

"A_MP_ivsap_24000000000040008062da9de35911da-cim:1",

"A_VA_D_ivs_176d9b0277aa400080000000000023f9-cim:2",

"A_VA_D_ivs_355862fe8b3240008000000000c8d73e-cim:2",

"A_VA_C_ivs_09ff145d4912400080000000001c7f4d-cim:2"

]

}

}

父主题： VCM系统配置接口


根据ID查询VCM集群信息数据请求处理

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后可以根据ID查询VCM集群信息数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/queryClusterInfoById
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /cuServer/vcm/systemInfo/queryClusterInfoById

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | content | Json | 必选 |
3 | clusterMemberId | String | 必选 | clusterMemberId在content里面

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | K | VCM返回响应错误码
2 | content | T<VcmResourceInfo> | 错误消息•VcmResourceInfo

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/queryClusterInfoById

{

content: {

clusterMemberId: "A_VCMAPI_i_18c345000000400080008807ae18512a-cim"

},

vcmSession: "JSESSIONID=569483ee-6c35-4bc9-b481-e09b0762cf539b1b8efa-476d-47a3"

}

接口返回消息示例数据如下：

{

"resultCode": "0",

"content": {

"cpuRatio": "8.0",

"gpuNum": "0",

"gpuUtility": "0.0",

"memUtility": "0.0",

"memoryRatio": "20.0",

"networkRatio": "0.0",

"storageLoad": "0.0",

"storageTotal": "15.0",

"storageUsed": "0.0"

}

}

父主题： VCM系统配置接口


根据ID查询集群资源信息数据请求处理

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后可以根据ID查询集群资源信息数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/queryClusterStatistics
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /cuServer/vcm/systemInfo/queryClusterStatistics

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | vcmContentRequest | ClusterStatisticsRequestContent | 必选 | •ClusterStatisticsReques...

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | K | VCM返回响应错误码
2 | content | T<QueryClusterStatisticsContent> | 错误消息•QueryClusterStatisticsC...

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/queryClusterStatistics

{

content: {

containerId: "0",

startTime: "1582473600000",

endTime: "1582591834020"

},

vcmSession: "JSESSIONID=84a6216b-4455-4d37-afca-43b352e55a58a64f2132-c9e5-4e4c"

}

接口返回消息示例数据如下：

{

"resultCode": "0",

"content": {

"cupRatioList": [

{

"id": "55000",

"licenseCount": "0",

"licenseType": "0",

"queryDateTime": "2020-02-23 16:00",

"queryTime": "2020-02-23T16:00:00.135+08:00",

"systemRate": "4.3",

"systemType": "cpuRatio"

},

{

"id": "55097",

"licenseCount": "0",

"licenseType": "0",

"queryDateTime": "2020-02-23 16:10",

"queryTime": "2020-02-23T16:10:00.173+08:00",

"systemRate": "3.5",

"systemType": "cpuRatio"

}

]

}

}

父主题： VCM系统配置接口


查询VCM License资源信息数据请求处理

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后可以查询VCM License资源信息数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/queryLicenseStatistics
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /cuServer/vcm/systemInfo/queryLicenseStatistics

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | vcmContentRequest | LicenseStatisticsRequestContent | 必选 | •LicenseStatisticsReques...

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | K | VCM返回响应错误码
2 | content | T<QueryLicenseStatisticsContent > | 错误消息•QueryLicenseStatisticsC...

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/queryLicenseStatistics

{

content: {

startTime: "1582473600000",

endTime: "1582591834020"

},

vcmSession: "JSESSIONID=84a6216b-4455-4d37-afca-43b352e55a58a64f2132-c9e5-4e4c"

}

接口返回消息示例数据如下：

{

"resultCode": "0",

"content": {

"abstractLicense": [

{

"id": "54951",

"licenseCount": "0",

"licenseType": "1",

"queryDateTime": "2020-02-23 16:00",

"queryTime": "2020-02-23T16:00:00.104+08:00"

},

{

"id": "55048",

"licenseCount": "0",

"licenseType": "1",

"queryDateTime": "2020-02-23 16:10",

"queryTime": "2020-02-23T16:10:00.144+08:00"

}

]

}

}

父主题： VCM系统配置接口


查询VCM License数量请求处理

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后可以查询VCM License数量请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/queryLicenseNumber
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST /cuServer/vcm/systemInfo/queryLicenseNumber

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | K | VCM返回响应错误码
2 | content | T<QueryLicenseNumberContent> | 错误消息•QueryLicenseNumberConte...

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/systemInfo/queryLicenseNumber

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

}

接口返回消息示例数据如下：

{

"resultCode": "0",

"content": {

"licenseStatusInfo": {

"endDate": "3019-06-23",

"keepDate": "60",

"status": "1"

},

"licenseThirdTotalList": [

{

"code": "0804000500",

"total": "103"

}

],

"licenseThirdUsedList": [

{

"code": "0804000500",

"total": "0"

}

],

"licenseTotalInfo": {

"abstractLicense": "10000000",

"behaviorLicense": "10000000",

"cloudWalkFacePictureLicense": null,

"cloudWalkPicFacePictureLicense": null,

"cwImageFacialRecognition": null,

"cwVideoFacialRecognition": null,

"faceLicense": null,

"faceN2Nlicense": null,

"facePicLicense": null,

"faceQueryLicense": "10000000",

"imageFacialRecognition": "10000000",

"indexLicense": "10000000",

"plateLicense": "10000000",

"sbiFeatureLicense": "10000000",

"sbiFeatureQueryLicense": "10000000",

"sbiVehicleLicense": "10000000",

"vehicleGlobalLicense": "10000000",

"vehicleLicense": "10000000",

"vehicleQueryLicense": "10000000",

"vehicleSearchGlobalLicense": "10000000",

"videoFacialRecognition": "10000000"

},

"licenseUsedInfo": {

"abstractLicense": "0",

"behaviorLicense": "0",

"cloudWalkFacePictureLicense": null,

"cloudWalkPicFacePictureLicense": null,

"cwImageFacialRecognition": null,

"cwVideoFacialRecognition": null,

"faceLicense": null,

"faceN2Nlicense": null,

"facePicLicense": null,

"faceQueryLicense": "0",

"imageFacialRecognition": "0",

"indexLicense": "0",

"plateLicense": "0",

"sbiFeatureLicense": "0",

"sbiFeatureQueryLicense": "0",

"sbiVehicleLicense": "0",

"vehicleGlobalLicense": "0",

"vehicleLicense": "0",

"vehicleQueryLicense": "0",

"vehicleSearchGlobalLicense": "0",

"videoFacialRecognition": "0"

}

}

}

父主题： VCM系统配置接口


用户在线数配置查询

接口描述

此接口用于查询用户在线数配置

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/getUserConfiguration
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/getUserConfiguration HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID=17F834B2A415D1CD3AD166C3F67EF77573F1ADEC1E03E9BD8D52913B9D06CE13

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 |

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Result | •Result
2 | config | UserConfig | 配置结果

使用示例

接口请求消息示例数据如下：

Body：

{

"vcmSession":

"JSESSIONID=439e4647-d99a-431d-b919-228e243e1f64085ea947-8522-4a03"

}

接口返回消息示例数据如下：

{

"config":{

"maxOnlineUser":4999

},

"result":{

"errorMessage":"Success.",

"resultCode":"0"

}

}

父主题： VCM系统配置接口


用户在线数配置管理

接口描述

此接口用于用户在线数配置管理

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/userConfigureManager
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/userConfigureManager HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID=17F834B2A415D1CD3AD166C3F67EF77573F1ADEC1E03E9BD8D52913B9D06CE13

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 |
2 | requestBody | EditConfigRequest | 必选 | •EditConfigRequest

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Object | •Result
1.1 | resultCode | String | 成功返回0，失败返回错误码
1.2 | errorMessage | String | 操作结果描述

使用示例

接口请求消息示例数据如下：

Body：

{

"vcmSession":

"JSESSIONID=439e4647-d99a-431d-b919-228e243e1f64085ea947-8522-4a03"，

"requestBody":{

"config":{

"maxOnlineUser":4999

}}

}

接口返回消息示例数据如下：

{

"result":{

"errorMessage":"Success.",

"resultCode":"0"

}

}

父主题： VCM系统配置接口


AD域配置查询

接口描述

此接口用于获取ad域信息

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/getAdConfig
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/getAdConfig HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID= 19CEB5E8197367F5968E495B062BA3079C8F1A5A3BAAAE15D7E2777C00CBC3F2

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | JSESSIONID= ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Result | •Result
2 | adConfig | AdConfig | •AdConfig

使用示例

接口请求消息示例数据如下：

Body：

{

"vcmSession":

"JSESSIONID= ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c "

}

接口返回消息示例数据如下：

{

"result":{

"errorMessage":"Success.",

"resultCode":"0"

},

"adConfig":{

"domain":"test",

"ip":"10.62.97.136",

"port":"8080"

}

}

父主题： VCM系统配置接口


AD域配置添加

接口描述

此接口用于新增\修改AD域信息

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/setAdConfig
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/setAdConfig HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID= 19CEB5E8197367F5968E495B062BA3079C8F1A5A3BAAAE15D7E2777C00CBC3F2

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | JSESSIONID= ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c
2 | requestBody | AdConfigRequest | 必选 | •AdConfigRequest

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Result | •Result

使用示例

接口请求消息示例数据如下：

Body：

{

"vcmSession":

"JSESSIONID= ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c ",

"requestBody":{

"adConfig":{

"domain":"test",

"ip":"10.62.97.136",

"port":"8080"

}

}

}

接口返回消息示例数据如下：

{

"result":{

"errorMessage":"Success.",

"resultCode":"0"

}

}

父主题： VCM系统配置接口


删除AD域

接口描述

此接口用于删除ad域信息

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/deleteAdConfig
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/deleteAdConfig HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID= 19CEB5E8197367F5968E495B062BA3079C8F1A5A3BAAAE15D7E2777C00CBC3F2

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | JSESSIONID= ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Result | •Result

使用示例

接口请求消息示例数据如下：

Body：

{

"vcmSession":

"JSESSIONID= ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c "

}

接口返回消息示例数据如下：

{

"result":{

"errorMessage":"Success.",

"resultCode":"0"

}

}

父主题： VCM系统配置接口


VCN账号检测

接口描述

此接口用于VCN账号的检测

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/vcnAccountValidate
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/vcnAccountValidate HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID= 19CEB5E8197367F5968E495B062BA3079C8F1A5A3BAAAE15D7E2777C00CBC3F2

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 |
2 | requestBody | VcnAccountValidateRequest | 必选 | •VcnAccountValidateReque...

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Result | •Result

使用示例

接口请求消息示例数据如下：

Body：

{

"vcmSession": "JSESSIONID=ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c",

"requestBody": {

"account": "vcmtest",

"password": "huawei@123",

"ip": "3.18.18.31",

"port": "9900"

}

}

接口返回消息示例数据如下：

{

"result":{

"errorMessage":"Success.",

"resultCode":"0"

}

}

父主题： VCM系统配置接口


特殊名单阈值查询

接口描述

此接口用于获取特殊名单阈值

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/querySpecialThreshold
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/querySpecialThreshold HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID= 19CEB5E8197367F5968E495B062BA3079C8F1A5A3BAAAE15D7E2777C00CBC3F2

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | JSESSIONID= xxx
2 | type | Integer | 必选 | 4

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Result | •Result
2 | responseList | Array | 参考•SearchSpecialThreshold：

使用示例

接口请求消息示例数据如下：

Body：

{"vcmSession":"JSESSIONID=ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c","type":4}

接口返回消息示例数据如下：

{

"responseList": [

{

"algorithmThresholds": [

{

"algorithmCode": "0204000100",

"algorithmName": "huawei_face_sdk",

"similarityThreshold": "80"

}

],

"id": "5e42cb062b906ec8f9964089",

"type": "4"

}

],

"result": {

"errorMessage": "Success.",

"resultCode": "0"

},

"total": 1

}

父主题： VCM系统配置接口


特殊名单阈值设置

接口描述

此接口用于获取ad域信息使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/updateSpecialThreshold
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/updateSpecialThreshold HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID= 19CEB5E8197367F5968E495B062BA3079C8F1A5A3BAAAE15D7E2777C00CBC3F2

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | JSESSIONID= xx
2 | requestBody | SpecialThresholdUpdateRequest | 必选 | •SpecialThresholdUpdateR...

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Result | •Result

使用示例

接口请求消息示例数据如下：

Body：

{"vcmSession":"JSESSIONID=ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c","requestBody":{"specialThreshold":{"algorithmThresholds":[{"algorithmCode":"0204000100","similarityThreshold":"80"}]}},"id":"5e42cb062b906ec8f9964089"}

接口返回消息示例数据如下：

{

"result":{

"errorMessage":"Success.",

"resultCode":"0"

}

}

父主题： VCM系统配置接口


区域信息配置查询

接口描述

此接口用于获取区域信息配置

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/getRegionalInformation
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/getRegionalInformation HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID= xx

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | JSESSIONID= xx
2 | alarmType | String | 必选 | 类型
3 | language | String | 必选 | 语言

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Result | •Result
2 | types | Array | 见•DataDictionaryType：

使用示例

接口请求消息示例数据如下：

Body：

{"vcmSession":"JSESSIONID=ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c","alarmType":"VCM.AREA","language":"zh_CN"}、

接口返回消息示例数据如下：

{

"result": {

"errorMessage": "Success.",

"resultCode": "0"

},

"types": [

{

"dataDictionarys": [

{

"description": "null",

"id": 10000007,

"name": "11---111",

"typeCode": "VCM.AREA",

"value": "123"

}

],

"typeCode": "VCM.AREA"

}

]

}

父主题： VCM系统配置接口


添加区域信息配置

接口描述

此接口用于添加区域信息配置

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/addRegionalInformation
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/addRegionalInformation HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID= xx

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | JSESSIONID= xx
2 | requestBody | AddDataDictionaryRequestEx | 必选 | 见 •AddDataDictionaryReques...

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Result | •Result

使用示例

接口请求消息示例数据如下：

Body：

{

"vcmSession": "JSESSIONID=ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c",

"requestBody": {

"typeCode": "VCM.AREA",

"dataDictionaryList": [

{

"dictionaryNameList": [

{

"name": "1",

"languageCode": "zh_CN"

}

],

"value": "1"

}

]

}

}

接口返回消息示例数据如下：

{

"result":{

"errorMessage":"Success.",

"resultCode":"0"

}

}

父主题： VCM系统配置接口


更新区域信息配置

接口描述

此接口用于更新区域信息配置

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/updateRegionalInformation
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/updateRegionalInformation HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID= xx

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | JSESSIONID= xx
2 | requestBody | UpdateDataDictionaryRequestEx | 必选 | •UpdateDataDictionaryReq...

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Result | •Result
2 | dataDictionarys | Array | •DataDictionary

使用示例

接口请求消息示例数据如下：

Body：

{

"vcmSession": "JSESSIONID=ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c",

"requestBody": {

"dataDictionaryList": [

{

"id": 10000012,

"dictionaryNameList": [

{

"name": "ajf11111111",

"languageCode": "zh_CN"

}

],

"value": "啊a1"

}

]

}

}

接口返回消息示例数据如下：

{

"dataDictionarys": [

{

"code": "0",

"id": "10000012"

}

],

"result": {

"errorMessage": "Success.",

"resultCode": "0"

}

}

父主题： VCM系统配置接口


删除区域信息配置

接口描述

此接口用于删除区域信息配置

使用说明

请求方法 | POST
请求URL | cuServer/vcm/systemInfo/deleteRegionalInformation
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/vcm/systemInfo/deleteRegionalInformation HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

cusSession: JSESSIONID= xx

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | JSESSIONID=xx
2 | requestBody | DeleteDataDictionaryRequestEx | 必选 | •DeleteDataDictionaryReq...

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | result | Result | •Result

使用示例

接口请求消息示例数据如下：

Body：

{

"vcmSession": "JSESSIONID=ec3da875-250e-476e-950a-b835486aaca7232bea02-61ed-490c",

"requestBody": {

"ids": [

10000012

]

}

}

接口返回消息示例数据如下：

{

"result":{

"errorMessage":"Success.",

"resultCode":"0"

}

}

父主题： VCM系统配置接口


1400接口

  • 接收视图库订阅
父主题： 内部接口


接收视图库订阅

接口描述

此接口为内部用于接收视图库订阅消息。

使用说明

请求方法 | POST
请求URL | /VIID/SubscribeNotifications
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /VIID/SubscribeNotifications HTTP/1.1

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

无

响应参数

视图库推送数据。

使用示例

接口请求消息示例数据如下：

https://192.168.203.36:18531/VIID/SubscribeNotifications

父主题： 1400接口


VCM数据分析相关接口

  • 查询VCM实时过车统计数据请求处理接口
  • 查询VCM历史过车统计数据请求处理接口
  • 查询VCM实时过脸统计数据请求处理接口
  • 查询VCM历史过脸统计数据请求处理接口
  • 查询VCM人数统计数据请求处理接口
  • 查询VCM实时过脸告警统计数据请求处理接口
  • 查询VCM历史过脸告警统计数据请求处理接口
  • 实时过车导出Excel接口
  • 历史过车导出Excel接口
  • 实时过脸告警导出Excel接口
  • 历史过脸告警导出Excel接口
  • 实时过脸导出Excel接口
  • 历史过脸导出Excel接口
  • 人数统计导出Excel接口
父主题： 内部接口


查询VCM实时过车统计数据请求处理接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询VCM实时过车统计数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/plateData/realTime
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/plateData/realTime

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | totalCount | Integer | 当前时间点的过车总量
4 | plateDatas | List | 实时过车统计列表,包含下列子项参数
 | time | String | 时间
 | cameraSn | String | 摄像机SN
 | cameraName | String | 摄像机名称
 | count | String | 数量

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/plateData/realTime

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"totalCount": 50,

"plateDatas": [

{

"time": "15577544871",

"cameraSn": "dsafdsfjlakjfe3230255877",

"cameraName": "test_face_00255877",

"count": "50"

}

]

}

父主题： VCM数据分析相关接口


查询VCM历史过车统计数据请求处理接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询VCM历史过车统计数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/plateData/history
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/plateData/history

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | totalCount | Integer | 当前时间点的过车总量
4 | plateDatas | List | 过车统计列表,包含下列子项参数
 | time | String | 时间
 | cameraSn | String | 摄像机SN
 | cameraName | String | 摄像机名称
 | count | String | 数量

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/plateData/history

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"totalCount": 50,

"plateDatas": [

{

"time": "15577544871",

"cameraSn": "dsafdsfjlakjfe3230255877",

"cameraName": "test_face_00255877",

"count": "50"

}

]

}

父主题： VCM数据分析相关接口


查询VCM实时过脸统计数据请求处理接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询VCM实时过脸统计数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/faceData/realTime
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/faceData/realTime

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | totalCount | Integer | 当前时间点的过脸总量
4 | faceDatas | List | 统计列表,包含下列子项参数
 | Time | String | 时间
 | cameraSn | String | 摄像机SN
 | cameraName | String | 摄像机名称
 | Count | String | 数量

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/faceData/realTime

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"totalCount": 50,

"faceDatas": [

{

"time": "15577544871",

"cameraSn": "dsafdsfjlakjfe3230255877",

"cameraName": "test_face_00255877",

"count": "50"

}

]

}

父主题： VCM数据分析相关接口


查询VCM历史过脸统计数据请求处理接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询VCM历史过脸统计数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/faceData/history
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/faceData/history

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | totalCount | Integer | 当前时间点的过脸总量
4 | faceDatas | List | 统计列表,包含下列子项参数
 | Time | String | 时间
 | cameraSn | String | 摄像机SN
 | cameraName | String | 摄像机名称
 | Count | String | 数量

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/faceData/history

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"totalCount": 50,

"faceDatas": [

{

"time": "15577544871",

"cameraSn": "dsafdsfjlakjfe3230255877",

"cameraName": "test_face_00255877",

"count": "50"

}

]

}

父主题： VCM数据分析相关接口


查询VCM人数统计数据请求处理接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询VCM人数统计数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/peopleData
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/peopleData

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | peopleDatas | List | 统计列表，包含下列子项参数
 | in | String | 进入摄像机
 | out | String | 离开摄像机
 | cameraSn | String | 摄像机SN
 | cameraName | String | 摄像机名称

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/peopleData

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"peopleDatas": {

"peopleData": [

{

"in": "10",

"out": "10",

"cameraSn": "dsfafewf3wr32rdsf",

"cameraName": "test_face_0014"

}

]

}

}

父主题： VCM数据分析相关接口


查询VCM实时过脸告警统计数据请求处理接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询VCM实时过脸告警统计数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/faceAlarmData/realTime
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/faceAlarmData/realTime

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | Time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | totalCount | Integer | 总数
4 | faceAlarmDatas | List | 统计列表
 | time | String | 时间
 | cameraSn | String | 摄像机SN
 | cameraName | String | 摄像机名称
 | count | String | 总数

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/faceAlarmData/realTime

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"totalCount": 50,

"faceAlarmDatas": {

"faceAlarmData": [

{

"time": "155746445455",

"cameraSn": "dsafksafjae3232rjksdjf",

"cameraName": "test_face_0478",

"count": "200"

}

]

}

}

父主题： VCM数据分析相关接口


查询VCM历史过脸告警统计数据请求处理接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询VCM历史过脸告警统计数据请求处理。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/faceAlarmData/history
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/faceAlarmData/history

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | Time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | totalCount | Integer | 总数
4 | faceAlarmDatas | List | 统计列表
 | time | String | 时间
 | cameraSn | String | 摄像机SN
 | cameraName | String | 摄像机名称
 | count | String | 总数

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/faceAlarmData/history

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"totalCount": 50,

"faceAlarmDatas": {

"faceAlarmData": [

{

"time": "155746445455",

"cameraSn": "dsafksafjae3232rjksdjf",

"cameraName": "test_face_0478",

"count": "200"

}

]

}

}

父主题： VCM数据分析相关接口


实时过车导出Excel接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后实时过车导出Excel。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/exportPlateTime
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/exportPlateTime

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | Time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表
3 | language | String | 必选 | 语言

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/exportPlateTime

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"language": "zh_cn",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}

父主题： VCM数据分析相关接口


历史过车导出Excel接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后历史过车导出Excel。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/exportPlateRange
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/exportPlateRange

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | Time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表
3 | language | String | 必选 | 语言

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/exportPlateRange

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"language": "zh_cn",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}

父主题： VCM数据分析相关接口


实时过脸告警导出Excel接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后实时过脸告警导出Excel。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/exportFaceAlarmTime
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/exportFaceAlarmTime

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | Time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表
3 | language | String | 必选 | 语言

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/exportFaceAlarmTime

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"language": "zh_cn",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}

父主题： VCM数据分析相关接口


历史过脸告警导出Excel接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后历史过脸告警导出Excel。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/exportFaceAlarmRange
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/exportFaceAlarmRange

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | Time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表
3 | language | String | 必选 | 语言

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/exportFaceAlarmRange

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"language": "zh_cn",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}

父主题： VCM数据分析相关接口


实时过脸导出Excel接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后实时过脸导出Excel。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/exportFaceTime
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/exportFaceTime

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | Time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表
3 | language | String | 必选 | 语言

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/exportFaceTime

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"language": "zh_cn",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}

父主题： VCM数据分析相关接口


历史过脸导出Excel接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后历史过脸导出Excel。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/exportFaceRange
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/exportFaceRange

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | Time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表
3 | language | String | 必选 | 语言

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/exportFaceRange

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"language": "zh_cn",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}

父主题： VCM数据分析相关接口


人数统计导出Excel接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后人数统计导出Excel。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/statisticAnalysis/exportPeople
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/statisticAnalysis/exportPeople

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | searchType、viewMode、time
 | searchType | String | 必选 | 统计方式（0 按时间，1按摄像机）
 | viewMode | String | 必选 | 查询方式 0按年 1按月 2按日
 | Time | String | 必选 | viewMode按日时，值为年份加月份加日份，如20170707
 | cameraSns | List | 必选 | 摄像机编码列表
3 | language | String | 必选 | 语言

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/statisticAnalysis/exportPeople

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"language": "zh_cn",

"requestBody": {

"searchType": "1",

"viewMode": "2",

"time": "20191018",

"cameraSns": [

"31100000000000000101#155735e26e7241e59fbc491093fe99cc",

"31100010000000000101#155735e26e7241e59fbc491093fe99cc"

]

}

}

父主题： VCM数据分析相关接口


域间管理接口

  • 查询域信息接口
  • 更新域信息接口
  • 查询域间账号接口
  • 修改域间账号密码接口
  • 查询域间账号密码同步结果接口
  • 删除其他域的域间账号接口
  • 修改域间IP接口
  • 设置域状态权限接口
  • 指定域编码查询可见分析资源接口
  • 同步下级域的设备信息接口
  • 指定域编码查询订阅资源接口
  • 获取设备域列表接口
  • 查询当前域间关系接口
  • 删除订阅信息接口
  • 重启订阅信息接口
  • 取消订阅订阅信息接口
  • 添加订阅信息接口
  • 查询标签订阅信息接口
  • 添加标签订阅信息接口
  • 删除订阅信息接口
  • 查询域间状态接口
  • 查询域状态权限接口
  • 同步域信息接口
  • 重置域间账号密码接口
  • 查询全量告警订阅信息
  • 添加全量告警订阅信息
父主题： 内部接口


查询域信息接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询域信息接口。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/getDomainInfo
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/getDomainInfo

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | domain | Objet | 域对象,包含下列子项参数
 | domainCode | String | 本级域编码
 | domainName | String | 本级域名称
 | parentDomainAccount | String | 上级域通信账号
 | parentDomainPwd | String | 上级域通信账号密码
 | parentDomainIP | String | 上级域IP地址
 | parentDomainPort | String | 上级域通信端口
 | isRegister | Integer | 0：注销，1：注册
 | description | String | 描述信息
 | natType | String | NAT穿越标识，0表示不需要NAT穿越，1标识需要NAT穿越

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/getDomainInfo

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"domain": {

"domainCode": "4wedgfd0fgfg24dfvd",

"domainName": "test_sdfs",

"parentDomainAccount": "testtd_df",

"parentDomainPwd": "pefsaa0",

"parentDomainIP": "127.0.0.1",

"parentDomainPort": "8099",

"isRegister": 1,

"description": "test_001",

"natType": "21"

}

}

父主题： 域间管理接口


更新域信息接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后更新域信息接口。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/updateDomainInfo
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/updateDomainInfo

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | Base64编码信息

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/updateDomainInfo

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"，

"requestBody": "0dec4a6d992f534b22c1b6f28f1dsfsh5"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


查询域间账号接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询域间账号接口。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/getDomainAccount
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/getDomainAccount

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 含子项参数page、limit、domain-ip
 | page | Integer | 必选 | 页码
 | limit | Integer | 必选 | 分页大小
 | domain-ip | String | 必选 | 域IP地址

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | count | Integer | 查询结果数量
4 | totalCount | Integer | 总数
5 | domainAccountList | List | 域间通信账号列表,包含下列子项参数
 | domainCode | String | 域间编码
 | domainAccount | String | 域账号
 | domainName | String | 域名称
 | domainPwd | String | 域密码
 | domainIP | String | 域IP
 | domainPort | Integer | 域端口
 | type | Integer | 类型
 | natType | Integer | IP类型标记，1表示需经过nat转换

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/getDomainAccount

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"，

"requestBody": "{

page: 1,

limit: 20,

domain-ip: "127.0.0.1"

}"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"count": 10,

"totalCount": 20,

"domainAccountList": [

{

"domainCode": "dsfaiwee0erfe",

"domainAccount": "test_e02",

"domainName": "test_e02",

"domainPwd": "test_e02",

"domainIP": "127.0.0.1",

"domainPort": 8099,

"type": 2,

"natType": 1

}

]

}

父主题： 域间管理接口


修改域间账号密码接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后修改域间账号密码。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/modifyDomainPwd
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/modifyDomainPwd

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | Base64编码信息

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/modifyDomainPwd

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"，

"requestBody": "534b22c1b6f28f17e931efrefdg32132ggf532fd"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


查询域间账号密码同步结果接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询域间账号密码同步结果。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/pwdPublishDetail
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/pwdPublishDetail

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 含子项参数page、limit、domain-ip、status
 | page | Integer | 必选 | 页码
 | limit | Integer | 必选 | 分页大小
 | domain-ip | String | 必选 | 域IP地址
 | status | Integer | 必选 | 状态码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | count | Integer | 查询结果数量
4 | totalCount | Integer | 总数
5 | pwdModifyResult | List | 密码修改结果列表，包含下列子项参数
 | id |  | ID
 | domainAccount |  | 域间通信账号
 | domainIP |  | 域间IP
 | type |  | 账号类型，0：本域，1：其它域
 | status |  | 密码修改结果，0：成功，1：失败

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/pwdPublishDetail

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"，

"requestBody": "{

page: 1,

limit: 20,

domain-ip: "127.0.0.1"，

status: 0

}"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"count": 10,

"totalCount": 20,

"pwdModifyResult": [

{

"id": 15588852525,

"domainAccount": "test_vcjsd",

"domainIP": "127.0.0.1",

"type": 0,

"status": 0

}

]

}

父主题： 域间管理接口


删除其他域的域间账号接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后删除其他域的域间账号。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/delDomainInfo
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/delDomainInfo

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 含子项参数domain-account
 | domain-account | String | 必选 | 域账号

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/delDomainInfo

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"，

"requestBody": "{

domain-account: "vcmtest_001"

}"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


修改域间IP接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后修改域间IP。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/modifyDomainIp
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/modifyDomainIp

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 含子项参数domain-ip、domain-code
 | domain-ip | String | 必选 | 域ip
 | domain-code | String | 必选 | 域编码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/modifyDomainIp

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"，

"requestBody": "{

domain-ip: "127.0.0.1",

domain-code: "abcdefg56hedefdlghsk36dfha19"

}"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


设置域状态权限接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后设置域状态权限。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/setDomainAccountPrivilege
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/setDomainAccountPrivilege

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 含子项参数privileges、domain-code
 | domain-code | String | 必选 | 域编码
 | privileges | List | 必选 | 权限列表,包含下列子项参数
 | type | String | 必选 | 类型
 | totalQuantity | Integer | 必选 | 总数
 | avlQuantity | Integer | 必选 | 平均数

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/setDomainAccountPrivilege

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"requestBody": {

"privileges": [

{

"type": "2",

"totalQuantity": 1000,

"avlQuantity": 57

}

],

"domain-code": "abcdefg56hedefdlghsk36dfha19"

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


指定域编码查询可见分析资源接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后指定域编码查询可见分析资源。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/getDomainDeviceList
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/getDomainDeviceList

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列子项参数
 | domainCode | String | 必选 | 域编码
 | cameraName | String | 必选 | 摄像机名称
 | use | Integer | 必选 | 类型：1表示物理卡口 2表示智能分析任务
 | type | String | 必选 | 当use为1：type值表示人卡口和车卡口 当use为2：type值表示具体的智能分析类型， 如人脸识别，车牌识别，行为分析等
 | algorithmCode | String | 必选 | 算法code
 | isSubscribed | String | 必选 | 是否被订阅
 | page | Integer | 必选 | 页码
 | limit | Integer | 必选 | 分页大小

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/getDomainDeviceList

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"requestBody": {

"domainCode": "47bcdsfsfsdfefa",

"cameraName": "test_face_001",

"use": 2,

"type": "2",

"algorithmCode": "47bcsaf3w32r23sdfz",

"isSubscribed": "true",

"page": 1,

"limit": 20

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


同步下级域的设备信息接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后同步下级域的设备信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/syncDomainCameraInfo
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/syncDomainCameraInfo

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 含子项参数domain-code
 | domain-code | String | 必选 | 域编码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/syncDomainCameraInfo

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"，

"requestBody": "{

domain-code: "abcdefg56hedefdlghsk36dfha19"

}"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


指定域编码查询订阅资源接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后指定域编码查询订阅资源。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/getSubscribeData
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/getSubscribeData

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列子项参数
 | domainCode | String | 必选 | 域编码（必选）
 | cameraSn | String | 必选 | 摄像机SN
 | cameraName | String | 必选 | 摄像机名称
 | subscribeType | String | 必选 | 订阅类型：1-人，2-车，3-行为分析告警。未订阅时该值为空（必选）
 | subscribeStatus | String | 必选 | 订阅状态：0-未订阅；1-订阅中；2-已订阅；3-取消订阅中；4-ALL
 | isFeature | String | 必选 | 是否需要推送特征值
 | page | String | 必选 | 页码
 | limit | String | 必选 | 分页大小
 | algorithmCode | String | 必选 | 算法code

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/getSubscribeData

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"requestBody": {

"domainCode": "c5255dddweewfew2321",

"cameraSn": "d3243c525565h87043g32",

"cameraName": "test_face_0025",

"subscribeType": "2",

"subscribeStatus": "1",

"isFeature": "false",

"page": "2",

"limit": "20",

"algorithmCode": "sadfsa3wqfe2df32435"

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


获取设备域列表接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后获取设备域列表。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/getDomainList
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/getDomainList

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/getDomainList

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


查询当前域间关系接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询当前域间关系。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/getDomainRelationList
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/getDomainRelationList

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/getDomainRelationList

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


删除订阅信息接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后删除订阅信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/deleteSubscribeData
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/deleteSubscribeData

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列子项参数
 | taskId | String | 必选 | 任务ID
 | subscribeInfoList | List | 必选 | 订阅ID列表，包含下列子项参数
 | subscribe-id | String | 必选 | 订阅ID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/deleteSubscribeData

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"requestBody": {

"taskId": "05d5f5sdaf2454218542",

"subscribe-info-list": [

{

"subscribe-id": "2454218542"

}

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


重启订阅信息接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后重启订阅信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/restartSubscribeData
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/restartSubscribeData

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列子项参数
 | taskId | String | 必选 | 任务ID
 | subscribeInfoList | List | 必选 | 订阅ID列表，包含下列子项参数
 | subscribe-id | String | 必选 | 订阅ID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/restartSubscribeData

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"requestBody": {

"taskId": "05d5f5sdaf2454218542",

"subscribe-info-list": [

{

"subscribe-id": "2454218542"

}

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


取消订阅订阅信息接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后取消订阅订阅信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/cancelSubscribeData
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/cancelSubscribeData

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列子项参数
 | taskId | String | 必选 | 任务ID
 | subscribeInfoList | List | 必选 | 订阅ID列表，包含下列子项参数
 | subscribe-id | String | 必选 | 订阅ID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/cancelSubscribeData

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"requestBody": {

"taskId": "05d5f5sdaf2454218542",

"subscribe-info-list": [

{

"subscribe-id": "2454218542"

}

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


添加订阅信息接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后添加订阅信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/addSubscribeData
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/addSubscribeData

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列子项参数
 | srcDomainCode | String | 必选 | 源域编码
 | dstDomainCode | String | 必选 | 目的域编码
 | isDomainTask | String | 必选 | 是否是多域的订阅任务
 | isVisible | String | 必选 | 是否可见
 | subscribeInfoList | List | 必选 | 订阅信息列表，包含下列子项参数
 | cameraSn | String | 必选 | 摄像机SN
 | cameraName | String | 必选 | 摄像机名称
 | taskId | String | 必选 | 任务ID
 | subscribeType | String | 必选 | 订阅类型
 | subscribeStatus | String | 必选 | 订阅状态
 | isFeature | String | 必选 | 是否特性开启
 | domainDeviceId | String | 必选 | 域设备ID
 | dataPassbackType | String | 必选 | 数据通过类型
 | fileId | String | 必选 | 字段ID
 | originalFileId | String | 必选 | 原始字段ID
 | analysisType | Integer | 必选 | 分析类型
 | isDomainTopic | Integer | 必选 | 是否域间Topic

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/addSubscribeData

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"requestBody": {

"srcDomainCode": "6sadfhj34sf47bc",

"dstDomainCode": "9666fhj34sf47bc",

"isDomainTask": "false",

"isVisible": "true",

"subscribe-info-list": [

{

"cameraSn": "sdafhsklasfjlewfwe2435df",

"cameraName": "test_face_0025",

"taskId": "22555",

"subscribeType": "2",

"subscribeStatus": "1",

"isFeature": "true",

"domainDeviceId": "2s5dsfwe5522sd2f5s",

"dataPassbackType": "2",

"fileId": "15556656",

"originalFileId": "8955552",

"analysisType": "2",

"isDomainTopic": "true",

}

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


查询标签订阅信息接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询标签订阅信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/getLabelSubscribeData
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/getLabelSubscribeData

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列子项参数
 | domainCode | String | 必选 | 域编码（必选）
 | cameraSn | String | 必选 | 摄像机SN
 | cameraName | String | 必选 | 摄像机名称
 | subscribeType | String | 必选 | 订阅类型：1-人，2-车，3-行为分析告警。未订阅时该值为空（必选）
 | subscribeStatus | String | 必选 | 订阅状态：0-未订阅；1-订阅中；2-已订阅；3-取消订阅中；4-ALL
 | isFeature | String | 必选 | 是否需要推送特征值
 | page | String | 必选 | 页码
 | limit | String | 必选 | 分页大小
 | algorithmCode | String | 必选 | 算法code

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/getLabelSubscribeData

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"requestBody": {

"domainCode": "155dfdsfslfjewaf555",

"cameraSn": "45457542158451241",

"cameraName": "test_face_00255",

"subscribeType": "1",

"subscribeStatus": "0",

"isFeature": "true",

"page": "20",

"limit": "50",

"algorithmCode": "55858df5dsafa5e5f5ae"

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"subscribeInfoList": []

}

父主题： 域间管理接口


添加标签订阅信息接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后添加标签订阅信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/addLabelSubscribeData
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/addLabelSubscribeData

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列子项参数
 | srcDomainCode | String | 必选 | 源域编码
 | dstDomainCode | String | 必选 | 目的域编码
 | isDomainTask | String | 必选 | 是否是多域的订阅任务
 | isVisible | String | 必选 | 是否可见
 | subscribeInfoList | List | 必选 | 订阅信息列表，包含下列子项参数
 | cameraSn | String | 必选 | 摄像机SN
 | cameraName | String | 必选 | 摄像机名称
 | taskId | String | 必选 | 任务ID
 | subscribeType | String | 必选 | 订阅类型
 | subscribeStatus | String | 必选 | 订阅状态
 | isFeature | String | 必选 | 是否特性开启

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/addLabelSubscribeData

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"requestBody": {

"srcDomainCode": "6sadfhj34sf47bc",

"dstDomainCode": "9666fhj34sf47bc",

"isDomainTask": "false",

"isVisible": "true",

"subscribe-info-list": [

{

"cameraSn": "sdafhsklasfjlewfwe2435df",

"cameraName": "test_face_0025",

"taskId": "22555",

"subscribeType": "2",

"subscribeStatus": "1",

"isFeature": "true",

"domainDeviceId": "2s5dsfwe5522sd2f5s",

"dataPassbackType": "2",

"fileId": "15556656",

"originalFileId": "8955552",

"analysisType": "2",

"isDomainTopic": "true",

}

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


删除订阅信息接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后删除订阅信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/deleteLabelSubscribeData
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/deleteLabelSubscribeData

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列子项参数
 | dst-domain-code | String | 必选 | 目标域编码
 | subscribeInfoList | List | 必选 | 订阅ID列表，包含下列子项参数
 | subscribe-id | String | 必选 | 订阅ID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/deleteLabelSubscribeData

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"requestBody": {

"dst-domain-code": "05d5f5sdaf2454218542",

"subscribe-info-list": [

{

"subscribe-id": "2454218542"

}

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


查询域间状态接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询域间状态。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/getDomainStatus
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/getDomainStatus

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | domainCode | String | 必选 | 域间编码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/getDomainStatus

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"domainCode": "abcdefg56hedefdlghsk36dfha19"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


查询域状态权限接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询域状态权限。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/getDomainAccountPrivilege
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/getDomainAccountPrivilege

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | domainCode | String | 必选 | 域间编码
3 | privilegeType | String | 必选 | 权限类别
4 | queryType | String | 必选 | 查询类别

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/getDomainAccountPrivilege

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

"domainCode": "abcdefg56hedefdlghsk36dfha19",

"privilegeType": "2",

"queryType": "0"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


同步域信息接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后同步域信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/syncDomainInfo
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/syncDomainInfo

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/syncDomainInfo

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc"

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


重置域间账号密码接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后重置域间账号密码。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/resetDomainPwd
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/resetDomainPwd

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列子项参数
 | domain-account | String | 必选 | 域间账号

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/resetDomainPwd

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

" requestBody": {

"domain-account": "testkfdla5e66afsewa"

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


查询全量告警订阅信息

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询全量告警订阅信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/getAlarmSubscribeData
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/getAlarmSubscribeData

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

请求字段 | 字段类型 | 可选/必选 | 字段名称
vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
requestBody | String | 必选 | 包含下列子项参数
dstDomainCode | String | 必选 | 域编码（必选）
subscribeType | String | 可选 | 订阅类型

响应参数

请求字段 | 字段类型 | 字段名称
resultCode | String | VCM返回响应错误码
errorMessage | String | 错误消息
DataSubscribeQueryResponse | DataSubscribeQueryResponse |

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/getAlarmSubscribeData

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

" requestBody": {

"dstDomainCode": "testkfdla5e66afsewa",

"subscribeType": "testkfdla5e66afsewa"

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0",

"subscribeAllInfoList": [{

"subscribeType": "4",

"alarmType": "1",

"enableAllSubscribe": "0"

}]

}

父主题： 域间管理接口


添加全量告警订阅信息

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后添加全量告警订阅信息。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/domainManagement/addAlarmlSubscribeData
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/domainManagement/addAlarmlSubscribeData

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

请求字段 | 字段类型 | 可选/必选 | 字段名称
vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
requestBody | String | 必选 | 包含下列子项参数
srcDomainCode | String | 必选 | 源域编码
dstDomainCode | String | 必选 | 目的域编码
subscribeInfoList | List<DomainSubscribeAllBean> | 必选 | 订阅信息列表•DomainSubscribeAllBean

响应参数

请求字段 | 字段类型 | 字段名称
resultCode | String | VCM返回响应错误码
errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/domainManagement/addAlarmlSubscribeData

{

"vcmSession": "JSESSIONID=d143a1ee-0dec-4a6d-992f-534b22c1b6f28f17e931-5256-47bc",

" requestBody": {

"srcDomainCode": "testkfdla5e66afsewa",

"dstDomainCode": "testkfdla5e66afsewa",

"subscribeInfoList": [{

"subscribeType": "4",

"alarmType": "1",

"enableAllSubscribe": "0"

}]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resultCode": "0"

}

父主题： 域间管理接口


布控任务接口

  • 查询布控任务接口
  • 新增布控任务接口
  • 编辑布控任务接口
  • 删除布控任务接口
父主题： 内部接口


查询布控任务接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后查询布控任务。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/suspectTask/searchSuspectTask
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/suspectTask/searchSuspectTask

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列参数
 | suspectId | String | 非必选 | 布控id
 | name | String | 非必选 | 布控任务名称，支持中文、英文、数字和.·-空格，首位不为特殊字符，长度[1,255]
 | startCreateTime | String | 非必选 | 布控任务创建开始时间,时间戳
 | endCreateTime | String | 非必选 | 布控任务创建结束时间,时间戳
 | createUser | String | 非必选 | 布控任务创建者
 | type | String | 非必选 | 1. 表示车辆布控 2. 表示人脸黑名单布控 3. 表示人脸白名单布控 -1,所有
 | enable | String | 非必选 | 是否启用
 | effectiveStatus | String | 非必选 | effectiveStatus
 | bayonetSn | String | 非必选 | 卡口编号
 | domains | List | 非必选 | 布控域信息
 | cameraSn | String | 非必选 | 摄像机编号
 | blackGroupId | String | 非必选 | 黑名单组id
 | groupId | String | 非必选 | 组别ID
 | page | Object | 必选 | 分页对象
 | cameraList | List | 非必选 | 摄像机列表
 | libraryId | String | 非必选 | 类别ID

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | Total | String | 总数
4 | suspectList | List | 布控任务列表，包含Suspect参数
5 | Suspect | Object | 布控任务对象，包含下列子项参数
 | srcDomainCode | String | 源域编码
 | srcDomainName | String | 源域名称
 | dstDomainCode | String | 目标域编码
 | suspectId | String | 主键
 | Name | String | 布控名称
 | Type | String | 类型
 | Enable | String | 是否启用
 | effectiveStatus | String | 布控过期状态 0:过期；1:不过期
 | createTime | String | 创建时间
 | createUser | String | 创建人
 | taskStatus | String | 布控任务状态，0为布控成功 1为布控中 2为布控失败
 | startDate | String | 开始日期
 | endDate | String | 结束日期
 | alarmLevel | String | v1.1版本新加入
 | hitType | String | 命中类型
 | confidenceThreshold | String | 默认值85
 | plateSimilar | String | plateSimilar
 | topN | String | topN
 | cameraList | List | 摄像机列表
 | timeList | List | 时间列表
 | Domains | List | 域间信息
 | blackGroupList | List | 黑名单组列表
 | groupList | List | 组别列表
 | libraryList | List | 静态库列表
 | Thresholds | List | 算法布控阈值信息列表
 | qualityThresholds | List | 质量分阈值
 | unSuspectedLibraryList | List | 疑似告警名单库列表（最多1个）

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/suspectTask/searchSuspectTask

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"requestBody": {

"page": {

"no": 1,

"pageSize": 20

}

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resulitCode": "0",

"total": "50",

"suspectList": {

"suspect": [

{

"srcDomainCode": "4ds545f5e0ewrew24455",

"srcDomainName": "test_or001",

"dstDomainCode": "6dhjuehdakhkahdhk455",

"suspectId": "0ewrew24455",

"Name": "test_or001",

"Type": "2",

"Enable": "true",

"effectiveStatus": "1",

"createTime": "152365585555",

"createUser": "test_or001",

"taskStatus": "0",

"startDate": "2019-02-14",

"endDate": "2019-02-14",

"alarmLevel": "7",

"hitType": "3",

"confidenceThreshold": "85",

"plateSimilar": "4ds545f55",

"topN": "dgser4ds545f",

"cameraList": [

],

"timeList": [

],

"Domains": [

],

"blackGroupList": [

],

"groupList": [

],

"libraryList": [

],

"Thresholds": [

],

"qualityThresholds": [

],

"unSuspectedLibraryList": [

]

}

]

}

}

父主题： 布控任务接口


新增布控任务接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后新增布控任务。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/suspectTask/addSuspectTask
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/suspectTask/addSuspectTask

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列参数
 | srcDomainCode | String | 非必选 | 发起方域编码
 | dstDomainCode | String | 非必选 | 目标域编码
 | domainRoute | String | 非必选 | 域间路由(内部使用字段)
 | suspectId | String | 非必选 | 布控ID，全域唯一(内部使用字段)
 | exSuspectId | String | 非必选 | 1400扩展布控任务ID
 | type | String | 必选 | 布控类型：1车辆布控 2人脸黑名单布控 3人脸白名单布控
 | hitType | String | 非必选 | 默认命中布控:1
 | name | String | 必选 | 布控任务名称
 | startDate | String | 必选 | 布控生效开始日期，时间格式YYYY-MM-DD
 | endDate | String | 必选 | 布控生效结束日期，时间格式YYYY-MM-DD
 | cameraList | List | 非必选 | 布控的卡口信息（兼容历史版本）
 | cameraSns | List | 非必选 | 布控的摄像机列表信息（1.2版本专用）
 | blackGroupList | List | 非必选 | 布控的黑名单组信息（兼容历史版本）
 | timeList | List | 必选 | 布控生效时间片段（最多100个）
 | groupList | List | 必选 | 黑名单组列表（最多100个）
 | topN | String | 非必选 | 布控告警topN，默认值为1
 | domains | List | 非必选 | 布控目标域及卡口组信息
 | libraryList | List | 非必选 | 静态库信息
 | unSuspectedLibraryList | List | 非必选 | 疑似告警名单库列表（最多1个）
 | alarmLevel | String | 非必选 | 默认为紧急:1
 | confidenceThreshold | String | 非必选 | 默认阈值:85
 | createUser | String | 非必选 | 布控任务创建者，从session中取(内部使用字段)
 | dtype | Integer | 非必选 | 新增，是否为适配多级多域新增的mongo数据类型(内部使用)
 | dstcodes | List | 非必选 | 新增，多级多域目标域信息(内部使用)
 | plateSimilar | String | 非必选 | 相似车牌开关
 | thresholds | List | 非必选 | 算法布控阈值信息列表
 | qualityThresholds | List | 非必选 | 质量分阈值

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | suspectId | String | 布控id
4 | exSuspectId | String | 1400扩展布控任务ID
5 | invalidCameraSns | List | 无效摄像机列表，指定摄像机布控时，如果摄像机不存在，系统会将无效摄像机过滤后新增或编辑布控任务，并返回无效的摄像机编码。

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/suspectTask/addSuspectTask

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"requestBody": {

"type": "2",

"name": "test_2test",

"startDate": "2019-02-14",

"endDate": "2019-02-14",

"timeList": [

{

"day": "2",

"startDate": "14:25:11",

"endDate": "21:37:40"

}

],

"groupList": [

{

"groupId": "4",

}

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resulitCode": "0",

"suspectId": "50",

"exSuspectId": "10",

"invalidCameraSns": []

}

父主题： 布控任务接口


编辑布控任务接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后编辑布控任务。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/suspectTask/editSuspectTask
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/suspectTask/editSuspectTask

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列参数
 | srcDomainCode | String | 非必选 | 发起方域编码
 | dstDomainCode | String | 非必选 | 目标域编码
 | suspectId | String | 非必选 | 布控ID，全域唯一(内部使用字段)
 | exSuspectId | String | 非必选 | 1400扩展布控任务ID
 | type | String | 必选 | 布控类型：1车辆布控 2人脸黑名单布控 3人脸白名单布控
 | hitType | String | 非必选 | 默认命中布控:1
 | name | String | 必选 | 布控任务名称
 | startDate | String | 必选 | 布控生效开始日期，时间格式YYYY-MM-DD
 | endDate | String | 必选 | 布控生效结束日期，时间格式YYYY-MM-DD
 | cameraList | List | 非必选 | 布控的卡口信息（兼容历史版本）
 | cameraSns | List | 非必选 | 布控的摄像机列表信息（1.2版本专用）
 | blackGroupList | List | 非必选 | 布控的黑名单组信息（兼容历史版本）
 | timeList | List | 必选 | 布控生效时间片段（最多100个）
 | groupList | List | 必选 | 黑名单组列表（最多100个）
 | topN | String | 非必选 | 布控告警topN，默认值为1
 | domains | List | 非必选 | 布控目标域及卡口组信息
 | libraryList | List | 非必选 | 静态库信息
 | unSuspectedLibraryList | List | 非必选 | 疑似告警名单库列表（最多1个）
 | alarmLevel | String | 非必选 | 默认为紧急:1
 | confidenceThreshold | String | 非必选 | 默认阈值:85
 | createUser | String | 非必选 | 布控任务创建者，从session中取(内部使用字段)
 | bwGroups | List | 非必选 | 仅域间使用
 | plateSimilar | String | 非必选 | 相似车牌开关
 | thresholds | List | 非必选 | 算法布控阈值信息列表
 | qualityThresholds | List | 非必选 | 质量分阈值

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息
3 | suspectId | String | 布控id
4 | invalidCameraSns | List | 无效摄像机列表，指定摄像机布控时，如果摄像机不存在，系统会将无效摄像机过滤后新增或编辑布控任务，并返回无效的摄像机编码。

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/suspectTask/editSuspectTask

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"requestBody": {

"type": "2",

"name": "test_2test",

"startDate": "2019-02-14",

"endDate": "2019-02-14",

"timeList": [

{

"day": "2",

"startDate": "14:25:11",

"endDate": "21:37:40"

}

],

"groupList": [

{

"groupId": "4",

}

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resulitCode": "0",

"suspectId": "50",

"invalidCameraSns": []

}

父主题： 布控任务接口


删除布控任务接口

接口描述

调用该接口前需要登录VCM平台成功，并且将从VCM获取到的SessionID并传入相关参数该接口，然后删除布控任务。

使用说明

请求方法 | POST
请求URL | cuServer/vcm/suspectTask/deleteSuspectTask
请求数据 | application/json;charset=UTF-8

HTTP Headers示例如下：

POST cuServer/vcm/suspectTask/deleteSuspectTask

Host: 192.168.203.36:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmSession | String | 必选 | 登录VCM平台成功之后，获取到的SessionID
2 | requestBody | String | 必选 | 包含下列参数
 | srcDomainCode | String | 非必选 | 发起方域编码
 | dstDomainCode | String | 非必选 | 目标域编码
 | suspectIds | List | 非必选 | 布控id列表（最多100个）
 | type | String | 必选 | 布控类型：1车辆布控 2人脸黑名单布控 3人脸白名单布控

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | VCM返回响应错误码
2 | errorMessage | String | 错误消息

使用示例

接口请求消息示例如下：

https://192.168.203.36:18531/cuServer/vcm/suspectTask/deleteSuspectTask

{

"vcmSession": "JSESSIONID=86332369-3b4a-47d1-bc80-5dffe177b050e9b7b223-6049-4d04",

"requestBody": {

"type": "2",

"srcDomainCode": "205258855sdggf2345",

"dstDomainCode": "2019dfdfh35r325566",

"suspectList": [

{

" suspectId ": "4"

}

]

}

}

接口返回消息示例数据如下：

{

"errorMessage": "Success.",

"resulitCode": "0"

}

父主题： 布控任务接口


通用接口

  • 设置VCM服务器信息
父主题： 内部接口


设置VCM服务器信息

接口描述

此接口用于设置VCM服务器信息

使用说明

请求方法 | POST
请求URL | cuServer/common/setVcmServerInfo
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/common/setVcmServerInfo HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | vcmIp | String | 必选 | Vcm的ip地址
2 | vcmPort | String | 可选 | Vcm的端口

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 成功返回0，失败返回错误码

使用示例

接口请求消息示例数据如下：

Body：

{

"vcmIp":"1.1.1.1",

"vcmPort":"20"

}

接口返回消息示例数据如下：

{

"resultCode":"0"

}

父主题： 通用接口


GIS服务接口

  • 获取GIS Token请求处理
  • 通过GIS服务器配置信息获取GIS Token请求处理
  • 新增图层信息请求处理
  • 修改图层信息请求处理
  • 获取所有图层信息请求处理
  • 获取指定GIS服务器配置信息请求处理
  • 删除GIS服务器配置信息请求处理
父主题： 内部接口


获取GIS Token请求处理

接口描述

此接口用于获取GIS Token请求处理

使用说明

请求方法 | GET
请求URL | cuServer/gis/getGisToken/{layerCode}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET /cuServer/gis/getGisToken/{layerCode} HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | layerCode | String | 必选 | 图层编码

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 失败返回错误码，成功返回0
2 | content | GetGisTokenContent | 见•GetGisTokenContent

使用示例

接口请求消息示例数据如下：

https://3.18.18.31:18531/cuServer/gis/getGisToken/123

接口返回消息示例数据如下：

{"resultCode":0,"content":{"gisTokenInfo":{"gisToken":"a","expiration":"11"}}}

父主题： GIS服务接口


通过GIS服务器配置信息获取GIS Token请求处理

接口描述

此接口用于通过GIS服务器配置信息获取GIS Token请求处理

使用说明

请求方法 | POST
请求URL | cuServer/gis/getGisTokenByServerInfo
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/gis/getGisTokenByServerInfo HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | isEnableConfig | String | 必选 |
2 | gisServerCode | String |  |
3 | gisServerName | String |  |
4 | gisServerIP | String |  |
5 | gisServerPort | String |  |
6 | gisUsername | String |  |
7 | gisPassword | String |  |
8 | gisServerType | String |  |
9 | expiration | String |  |
10 | isNeedLogin | String |  |

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 失败返回错误码，成功返回0
2 | content | GetGisTokenContent | 见•GetGisTokenContent

使用示例

接口请求消息示例数据如下：

{

"isEnableConfig":"",

"gisServerCode":"",

"gisServerName":"",

"gisServerIP":"",

"gisServerPort":"",

"gisUsername":"",

"gisPassword":"",

"gisServerType":"",

"expiration":"",

"isNeedLogin":""

}

接口返回消息示例数据如下：

{

"resultCode":0,

"content":{

"gisTokenInfo":{

"gisToken":"",

"expiration":""

}

}

}

父主题： GIS服务接口


新增图层信息请求处理

接口描述

此接口用于新增图层信息请求处理

使用说明

请求方法 | POST
请求URL | cuServer/gis/addLayerInfo
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/gis/addLayerInfo HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | gisServerInfo | GisServerInfo | 必选 | 见 •GisServerInfo
2 | layerInfo | String | 必选 |

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 失败返回错误码，成功返回0
2 | content | AddLayerInfoContent | 见•AddLayerInfoContent

使用示例

接口请求消息示例数据如下：

{

"layerInfo":"",

"gisServerInfo":{

"isEnableConfig":"",

"gisServerCode":"",

"gisServerName":"",

"gisServerIP":"",

"gisServerPort":"",

"gisUsername":"",

"gisPassword":"",

"gisServerType":"",

"expiration":"",

"isNeedLogin":""

}

}

接口返回消息示例数据如下：

{

"resultCode":0,

"content":{

"layerCode":""

}

}

父主题： GIS服务接口


修改图层信息请求处理

接口描述

此接口用于修改图层信息请求处理

使用说明

请求方法 | POST
请求URL | cuServer/gis/modifyLayerInfo
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

POST /cuServer/gis/addLayerInfo HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | gisServerInfo | GisServerInfo | 必选 | 见 •GisServerInfo
2 | layerCode | String | 必选 |
3 | layerInfo | String | 必选 |

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 失败返回错误码，成功返回0

使用示例

接口请求消息示例数据如下：

{

"layerInfo":"",

"layerCode":"",

"gisServerInfo":{

"isEnableConfig":"",

"gisServerCode":"",

"gisServerName":"",

"gisServerIP":"",

"gisServerPort":"",

"gisUsername":"",

"gisPassword":"",

"gisServerType":"",

"expiration":"",

"isNeedLogin":""

}

}

接口返回消息示例数据如下：

{

"resultCode":0

}

父主题： GIS服务接口


获取所有图层信息请求处理

接口描述

此接口用于获取所有图层信息请求处理

使用说明

请求方法 | GET
请求URL | cuServer/gis/getAllLayerInfo
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET cuServer/gis/getAllLayerInfo HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

无

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | content | GetLayerInfoContent | 见•GetLayerInfoContent
2 | resultCode | String | 失败返回错误码，成功返回0

使用示例

接口请求消息示例数据如下：

https://3.18.18.31:18531/cuServer/gis/getAllLayerInfo

接口返回消息示例数据如下：

{

"resultCode":0,

"content":{

"layerInfoList":[{

"layerCode":"",

"layerInfo":"",

"gisServerInfo":{

"isEnableConfig":"",

"gisServerCode":"",

"gisServerName":"",

"gisServerIP":"",

"gisServerPort":"",

"gisUsername":"",

"gisPassword":"",

"gisServerType":"",

"expiration":"",

"isNeedLogin":""

}

}]

}

}

父主题： GIS服务接口


获取指定GIS服务器配置信息请求处理

接口描述

此接口用于获取指定GIS服务器配置信息请求处理

使用说明

请求方法 | GET
请求URL | cuServer/gis/getLayerInfo/{layerCode}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET cuServer/gis/getLayerInfo/{layerCode} HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | layerCode | String | 必选 |

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | content | GetLayerInfoContent | 见•GetLayerInfoContent
2 | resultCode | String | 失败返回错误码，成功返回0

使用示例

接口请求消息示例数据如下：

https://3.18.18.31:18531/cuServer/gis/getLayerInfo/123

接口返回消息示例数据如下：

{

"resultCode":0,

"content":{

"layerInfoList":[{

"layerCode":"",

"layerInfo":"",

"gisServerInfo":{

"isEnableConfig":"",

"gisServerCode":"",

"gisServerName":"",

"gisServerIP":"",

"gisServerPort":"",

"gisUsername":"",

"gisPassword":"",

"gisServerType":"",

"expiration":"",

"isNeedLogin":""

}

}]

}

}

父主题： GIS服务接口


删除GIS服务器配置信息请求处理

接口描述

此接口用于删除GIS服务器配置信息请求处理

使用说明

请求方法 | DELETE
请求URL | cuServer/gis/deleteLayerInfo/{layerCode}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

DELETE /cuServer/gis/deleteLayerInfo/{layerCode} HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | layerCode | String | 必选 |

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 失败返回错误码，成功返回0

使用示例

接口请求消息示例数据如下：

https://3.18.18.31:18531/cuServer/gis/deleteLayerInfo/123

接口返回消息示例数据如下：

{

"resultCode":0

}

父主题： GIS服务接口


系统及用户文件处理接口

  • 上传系统文件请求处理
  • 下载全部系统文件请求处理
  • 下载系统文件请求处理
  • 上传用户文件请求处理
  • 下载全部用户文件请求处理
  • 下载指定用户文件请求处理
  • 获取文件SHA值请求处理
父主题： 内部接口


上传系统文件请求处理

接口描述

此接口用于上传文件请求处理

使用说明

请求方法 | PUT
请求URL | cuServer/systemConfigFile/setSystemConfigFile
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

PUT /cuServer/systemConfigFile/setSystemConfigFile HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | fileName | String | 必选 |
2 | fileContent | String | 必选 |

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 失败返回错误码，成功返回0

使用示例

接口请求消息示例数据如下：

{

"fileName":"",

"fileContent":""

}接口返回消息示例数据如下：

{

"resultCode":0

}

父主题： 系统及用户文件处理接口


下载全部系统文件请求处理

接口描述

此接口用于下载全部文件请求处理

使用说明

请求方法 | GET
请求URL | cuServer/systemConfigFile/getAllSystemConfigFiles
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET cuServer/systemConfigFile/getAllSystemConfigFiles HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

无

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | content | GetSystemFileContent | 见•GetSystemFileContent
2 | resultCode | String | 失败返回错误码，成功返回0

使用示例

接口请求消息示例数据如下：

https://3.18.18.31:18531/cuServer/systemConfigFile/getAllSystemConfigFiles

接口返回消息示例数据如下：

{

"resultCode":0,

"content":{

"fileInfoList":[{

"fileName":"",

"fileName":""

}]

}

}

父主题： 系统及用户文件处理接口


下载系统文件请求处理

接口描述

此接口用于下载文件请求处理

使用说明

请求方法 | GET
请求URL | cuServer/systemConfigFile/getSystemConfigFile/{fileName}
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET cuServer/systemConfigFile/getSystemConfigFile/{fileName} HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | fileName | String | 必选 |

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | content | GetSystemFileContent | 见•GetSystemFileContent
2 | resultCode | String | 失败返回错误码，成功返回0

使用示例

接口请求消息示例数据如下：

https://3.18.18.31:18531/cuServer/systemConfigFile/getSystemConfigFile/eeee

接口返回消息示例数据如下：

{

"resultCode":0,

"content":{

"fileInfoList":[{

"fileName":"",

"fileName":""

}]

}

}

父主题： 系统及用户文件处理接口


上传用户文件请求处理

接口描述

此接口用于上传文件请求处理

使用说明

请求方法 | PUT
请求URL | cuServer/userConfigFile/setUserConfigFile
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

PUT /cuServer/userConfigFile/setUserConfigFile HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | fileName | String | 必选 |
2 | filePath | String | 必选 |
3 | fileBase64Value | String | 必选 |
4 | shaValue | String | 必选 |

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | resultCode | String | 失败返回错误码，成功返回0

使用示例

接口请求消息示例数据如下：

{

"fileName":"",

"fileContent":"",

"fileBase64Value":"",

"shaValue":""

}

接口返回消息示例数据如下：

{

"resultCode":0

}

父主题： 系统及用户文件处理接口


下载全部用户文件请求处理

接口描述

此接口用于下载全部文件请求处理

使用说明

请求方法 | GET
请求URL | cuServer/userConfigFile/getAllUserConfigFiles
请求数据 | application/json;charset=UTF-8

HTTP Header示例如下：

GET cuServer/userConfigFile/getAllUserConfigFiles HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | content | GetUserFileContent | 见•GetUserFileContent
2 | resultCode | String | 失败返回错误码，成功返回0

使用示例

接口请求消息示例数据如下：

https://3.18.18.31:18531/cuServer/userConfigFile/getAllUserConfigFiles

接口返回消息示例数据如下：

{

"resultCode":0,

"content":{

"fileInfoList":[{

"fileName":"",

"fileContent":"",

"fileBase64Value":"",

"shaValue":

}]

}

}

父主题： 系统及用户文件处理接口


下载指定用户文件请求处理

接口描述

此接口用于下载指定文件请求处理

使用说明

请求方法 | GET
请求URL | cuServer/userConfigFile/getUserConfigFile/{fileName}
请求数据 | application/json;charset=UTF-8

GET Header示例如下：

POST cuServer/userConfigFile/getUserConfigFile/{fileName} HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | fileName | String | 必选 |

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | content | GetUserFileContent | 见•GetUserFileContent
2 | resultCode | String | 失败返回错误码，成功返回0

使用示例

接口请求消息示例数据如下：

https://3.18.18.31:18531/cuServer/userConfigFile/getUserConfigFile/zz

接口返回消息示例数据如下：

{

"resultCode":0,

"content":{

"fileInfoList":[{

"fileName":"",

"fileContent":"",

"fileBase64Value":"",

"shaValue":

}]

}

}

父主题： 系统及用户文件处理接口


获取文件SHA值请求处理

接口描述

此接口用于获取文件SHA值请求处理

使用说明

请求方法 | GET
请求URL | cuServer/userConfigFile/getShaForFile/{fileName}
请求数据 | application/json;charset=UTF-8

GET Header示例如下：

POST cuServer/userConfigFile/getShaForFile/{fileName} HTTP/1.1

Host: 3.18.18.31:18531

Content-Type: application/json

Cache-Control: no-cache

参数描述

请求参数

序号 | 请求字段 | 字段类型 | 可选/必选 | 字段名称
1 | fileName | String | 必选 |

响应参数

序号 | 请求字段 | 字段类型 | 字段名称
1 | content | GetShaContent | 见•GetShaContent
2 | resultCode | String | 失败返回错误码，成功返回0

使用示例

接口请求消息示例数据如下：

https://3.18.18.31:18531/cuServer/userConfigFile/getShaForFile/zz

接口返回消息示例数据如下：

{

"resultCode":0,

"content":{

"shaValue":""

}

}

父主题： 系统及用户文件处理接口